Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Update .Net Framework 3.5 service Pack 1

microsoft.public.windowsupdate






Speedup My PC
Reply
  #1 (permalink)  
Old 09-26-2009
Bob S
 

Posts: n/a
Update .Net Framework 3.5 service Pack 1
I am using Windows XP MCE with .Net 2.0. I have had
Update .Net Framework 3.5 service Pack 1 (KB951847) try to install and fail.
Can anybody tell me what to do?
Thank you in advance,
Bob


Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 09-26-2009
MowGreen
 

Posts: n/a
Re: Update .Net Framework 3.5 service Pack 1
Bob S wrote:

> I am using Windows XP MCE with .Net 2.0. I have had
> Update .Net Framework 3.5 service Pack 1 (KB951847) try to install and fail.
> Can anybody tell me what to do?
> Thank you in advance,
> Bob
>
>


How to determine which versions of the .NET Framework are installed and
whether service packs have been applied
http://msdn.microsoft.com/en-us/kb/kb00318785.aspx

IF no there are no higher versions than .NET Framework 2.0 installed,
suggest that you apply Microsoft .NET Framework 2.0 Service Pack 2:
http://www.microsoft.com/downloads/d...displaylang=en

Then install the application compatibility update for .NET Framework 2.0
SP2:
http://www.microsoft.com/downloads/d...4-6450b0212565

Scroll to the bottom of the above page and click the Download button
next to NDP20SP2-KB958481-x86.exe

*Save* both downloads when prompted to either run or *save* them.
When the downloads are completed, close *all* open programs and browsers.

Apply .NET Framework 2.0 SP2 first (NetFx20SP2_x86.exe), restart if
prompted to.
Then install NDP20SP2-KB958481-x86.exe, reboot if prompted to.

If either do not install properly, then see:

Where to find .NET Framework 2.0 SP1, 2.0 SP2, 3.0 SP1, 3.0 SP2, 3.5 and
3.5 SP1 setup log files
http://blogs.msdn.com/astebner/archi...0/8445569.aspx

You can also run the .NET Framework Setup Verification Tool to check the
..NET Framework that was *included* in MCE and subsequent .NET Frameworks
that were installed:
http://blogs.msdn.com/astebner/pages/8999004.aspx

Also see: How to repair the .NET Framework 1.0 that ships as part of the
OS on Media Center and Tablet PC
http://blogs.msdn.com/astebner/archi...01/459631.aspx
and
Updated: what to do if other .NET Framework setup troubleshooting steps
do not help
http://blogs.msdn.com/astebner/archi...7/8108332.aspx

If there are still issues installing either the .NET Framework 2.0 SP2
or the application compatibility update (NDP20SP2-KB958481-x86.exe), you
can contact Aaron from here:
http://blogs.msdn.com/astebner/contact.aspx


MowGreen
===============
*-343-* FDNY
Never Forgotten
===============

banthecheck.com
"Security updates should *never* have *non-security content* prechecked"



Reply With Quote
  #3 (permalink)  
Old 09-27-2009
Bob S
 

Posts: n/a
Re: Update .Net Framework 3.5 service Pack 1
Thank you, MowGreen, for a very thorough answer. Fantastic.
I DID run into difficulties with the first install. The NetFx20SP2... did
NOT install. Before I go through all of the other steps, can I ask you how
much I really need these Service Packs etc?
Are these optional? If so, can I just remove them from the list?
Thanks a lot.
Bob


"MowGreen" <mowgreen@nowandzen.com> wrote in message
news:Olgbh7tPKHA.352@TK2MSFTNGP02.phx.gbl...
> Bob S wrote:
>
>> I am using Windows XP MCE with .Net 2.0. I have had
>> Update .Net Framework 3.5 service Pack 1 (KB951847) try to install and
>> fail. Can anybody tell me what to do?
>> Thank you in advance,
>> Bob

>
> How to determine which versions of the .NET Framework are installed and
> whether service packs have been applied
> http://msdn.microsoft.com/en-us/kb/kb00318785.aspx
>
> IF no there are no higher versions than .NET Framework 2.0 installed,
> suggest that you apply Microsoft .NET Framework 2.0 Service Pack 2:
> http://www.microsoft.com/downloads/d...displaylang=en
>
> Then install the application compatibility update for .NET Framework 2.0
> SP2:
> http://www.microsoft.com/downloads/d...4-6450b0212565
>
> Scroll to the bottom of the above page and click the Download button next
> to NDP20SP2-KB958481-x86.exe
>
> *Save* both downloads when prompted to either run or *save* them.
> When the downloads are completed, close *all* open programs and browsers.
>
> Apply .NET Framework 2.0 SP2 first (NetFx20SP2_x86.exe), restart if
> prompted to.
> Then install NDP20SP2-KB958481-x86.exe, reboot if prompted to.
>
> If either do not install properly, then see:
>
> Where to find .NET Framework 2.0 SP1, 2.0 SP2, 3.0 SP1, 3.0 SP2, 3.5 and
> 3.5 SP1 setup log files
> http://blogs.msdn.com/astebner/archi...0/8445569.aspx
>
> You can also run the .NET Framework Setup Verification Tool to check the
> .NET Framework that was *included* in MCE and subsequent .NET Frameworks
> that were installed:
> http://blogs.msdn.com/astebner/pages/8999004.aspx
>
> Also see: How to repair the .NET Framework 1.0 that ships as part of the
> OS on Media Center and Tablet PC
> http://blogs.msdn.com/astebner/archi...01/459631.aspx
> and
> Updated: what to do if other .NET Framework setup troubleshooting steps do
> not help
> http://blogs.msdn.com/astebner/archi...7/8108332.aspx
>
> If there are still issues installing either the .NET Framework 2.0 SP2 or
> the application compatibility update (NDP20SP2-KB958481-x86.exe), you can
> contact Aaron from here:
> http://blogs.msdn.com/astebner/contact.aspx
>
>
> MowGreen
> ===============
> *-343-* FDNY
> Never Forgotten
> ===============
>
> banthecheck.com
> "Security updates should *never* have *non-security content* prechecked"
>
>
>



Reply With Quote
  #4 (permalink)  
Old 09-28-2009
MowGreen
 

Posts: n/a
Re: Update .Net Framework 3.5 service Pack 1
You're mowst welcome, Bob. The question is not if *you* need the SP,
it's IF the *software* that installed .NET Framework 2 *needs* them.
Since .NET 2 isn't native to MCE, then some software or hardware that
was subsequently installed is what installed .NET 2.
Here's a list that includes the Hotfixes for .NET 2 on this page:
http://support.microsoft.com/kb/951847

Suggest you Verify that .NET Framework 2 is installed properly prior to
attempting another installation of .NET Framework SP2.
Then follow Aaron's steps if it's not installed properly.
That's what appears to be the issue here, the improper installation of
..NET 2.


MowGreen
===============
*-343-* FDNY
Never Forgotten
===============

banthecheck.com
"Security updates should *never* have *non-security content* prechecked"



Bob S wrote:

> Thank you, MowGreen, for a very thorough answer. Fantastic.
> I DID run into difficulties with the first install. The NetFx20SP2... did
> NOT install. Before I go through all of the other steps, can I ask you how
> much I really need these Service Packs etc?
> Are these optional? If so, can I just remove them from the list?
> Thanks a lot.
> Bob
>
>
> "MowGreen" <mowgreen@nowandzen.com> wrote in message
> news:Olgbh7tPKHA.352@TK2MSFTNGP02.phx.gbl...
>
>>Bob S wrote:
>>
>>
>>>I am using Windows XP MCE with .Net 2.0. I have had
>>>Update .Net Framework 3.5 service Pack 1 (KB951847) try to install and
>>>fail. Can anybody tell me what to do?
>>>Thank you in advance,
>>>Bob

>>
>>How to determine which versions of the .NET Framework are installed and
>>whether service packs have been applied
>>http://msdn.microsoft.com/en-us/kb/kb00318785.aspx
>>
>>IF no there are no higher versions than .NET Framework 2.0 installed,
>>suggest that you apply Microsoft .NET Framework 2.0 Service Pack 2:
>>http://www.microsoft.com/downloads/d...displaylang=en
>>
>>Then install the application compatibility update for .NET Framework 2.0
>>SP2:
>>http://www.microsoft.com/downloads/d...4-6450b0212565
>>
>>Scroll to the bottom of the above page and click the Download button next
>>to NDP20SP2-KB958481-x86.exe
>>
>>*Save* both downloads when prompted to either run or *save* them.
>>When the downloads are completed, close *all* open programs and browsers.
>>
>>Apply .NET Framework 2.0 SP2 first (NetFx20SP2_x86.exe), restart if
>>prompted to.
>>Then install NDP20SP2-KB958481-x86.exe, reboot if prompted to.
>>
>>If either do not install properly, then see:
>>
>>Where to find .NET Framework 2.0 SP1, 2.0 SP2, 3.0 SP1, 3.0 SP2, 3.5 and
>>3.5 SP1 setup log files
>>http://blogs.msdn.com/astebner/archi...0/8445569.aspx
>>
>>You can also run the .NET Framework Setup Verification Tool to check the
>>.NET Framework that was *included* in MCE and subsequent .NET Frameworks
>>that were installed:
>>http://blogs.msdn.com/astebner/pages/8999004.aspx
>>
>>Also see: How to repair the .NET Framework 1.0 that ships as part of the
>>OS on Media Center and Tablet PC
>>http://blogs.msdn.com/astebner/archi...01/459631.aspx
>>and
>>Updated: what to do if other .NET Framework setup troubleshooting steps do
>>not help
>>http://blogs.msdn.com/astebner/archi...7/8108332.aspx
>>
>>If there are still issues installing either the .NET Framework 2.0 SP2 or
>>the application compatibility update (NDP20SP2-KB958481-x86.exe), you can
>>contact Aaron from here:
>>http://blogs.msdn.com/astebner/contact.aspx
>>
>>
>>MowGreen
>>===============
>> *-343-* FDNY
>>Never Forgotten
>>===============
>>
>>banthecheck.com
>>"Security updates should *never* have *non-security content* prechecked"
>>
>>
>>

>
>
>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Update to .NET Framework 3.5 Service Pack 1 for the .NET Framework Assistant 1.0 x86 (KB963707) t-4-2 microsoft.public.windowsupdate 18 07-11-2009 10:24
Update of Net framework 3.5 service pack 1 and sql server 2005 service pack 3 does not complete-hangs during install JohnPierce54 Windows Vista Home Premium 0 04-14-2009 17:10
Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x64 Installation problem BP microsoft.public.windowsupdate 8 03-16-2009 03:59
KB951847 .net framework 305 service pack 1 and update ralph microsoft.public.windowsupdate 9 03-14-2009 03:21
Update failure - Framework 1.1 Service Pack 1 NoSpam microsoft.public.windows.vista.installation setup 0 11-29-2007 00:47




All times are GMT +1. The time now is 20:33.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120