Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

IUpdateDownloader::Download() returns 0x80240044

microsoft.public.windowsupdate






Speedup My PC
Reply
  #1 (permalink)  
Old 06-11-2009
CtA
 

Posts: n/a
IUpdateDownloader::Download() returns 0x80240044
Hi,
IUpdateDownloader:ownload() returns 0x80240044 on logged on user as in
User Group, Same call works fine when logged on user is in Admnistrator group.

But MSDN documentation does not mentioned about this, also I could not find
description for the error code.

Any help?

Thanks n Advance.
CtA

Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 06-12-2009
MowGreen
 

Posts: n/a
Re: IUpdateDownloader::Download() returns 0x80240044
CtA wrote:

> Hi,
> IUpdateDownloader:ownload() returns 0x80240044 on logged on user as in
> User Group, Same call works fine when logged on user is in Admnistrator group.
>
> But MSDN documentation does not mentioned about this, also I could not find
> description for the error code.
>
> Any help?
>
> Thanks n Advance.
> CtA
>



0x80240004 WU_E_NOT_INITIALIZED
Object is not correctly initialized.

OK ... so, you're trying to use a script in *what* doing *what* ?
Nevermind ... I'll go search MSDN ...
http://msdn.microsoft.com/en-us/libr...34(VS.85).aspx


MowGreen
===============
*-343-* FDNY
Never Forgotten
===============
Reply With Quote
  #3 (permalink)  
Old 06-12-2009
CtA
 

Posts: n/a
Re: IUpdateDownloader::Download() returns 0x80240044
Are you sure about that?
I asked about 0x80240044, but you replied about
0x80240004(WU_E_NOT_INITIALIZED)
I'm trying to get driver update for specific hardware, everything works fine
for user in Administrator group, i want to do same thing for a user in
Standard User group.

Thanks
"MowGreen" wrote:

> CtA wrote:
>
> > Hi,
> > IUpdateDownloader:ownload() returns 0x80240044 on logged on user as in
> > User Group, Same call works fine when logged on user is in Admnistrator group.
> >
> > But MSDN documentation does not mentioned about this, also I could not find
> > description for the error code.
> >
> > Any help?
> >
> > Thanks n Advance.
> > CtA
> >

>
>
> 0x80240004 WU_E_NOT_INITIALIZED
> Object is not correctly initialized.
>
> OK ... so, you're trying to use a script in *what* doing *what* ?
> Nevermind ... I'll go search MSDN ...
> http://msdn.microsoft.com/en-us/libr...34(VS.85).aspx
>
>
> MowGreen
> ===============
> *-343-* FDNY
> Never Forgotten
> ===============
>

Reply With Quote
  #4 (permalink)  
Old 06-12-2009
PA Bear [MS MVP]
 

Posts: n/a
Re: IUpdateDownloader::Download() returns 0x80240044
Are you referring to WSUS?

CtA wrote:
> Hi,
> IUpdateDownloader:ownload() returns 0x80240044 on logged on user as in
> User Group, Same call works fine when logged on user is in Admnistrator
> group.
>
> But MSDN documentation does not mentioned about this, also I could not
> find
> description for the error code.
>
> Any help?
>
> Thanks n Advance.
> CtA


Reply With Quote
  #5 (permalink)  
Old 06-12-2009
CtA
 

Posts: n/a
Re: IUpdateDownloader::Download() returns 0x80240044

Underneath it is same, but I'm not sure about that, i'm refering to Windows
Update Agent COM API
"PA Bear [MS MVP]" wrote:

> Are you referring to WSUS?
>
> CtA wrote:
> > Hi,
> > IUpdateDownloader:ownload() returns 0x80240044 on logged on user as in
> > User Group, Same call works fine when logged on user is in Admnistrator
> > group.
> >
> > But MSDN documentation does not mentioned about this, also I could not
> > find
> > description for the error code.
> >
> > Any help?
> >
> > Thanks n Advance.
> > CtA

>
>

Reply With Quote
  #6 (permalink)  
Old 06-12-2009
PA Bear [MS MVP]
 

Posts: n/a
Re: IUpdateDownloader::Download() returns 0x80240044
If the client is updating via WSUS (as the error suggests), it really isn't
the same & you should be posting in the WSUS-specific newsgroup:
microsoft.public.windows.server.update_services


CtA wrote:
> Underneath it is same, but I'm not sure about that, i'm refering to
> Windows
> Update Agent COM API
>
> "PA Bear [MS MVP]" wrote:
>> Are you referring to WSUS?
>>
>> CtA wrote:
>>> Hi,
>>> IUpdateDownloader:ownload() returns 0x80240044 on logged on user as in
>>> User Group, Same call works fine when logged on user is in Admnistrator
>>> group.
>>>
>>> But MSDN documentation does not mentioned about this, also I could not
>>> find
>>> description for the error code.
>>>
>>> Any help?
>>>
>>> Thanks n Advance.
>>> CtA


Reply With Quote
  #7 (permalink)  
Old 06-12-2009
CtA
 

Posts: n/a
Re: IUpdateDownloader::Download() returns 0x80240044

Any question regarding Windows Update Agent COM API belongs to this
newsgroup or not?

As long as somebody could shed some details could help others.

"PA Bear [MS MVP]" wrote:

> If the client is updating via WSUS (as the error suggests), it really isn't
> the same & you should be posting in the WSUS-specific newsgroup:
> microsoft.public.windows.server.update_services
>
>
> CtA wrote:
> > Underneath it is same, but I'm not sure about that, i'm refering to
> > Windows
> > Update Agent COM API
> >
> > "PA Bear [MS MVP]" wrote:
> >> Are you referring to WSUS?
> >>
> >> CtA wrote:
> >>> Hi,
> >>> IUpdateDownloader:ownload() returns 0x80240044 on logged on user as in
> >>> User Group, Same call works fine when logged on user is in Admnistrator
> >>> group.
> >>>
> >>> But MSDN documentation does not mentioned about this, also I could not
> >>> find
> >>> description for the error code.
> >>>
> >>> Any help?
> >>>
> >>> Thanks n Advance.
> >>> CtA

>
>

Reply With Quote
  #8 (permalink)  
Old 06-12-2009
MowGreen
 

Posts: n/a
Re: IUpdateDownloader::Download() returns 0x80240044
No. I dropped a 4 and posted nothing worth checking out, CtA.
FWIW, I can't find anything about the error, 0x80240044, either.
All I found were the MSDN articles on the IUpdateDownloader Interface.
You've probably checked them out, too.
Sorry about that.

Perhaps you should try the "Send comments about this topic to Microsoft"
link and see if you get a response.


MowGreen
===============
*-343-* FDNY
Never Forgotten
===============



CtA wrote:

> Are you sure about that?
> I asked about 0x80240044, but you replied about
> 0x80240004(WU_E_NOT_INITIALIZED)
> I'm trying to get driver update for specific hardware, everything works fine
> for user in Administrator group, i want to do same thing for a user in
> Standard User group.
>
> Thanks
> "MowGreen" wrote:
>
>
>>CtA wrote:
>>
>>
>>>Hi,
>>>IUpdateDownloader:ownload() returns 0x80240044 on logged on user as in
>>>User Group, Same call works fine when logged on user is in Admnistrator group.
>>>
>>>But MSDN documentation does not mentioned about this, also I could not find
>>>description for the error code.
>>>
>>>Any help?
>>>
>>>Thanks n Advance.
>>>CtA
>>>

>>
>>
>>0x80240004 WU_E_NOT_INITIALIZED
>>Object is not correctly initialized.
>>
>>OK ... so, you're trying to use a script in *what* doing *what* ?
>>Nevermind ... I'll go search MSDN ...
>>http://msdn.microsoft.com/en-us/libr...34(VS.85).aspx
>>
>>
>>MowGreen
>>===============
>> *-343-* FDNY
>>Never Forgotten
>>===============
>>

Reply With Quote
  #9 (permalink)  
Old 06-14-2009
Harry Johnston [MVP]
 

Posts: n/a
Re: IUpdateDownloader::Download() returns 0x80240044
CtA wrote:

> IUpdateDownloader:ownload() returns 0x80240044 on logged on user as in
> User Group, Same call works fine when logged on user is in Admnistrator group.


Have you tried setting the ElevateNonAdmins registry option? I'm not sure
whether it affects the COM API, but it seems reasonable to suppose that it would.

<http://technet.microsoft.com/en-us/library/cc708449.aspx>

http://technet.microsoft.com/en-us/l.../cc708449.aspx

If the problem was lack of permission, I'd have expected to see error code 5
rather than an apparently undocumented code, but you never know.

You could also try using Process Monitor to see if there's an underlying file or
registry error occurring:

<http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx>

http://technet.microsoft.com/en-us/s.../bb896645.aspx

If so, it might give you some hints.

It seems unlikely that the issue is related to whether you're using WSUS or not.
It could, however, be worth asking in the WSUS newsgroup as well, because most
folks wanting to do this kind of technical WU stuff tend to be in a corporate
environment and therefore use WSUS. However, I don't hold out much hope; I'm
not aware of anyone in either group who has worked with the COM API much.

Harry.


>
> But MSDN documentation does not mentioned about this, also I could not find
> description for the error code.
>
> Any help?
>
> Thanks n Advance.
> CtA
>

Reply With Quote
  #10 (permalink)  
Old 06-14-2009
Harry Johnston [MVP]
 

Posts: n/a
Re: IUpdateDownloader::Download() returns 0x80240044
PA Bear [MS MVP] wrote:

> If the client is updating via WSUS (as the error suggests), it really
> isn't the same & you should be posting in the WSUS-specific newsgroup:
> microsoft.public.windows.server.update_services


For the record, while the Windows Update Agent error codes happen to be
documented in the WSUS section of the MSDN, they apply equally well to
conventional Windows/Microsoft Update as well.

Harry.

>
>
> CtA wrote:
>> Underneath it is same, but I'm not sure about that, i'm refering to
>> Windows
>> Update Agent COM API
>>
>> "PA Bear [MS MVP]" wrote:
>>> Are you referring to WSUS?
>>>
>>> CtA wrote:
>>>> Hi,
>>>> IUpdateDownloader:ownload() returns 0x80240044 on logged on user
>>>> as in
>>>> User Group, Same call works fine when logged on user is in Admnistrator
>>>> group.
>>>>
>>>> But MSDN documentation does not mentioned about this, also I could not
>>>> find
>>>> description for the error code.
>>>>
>>>> Any help?
>>>>
>>>> Thanks n Advance.
>>>> CtA

>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
L0phtcrack returns Steve Security News 0 05-28-2009 04:50
The One-Use, Self-Destructing DVD Returns Steve General Technology News 0 06-04-2008 09:50
ipconfig returns too much David Lozzi microsoft.public.windows.vista.networking sharing 3 01-17-2008 08:19
The Age of the Airship Returns? Steve General Technology News 0 01-06-2008 19:20
Warezov Returns Paul Security News 0 04-03-2007 14:03




All times are GMT +1. The time now is 00:51.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120