Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Clients not displayed in WSUS

microsoft.public.windowsupdate






Speedup My PC
Reply
  #1 (permalink)  
Old 05-06-2009
guv
 

Posts: n/a
Clients not displayed in WSUS

I am using the latest version of WSUS, and have setup my required groups and
the correct group policy. I have 6 machines in the aWSUS group and in the
right OU and group policy. Only 3 of them are displayed on WSUS, and the
other 3 are not being displayed. All machines are running windows 2003 SP2.
I have attached some errors from the windowsupdate log from two of the
machines:



Launched new AU client for directive 'Setup Wizard', session id = 0x1
2009-05-06 11:45:57:321 8144 1a40 Misc =========== Logging initialized
(build: 7.2.6001.788, tz: +0100) ===========
2009-05-06 11:45:57:321 8144 1a40 Misc = Process:
C:\WINDOWS\system32\wuauclt.exe
2009-05-06 11:45:57:305 8144 1a40 AUClnt Launched Client UI process
2009-05-06 11:45:57:649 8144 1a40 Misc =========== Logging initialized
(build: 7.2.6001.788, tz: +0100) ===========
2009-05-06 11:45:57:649 8144 1a40 Misc = Process:
C:\WINDOWS\system32\wuauclt.exe
2009-05-06 11:45:57:649 8144 1a40 Misc = Module:
C:\WINDOWS\system32\wucltui.dll
2009-05-06 11:45:57:649 8144 1a40 CltUI AU client got new directive = 'Setup
Wizard', serviceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, return =
0x00000000
2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
(dwMessage=0x0, uFlags=0x3, hr=0x80070002)
2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
(dwMessage=0x0, uFlags=0x3, hr=0x80070002)
2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
(dwMessage=0x0, uFlags=0x3, hr=0x80070002)
2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
(dwMessage=0x0, uFlags=0x3, hr=0x80070002)
2009-05-06 11:45:57:680 8144 1a40 CltUI FATAL: Failed to show client UI,
directive=2, hr=80070002
2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
(dwMessage=0x2, uFlags=0x0, hr=0x80070002)
2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
(dwMessage=0x2, uFlags=0x0, hr=0x80070002)
2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
(dwMessage=0x2, uFlags=0x0, hr=0x80070002)
2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
(dwMessage=0x2, uFlags=0x0, hr=0x80070002)
2009-05-06 11:45:57:805 836 7f0 AU AU received handle event
2009-05-06 11:45:57:805 836 7f0 AU AU setting pending client directive to
'Setup Wizard'
2009-05-06 11:46:13:165 836 7f0 AU Launched new AU client for directive
'Setup Wizard', session id = 0x1
2009-05-06 11:46:13:243 1932 aac Misc =========== Logging initialized
(build: 7.2.6001.788, tz: +0100) ===========
2009-05-06 11:46:13:243 1932 aac Misc = Process:
C:\WINDOWS\system32\wuauclt.exe
2009-05-06 11:46:13:243 1932 aac AUClnt Launched Client UI process
2009-05-06 11:46:13:462 1932 aac Misc =========== Logging initialized
(build: 7.2.6001.788, tz: +0100) ===========
2009-05-06 11:46:13:462 1932 aac Misc = Process:
C:\WINDOWS\system32\wuauclt.exe
2009-05-06 11:46:13:462 1932 aac Misc = Module:
C:\WINDOWS\system32\wucltui.dll
2009-05-06 11:46:13:462 1932 aac CltUI AU client got new directive = 'Setup
Wizard', serviceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, return =
0x00000000
2009-05-06 11:50:40:165 836 7f0 AU AU received policy change subscription
event
2009-05-06 11:55:00:509 836 7f0 AU ########### AU: Uninitializing
Automatic Updates ###########
2009-05-06 11:55:00:524 1932 aac CltUI AU client got new directive = 'None',
serviceId = {00000000-0000-0000-0000-000000000000}, return = 0x80010108
2009-05-06 11:55:00:524 1932 aac CltUI FATAL: Failed to show client UI,
directive=2, hr=80010108
2009-05-06 11:55:00:555 836 7f0 Service *********
2009-05-06 11:55:00:555 836 7f0 Service ** END ** Service: Service exit
[Exit code = 0x240001]


Are you able to assist in what this errors is and what solutions can I use
to get these machines displayed in WSUS.


Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 05-06-2009
Ǝиçεl
 

Posts: n/a
RE: Clients not displayed in WSUS
Perhaps try the WSUS Newsgroup

On the web:
<http://www.microsoft.com/communities/newsgroups/list/en-us/default.aspx?dg=microsoft.public.windows.server.up date_services>

In your newsreader:
news://msnews.microsoft.com/microsof...pdate_services
-=-

Thanks and good luck !
-=-

"guv" wrote:

>
> I am using the latest version of WSUS, and have setup my required groups and
> the correct group policy. I have 6 machines in the aWSUS group and in the
> right OU and group policy. Only 3 of them are displayed on WSUS, and the
> other 3 are not being displayed. All machines are running windows 2003 SP2.
> I have attached some errors from the windowsupdate log from two of the
> machines:
>
>
>
> Launched new AU client for directive 'Setup Wizard', session id = 0x1
> 2009-05-06 11:45:57:321 8144 1a40 Misc =========== Logging initialized
> (build: 7.2.6001.788, tz: +0100) ===========
> 2009-05-06 11:45:57:321 8144 1a40 Misc = Process:
> C:\WINDOWS\system32\wuauclt.exe
> 2009-05-06 11:45:57:305 8144 1a40 AUClnt Launched Client UI process
> 2009-05-06 11:45:57:649 8144 1a40 Misc =========== Logging initialized
> (build: 7.2.6001.788, tz: +0100) ===========
> 2009-05-06 11:45:57:649 8144 1a40 Misc = Process:
> C:\WINDOWS\system32\wuauclt.exe
> 2009-05-06 11:45:57:649 8144 1a40 Misc = Module:
> C:\WINDOWS\system32\wucltui.dll
> 2009-05-06 11:45:57:649 8144 1a40 CltUI AU client got new directive = 'Setup
> Wizard', serviceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, return =
> 0x00000000
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x0, uFlags=0x3, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x0, uFlags=0x3, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x0, uFlags=0x3, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x0, uFlags=0x3, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 CltUI FATAL: Failed to show client UI,
> directive=2, hr=80070002
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x2, uFlags=0x0, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x2, uFlags=0x0, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x2, uFlags=0x0, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x2, uFlags=0x0, hr=0x80070002)
> 2009-05-06 11:45:57:805 836 7f0 AU AU received handle event
> 2009-05-06 11:45:57:805 836 7f0 AU AU setting pending client directive to
> 'Setup Wizard'
> 2009-05-06 11:46:13:165 836 7f0 AU Launched new AU client for directive
> 'Setup Wizard', session id = 0x1
> 2009-05-06 11:46:13:243 1932 aac Misc =========== Logging initialized
> (build: 7.2.6001.788, tz: +0100) ===========
> 2009-05-06 11:46:13:243 1932 aac Misc = Process:
> C:\WINDOWS\system32\wuauclt.exe
> 2009-05-06 11:46:13:243 1932 aac AUClnt Launched Client UI process
> 2009-05-06 11:46:13:462 1932 aac Misc =========== Logging initialized
> (build: 7.2.6001.788, tz: +0100) ===========
> 2009-05-06 11:46:13:462 1932 aac Misc = Process:
> C:\WINDOWS\system32\wuauclt.exe
> 2009-05-06 11:46:13:462 1932 aac Misc = Module:
> C:\WINDOWS\system32\wucltui.dll
> 2009-05-06 11:46:13:462 1932 aac CltUI AU client got new directive = 'Setup
> Wizard', serviceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, return =
> 0x00000000
> 2009-05-06 11:50:40:165 836 7f0 AU AU received policy change subscription
> event
> 2009-05-06 11:55:00:509 836 7f0 AU ########### AU: Uninitializing
> Automatic Updates ###########
> 2009-05-06 11:55:00:524 1932 aac CltUI AU client got new directive = 'None',
> serviceId = {00000000-0000-0000-0000-000000000000}, return = 0x80010108
> 2009-05-06 11:55:00:524 1932 aac CltUI FATAL: Failed to show client UI,
> directive=2, hr=80010108
> 2009-05-06 11:55:00:555 836 7f0 Service *********
> 2009-05-06 11:55:00:555 836 7f0 Service ** END ** Service: Service exit
> [Exit code = 0x240001]
>
>
> Are you able to assist in what this errors is and what solutions can I use
> to get these machines displayed in WSUS.
>
>
>

Reply With Quote
  #3 (permalink)  
Old 05-06-2009
PA Bear [MS MVP]
 

Posts: n/a
Re: Clients not displayed in WSUS
[[ Right pew, wrong church. Forwarded to WSUS newsgroup
(microsoft.public.windows.server.update_services) via crosspost as a
convenience to OP.

On the web:
http://www.microsoft.com/communities... date_services

In your newsreader:
news://msnews.microsoft.com/microsof...pdate_services
]]

guv wrote:
> I am using the latest version of WSUS, and have setup my required groups
> and
> the correct group policy. I have 6 machines in the aWSUS group and in the
> right OU and group policy. Only 3 of them are displayed on WSUS, and the
> other 3 are not being displayed. All machines are running windows 2003
> SP2.
> I have attached some errors from the windowsupdate log from two of the
> machines:
>
>
>
> Launched new AU client for directive 'Setup Wizard', session id = 0x1
> 2009-05-06 11:45:57:321 8144 1a40 Misc =========== Logging initialized
> (build: 7.2.6001.788, tz: +0100) ===========
> 2009-05-06 11:45:57:321 8144 1a40 Misc = Process:
> C:\WINDOWS\system32\wuauclt.exe
> 2009-05-06 11:45:57:305 8144 1a40 AUClnt Launched Client UI process
> 2009-05-06 11:45:57:649 8144 1a40 Misc =========== Logging initialized
> (build: 7.2.6001.788, tz: +0100) ===========
> 2009-05-06 11:45:57:649 8144 1a40 Misc = Process:
> C:\WINDOWS\system32\wuauclt.exe
> 2009-05-06 11:45:57:649 8144 1a40 Misc = Module:
> C:\WINDOWS\system32\wucltui.dll
> 2009-05-06 11:45:57:649 8144 1a40 CltUI AU client got new directive =
> 'Setup
> Wizard', serviceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, return =
> 0x00000000
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x0, uFlags=0x3, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x0, uFlags=0x3, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x0, uFlags=0x3, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x0, uFlags=0x3, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 CltUI FATAL: Failed to show client UI,
> directive=2, hr=80070002
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x2, uFlags=0x0, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x2, uFlags=0x0, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x2, uFlags=0x0, hr=0x80070002)
> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
> (dwMessage=0x2, uFlags=0x0, hr=0x80070002)
> 2009-05-06 11:45:57:805 836 7f0 AU AU received handle event
> 2009-05-06 11:45:57:805 836 7f0 AU AU setting pending client directive to
> 'Setup Wizard'
> 2009-05-06 11:46:13:165 836 7f0 AU Launched new AU client for directive
> 'Setup Wizard', session id = 0x1
> 2009-05-06 11:46:13:243 1932 aac Misc =========== Logging initialized
> (build: 7.2.6001.788, tz: +0100) ===========
> 2009-05-06 11:46:13:243 1932 aac Misc = Process:
> C:\WINDOWS\system32\wuauclt.exe
> 2009-05-06 11:46:13:243 1932 aac AUClnt Launched Client UI process
> 2009-05-06 11:46:13:462 1932 aac Misc =========== Logging initialized
> (build: 7.2.6001.788, tz: +0100) ===========
> 2009-05-06 11:46:13:462 1932 aac Misc = Process:
> C:\WINDOWS\system32\wuauclt.exe
> 2009-05-06 11:46:13:462 1932 aac Misc = Module:
> C:\WINDOWS\system32\wucltui.dll
> 2009-05-06 11:46:13:462 1932 aac CltUI AU client got new directive =
> 'Setup
> Wizard', serviceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, return =
> 0x00000000
> 2009-05-06 11:50:40:165 836 7f0 AU AU received policy change subscription
> event
> 2009-05-06 11:55:00:509 836 7f0 AU ########### AU: Uninitializing
> Automatic Updates ###########
> 2009-05-06 11:55:00:524 1932 aac CltUI AU client got new directive =
> 'None',
> serviceId = {00000000-0000-0000-0000-000000000000}, return = 0x80010108
> 2009-05-06 11:55:00:524 1932 aac CltUI FATAL: Failed to show client UI,
> directive=2, hr=80010108
> 2009-05-06 11:55:00:555 836 7f0 Service *********
> 2009-05-06 11:55:00:555 836 7f0 Service ** END ** Service: Service
> exit
> [Exit code = 0x240001]
>
>
> Are you able to assist in what this errors is and what solutions can I use
> to get these machines displayed in WSUS.


Reply With Quote
  #4 (permalink)  
Old 05-07-2009
Harry Johnston [MVP]
 

Posts: n/a
Re: Clients not displayed in WSUS
> guv wrote:
>> I am using the latest version of WSUS, and have setup my required
>> groups and the correct group policy. [...]


Looks like the affected machines are not receiving the group policy settings, or
you have configured the group policy incorrectly. What group policy settings
did you apply?

Harry.


I have 6 machines in the aWSUS group and in
>> the
>> right OU and group policy. Only 3 of them are displayed on WSUS, and the
>> other 3 are not being displayed. All machines are running windows
>> 2003 SP2.
>> I have attached some errors from the windowsupdate log from two of the
>> machines:
>>
>>
>>
>> Launched new AU client for directive 'Setup Wizard', session id = 0x1
>> 2009-05-06 11:45:57:321 8144 1a40 Misc =========== Logging initialized
>> (build: 7.2.6001.788, tz: +0100) ===========
>> 2009-05-06 11:45:57:321 8144 1a40 Misc = Process:
>> C:\WINDOWS\system32\wuauclt.exe
>> 2009-05-06 11:45:57:305 8144 1a40 AUClnt Launched Client UI process
>> 2009-05-06 11:45:57:649 8144 1a40 Misc =========== Logging initialized
>> (build: 7.2.6001.788, tz: +0100) ===========
>> 2009-05-06 11:45:57:649 8144 1a40 Misc = Process:
>> C:\WINDOWS\system32\wuauclt.exe
>> 2009-05-06 11:45:57:649 8144 1a40 Misc = Module:
>> C:\WINDOWS\system32\wucltui.dll
>> 2009-05-06 11:45:57:649 8144 1a40 CltUI AU client got new directive =
>> 'Setup
>> Wizard', serviceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, return =
>> 0x00000000
>> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
>> (dwMessage=0x0, uFlags=0x3, hr=0x80070002)
>> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
>> (dwMessage=0x0, uFlags=0x3, hr=0x80070002)
>> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
>> (dwMessage=0x0, uFlags=0x3, hr=0x80070002)
>> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
>> (dwMessage=0x0, uFlags=0x3, hr=0x80070002)
>> 2009-05-06 11:45:57:680 8144 1a40 CltUI FATAL: Failed to show client UI,
>> directive=2, hr=80070002
>> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
>> (dwMessage=0x2, uFlags=0x0, hr=0x80070002)
>> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
>> (dwMessage=0x2, uFlags=0x0, hr=0x80070002)
>> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
>> (dwMessage=0x2, uFlags=0x0, hr=0x80070002)
>> 2009-05-06 11:45:57:680 8144 1a40 AUClnt WARNING: Shell_NotifyIcon failed
>> (dwMessage=0x2, uFlags=0x0, hr=0x80070002)
>> 2009-05-06 11:45:57:805 836 7f0 AU AU received handle event
>> 2009-05-06 11:45:57:805 836 7f0 AU AU setting pending client
>> directive to
>> 'Setup Wizard'
>> 2009-05-06 11:46:13:165 836 7f0 AU Launched new AU client for directive
>> 'Setup Wizard', session id = 0x1
>> 2009-05-06 11:46:13:243 1932 aac Misc =========== Logging initialized
>> (build: 7.2.6001.788, tz: +0100) ===========
>> 2009-05-06 11:46:13:243 1932 aac Misc = Process:
>> C:\WINDOWS\system32\wuauclt.exe
>> 2009-05-06 11:46:13:243 1932 aac AUClnt Launched Client UI process
>> 2009-05-06 11:46:13:462 1932 aac Misc =========== Logging initialized
>> (build: 7.2.6001.788, tz: +0100) ===========
>> 2009-05-06 11:46:13:462 1932 aac Misc = Process:
>> C:\WINDOWS\system32\wuauclt.exe
>> 2009-05-06 11:46:13:462 1932 aac Misc = Module:
>> C:\WINDOWS\system32\wucltui.dll
>> 2009-05-06 11:46:13:462 1932 aac CltUI AU client got new directive =
>> 'Setup
>> Wizard', serviceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, return =
>> 0x00000000
>> 2009-05-06 11:50:40:165 836 7f0 AU AU received policy change
>> subscription
>> event
>> 2009-05-06 11:55:00:509 836 7f0 AU ########### AU: Uninitializing
>> Automatic Updates ###########
>> 2009-05-06 11:55:00:524 1932 aac CltUI AU client got new directive =
>> 'None',
>> serviceId = {00000000-0000-0000-0000-000000000000}, return = 0x80010108
>> 2009-05-06 11:55:00:524 1932 aac CltUI FATAL: Failed to show client UI,
>> directive=2, hr=80010108
>> 2009-05-06 11:55:00:555 836 7f0 Service *********
>> 2009-05-06 11:55:00:555 836 7f0 Service ** END ** Service: Service
>> exit
>> [Exit code = 0x240001]
>>
>>
>> Are you able to assist in what this errors is and what solutions can I
>> use
>> to get these machines displayed in WSUS.

>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
WSUS 3.0 Clients are not showing in wsus admin console Rock41 microsoft.public.windowsupdate 6 09-24-2009 19:58
WSUS clients not registering Ted microsoft.public.windowsupdate 8 06-11-2009 17:20
WSUS 3.0 Clients are not showing in wsus admin console - different twist troy04 microsoft.public.windowsupdate 3 01-07-2009 06:15
WSUS Not Updating Clients Anna microsoft.public.windowsupdate 3 11-12-2008 21:50
WSUS clients are not appearing in WSUS console RAV microsoft.public.windowsupdate 2 03-13-2008 20:08




All times are GMT +1. The time now is 06:23.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120