Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Windows Update runs for days - 100% cpu utilization

microsoft.public.windowsupdate






Speedup My PC
Reply
  #1 (permalink)  
Old 04-27-2009
Nick Cozby
 

Posts: n/a
Windows Update runs for days - 100% cpu utilization
Hi All -

I have 4 identical servers that are all exhibiting the same issue. We have
hundreds of other clients and servers that are not experiencing this issue
and pull updates just fine from the same WSUS server.

All 4 servers are Windows 2003 x64 SP2. All 4 had been working just fine
getting updates for over 6 months. All 4 began exhibiting this issue at the
same time last week. No known changes to any of the systems.

On each server, the "Automatic Update" service runs to pull updates from our
WSUS server. The server then becomes sluggish (100% cpu utilization from
svchost.exe) and remains so until the Automatic Updates service is stopped.
Process Explorer view of the offending svchost.exe process shows that it is
the Windows Update that is consuming the CPU. I let it run like this over
the weekend, and it remained at 100% cpu utilization for 4 days without
installing a single update. Below is the resuling text in the
WindowsUpdate.log. I had to manually kill the Automatic Update service this
morning to stop the 100% utilization.

2009-04-23 16:06:35:736 808 dc8 PT +++++++++++ PT: Synchronizing server
updates +++++++++++
2009-04-23 16:06:35:736 808 dc8 PT + ServiceId =
{3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL =
http://RAD-VMSRVSUS1/ClientWebService/client.asmx
2009-04-23 16:06:49:173 808 dc8 PT +++++++++++ PT: Synchronizing extended
update info +++++++++++
2009-04-23 16:06:49:173 808 dc8 PT + ServiceId =
{3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL =
http://RAD-VMSRVSUS1/ClientWebService/client.asmx
2009-04-23 16:12:08:595 1872 7a0 COMAPI -------------
2009-04-23 16:12:08:595 1872 7a0 COMAPI -- START -- COMAPI: Search
[ClientId = Exchange12]
2009-04-23 16:12:08:595 1872 7a0 COMAPI ---------
2009-04-23 16:12:08:595 1872 7a0 COMAPI <<-- SUBMITTED -- COMAPI: Search
[ClientId = Exchange12]
2009-04-24 05:00:10:001 808 e48 AU Forced install timer expired for
scheduled install
2009-04-24 05:00:10:001 808 e48 AU UpdateDownloadProperties: 0 download(s)
are still in progress.
2009-04-24 05:00:10:017 808 e48 AU Setting AU scheduled install time to
2009-04-25 10:00:00
2009-04-25 05:00:10:017 808 e48 AU Forced install timer expired for
scheduled install
2009-04-25 05:00:10:017 808 e48 AU UpdateDownloadProperties: 0 download(s)
are still in progress.
2009-04-25 05:00:10:017 808 e48 AU Setting AU scheduled install time to
2009-04-26 10:00:00
2009-04-26 05:00:10:033 808 e48 AU Forced install timer expired for
scheduled install
2009-04-26 05:00:10:033 808 e48 AU UpdateDownloadProperties: 0 download(s)
are still in progress.
2009-04-26 05:00:10:033 808 e48 AU Setting AU scheduled install time to
2009-04-27 10:00:00
2009-04-27 00:50:11:001 808 e48 AU ########### AU: Uninitializing
Automatic Updates ###########
2009-04-27 00:50:11:001 808 dc8 Agent * WARNING: Failed to filter search
results, error = 0x8024000B
2009-04-27 00:50:11:064 808 dc8 Agent *********
2009-04-27 00:50:11:064 808 dc8 Agent ** END ** Agent: Finding updates
[CallerId = AutomaticUpdates]
2009-04-27 00:50:11:064 808 dc8 Agent *************
2009-04-27 00:50:11:079 808 e48 Agent Sending shutdown notification to client
2009-04-27 00:50:11:079 1872 56c COMAPI WARNING: Received service
shutdown/self-update notification.




Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 04-27-2009
PA Bear [MS MVP]
 

Posts: n/a
Re: Windows Update runs for days - 100% cpu utilization
See recent posts in this possibly-related thread:
http://groups.google.com/group/micro...2272d743e5ee35
Or see
http://blogs.technet.com/sbs/archive...e-the-cpu.aspx
--
~Robear Dyer (PA Bear)
MS MVP-IE, Mail, Security, Windows Client - since 2002


Nick Cozby wrote:
> I have 4 identical servers that are all exhibiting the same issue. We
> have
> hundreds of other clients and servers that are not experiencing this issue
> and pull updates just fine from the same WSUS server.
>
> All 4 servers are Windows 2003 x64 SP2. All 4 had been working just fine
> getting updates for over 6 months. All 4 began exhibiting this issue at
> the
> same time last week. No known changes to any of the systems.
>
> On each server, the "Automatic Update" service runs to pull updates from
> our
> WSUS server. The server then becomes sluggish (100% cpu utilization from
> svchost.exe) and remains so until the Automatic Updates service is
> stopped.
> Process Explorer view of the offending svchost.exe process shows that it
> is
> the Windows Update that is consuming the CPU. I let it run like this over
> the weekend, and it remained at 100% cpu utilization for 4 days without
> installing a single update. Below is the resuling text in the
> WindowsUpdate.log. I had to manually kill the Automatic Update service
> this
> morning to stop the 100% utilization.
>
> 2009-04-23 16:06:35:736 808 dc8 PT +++++++++++ PT: Synchronizing server
> updates +++++++++++
> 2009-04-23 16:06:35:736 808 dc8 PT + ServiceId =
> {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL =
> http://RAD-VMSRVSUS1/ClientWebService/client.asmx
> 2009-04-23 16:06:49:173 808 dc8 PT +++++++++++ PT: Synchronizing extended
> update info +++++++++++
> 2009-04-23 16:06:49:173 808 dc8 PT + ServiceId =
> {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL =
> http://RAD-VMSRVSUS1/ClientWebService/client.asmx
> 2009-04-23 16:12:08:595 1872 7a0 COMAPI -------------
> 2009-04-23 16:12:08:595 1872 7a0 COMAPI -- START -- COMAPI: Search
> [ClientId = Exchange12]
> 2009-04-23 16:12:08:595 1872 7a0 COMAPI ---------
> 2009-04-23 16:12:08:595 1872 7a0 COMAPI <<-- SUBMITTED -- COMAPI: Search
> [ClientId = Exchange12]
> 2009-04-24 05:00:10:001 808 e48 AU Forced install timer expired for
> scheduled install
> 2009-04-24 05:00:10:001 808 e48 AU UpdateDownloadProperties: 0 download(s)
> are still in progress.
> 2009-04-24 05:00:10:017 808 e48 AU Setting AU scheduled install time to
> 2009-04-25 10:00:00
> 2009-04-25 05:00:10:017 808 e48 AU Forced install timer expired for
> scheduled install
> 2009-04-25 05:00:10:017 808 e48 AU UpdateDownloadProperties: 0 download(s)
> are still in progress.
> 2009-04-25 05:00:10:017 808 e48 AU Setting AU scheduled install time to
> 2009-04-26 10:00:00
> 2009-04-26 05:00:10:033 808 e48 AU Forced install timer expired for
> scheduled install
> 2009-04-26 05:00:10:033 808 e48 AU UpdateDownloadProperties: 0 download(s)
> are still in progress.
> 2009-04-26 05:00:10:033 808 e48 AU Setting AU scheduled install time to
> 2009-04-27 10:00:00
> 2009-04-27 00:50:11:001 808 e48 AU ########### AU: Uninitializing
> Automatic Updates ###########
> 2009-04-27 00:50:11:001 808 dc8 Agent * WARNING: Failed to filter search
> results, error = 0x8024000B
> 2009-04-27 00:50:11:064 808 dc8 Agent *********
> 2009-04-27 00:50:11:064 808 dc8 Agent ** END ** Agent: Finding updates
> [CallerId = AutomaticUpdates]
> 2009-04-27 00:50:11:064 808 dc8 Agent *************
> 2009-04-27 00:50:11:079 808 e48 Agent Sending shutdown notification to
> client 2009-04-27 00:50:11:079 1872 56c COMAPI WARNING: Received service
> shutdown/self-update notification.


Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vista Windows Back-Up 100% Disk Utilization Banjo200 microsoft.public.windows.vista.performance maintenance 1 04-18-2009 17:32
RE: Windows update fails to install updates for 5 days now clou microsoft.public.windowsupdate 1 08-20-2008 20:24
Hard disc runs & runs in Vista Basic Bute01 Windows Vista General 2 07-15-2008 22:00
RE: Windows update fails to install updates for 5 days now - FIX MR. C. microsoft.public.windowsupdate 0 03-06-2008 05:15
Update KB941649 Failed (trying for several days now) ChicaCalifornia microsoft.public.windowsupdate 1 11-24-2007 10:50




All times are GMT +1. The time now is 16:06.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120