Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Automatic Updates and wuauserve error

microsoft.public.windowsupdate






Speedup My PC
Reply
  #1 (permalink)  
Old 08-31-2008
marvinmycat
 

Posts: n/a
Automatic Updates and wuauserve error
Windows XP Pro 64-bit

Windows Automatic Updates website reports "Administrators Only" and starting
wuauaserv generates error 126: spcified module not found.

So far, I've done 99% of what I could dig up on the web and on MS Support
sites. The list is huge of what I have done to date. BITS, etc. all other
processes work without problem. I'e gone through and registered all dll's
several times, edited the registry for any missing entries, changed
permissions of all associated processes, ran the update service as
Administrator, re-intalled SP2, etc. Nothing has wokred to date.

So where I'm at now, everytime I start Windows Update service, I revceive
the specified module not found message. What I'm hoping for, is that someone
can point me to where the dll file is that the service is calling in order to
even see if I'm missing a module, and how I would go about reading it.

Below is a lst of things I've done to date - thanks in advance for any help:

Per Support email:

Verify the System component
Click "Start" and "Run", type "REGSVR32 wuapi.DLL" (without quotations) in
the open box and click "OK".

Rename all the Windows Update temporary folders
1. Click "Start", "Run", type: "notepad C:\remove.bat" (without quotations)
and press Enter. Choose "Yes" when you are prompted.
2. Copy the following commands and then paste them into the opened Notepad
window.

net stop wuauserv
net stop CryptSvc
ren %windir%\system32\catroot2 catroot2.old
ren %windir%\SoftwareDistribution sold.old
net start CryptSvc
net start wuauserv

Ran that folder.

Reset Internet Explorer

Collected System Information, sent to support.


Reregister the Msinfo32.dll file. To do this, follow these steps:
a. Click Start, click Run, type Regsvr32 "c:\program files\common
files\microsoft shared\msinfo\msinfo32.dll"
File exists - receive error:
module not found.
Also did the above within the :Program Files (86)" directory. Same results
as above.

Make sure that Task Scheduler works. If you still experience the problem,
reregister the Schedsvc.dll file. To do this, follow these steps:
a. Click Start, click Run, type Regsvr32 "%SystemRoot%\System32\
schedsvc.dll", and then click OK.
file exists - receive error:
module not found.

downloaded windowsupdateagent30-x64.exe and ran command
"C:\WindowsUpdateAgent30-x64.exe /wuforce"
received error from Windows Update Agent Installer:
Install failed with the following error number: 0x8007041d

register:
regsvr32.exe qmgrprxy.dll
regsvr32.exe qmgr.dll
regsvr32 wuaueng.dll
regsvr32 wuapi.dll
regsvr32 wups.dll
regsvr32 wups2.dll
regsvr32 wuweb.dll

reboot and tried update for log file - below:

2008-08-09 08:49:23:921 948 a0c Misc =========== Logging initialized
(build: 7.0.6000.381, tz: -0400) ===========
2008-08-09 08:49:23:921 948 a0c Misc = Process: C:\Program Files
(x86)\Internet Explorer\IEXPLORE.EXE
2008-08-09 08:49:23:921 948 a0c Misc = Module:
C:\WINDOWS\SysWow64\wuapi.dll
2008-08-09 08:49:23:921 948 a0c COMAPI FATAL: Unable to connect to the
service (hr=80080005)
2008-08-09 08:49:23:921 948 a0c COMAPI WARNING: Unable to establish
connection to the service. (hr=80080005)
2008-08-09 08:49:55:015 948 a0c COMAPI FATAL: Unable to connect to the
service (hr=80080005)
2008-08-09 08:49:55:015 948 a0c COMAPI WARNING: Unable to establish
connection to the service. (hr=80080005)

Win Spt.:

At this time, we can try the following steps to repair Automatic Update
Service.

Reinstalling the Automatic Update Service:
===============================
Click Start / Run then type the following command then click OK.

%SystemRoot%\System32\rundll32.exe setupapi,InstallHinfSection
DefaultInstall 132 %SystemRoot%\inf\au.inf

The setup process will try to restore the registry branches automatically.
You may not receive any notification. However, if some files cannot be
located automatically, we will be prompted to select the installation source.
Please click browse, and go to this location:

C:\Windows\ServicePackFiles\i386

If this folder is not available, please choose the folder C:\Windows\System32.

Restart the computer and test the issue.

If the problem persists, let’s register all the components related to
Automatic Updates
========
Click Start, click Run, type the following command and click OK after each
roll. You are expected to receive a successful confirmation after running
each command:

REGSVR32 WUAPI.DLL
REGSVR32 WUAUENG.DLL
REGSVR32 WUAUENG1.DLL
REGSVR32 WUCLTUI.DLL
REGSVR32 WUPS.DLL

Please visit the Windows Update site: http://windowsupdate.microsoft.com to
test the issue again.

If any error code or error message was received when performing the steps
shown above, please capture a screenshot for my further research:
================
NOTE: In order to reduce the size of the screenshot file, please use the
JPEG format to save the picture. Please refer to the following steps.
How to capture a screenshot:
=======================
1. When the error appears, please press the Print Screen key (PrtScn) on
your keyboard.
2. Click Start, click Run, type MSPAINT, and click OK.
3. In Paint, click Paste under the Edit Menu, click Save under the File
menu, type a file name for the screenshot, choose JPEG as "Save as type",
click "Desktop" on the left pane, and click Save.
4. Please find the screenshot on the Desktop and send it as an attachment to
support.

Thank you for your cooperation. Please try the steps shown above and let me
know the results at your earliest convenience. If you have any questions or
concerns regarding this issue, please don't hesitate to tell me. It is my
pleasure to be of assistance.


Microsoft Windows Support Professional

When running the command the first time, It was looking for file wwuapi.dll
from SP2 CD-ROM. I could not locate it on the OS install software w/ SP2
included, nor was it anywhere on the Internet. I had to cancel the process
in lieu of continuing without the file, as I'm looking at the steps ahead and
do not see that file included.
Per instructions, there is no path C:\Windows\ServicePackFiles\i386 on my
machine. The files wwuapi.dll and wwups.dll are not located in the above
directory or C:\Windows\System32.
When running the command a second time, the file wuapi.dll is needed from
SP2 CD-ROM (C:\WINODOWS\inf\amd64). I gave it the one on the CD-ROM. The
process window closed, and I've no clue if it completed succedssfully.

Registering files failed - REGSVR32 WUAUENG1.DLL (module not found).
5.7.3790.3959 Copied this file from Internet to System32 and SystemWOW64
directories, tried to register file and received "...not an executable file
and no registration helper is registered for this file type."

I'm an IDIOT!

cd %windir%\system32 - then registered following files:

• Regsvr32 Jscript.dll
• Regsvr32 Msxml3.dll
• Regsvr32 Atl.dll
• Regsvr32 Wuapi.dll
• Regsvr32 Wuaueng.dll
• Regsvr32 Wuaueng1.dll
• Regsvr32 Wucltui.dll
• Regsvr32 Wups.dll
• Regsvr32 Wuweb.dll

Rename the SoftwareDistribution folder. To do this, follow these steps:
a. Click Start, click Run, type %windir%, and then click OK.

Note The %windir% folder is the folder where you installed Microsoft Windows.
b. Locate the SoftwareDistribution folder.
c. Right-click the SoftwareDistribution folder, and then click Rename.
d. Type OldSD, and then press ENTER.
4. Start the Automatic Updates service and the BITS service. To do this,
follow these steps:
a. Click Start, click Run, type services.msc, and then click OK.
b. In the list of services, right-click Automatic Updates, and then click
Properties.
c. In the Automatic Updates Properties dialog box, click the General tab,
click Start, and then click OK.
d. In the list of services, right-click Background Intelligent Transfer
Service, and then click Properties.
e. In the Background Intelligent Transfer Service Properties dialog box,
click the General tab, click Start, and then click OK.

AutoUpdate fails - same error 126.

cd %windir%\sysWOW64 - then registered following files - all OK except as
noted below:

• Regsvr32 Jscript.dll
• Regsvr32 Msxml3.dll
• Regsvr32 Atl.dll
• Regsvr32 Wuapi.dll
• Regsvr32 Wuaueng.dll
• Regsvr32 Wuaueng1.dll
• Regsvr32 Wucltui.dll - module not found
• Regsvr32 Wups.dll
• Regsvr32 Wuweb.dll

Win Update - Admin error. Log:

2008-08-12 09:13:26-0400 1232 b6c ChangeServiceConfig for wuauserv succeeded
2008-08-12 09:14:11-0400 2432 604 CreateObject for
Microsoft.Update.AgentInfo failed: error 0x80040111
2008-08-12 09:14:41-0400 2432 604 Unable to connect to the service
(hr=80080005)
2008-08-12 09:14:41-0400 2432 604 Unable to establish connection to the
service. (hr=80080005)
2008-08-12 09:14:42-0400 2432 604 CreateObject for
Microsoft.Update.AgentInfo failed: error 0x80040111
2008-08-12 09:15:12-0400 2432 604 Unable to connect to the service
(hr=80080005)
2008-08-12 09:15:12-0400 2432 604 Unable to establish connection to the
service. (hr=80080005)
2008-08-12 09:24:15-0400 1116 8c ChangeServiceConfig for wuauserv succeeded
2008-08-12 09:26:13-0400 2712 3b4 CreateObject for
Microsoft.Update.AgentInfo failed: error 0x80040111
2008-08-12 09:26:43-0400 2712 3b4 Unable to connect to the service
(hr=80080005)
2008-08-12 09:26:43-0400 2712 3b4 Unable to establish connection to the
service. (hr=80080005)
2008-08-12 09:27:02-0400 2576 308 CreateObject for
Microsoft.Update.AgentInfo failed: error 0x80040111
2008-08-12 09:27:32-0400 2576 308 Unable to connect to the service
(hr=80080005)
2008-08-12 09:27:32-0400 2576 308 Unable to establish connection to the
service. (hr=80080005)
2008-08-12 09:27:33-0400 2576 308 CreateObject for
Microsoft.Update.AgentInfo failed: error 0x80040111
2008-08-12 09:28:03-0400 2576 308 Unable to connect to the service
(hr=80080005)
2008-08-12 09:28:03-0400 2576 308 Unable to establish connection to the
service. (hr=80080005)

copied from install CD AMD64 to Windows\sysWOW64 wucltui.dll, tried to
register - failed after renaming to .dll.
system32 registers fine.


================================================== ================================================== ================


At this time, I suggest we try the following steps to reinstall Windows 2003
SP2 to fix the issue.


Suggestion 1: Set Cryptographic Services to automatic
==============================
Set the Cryptographic Services to Automatic, and then try to install the
program again. To set the Cryptographic Services to Automatic, follow these
steps: 1. Start the Administrative Tools utility in Control Panel.

2. Double-click Services.
3. Right-click "Cryptographic Services", and then click Properties.
4. Click Automatic for Startup type, and then click “Start”. If it is
started, please stop and then restart it.

setup was fine.

Suggestion 2: Clear the temporary file and restart the hotfix installation
or the service pack installation

================================================== =================
1. Delete all the tmp*.cat files in the following folders:

%systemroot%\system32\CatRoot\{127D0A1D-4EF2-11D1-8608-00C04FC295EE}

0 found
%systemroot%\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}

0 found

2. Delete all the kb*.cat files in the following folders:

%systemroot%\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}

40 deleted

%systemroot%\System32\CatRoot\{127D0A1D-4EF2-11D1-8608-00C04FC295EE}

0 found

3. Delete all the oem*.* files from the %systemroot%\inf folder.

76 deleted
4. At the command prompt, type the following commands. Press ENTER after
each command.


net stop cryptsvc
ren %systemroot%\System32\Catroot2 oldcatroot2
net start cryptsvc
exit

stopped, renamed, started ok.


Suggestion 3: Remove the hidden attribute from %Windir% and from its
subfolders

================================================== =====

1. Click “Start”, click “Run”, type cmd in the Open box, and then OK.

2. At the command prompt, type the following commands, pressing ENTER after
each line:

attrib -s -h %windir%
attrib -s -h %windir%\system32
attrib -s -h %windir%\system32\catroot2
exit

everyhing good, except we renamed the catroot2 to oldcatroot2 - geeze!


Suggestion 4: Reregister DLL files that are associated with Cryptographic
Services

================================================== ==

1. Click “Start”, click “Run”, type cmd in the Open box, and then OK.

2. At the command prompt, type the following commands, and press ENTER after
each command:

regsvr32 /u softpub.dll
regsvr32 /u wintrust.dll
regsvr32 /u initpki.dll
regsvr32 /u dssenh.dll
regsvr32 /u rsaenh.dll
regsvr32 /u gpkcsp.dll
regsvr32 /u sccbase.dll
regsvr32 /u slbcsp.dll
regsvr32 /u mssip32.dll
regsvr32 /u cryptdlg.dll

exit

Note Click OK if you are prompted.

all worked.

3. Restart your computer.
4. Click “Start”, click “Run”, type cmd in the Open box, and then click OK.
5. At the command prompt, type the following commands, and press ENTER
after each command:

regsvr32 softpub.dll
regsvr32 wintrust.dll
regsvr32 initpki.dll
regsvr32 dssenh.dll
regsvr32 rsaenh.dll
regsvr32 gpkcsp.dll
regsvr32 sccbase.dll
regsvr32 slbcsp.dll
regsvr32 mssip32.dll
regsvr32 cryptdlg.dll
exit

all good.

Note Click OK if you are prompted.

6. Restart the computer.

ok...

Suggestion 5: Rename the Edb.log file
=============================

1. Click “Start”, click “Run”, type cmd in the Open box, and then OK.

2. At the command prompt, type the following command, and then press ENTER:



ren %systemroot%\system32\catroot2\Edb.log *.tst

done.


Suggestion 6: Download and Install Service Pack 2 manually
==================================



Please first visit the link and download the patch to Desktop.


Windows Server 2003 Service Pack 2 (32-bit x86):

http://www.microsoft.com/downloads/d...DisplayLang=en

NO - TRY 64-bit:

http://www.microsoft.com/downloads/d...DisplayLang=en

Please double click the downloaded update file and install it. If any error
appears during the installation, please help to capture an error screenshot.
The detailed error information will be very useful for us to narrow down the
issue.

SP2 installed without problems. UPdate failes with "Administrators Only"
message.

Screenshot

----------------------------

1) When the error message appears press the Print Screen key (PrtScn) on
your keyboard.
2) Click “Start”, click “Run”, type MSPAINT, and click “OK”.
3) In Paint, click Paste under the Edit Menu, click Save under the File
menu, type a file name for the snap shot, choose JPEG as "Save as type", and
click Save.
4) Please send this file to my email account: v-30vix@mssupport.microsoft.com

svcpack.log
======================

1) Click "Start", click "Run", type: %windir% and then press Enter.
2) Locate a file named "svcpack.log".
3) Please send this file to my email account:



If that dose not works, this issue can be caused by the second factor. At
that point, I suggest involving our Windows 2003 supporter to get
professional help. Please be assured that I will provide further help
regarding the issue.





http://www.p2plife.com/forums/All_up...ail-t1938.html

added BITS and wuauserv entries to
HKEY_Local_Machine\Software\Microsoft\WindowsNT\Cu rrentVersion\SvcHost.
Rebooted.

nope.

%SystemRoot%\System32\rundll32.exe setupapi,InstallHinfSection
DefaultInstall132 %SystemRoot%\inf\au.inf

still stuck.
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 08-31-2008
Robert Aldwinckle
 

Posts: n/a
Re: Automatic Updates and wuauserve error
(cross-post added to 64bit.general)
"marvinmycat" <marvinmycat@discussions.microsoft.com> wrote in message
news:5E23E337-E9BD-4781-B32C-7E41CA7E1595@microsoft.com...
> Windows XP Pro 64-bit
>
> Windows Automatic Updates website reports "Administrators Only" and starting
> wuauaserv generates error 126: spcified module not found.



What module is not found? Is there any supplementary information in
the Event Viewer Application log? WindowsUpdate.log with verbose logging?
(Ref. KB902093). If necessary you could Run... ProcMon to capture
the file access failure which probably generated this message.

The same diagnostic approach could be used to clarify some of your other
symptoms. E.g. when you installed the Update Agent you got 0x8007041D
That is probably just a different symptom of the same problem.

This could be yet another symptom of it. (Copied from below.)

> 2008-08-09 08:49:23:921 948 a0c COMAPI FATAL: Unable to connect to the
> service (hr=80080005)


Again, ProcMon could clarify this by supplementing the message with related
file and registry accesses.

Hmm... here is a specific message about a missing module.

> • Regsvr32 Wucltui.dll - module not found


What did you try to do about that? Oh. I see it could be a symptom of
just a difference in implementation between x64 and x32 versions?
And that you have seen other differences in that regard using the suggestions
you have picked up in your quest. Unfortunately I have no knowledge of
such differences. Cross-posting to 64bit.general for convenience.


>
> So far, I've done 99% of what I could dig up on the web and on MS Support sites.

....


Using ProcMon falls into that other 1%? <eg>
(BTW I'm not even certain that there is 64bit version of ProcMon
for you to try.)


Good luck

Robert Aldwinckle
---

(Remainder of OP copied for convenience of new readers.)

> So far, I've done 99% of what I could dig up on the web and on MS Support
> sites. The list is huge of what I have done to date. BITS, etc. all other
> processes work without problem. I'e gone through and registered all dll's
> several times, edited the registry for any missing entries, changed
> permissions of all associated processes, ran the update service as
> Administrator, re-intalled SP2, etc. Nothing has wokred to date.
>
> So where I'm at now, everytime I start Windows Update service, I revceive
> the specified module not found message. What I'm hoping for, is that someone
> can point me to where the dll file is that the service is calling in order to
> even see if I'm missing a module, and how I would go about reading it.
>
> Below is a lst of things I've done to date - thanks in advance for any help:
>
> Per Support email:
>
> Verify the System component
> Click "Start" and "Run", type "REGSVR32 wuapi.DLL" (without quotations) in
> the open box and click "OK".
>
> Rename all the Windows Update temporary folders
> 1. Click "Start", "Run", type: "notepad C:\remove.bat" (without quotations)
> and press Enter. Choose "Yes" when you are prompted.
> 2. Copy the following commands and then paste them into the opened Notepad
> window.
>
> net stop wuauserv
> net stop CryptSvc
> ren %windir%\system32\catroot2 catroot2.old
> ren %windir%\SoftwareDistribution sold.old
> net start CryptSvc
> net start wuauserv
>
> Ran that folder.
>
> Reset Internet Explorer
>
> Collected System Information, sent to support.
>
>
> Reregister the Msinfo32.dll file. To do this, follow these steps:
> a. Click Start, click Run, type Regsvr32 "c:\program files\common
> files\microsoft shared\msinfo\msinfo32.dll"
> File exists - receive error:
> module not found.
> Also did the above within the :Program Files (86)" directory. Same results
> as above.
>
> Make sure that Task Scheduler works. If you still experience the problem,
> reregister the Schedsvc.dll file. To do this, follow these steps:
> a. Click Start, click Run, type Regsvr32 "%SystemRoot%\System32\
> schedsvc.dll", and then click OK.
> file exists - receive error:
> module not found.
>
> downloaded windowsupdateagent30-x64.exe and ran command
> "C:\WindowsUpdateAgent30-x64.exe /wuforce"
> received error from Windows Update Agent Installer:
> Install failed with the following error number: 0x8007041d
>
> register:
> regsvr32.exe qmgrprxy.dll
> regsvr32.exe qmgr.dll
> regsvr32 wuaueng.dll
> regsvr32 wuapi.dll
> regsvr32 wups.dll
> regsvr32 wups2.dll
> regsvr32 wuweb.dll
>
> reboot and tried update for log file - below:
>
> 2008-08-09 08:49:23:921 948 a0c Misc =========== Logging initialized
> (build: 7.0.6000.381, tz: -0400) ===========
> 2008-08-09 08:49:23:921 948 a0c Misc = Process: C:\Program Files
> (x86)\Internet Explorer\IEXPLORE.EXE
> 2008-08-09 08:49:23:921 948 a0c Misc = Module:
> C:\WINDOWS\SysWow64\wuapi.dll
> 2008-08-09 08:49:23:921 948 a0c COMAPI FATAL: Unable to connect to the
> service (hr=80080005)
> 2008-08-09 08:49:23:921 948 a0c COMAPI WARNING: Unable to establish
> connection to the service. (hr=80080005)
> 2008-08-09 08:49:55:015 948 a0c COMAPI FATAL: Unable to connect to the
> service (hr=80080005)
> 2008-08-09 08:49:55:015 948 a0c COMAPI WARNING: Unable to establish
> connection to the service. (hr=80080005)
>
> Win Spt.:
>
> At this time, we can try the following steps to repair Automatic Update
> Service.
>
> Reinstalling the Automatic Update Service:
> ===============================
> Click Start / Run then type the following command then click OK.
>
> %SystemRoot%\System32\rundll32.exe setupapi,InstallHinfSection
> DefaultInstall 132 %SystemRoot%\inf\au.inf
>
> The setup process will try to restore the registry branches automatically.
> You may not receive any notification. However, if some files cannot be
> located automatically, we will be prompted to select the installation source.
> Please click browse, and go to this location:
>
> C:\Windows\ServicePackFiles\i386
>
> If this folder is not available, please choose the folder C:\Windows\System32.
>
> Restart the computer and test the issue.
>
> If the problem persists, let’s register all the components related to
> Automatic Updates
> ========
> Click Start, click Run, type the following command and click OK after each
> roll. You are expected to receive a successful confirmation after running
> each command:
>
> REGSVR32 WUAPI.DLL
> REGSVR32 WUAUENG.DLL
> REGSVR32 WUAUENG1.DLL
> REGSVR32 WUCLTUI.DLL
> REGSVR32 WUPS.DLL
>
> Please visit the Windows Update site: http://windowsupdate.microsoft.com to
> test the issue again.
>
> If any error code or error message was received when performing the steps
> shown above, please capture a screenshot for my further research:
> ================
> NOTE: In order to reduce the size of the screenshot file, please use the
> JPEG format to save the picture. Please refer to the following steps.
> How to capture a screenshot:
> =======================
> 1. When the error appears, please press the Print Screen key (PrtScn) on
> your keyboard.
> 2. Click Start, click Run, type MSPAINT, and click OK.
> 3. In Paint, click Paste under the Edit Menu, click Save under the File
> menu, type a file name for the screenshot, choose JPEG as "Save as type",
> click "Desktop" on the left pane, and click Save.
> 4. Please find the screenshot on the Desktop and send it as an attachment to
> support.
>
> Thank you for your cooperation. Please try the steps shown above and let me
> know the results at your earliest convenience. If you have any questions or
> concerns regarding this issue, please don't hesitate to tell me. It is my
> pleasure to be of assistance.
>
>
> Microsoft Windows Support Professional
>
> When running the command the first time, It was looking for file wwuapi.dll
> from SP2 CD-ROM. I could not locate it on the OS install software w/ SP2
> included, nor was it anywhere on the Internet. I had to cancel the process
> in lieu of continuing without the file, as I'm looking at the steps ahead and
> do not see that file included.
> Per instructions, there is no path C:\Windows\ServicePackFiles\i386 on my
> machine. The files wwuapi.dll and wwups.dll are not located in the above
> directory or C:\Windows\System32.
> When running the command a second time, the file wuapi.dll is needed from
> SP2 CD-ROM (C:\WINODOWS\inf\amd64). I gave it the one on the CD-ROM. The
> process window closed, and I've no clue if it completed succedssfully.
>
> Registering files failed - REGSVR32 WUAUENG1.DLL (module not found).
> 5.7.3790.3959 Copied this file from Internet to System32 and SystemWOW64
> directories, tried to register file and received "...not an executable file
> and no registration helper is registered for this file type."
>
> I'm an IDIOT!
>
> cd %windir%\system32 - then registered following files:
>
> • Regsvr32 Jscript.dll
> • Regsvr32 Msxml3.dll
> • Regsvr32 Atl.dll
> • Regsvr32 Wuapi.dll
> • Regsvr32 Wuaueng.dll
> • Regsvr32 Wuaueng1.dll
> • Regsvr32 Wucltui.dll
> • Regsvr32 Wups.dll
> • Regsvr32 Wuweb.dll
>
> Rename the SoftwareDistribution folder. To do this, follow these steps:
> a. Click Start, click Run, type %windir%, and then click OK.
>
> Note The %windir% folder is the folder where you installed Microsoft Windows.
> b. Locate the SoftwareDistribution folder.
> c. Right-click the SoftwareDistribution folder, and then click Rename.
> d. Type OldSD, and then press ENTER.
> 4. Start the Automatic Updates service and the BITS service. To do this,
> follow these steps:
> a. Click Start, click Run, type services.msc, and then click OK.
> b. In the list of services, right-click Automatic Updates, and then click
> Properties.
> c. In the Automatic Updates Properties dialog box, click the General tab,
> click Start, and then click OK.
> d. In the list of services, right-click Background Intelligent Transfer
> Service, and then click Properties.
> e. In the Background Intelligent Transfer Service Properties dialog box,
> click the General tab, click Start, and then click OK.
>
> AutoUpdate fails - same error 126.
>
> cd %windir%\sysWOW64 - then registered following files - all OK except as
> noted below:
>
> • Regsvr32 Jscript.dll
> • Regsvr32 Msxml3.dll
> • Regsvr32 Atl.dll
> • Regsvr32 Wuapi.dll
> • Regsvr32 Wuaueng.dll
> • Regsvr32 Wuaueng1.dll
> • Regsvr32 Wucltui.dll - module not found
> • Regsvr32 Wups.dll
> • Regsvr32 Wuweb.dll
>
> Win Update - Admin error. Log:
>
> 2008-08-12 09:13:26-0400 1232 b6c ChangeServiceConfig for wuauserv succeeded
> 2008-08-12 09:14:11-0400 2432 604 CreateObject for
> Microsoft.Update.AgentInfo failed: error 0x80040111
> 2008-08-12 09:14:41-0400 2432 604 Unable to connect to the service
> (hr=80080005)
> 2008-08-12 09:14:41-0400 2432 604 Unable to establish connection to the
> service. (hr=80080005)
> 2008-08-12 09:14:42-0400 2432 604 CreateObject for
> Microsoft.Update.AgentInfo failed: error 0x80040111
> 2008-08-12 09:15:12-0400 2432 604 Unable to connect to the service
> (hr=80080005)
> 2008-08-12 09:15:12-0400 2432 604 Unable to establish connection to the
> service. (hr=80080005)
> 2008-08-12 09:24:15-0400 1116 8c ChangeServiceConfig for wuauserv succeeded
> 2008-08-12 09:26:13-0400 2712 3b4 CreateObject for
> Microsoft.Update.AgentInfo failed: error 0x80040111
> 2008-08-12 09:26:43-0400 2712 3b4 Unable to connect to the service
> (hr=80080005)
> 2008-08-12 09:26:43-0400 2712 3b4 Unable to establish connection to the
> service. (hr=80080005)
> 2008-08-12 09:27:02-0400 2576 308 CreateObject for
> Microsoft.Update.AgentInfo failed: error 0x80040111
> 2008-08-12 09:27:32-0400 2576 308 Unable to connect to the service
> (hr=80080005)
> 2008-08-12 09:27:32-0400 2576 308 Unable to establish connection to the
> service. (hr=80080005)
> 2008-08-12 09:27:33-0400 2576 308 CreateObject for
> Microsoft.Update.AgentInfo failed: error 0x80040111
> 2008-08-12 09:28:03-0400 2576 308 Unable to connect to the service
> (hr=80080005)
> 2008-08-12 09:28:03-0400 2576 308 Unable to establish connection to the
> service. (hr=80080005)
>
> copied from install CD AMD64 to Windows\sysWOW64 wucltui.dll, tried to
> register - failed after renaming to .dll.
> system32 registers fine.
>
>
> ================================================== ================================================== ================
>
>
> At this time, I suggest we try the following steps to reinstall Windows 2003
> SP2 to fix the issue.
>
>
> Suggestion 1: Set Cryptographic Services to automatic
> ==============================
> Set the Cryptographic Services to Automatic, and then try to install the
> program again. To set the Cryptographic Services to Automatic, follow these
> steps: 1. Start the Administrative Tools utility in Control Panel.
>
> 2. Double-click Services.
> 3. Right-click "Cryptographic Services", and then click Properties.
> 4. Click Automatic for Startup type, and then click “Start”. If it is
> started, please stop and then restart it.
>
> setup was fine.
>
> Suggestion 2: Clear the temporary file and restart the hotfix installation
> or the service pack installation
>
> ================================================== =================
> 1. Delete all the tmp*.cat files in the following folders:
>
> %systemroot%\system32\CatRoot\{127D0A1D-4EF2-11D1-8608-00C04FC295EE}
>
> 0 found
> %systemroot%\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}
>
> 0 found
>
> 2. Delete all the kb*.cat files in the following folders:
>
> %systemroot%\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}
>
> 40 deleted
>
> %systemroot%\System32\CatRoot\{127D0A1D-4EF2-11D1-8608-00C04FC295EE}
>
> 0 found
>
> 3. Delete all the oem*.* files from the %systemroot%\inf folder.
>
> 76 deleted
> 4. At the command prompt, type the following commands. Press ENTER after
> each command.
>
>
> net stop cryptsvc
> ren %systemroot%\System32\Catroot2 oldcatroot2
> net start cryptsvc
> exit
>
> stopped, renamed, started ok.
>
>
> Suggestion 3: Remove the hidden attribute from %Windir% and from its
> subfolders
>
> ================================================== =====
>
> 1. Click “Start”, click “Run”, type cmd in the Open box, and then OK.
>
> 2. At the command prompt, type the following commands, pressing ENTER after
> each line:
>
> attrib -s -h %windir%
> attrib -s -h %windir%\system32
> attrib -s -h %windir%\system32\catroot2
> exit
>
> everyhing good, except we renamed the catroot2 to oldcatroot2 - geeze!
>
>
> Suggestion 4: Reregister DLL files that are associated with Cryptographic
> Services
>
> ================================================== ==
>
> 1. Click “Start”, click “Run”, type cmd in the Open box, and then OK.
>
> 2. At the command prompt, type the following commands, and press ENTER after
> each command:
>
> regsvr32 /u softpub.dll
> regsvr32 /u wintrust.dll
> regsvr32 /u initpki.dll
> regsvr32 /u dssenh.dll
> regsvr32 /u rsaenh.dll
> regsvr32 /u gpkcsp.dll
> regsvr32 /u sccbase.dll
> regsvr32 /u slbcsp.dll
> regsvr32 /u mssip32.dll
> regsvr32 /u cryptdlg.dll
>
> exit
>
> Note Click OK if you are prompted.
>
> all worked.
>
> 3. Restart your computer.
> 4. Click “Start”, click “Run”, type cmd in the Open box, and then click OK.
> 5. At the command prompt, type the following commands, and press ENTER
> after each command:
>
> regsvr32 softpub.dll
> regsvr32 wintrust.dll
> regsvr32 initpki.dll
> regsvr32 dssenh.dll
> regsvr32 rsaenh.dll
> regsvr32 gpkcsp.dll
> regsvr32 sccbase.dll
> regsvr32 slbcsp.dll
> regsvr32 mssip32.dll
> regsvr32 cryptdlg.dll
> exit
>
> all good.
>
> Note Click OK if you are prompted.
>
> 6. Restart the computer.
>
> ok...
>
> Suggestion 5: Rename the Edb.log file
> =============================
>
> 1. Click “Start”, click “Run”, type cmd in the Open box, and then OK.
>
> 2. At the command prompt, type the following command, and then press ENTER:
>
>
>
> ren %systemroot%\system32\catroot2\Edb.log *.tst
>
> done.
>
>
> Suggestion 6: Download and Install Service Pack 2 manually
> ==================================
>
>
>
> Please first visit the link and download the patch to Desktop.
>
>
> Windows Server 2003 Service Pack 2 (32-bit x86):
>
> http://www.microsoft.com/downloads/d...DisplayLang=en
>
> NO - TRY 64-bit:
>
> http://www.microsoft.com/downloads/d...DisplayLang=en
>
> Please double click the downloaded update file and install it. If any error
> appears during the installation, please help to capture an error screenshot.
> The detailed error information will be very useful for us to narrow down the
> issue.
>
> SP2 installed without problems. UPdate failes with "Administrators Only"
> message.
>
> Screenshot
>
> ----------------------------
>
> 1) When the error message appears press the Print Screen key (PrtScn) on
> your keyboard.
> 2) Click “Start”, click “Run”, type MSPAINT, and click “OK”.
> 3) In Paint, click Paste under the Edit Menu, click Save under the File
> menu, type a file name for the snap shot, choose JPEG as "Save as type", and
> click Save.
> 4) Please send this file to my email account: v-30vix@mssupport.microsoft.com
>
> svcpack.log
> ======================
>
> 1) Click "Start", click "Run", type: %windir% and then press Enter.
> 2) Locate a file named "svcpack.log".
> 3) Please send this file to my email account:
>
>
>
> If that dose not works, this issue can be caused by the second factor. At
> that point, I suggest involving our Windows 2003 supporter to get
> professional help. Please be assured that I will provide further help
> regarding the issue.
>
>
>
>
>
> http://www.p2plife.com/forums/All_up...ail-t1938.html
>
> added BITS and wuauserv entries to
> HKEY_Local_Machine\Software\Microsoft\WindowsNT\Cu rrentVersion\SvcHost.
> Rebooted.
>
> nope.
>
> %SystemRoot%\System32\rundll32.exe setupapi,InstallHinfSection
> DefaultInstall132 %SystemRoot%\inf\au.inf
>
> still stuck.



Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting an error when turning on Automatic Updates Gary microsoft.public.windowsupdate 6 08-28-2008 23:49
How do I get automatic Windows updates if that feature is greyed out in Automatic Updates in System Properties? nospam1@nospam.xxy microsoft.public.windowsupdate 2 08-22-2008 03:25
Re: Automatic Updates Generating Error Pedro Jr microsoft.public.windowsupdate 0 11-05-2007 17:50




All times are GMT +1. The time now is 19:58.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120