Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

RE: KB898461 consistently fails to install

microsoft.public.windowsupdate






Speedup My PC
Reply
  #1 (permalink)  
Old 05-31-2008
Wolverine
 

Posts: n/a
RE: KB898461 consistently fails to install
Forgot to mention that I also have posted a blog having the same solution
which can be accessed at:

http://funcomputing.blogsome.com/200...blem-solution/

BR, Wolverine

"Malc" wrote:

> I'm trying to update a Win XP SP2 installation but since KB898461
> failed to install, all subsequent updates have also failed (898461 was
> the new update installer). The installation is now 6 months out of
> date...
>
> I've tried downloading the patch and running it locally but it fails
> with a MessageBox ("The system cannot find the file specified"). I
> don't know which file can't be found; my analysis of the log file is
> that several aspects of the installation may have failed.
>
> Can you help? I've tried setting Windows\CurrentVersion\Setup\LogLevel
> to 0x80006060 but I think it didn't add any detail to the log file.
> I've tried emptying the DataStore and Download subdirectories in
> SoftwareDistribution but it didn't help; neither did running the patch
> in safe mode.
>
> Here's a typical log file.
>
> 1.641:
> ================================================== ==============================
> 1.641: 2005/12/26 16:51:58.715 (local)
> 1.641: c:\355571f7444f803dcd5cbb7c9951\update\update.exe (version
> 6.1.22.4)
> 1.656: Hotfix started with following command line: /log:c:\temp\log.txt
>
> 103.766: In Function TestVolatileFlag, line 11660, RegOpenKeyEx failed
> with error 0x2
> 103.766: In Function TestVolatileFlag, line 11692, RegOpenKeyEx failed
> with error 0x2
> 103.766: DoInstallation: CleanPFR failed: 0x2
> 103.812: SetProductTypes: InfProductBuildType=BuildType.IC
> 103.812: SetAltOsLoaderPath: No section uses DirId 65701; done.
> 103.875: DoInstallation: FetchSourceURL for
> c:\355571f7444f803dcd5cbb7c9951\update\update_SP2G DR.inf failed
> 103.875: CreateUninstall = 1,Directory =
> C:\WINDOWS\$NtUninstallKB898461$
> 103.875: LoadFileQueues: UpdSpGetSourceFileLocation for halaacpi.dll
> failed: 0xe0000102
> 103.875: LoadFileQueues: QueueMigrationStageFiles failed: 0x00000003
> 103.875: InventoryThread: LoadFileQueues failed with error: 0x3
> 103.875: Inventory complete: ReturnStatus=3, 0 ticks
> 103.875: Num Ticks for invent : 0
> 103.937: The system cannot find the path specified.
> 115.672: Message displayed to the user: The system cannot find the path
> specified.
> 115.672: User Input: OK
> 115.672: KB898461 installation did not complete.
> 117.531: Message displayed to the user: KB898461 installation did not
> complete.
> 117.531: User Input: OK
> 117.531: Update.exe extended error code = 0x3
> 117.531: Update.exe return code was masked to 0x643 for MSI custom
> action compliance.
>
> Curiously, KB886185 has failed with similar errors since December
> 2004...
>
> Thanks in advance for any help,
> Malc
>
>

Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 10-16-2008
Gwynevar
 

Posts: n/a
RE: KB898461 consistently fails to install
I tried your fix and all of them worked okay except for the REGSVR32
WUAUENG1.DLL. It keeps telling me that it failed because the dll does not
exist. Do you have any idea how to fix this problem? I have tried several
different solutions and even reinstalled XP Pro a few times. Nothing seems
to help and I am pulling my hair out at this point. It's preventing several
critical updates from coming through and it seems to be interfering with
other software downloads as well.

"Wolverine" wrote:

> Forgot to mention that I also have posted a blog having the same solution
> which can be accessed at:
>
> http://funcomputing.blogsome.com/200...blem-solution/
>
> BR, Wolverine
>
> "Malc" wrote:
>
> > I'm trying to update a Win XP SP2 installation but since KB898461
> > failed to install, all subsequent updates have also failed (898461 was
> > the new update installer). The installation is now 6 months out of
> > date...
> >
> > I've tried downloading the patch and running it locally but it fails
> > with a MessageBox ("The system cannot find the file specified"). I
> > don't know which file can't be found; my analysis of the log file is
> > that several aspects of the installation may have failed.
> >
> > Can you help? I've tried setting Windows\CurrentVersion\Setup\LogLevel
> > to 0x80006060 but I think it didn't add any detail to the log file.
> > I've tried emptying the DataStore and Download subdirectories in
> > SoftwareDistribution but it didn't help; neither did running the patch
> > in safe mode.
> >
> > Here's a typical log file.
> >
> > 1.641:
> > ================================================== ==============================
> > 1.641: 2005/12/26 16:51:58.715 (local)
> > 1.641: c:\355571f7444f803dcd5cbb7c9951\update\update.exe (version
> > 6.1.22.4)
> > 1.656: Hotfix started with following command line: /log:c:\temp\log.txt
> >
> > 103.766: In Function TestVolatileFlag, line 11660, RegOpenKeyEx failed
> > with error 0x2
> > 103.766: In Function TestVolatileFlag, line 11692, RegOpenKeyEx failed
> > with error 0x2
> > 103.766: DoInstallation: CleanPFR failed: 0x2
> > 103.812: SetProductTypes: InfProductBuildType=BuildType.IC
> > 103.812: SetAltOsLoaderPath: No section uses DirId 65701; done.
> > 103.875: DoInstallation: FetchSourceURL for
> > c:\355571f7444f803dcd5cbb7c9951\update\update_SP2G DR.inf failed
> > 103.875: CreateUninstall = 1,Directory =
> > C:\WINDOWS\$NtUninstallKB898461$
> > 103.875: LoadFileQueues: UpdSpGetSourceFileLocation for halaacpi.dll
> > failed: 0xe0000102
> > 103.875: LoadFileQueues: QueueMigrationStageFiles failed: 0x00000003
> > 103.875: InventoryThread: LoadFileQueues failed with error: 0x3
> > 103.875: Inventory complete: ReturnStatus=3, 0 ticks
> > 103.875: Num Ticks for invent : 0
> > 103.937: The system cannot find the path specified.
> > 115.672: Message displayed to the user: The system cannot find the path
> > specified.
> > 115.672: User Input: OK
> > 115.672: KB898461 installation did not complete.
> > 117.531: Message displayed to the user: KB898461 installation did not
> > complete.
> > 117.531: User Input: OK
> > 117.531: Update.exe extended error code = 0x3
> > 117.531: Update.exe return code was masked to 0x643 for MSI custom
> > action compliance.
> >
> > Curiously, KB886185 has failed with similar errors since December
> > 2004...
> >
> > Thanks in advance for any help,
> > Malc
> >
> >

Reply With Quote
  #3 (permalink)  
Old 10-17-2008
Robert Aldwinckle
 

Posts: n/a
Re: KB898461 consistently fails to install
"Gwynevar" <Gwynevar@discussions.microsoft.com> wrote in message news:B61EA447-DE83-42F7-AB65-C21165A7EE9C@microsoft.com...
>I tried your fix and all of them worked okay except for the REGSVR32
> WUAUENG1.DLL.


> It keeps telling me that it failed because the dll does not exist.



Please report the exact symptoms you see and not your interpretations
of them.


> Do you have any idea how to fix this problem?



It will depend on what you are really seeing.
Check to see if there is a wuaueng1.dll module
If it's there then the message you are getting means
that one of the depedendent modules of that modules
is either missing or not accessible.

If necessary you could use DependencyWalker with its profiler
command to re-execute that regsvr32.exe command.
Then you could see in its trace exactly which module the message
your are getting is referring to.


Good luck

Robert Aldwinckle
---


> I have tried several
> different solutions and even reinstalled XP Pro a few times. Nothing seems
> to help and I am pulling my hair out at this point. It's preventing several
> critical updates from coming through and it seems to be interfering with
> other software downloads as well.
>
> "Wolverine" wrote:
>
>> Forgot to mention that I also have posted a blog having the same solution
>> which can be accessed at:
>>
>> http://funcomputing.blogsome.com/200...blem-solution/
>>
>> BR, Wolverine
>>
>> "Malc" wrote:
>>
>> > I'm trying to update a Win XP SP2 installation but since KB898461
>> > failed to install, all subsequent updates have also failed (898461 was
>> > the new update installer). The installation is now 6 months out of
>> > date...
>> >
>> > I've tried downloading the patch and running it locally but it fails
>> > with a MessageBox ("The system cannot find the file specified"). I
>> > don't know which file can't be found; my analysis of the log file is
>> > that several aspects of the installation may have failed.
>> >
>> > Can you help? I've tried setting Windows\CurrentVersion\Setup\LogLevel
>> > to 0x80006060 but I think it didn't add any detail to the log file.
>> > I've tried emptying the DataStore and Download subdirectories in
>> > SoftwareDistribution but it didn't help; neither did running the patch
>> > in safe mode.
>> >
>> > Here's a typical log file.
>> >
>> > 1.641:
>> > ================================================== ==============================
>> > 1.641: 2005/12/26 16:51:58.715 (local)
>> > 1.641: c:\355571f7444f803dcd5cbb7c9951\update\update.exe (version
>> > 6.1.22.4)
>> > 1.656: Hotfix started with following command line: /log:c:\temp\log.txt
>> >
>> > 103.766: In Function TestVolatileFlag, line 11660, RegOpenKeyEx failed
>> > with error 0x2
>> > 103.766: In Function TestVolatileFlag, line 11692, RegOpenKeyEx failed
>> > with error 0x2
>> > 103.766: DoInstallation: CleanPFR failed: 0x2
>> > 103.812: SetProductTypes: InfProductBuildType=BuildType.IC
>> > 103.812: SetAltOsLoaderPath: No section uses DirId 65701; done.
>> > 103.875: DoInstallation: FetchSourceURL for
>> > c:\355571f7444f803dcd5cbb7c9951\update\update_SP2G DR.inf failed
>> > 103.875: CreateUninstall = 1,Directory =
>> > C:\WINDOWS\$NtUninstallKB898461$
>> > 103.875: LoadFileQueues: UpdSpGetSourceFileLocation for halaacpi.dll
>> > failed: 0xe0000102
>> > 103.875: LoadFileQueues: QueueMigrationStageFiles failed: 0x00000003
>> > 103.875: InventoryThread: LoadFileQueues failed with error: 0x3
>> > 103.875: Inventory complete: ReturnStatus=3, 0 ticks
>> > 103.875: Num Ticks for invent : 0
>> > 103.937: The system cannot find the path specified.
>> > 115.672: Message displayed to the user: The system cannot find the path
>> > specified.
>> > 115.672: User Input: OK
>> > 115.672: KB898461 installation did not complete.
>> > 117.531: Message displayed to the user: KB898461 installation did not
>> > complete.
>> > 117.531: User Input: OK
>> > 117.531: Update.exe extended error code = 0x3
>> > 117.531: Update.exe return code was masked to 0x643 for MSI custom
>> > action compliance.
>> >
>> > Curiously, KB886185 has failed with similar errors since December
>> > 2004...
>> >
>> > Thanks in advance for any help,
>> > Malc
>> >
>> >



Reply With Quote
  #4 (permalink)  
Old 04-12-2009
Wolverine
 

Posts: n/a
RE: KB898461 consistently fails to install
Hi,

It seems to me that you do not have that dll in your system32 folder. Try
googling for it and download one from the web and try running the command
again. If it gives some other dll missing error, just keep on putting the
relevant dlls in the system32 folder and I don't see why it should not work.

Peace, Wolverine
http://www.funcomputing.co.nr/
http://funcomputing.blogsome.com/

"Gwynevar" wrote:

> I tried your fix and all of them worked okay except for the REGSVR32
> WUAUENG1.DLL. It keeps telling me that it failed because the dll does not
> exist. Do you have any idea how to fix this problem? I have tried several
> different solutions and even reinstalled XP Pro a few times. Nothing seems
> to help and I am pulling my hair out at this point. It's preventing several
> critical updates from coming through and it seems to be interfering with
> other software downloads as well.
>
> "Wolverine" wrote:
>
> > Forgot to mention that I also have posted a blog having the same solution
> > which can be accessed at:
> >
> > http://funcomputing.blogsome.com/200...blem-solution/
> >
> > BR, Wolverine
> >
> > "Malc" wrote:
> >
> > > I'm trying to update a Win XP SP2 installation but since KB898461
> > > failed to install, all subsequent updates have also failed (898461 was
> > > the new update installer). The installation is now 6 months out of
> > > date...
> > >
> > > I've tried downloading the patch and running it locally but it fails
> > > with a MessageBox ("The system cannot find the file specified"). I
> > > don't know which file can't be found; my analysis of the log file is
> > > that several aspects of the installation may have failed.
> > >
> > > Can you help? I've tried setting Windows\CurrentVersion\Setup\LogLevel
> > > to 0x80006060 but I think it didn't add any detail to the log file.
> > > I've tried emptying the DataStore and Download subdirectories in
> > > SoftwareDistribution but it didn't help; neither did running the patch
> > > in safe mode.
> > >
> > > Here's a typical log file.
> > >
> > > 1.641:
> > > ================================================== ==============================
> > > 1.641: 2005/12/26 16:51:58.715 (local)
> > > 1.641: c:\355571f7444f803dcd5cbb7c9951\update\update.exe (version
> > > 6.1.22.4)
> > > 1.656: Hotfix started with following command line: /log:c:\temp\log.txt
> > >
> > > 103.766: In Function TestVolatileFlag, line 11660, RegOpenKeyEx failed
> > > with error 0x2
> > > 103.766: In Function TestVolatileFlag, line 11692, RegOpenKeyEx failed
> > > with error 0x2
> > > 103.766: DoInstallation: CleanPFR failed: 0x2
> > > 103.812: SetProductTypes: InfProductBuildType=BuildType.IC
> > > 103.812: SetAltOsLoaderPath: No section uses DirId 65701; done.
> > > 103.875: DoInstallation: FetchSourceURL for
> > > c:\355571f7444f803dcd5cbb7c9951\update\update_SP2G DR.inf failed
> > > 103.875: CreateUninstall = 1,Directory =
> > > C:\WINDOWS\$NtUninstallKB898461$
> > > 103.875: LoadFileQueues: UpdSpGetSourceFileLocation for halaacpi.dll
> > > failed: 0xe0000102
> > > 103.875: LoadFileQueues: QueueMigrationStageFiles failed: 0x00000003
> > > 103.875: InventoryThread: LoadFileQueues failed with error: 0x3
> > > 103.875: Inventory complete: ReturnStatus=3, 0 ticks
> > > 103.875: Num Ticks for invent : 0
> > > 103.937: The system cannot find the path specified.
> > > 115.672: Message displayed to the user: The system cannot find the path
> > > specified.
> > > 115.672: User Input: OK
> > > 115.672: KB898461 installation did not complete.
> > > 117.531: Message displayed to the user: KB898461 installation did not
> > > complete.
> > > 117.531: User Input: OK
> > > 117.531: Update.exe extended error code = 0x3
> > > 117.531: Update.exe return code was masked to 0x643 for MSI custom
> > > action compliance.
> > >
> > > Curiously, KB886185 has failed with similar errors since December
> > > 2004...
> > >
> > > Thanks in advance for any help,
> > > Malc
> > >
> > >

Reply With Quote
  #5 (permalink)  
Old 04-13-2009
MowGreen
 

Posts: n/a
Re: KB898461 consistently fails to install
Bad idea ! Why not just install the Windows Update Agent from the link
on this MSKB and obtain all of the .dlls from a 'Trusted' Source ?

How to obtain the latest version of the Windows Update Agent to help
manage updates on a computer
http://support.microsoft.com/kb/949104

To replace wuaueng1.dll, either use the copy in
WINDOWS\System32\dllcache or in, leat preferred,
WINDOWS\ServicePackFiles\i386.


MowGreen
===============
*-343-* FDNY
Never Forgotten
===============


Wolverine wrote:

> Hi,
>
> It seems to me that you do not have that dll in your system32 folder. Try
> googling for it and download one from the web and try running the command
> again. If it gives some other dll missing error, just keep on putting the
> relevant dlls in the system32 folder and I don't see why it should not work.
>
> Peace, Wolverine
> http://www.funcomputing.co.nr/
> http://funcomputing.blogsome.com/
>
> "Gwynevar" wrote:
>
>
>>I tried your fix and all of them worked okay except for the REGSVR32
>>WUAUENG1.DLL. It keeps telling me that it failed because the dll does not
>>exist. Do you have any idea how to fix this problem? I have tried several
>>different solutions and even reinstalled XP Pro a few times. Nothing seems
>>to help and I am pulling my hair out at this point. It's preventing several
>>critical updates from coming through and it seems to be interfering with
>>other software downloads as well.
>>
>>"Wolverine" wrote:
>>
>>
>>>Forgot to mention that I also have posted a blog having the same solution
>>>which can be accessed at:
>>>
>>>http://funcomputing.blogsome.com/200...blem-solution/
>>>
>>>BR, Wolverine
>>>
>>>"Malc" wrote:
>>>
>>>
>>>>I'm trying to update a Win XP SP2 installation but since KB898461
>>>>failed to install, all subsequent updates have also failed (898461 was
>>>>the new update installer). The installation is now 6 months out of
>>>>date...
>>>>
>>>>I've tried downloading the patch and running it locally but it fails
>>>>with a MessageBox ("The system cannot find the file specified"). I
>>>>don't know which file can't be found; my analysis of the log file is
>>>>that several aspects of the installation may have failed.
>>>>
>>>>Can you help? I've tried setting Windows\CurrentVersion\Setup\LogLevel
>>>>to 0x80006060 but I think it didn't add any detail to the log file.
>>>>I've tried emptying the DataStore and Download subdirectories in
>>>>SoftwareDistribution but it didn't help; neither did running the patch
>>>>in safe mode.
>>>>
>>>>Here's a typical log file.
>>>>
>>>>1.641:
>>>>============================================== ==================================
>>>>1.641: 2005/12/26 16:51:58.715 (local)
>>>>1.641: c:\355571f7444f803dcd5cbb7c9951\update\update.exe (version
>>>>6.1.22.4)
>>>>1.656: Hotfix started with following command line: /log:c:\temp\log.txt
>>>>
>>>>103.766: In Function TestVolatileFlag, line 11660, RegOpenKeyEx failed
>>>>with error 0x2
>>>>103.766: In Function TestVolatileFlag, line 11692, RegOpenKeyEx failed
>>>>with error 0x2
>>>>103.766: DoInstallation: CleanPFR failed: 0x2
>>>>103.812: SetProductTypes: InfProductBuildType=BuildType.IC
>>>>103.812: SetAltOsLoaderPath: No section uses DirId 65701; done.
>>>>103.875: DoInstallation: FetchSourceURL for
>>>>c:\355571f7444f803dcd5cbb7c9951\update\update_ SP2GDR.inf failed
>>>>103.875: CreateUninstall = 1,Directory =
>>>>C:\WINDOWS\$NtUninstallKB898461$
>>>>103.875: LoadFileQueues: UpdSpGetSourceFileLocation for halaacpi.dll
>>>>failed: 0xe0000102
>>>>103.875: LoadFileQueues: QueueMigrationStageFiles failed: 0x00000003
>>>>103.875: InventoryThread: LoadFileQueues failed with error: 0x3
>>>>103.875: Inventory complete: ReturnStatus=3, 0 ticks
>>>>103.875: Num Ticks for invent : 0
>>>>103.937: The system cannot find the path specified.
>>>>115.672: Message displayed to the user: The system cannot find the path
>>>>specified.
>>>>115.672: User Input: OK
>>>>115.672: KB898461 installation did not complete.
>>>>117.531: Message displayed to the user: KB898461 installation did not
>>>>complete.
>>>>117.531: User Input: OK
>>>>117.531: Update.exe extended error code = 0x3
>>>>117.531: Update.exe return code was masked to 0x643 for MSI custom
>>>>action compliance.
>>>>
>>>>Curiously, KB886185 has failed with similar errors since December
>>>>2004...
>>>>
>>>>Thanks in advance for any help,
>>>>Malc
>>>>
>>>>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
RE: KB898461 consistently fails to install Wolverine microsoft.public.windowsupdate 16 11-16-2008 20:01
Re: KB898461 consistently fails to install Wade microsoft.public.windowsupdate 0 03-01-2008 19:38
RE: Update for Windows XP (KB898461) Cannot install Error Code Ox80070003 any ideas microsoft.public.windowsupdate 0 02-16-2008 17:16
KB898461 Still Won't Install! Nesser microsoft.public.windowsupdate 5 11-20-2007 06:03
RE: cannot install kb898461 frantic mom microsoft.public.windowsupdate 0 11-03-2007 23:47




All times are GMT +1. The time now is 09:41.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120