Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

service pack 2 install fail

microsoft.public.windowsupdate






Speedup My PC
Reply
  #1 (permalink)  
Old 01-11-2008
Eric
 

Posts: n/a
service pack 2 install fail
When installing service pack 2, I get the dreaded ‘Access is Denied” error
Error code: 80070005
‘Service pack 2 installation did not complete’
‘Windows server 2003 has been partially updated and may not work properally’

My Os is exchange 2003-32bit

I tried to follow the fix in kb873148 give to another post and no reg key
was given
(segment copy of setupapi log)
#I054 Interfaces installed.
#-166 Device install function: DIF_INSTALLDEVICE.
#I123 Doing full install of "USB\VID_046D&PID_0840\5&DF80ACA&2&2".
#E008 Setting registry value
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run Once\OVCOMSReg
#E033 Error 1459: This operation requires an interactive window station.
#E065 Parsing AddReg section [RunOnce.AddReg] in "c:\windows\inf\ovcam.inf"
failed. Error 1459: This operation requires an interactive window station.
#E064 Parsing install section [PID_0840.NT] in "c:\windows\inf\ovcam.inf"
failed. Error 1459: This operation requires an interactive window station.
#E122 Device install failed. Error 1459: This operation requires an
interactive window station.
#E154 Class installer failed. Error 0xe000022b: The class installer has
denied the request to install or upgrade this device.
[2007/03/16 18:25:35 656.540]
#-198 Command line processed: "C:\WINDOWS\system32\mmc.exe"
C:\WINDOWS\system32\devmgmt.msc
#-148 Loading coinstaller modules for "Lucent Win Modem".
#W360 An unsigned, incorrectly signed, or Authenticode(tm) signed file
"C:\WINDOWS\system32\setup\FxsOcm.dll" for driver "Lucent Win Modem" will be
installed (Policy=Ignore). Error 5: Access is denied.
#E144 Loading module "C:\WINDOWS\system32\setup\FxsOcm.dll" failed. Error 5:
Access is denied.

Service pack 2 couldn’t fail due to a modem driver? So I checked the svcpack
log
it says:"window media services is not present"

(segment copy of svcpack log)
6.360: Windows Media Services is Not Present
6.360: First Condition in Non.KN.Condition.Section Succeeded
6.360: Condition succeeded for section Non.KN.Condition.Section in Line 1 of
Non.KN.Help.ExtendedConditional.Advanced

this part may answer the problem

6.766: DoInstallation:UpdSpOpenInfFile for OldUninstallInf file
C:\WINDOWS\$NtServicePackUninstall$\spuninst\spuni nst.inf not found: 0x3
6.766: CreateUninstall = 1,Directory = C:\WINDOWS\$NtServicePackUninstall$
14.938: CheckRegistryValue: Registry - Inf integer values mismatch
15.375: ref tag c:\windows\driver cache\i386\sp2.cab does not exist
15.406: ref tag c:\windows\servicepackfiles\i386\sp2.cab does not exist
15.610: Starting AnalyzeComponents
15.610: AnalyzePhaseZero used 0 ticks

20.453: Condition succeeded for section Non.KN.Condition.Section in Line 1
of Non.KN.Help.ExtendedConditional.Advanced
20.453: Windows Media Services is Not Present
20.453: Fist Condition in KN.Condition.Section Failed
20.453: Condition Check for Line 1 of KN.Help.ExtendedConditional.Advanced
returned FALSE
20.469: Express: 87,549,013 bytes were downloaded.

2.188: HotfixRefreshRequired is Not Present
2.188: First Condition in HotfixRefresh.Registry.Check.Section Succeeded
2.188: Condition succeeded for section HotfixRefresh.Registry.Check.Section
in Line 10 of PreRequisite
10.469: In Function TestVolatileFlag, line 12013, RegOpenKeyEx failed with
error 0x2
10.469: In Function TestVolatileFlag, line 12045, RegOpenKeyEx failed with
error 0x2
10.469: DoInstallation: CleanPFR failed: 0x2
10.469: In Function GetBuildType, line 1170, RegQueryValueEx failed with
error 0x2
10.469: SetProductTypes: InfProductBuildType=BuildType.IA
10.485: SetAltOsLoaderPath: No section uses DirId 65701; done.
10.563: GetGenericPathNameWithRoot: Unable to open HKLM,
SOFTWARE\Microsoft\ADMT, 0x2.
10.563: SetDynamicDirectoryId: Failure while generating dynamic path, 0xf111
10.578: R2BuildNumber is Not Present

399.844: Enumerating Devices of Unknown, GUID
{4D36E97E-E325-11CE-BFC1-08002BE10318}
408.531: Copied file: C:\WINDOWS\system32\spmsg.dll
411.656: PFE2: Per File Exceptions will not be used.
411.750: GetCatVersion: Failed to retrieve version information from
C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.scw.cat with error 0x57
411.750: GetCatVersion: Failed to retrieve version information from
C:\WINDOWS\Tmp.0.scw.cat with error 0x80092004
413.672: GetCatVersion: Failed to retrieve version information from
C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.sasetup.cat with error 0x57

399.844: Enumerating Devices of Unknown, GUID
{4D36E97E-E325-11CE-BFC1-08002BE10318}
408.531: Copied file: C:\WINDOWS\system32\spmsg.dll
411.656: PFE2: Per File Exceptions will not be used.
411.750: GetCatVersion: Failed to retrieve version information from
C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.scw.cat with error 0x57
411.750: GetCatVersion: Failed to retrieve version information from
C:\WINDOWS\Tmp.0.scw.cat with error 0x80092004
413.672: GetCatVersion: Failed to retrieve version information from
C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.sasetup.cat with error 0x57

1296.125: Update.exe extended error code = 0x5

I need a fix to the problem as I want to install service pack 2 so that I
can install third party software that risks corrupting the system again

Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 01-11-2008
Eric
 

Posts: n/a
RE: service pack 2 install fail
adding to message

I had installed successfully service pack 2 with media player 10 and some
updates (on Dec 26th).
This currupted various parts of my system including WMP10 and the add/remove
windows components. I finally found a fix for the add/remove compnents and
WMS are installed and the A/R components are working fine

noumerous times i have since attempted to install service pack 2 since then
all with the same error.

anyone?

"Eric" wrote:

> When installing service pack 2, I get the dreaded ‘Access is Denied” error
> Error code: 80070005
> ‘Service pack 2 installation did not complete’
> ‘Windows server 2003 has been partially updated and may not work properally’
>
> My Os is exchange 2003-32bit
>
> I tried to follow the fix in kb873148 give to another post and no reg key
> was given
> (segment copy of setupapi log)
> #I054 Interfaces installed.
> #-166 Device install function: DIF_INSTALLDEVICE.
> #I123 Doing full install of "USB\VID_046D&PID_0840\5&DF80ACA&2&2".
> #E008 Setting registry value
> HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run Once\OVCOMSReg
> #E033 Error 1459: This operation requires an interactive window station.
> #E065 Parsing AddReg section [RunOnce.AddReg] in "c:\windows\inf\ovcam.inf"
> failed. Error 1459: This operation requires an interactive window station.
> #E064 Parsing install section [PID_0840.NT] in "c:\windows\inf\ovcam.inf"
> failed. Error 1459: This operation requires an interactive window station.
> #E122 Device install failed. Error 1459: This operation requires an
> interactive window station.
> #E154 Class installer failed. Error 0xe000022b: The class installer has
> denied the request to install or upgrade this device.
> [2007/03/16 18:25:35 656.540]
> #-198 Command line processed: "C:\WINDOWS\system32\mmc.exe"
> C:\WINDOWS\system32\devmgmt.msc
> #-148 Loading coinstaller modules for "Lucent Win Modem".
> #W360 An unsigned, incorrectly signed, or Authenticode(tm) signed file
> "C:\WINDOWS\system32\setup\FxsOcm.dll" for driver "Lucent Win Modem" will be
> installed (Policy=Ignore). Error 5: Access is denied.
> #E144 Loading module "C:\WINDOWS\system32\setup\FxsOcm.dll" failed. Error 5:
> Access is denied.
>
> Service pack 2 couldn’t fail due to a modem driver? So I checked the svcpack
> log
> it says:"window media services is not present"
>
> (segment copy of svcpack log)
> 6.360: Windows Media Services is Not Present
> 6.360: First Condition in Non.KN.Condition.Section Succeeded
> 6.360: Condition succeeded for section Non.KN.Condition.Section in Line 1 of
> Non.KN.Help.ExtendedConditional.Advanced
> …
> this part may answer the problem
>
> 6.766: DoInstallation:UpdSpOpenInfFile for OldUninstallInf file
> C:\WINDOWS\$NtServicePackUninstall$\spuninst\spuni nst.inf not found: 0x3
> 6.766: CreateUninstall = 1,Directory = C:\WINDOWS\$NtServicePackUninstall$
> 14.938: CheckRegistryValue: Registry - Inf integer values mismatch
> 15.375: ref tag c:\windows\driver cache\i386\sp2.cab does not exist
> 15.406: ref tag c:\windows\servicepackfiles\i386\sp2.cab does not exist
> 15.610: Starting AnalyzeComponents
> 15.610: AnalyzePhaseZero used 0 ticks
> …
> 20.453: Condition succeeded for section Non.KN.Condition.Section in Line 1
> of Non.KN.Help.ExtendedConditional.Advanced
> 20.453: Windows Media Services is Not Present
> 20.453: Fist Condition in KN.Condition.Section Failed
> 20.453: Condition Check for Line 1 of KN.Help.ExtendedConditional.Advanced
> returned FALSE
> 20.469: Express: 87,549,013 bytes were downloaded.
> …
> 2.188: HotfixRefreshRequired is Not Present
> 2.188: First Condition in HotfixRefresh.Registry.Check.Section Succeeded
> 2.188: Condition succeeded for section HotfixRefresh.Registry.Check.Section
> in Line 10 of PreRequisite
> 10.469: In Function TestVolatileFlag, line 12013, RegOpenKeyEx failed with
> error 0x2
> 10.469: In Function TestVolatileFlag, line 12045, RegOpenKeyEx failed with
> error 0x2
> 10.469: DoInstallation: CleanPFR failed: 0x2
> 10.469: In Function GetBuildType, line 1170, RegQueryValueEx failed with
> error 0x2
> 10.469: SetProductTypes: InfProductBuildType=BuildType.IA
> 10.485: SetAltOsLoaderPath: No section uses DirId 65701; done.
> 10.563: GetGenericPathNameWithRoot: Unable to open HKLM,
> SOFTWARE\Microsoft\ADMT, 0x2.
> 10.563: SetDynamicDirectoryId: Failure while generating dynamic path, 0xf111
> 10.578: R2BuildNumber is Not Present
> …
> 399.844: Enumerating Devices of Unknown, GUID
> {4D36E97E-E325-11CE-BFC1-08002BE10318}
> 408.531: Copied file: C:\WINDOWS\system32\spmsg.dll
> 411.656: PFE2: Per File Exceptions will not be used.
> 411.750: GetCatVersion: Failed to retrieve version information from
> C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.scw.cat with error 0x57
> 411.750: GetCatVersion: Failed to retrieve version information from
> C:\WINDOWS\Tmp.0.scw.cat with error 0x80092004
> 413.672: GetCatVersion: Failed to retrieve version information from
> C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.sasetup.cat with error 0x57
> …
> 399.844: Enumerating Devices of Unknown, GUID
> {4D36E97E-E325-11CE-BFC1-08002BE10318}
> 408.531: Copied file: C:\WINDOWS\system32\spmsg.dll
> 411.656: PFE2: Per File Exceptions will not be used.
> 411.750: GetCatVersion: Failed to retrieve version information from
> C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.scw.cat with error 0x57
> 411.750: GetCatVersion: Failed to retrieve version information from
> C:\WINDOWS\Tmp.0.scw.cat with error 0x80092004
> 413.672: GetCatVersion: Failed to retrieve version information from
> C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.sasetup.cat with error 0x57
> …
> 1296.125: Update.exe extended error code = 0x5
>
> I need a fix to the problem as I want to install service pack 2 so that I
> can install third party software that risks corrupting the system again
>

Reply With Quote
  #3 (permalink)  
Old 01-12-2008
MowGreen [MVP]
 

Posts: n/a
Re: service pack 2 install fail
Cross posted for poster's convenience to:
Windows Server - General newsgroup

news://msnews.microsoft.com/microsof...server.general
[ for OE ]

http://www.microsoft.com/technet/com...rver.ge neral
[ Browser based newsgroup view ]

It would be best to post this issue to the Windows Server - General
newsgroup, Eric.
BTW, the OS is Windows Server 2003.


MowGreen [MVP 2003-2008]
===============
*-343-* FDNY
Never Forgotten
===============


Eric wrote:

> When installing service pack 2, I get the dreaded ‘Access is Denied” error
> Error code: 80070005
> ‘Service pack 2 installation did not complete’
> ‘Windows server 2003 has been partially updated and may not work properally’
>
> My Os is exchange 2003-32bit
>
> I tried to follow the fix in kb873148 give to another post and no reg key
> was given
> (segment copy of setupapi log)
> #I054 Interfaces installed.
> #-166 Device install function: DIF_INSTALLDEVICE.
> #I123 Doing full install of "USB\VID_046D&PID_0840\5&DF80ACA&2&2".
> #E008 Setting registry value
> HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run Once\OVCOMSReg
> #E033 Error 1459: This operation requires an interactive window station.
> #E065 Parsing AddReg section [RunOnce.AddReg] in "c:\windows\inf\ovcam.inf"
> failed. Error 1459: This operation requires an interactive window station.
> #E064 Parsing install section [PID_0840.NT] in "c:\windows\inf\ovcam.inf"
> failed. Error 1459: This operation requires an interactive window station.
> #E122 Device install failed. Error 1459: This operation requires an
> interactive window station.
> #E154 Class installer failed. Error 0xe000022b: The class installer has
> denied the request to install or upgrade this device.
> [2007/03/16 18:25:35 656.540]
> #-198 Command line processed: "C:\WINDOWS\system32\mmc.exe"
> C:\WINDOWS\system32\devmgmt.msc
> #-148 Loading coinstaller modules for "Lucent Win Modem".
> #W360 An unsigned, incorrectly signed, or Authenticode(tm) signed file
> "C:\WINDOWS\system32\setup\FxsOcm.dll" for driver "Lucent Win Modem" will be
> installed (Policy=Ignore). Error 5: Access is denied.
> #E144 Loading module "C:\WINDOWS\system32\setup\FxsOcm.dll" failed. Error 5:
> Access is denied.
>
> Service pack 2 couldn’t fail due to a modem driver? So I checked the svcpack
> log
> it says:"window media services is not present"
>
> (segment copy of svcpack log)
> 6.360: Windows Media Services is Not Present
> 6.360: First Condition in Non.KN.Condition.Section Succeeded
> 6.360: Condition succeeded for section Non.KN.Condition.Section in Line 1 of
> Non.KN.Help.ExtendedConditional.Advanced
> …
> this part may answer the problem
>
> 6.766: DoInstallation:UpdSpOpenInfFile for OldUninstallInf file
> C:\WINDOWS\$NtServicePackUninstall$\spuninst\spuni nst.inf not found: 0x3
> 6.766: CreateUninstall = 1,Directory = C:\WINDOWS\$NtServicePackUninstall$
> 14.938: CheckRegistryValue: Registry - Inf integer values mismatch
> 15.375: ref tag c:\windows\driver cache\i386\sp2.cab does not exist
> 15.406: ref tag c:\windows\servicepackfiles\i386\sp2.cab does not exist
> 15.610: Starting AnalyzeComponents
> 15.610: AnalyzePhaseZero used 0 ticks
> …
> 20.453: Condition succeeded for section Non.KN.Condition.Section in Line 1
> of Non.KN.Help.ExtendedConditional.Advanced
> 20.453: Windows Media Services is Not Present
> 20.453: Fist Condition in KN.Condition.Section Failed
> 20.453: Condition Check for Line 1 of KN.Help.ExtendedConditional.Advanced
> returned FALSE
> 20.469: Express: 87,549,013 bytes were downloaded.
> …
> 2.188: HotfixRefreshRequired is Not Present
> 2.188: First Condition in HotfixRefresh.Registry.Check.Section Succeeded
> 2.188: Condition succeeded for section HotfixRefresh.Registry.Check.Section
> in Line 10 of PreRequisite
> 10.469: In Function TestVolatileFlag, line 12013, RegOpenKeyEx failed with
> error 0x2
> 10.469: In Function TestVolatileFlag, line 12045, RegOpenKeyEx failed with
> error 0x2
> 10.469: DoInstallation: CleanPFR failed: 0x2
> 10.469: In Function GetBuildType, line 1170, RegQueryValueEx failed with
> error 0x2
> 10.469: SetProductTypes: InfProductBuildType=BuildType.IA
> 10.485: SetAltOsLoaderPath: No section uses DirId 65701; done.
> 10.563: GetGenericPathNameWithRoot: Unable to open HKLM,
> SOFTWARE\Microsoft\ADMT, 0x2.
> 10.563: SetDynamicDirectoryId: Failure while generating dynamic path, 0xf111
> 10.578: R2BuildNumber is Not Present
> …
> 399.844: Enumerating Devices of Unknown, GUID
> {4D36E97E-E325-11CE-BFC1-08002BE10318}
> 408.531: Copied file: C:\WINDOWS\system32\spmsg.dll
> 411.656: PFE2: Per File Exceptions will not be used.
> 411.750: GetCatVersion: Failed to retrieve version information from
> C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.scw.cat with error 0x57
> 411.750: GetCatVersion: Failed to retrieve version information from
> C:\WINDOWS\Tmp.0.scw.cat with error 0x80092004
> 413.672: GetCatVersion: Failed to retrieve version information from
> C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.sasetup.cat with error 0x57
> …
> 399.844: Enumerating Devices of Unknown, GUID
> {4D36E97E-E325-11CE-BFC1-08002BE10318}
> 408.531: Copied file: C:\WINDOWS\system32\spmsg.dll
> 411.656: PFE2: Per File Exceptions will not be used.
> 411.750: GetCatVersion: Failed to retrieve version information from
> C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.scw.cat with error 0x57
> 411.750: GetCatVersion: Failed to retrieve version information from
> C:\WINDOWS\Tmp.0.scw.cat with error 0x80092004
> 413.672: GetCatVersion: Failed to retrieve version information from
> C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.sasetup.cat with error 0x57
> …
> 1296.125: Update.exe extended error code = 0x5
>
> I need a fix to the problem as I want to install service pack 2 so that I
> can install third party software that risks corrupting the system again
>

Reply With Quote
  #4 (permalink)  
Old 01-12-2008
Ace Fekay [MVP]
 

Posts: n/a
Re: service pack 2 install fail
In news:%23w3sApKVIHA.3400@TK2MSFTNGP03.phx.gbl,
MowGreen [MVP] <mowgreen@nowandzen.com> typed:
> Cross posted for poster's convenience to:
> Windows Server - General newsgroup


> Eric wrote:
>
> > When installing service pack 2, I get the dreaded 'Access is
> > Denied" error Error code: 80070005
> > 'Service pack 2 installation did not complete'
> > 'Windows server 2003 has been partially updated and may not work
> > properally'


<snipped>

> > I need a fix to the problem as I want to install service pack 2 so
> > that I can install third party software that risks corrupting the system
> > again



It sounds like security was increased on this machine via a GPO or a third
party software is installed restricting it.

Try this:
You receive an error message when you try to install Windows XP Service Pack
2 or Windows Server 2003 Service Pack 1: "Access is denied"
http://support.microsoft.com/kb/873148

--
Regards,
Ace

This posting is provided "AS-IS" with no warranties or guarantees and
confers no rights.

Ace Fekay, MCSE 2003 & 2000, MCSA 2003 & 2000, MCSE+I, MCT,
MVP Microsoft MVP - Directory Services
Microsoft Certified Trainer

Infinite Diversities in Infinite Combinations


Reply With Quote
  #5 (permalink)  
Old 01-12-2008
Eric
 

Posts: n/a
Re: service pack 2 install fail
all ready been there, no hex value in the setupapi log as shown in my initial
post

"Ace Fekay [MVP]" wrote:

> In news:%23w3sApKVIHA.3400@TK2MSFTNGP03.phx.gbl,
> MowGreen [MVP] <mowgreen@nowandzen.com> typed:
> > Cross posted for poster's convenience to:
> > Windows Server - General newsgroup

>
> > Eric wrote:
> >
> > > When installing service pack 2, I get the dreaded 'Access is
> > > Denied" error Error code: 80070005
> > > 'Service pack 2 installation did not complete'
> > > 'Windows server 2003 has been partially updated and may not work
> > > properally'

>
> <snipped>
>
> > > I need a fix to the problem as I want to install service pack 2 so
> > > that I can install third party software that risks corrupting the system
> > > again

>
>
> It sounds like security was increased on this machine via a GPO or a third
> party software is installed restricting it.
>
> Try this:
> You receive an error message when you try to install Windows XP Service Pack
> 2 or Windows Server 2003 Service Pack 1: "Access is denied"
> http://support.microsoft.com/kb/873148
>
> --
> Regards,
> Ace
>
> This posting is provided "AS-IS" with no warranties or guarantees and
> confers no rights.
>
> Ace Fekay, MCSE 2003 & 2000, MCSA 2003 & 2000, MCSE+I, MCT,
> MVP Microsoft MVP - Directory Services
> Microsoft Certified Trainer
>
> Infinite Diversities in Infinite Combinations
>
>
>

Reply With Quote
  #6 (permalink)  
Old 01-12-2008
Ace Fekay [MVP]
 

Posts: n/a
Re: service pack 2 install fail
In news:48FF29E7-F900-4321-96A7-2A01577146BA@microsoft.com,
Eric <Eric@discussions.microsoft.com> typed:
> all ready been there, no hex value in the setupapi log as shown in my
> initial post


Sorry, saw that you tried that article.

Were the default drive permissions altered perhaps for increased security
such as removing the Everyone group? Reason why I ask is because of this
passage in the error log then everything just snowballed after that:
> 15.375: ref tag c:\windows\driver cache\i386\sp2.cab does not exist
> 15.406: ref tag c:\windows\servicepackfiles\i386\sp2.cab does not exist


Or how about these?

How to reset security settings back to the defaults:
http://support.microsoft.com/default...b;EN-US;313222

It could also be something simple as the clocks are not synched up and it is
failing authentication. Are you seeing any W32Time errors in the event logs?
Kerberos authentication uses the clock as one of the checks to insure the
authentication traffic is not being replayed. Are you having other problems
such as netlogon issues on the DC? Are you only pointing to your internal
DNS server in all of your machines or is there an ISP's DNS address in your
machine's IP properties?

If error 0x8DDD0002
You receive an "Administrators only" error message when you try to visit the
Windows Update Web site or the Microsoft Update Web site:
http://support.microsoft.com/?id=316524

Ace


Reply With Quote
  #7 (permalink)  
Old 01-14-2008
Eric
 

Posts: n/a
Re: service pack 2 install fail
you were right on with thisone. my everyone group was ghost.
thanx


"Ace Fekay [MVP]" wrote:

> In news:48FF29E7-F900-4321-96A7-2A01577146BA@microsoft.com,
> Eric <Eric@discussions.microsoft.com> typed:
> > all ready been there, no hex value in the setupapi log as shown in my
> > initial post

>
> Sorry, saw that you tried that article.
>
> Were the default drive permissions altered perhaps for increased security
> such as removing the Everyone group? Reason why I ask is because of this
> passage in the error log then everything just snowballed after that:
> > 15.375: ref tag c:\windows\driver cache\i386\sp2.cab does not exist
> > 15.406: ref tag c:\windows\servicepackfiles\i386\sp2.cab does not exist

>
> Or how about these?
>
> How to reset security settings back to the defaults:
> http://support.microsoft.com/default...b;EN-US;313222
>
> It could also be something simple as the clocks are not synched up and it is
> failing authentication. Are you seeing any W32Time errors in the event logs?
> Kerberos authentication uses the clock as one of the checks to insure the
> authentication traffic is not being replayed. Are you having other problems
> such as netlogon issues on the DC? Are you only pointing to your internal
> DNS server in all of your machines or is there an ISP's DNS address in your
> machine's IP properties?
>
> If error 0x8DDD0002
> You receive an "Administrators only" error message when you try to visit the
> Windows Update Web site or the Microsoft Update Web site:
> http://support.microsoft.com/?id=316524
>
> Ace
>
>
>

Reply With Quote
  #8 (permalink)  
Old 01-14-2008
Ace Fekay [MVP]
 

Posts: n/a
Re: service pack 2 install fail
In news:AB1A4169-1566-45FA-80B4-25B28966405D@microsoft.com,
Eric <Eric@discussions.microsoft.com> typed:
> you were right on with thisone. my everyone group was ghost.
> thanx


Yep,that will do it all the time, along with other problems. Actually, and
funny that the Everyone group needs to stay there. Just finite the
permissions on everything else, except the Windows folder.

I know you are trying to be security conscience, but there are other ways to
tighten up security, with security templates.

Here are more issues that can arise with altering default drive permissions.

Systems that have changed the default Access Control List permissions on the
%windir%\registration directory may experience various problems after you
install the Microsoft Security Bulletin MS05-051 (KB902400) for COM+ and MS
DTC
http://support.microsoft.com/kb/909444

For specific info, see:
http://blogs.technet.com/steriley/ar...08/414002.aspx
Here's an issue that comes up with removing Everyone off of the windows
folder:

Ace


Reply With Quote
  #9 (permalink)  
Old 01-25-2008
Calven
 

Posts: n/a
RE: service pack 2 install fail
The issue may occur if one of the following factors is true:

1. Security programs running in the background interfere with the
installation of Windows Updates.
2. The permission settings in the System Files and registry are inappropriate.

Let's take the following steps to troubleshoot this issue.

Suggestion 1: Temporarily disable the security programs for troubleshooting
purposes only
================================================== =================
Let's first ensure that any Spy Sweeper or firewall programs you have
running are not interfering with Windows Update. Even though you may have had
a Spy Sweeper/firewall accelerator running for some time without any previous
problems accessing Windows Update, new updates for these programs can create
unforeseen issues. For your convenience I have listed some of the more common
applications which may cause conflicts with Windows Update below.

Spy Sweeper
Sygate Personal Firewall
Norton Internet Security
Freedom Firewall
Zone Alarm Firewall

To determine if the above applications are causing the issue, please
temporarily turn them off and see if you can now access the Microsoft Windows
Update website. Please ensure the program is re-enabled after we complete the
troubleshooting steps.

If this issue appears to be related to a firewall program, I recommend that
you contact the firewall manufacturer to obtain the information to configure
the firewall options which allow access to the Windows Update site.

Suggestion 2: Reset permissions
========================
This step will reset the permission settings on this system, which may take
some time. Your patience is highly appreciated.

Step 1: Download SubInACL (SubInACL.exe)
-----------------------------------------
1. Please download the subinacl.msi from the following link and save the
installation patch on the Desktop:

http://www.microsoft.com/downloads/d...inityDownloads

2. Please go to the Desktop and double click the downloaded file to install
it.
3. Please select C:\Windows\System32 as the destination folder during the
installation (Note: We assume C:\ is the system partition). Later we will use
this tool to reset the current permission settings on the machine.

Step 2:
-------
1. Click Start, Run, type: notepad C:\reset.cmd and press Enter. Choose Yes
when you are prompted.
2. Copy the following commands and then paste them into the opened Notepad
window:

@echo off

subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f

subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=system=f

@Echo =========================
@Echo Finished.
@Echo =========================
@pause

3. After pasting the above commands, please close the Notepad window. Choose
Yes when prompted to save the file.
4. Click Start, Run, type: C:\reset.cmd and press Enter to run the commands
pasted.
5. You will see a DOS-like window processing the request.

(NOTE: This step may take several minutes, please be patient. When it is
finished, you will be prompted with "Finished, press any key to continue".)

Best Regards,

Calven


Reply With Quote
  #10 (permalink)  
Old 09-08-2010
Smiling Carcass's Avatar  

Join Date: Sep 2010
Location: UK
Posts: 4
Smiling Carcass is on a distinguished road
Thanks: 0
Thanked 1 Time in 1 Post
Re: service pack 2 install fail
I arrived here because I was having the this action requires an interactive window station error while trying to install my Synaptics touch pad driver. Thanks to Calven. Your resetting permissions allowed Vista to automatically install the driver.

Anybody with this problem should try this. Ill be happy to stand corrected, but if you re-set permissions I cannot see it causing problems. I decided to try it because I am a tinkerer and realised it could work and probably couldnt hurt.

Thanks again, Calven.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
windows xp service pack 3 will not install julia_jones59 microsoft.public.windowsupdate 11 01-31-2008 16:37
Office xp service pack 3 will not install bean microsoft.public.windowsupdate 5 01-09-2008 18:25
Vista Service Pack 1 install Ravel36 microsoft.public.windows.vista.performance maintenance 3 01-05-2008 17:59
can't install service pack 3 roro microsoft.public.windowsupdate 4 12-28-2007 02:28
Re: Microsoft XML Core Services 4.0 Service Pack 2 (KB936181) fail dianastarmurray@gmail.com microsoft.public.windowsupdate 0 11-06-2007 03:44




All times are GMT +1. The time now is 00:43.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120