Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Re: Windows Installer 3.1 Won't Install

microsoft.public.windowsupdate






Speedup My PC
Reply
  #1 (permalink)  
Old 12-08-2007
Sulian
 

Posts: n/a
Re: Windows Installer 3.1 Won't Install
Hi,

I am now getting this problem with Installer 3.1

I deleted some files yesterday (WMP operating files) that meant I had to
repair XP using the setup CD, all worked ok and the system is fine apart from
this issue.

I ran SubInACL tool and that appeared to run ok but the problem persists.

I then ran through your second suggestion, located the system32 folder and
then found that there were two CatRoot folders; CatRoot and CatRoot2.

I clicked on properties on both files but no 'Security' tab appeared on
either file so I was unable to continue.

As this thread is several months old and I always have automatic updates
turned on I can only assume that it uploaded ok when first released and that
repairing XP has caused a problem.

Any advice you could give that may resolve this issue would be greatly
appreciated.

Thanks
Sulian






"MowGreen [MVP]" wrote:

> Repair file and registry permissions by following the steps laid out here :
>
> Solving setup errors by using the SubInACL tool to repair file and
> registry permissions
> http://blogs.msdn.com/astebner/archi...04/739820.aspx
>
> Or, you could try this ... if this is XP Home Edition restart the system
> to Safe Mode and log on with the Administrator account [if this is XP
> Pro then skip this step and go on to the next section]
>
> Show hidden files, folders, and system files:
> http://www.bleepingcomputer.com/tuto...l62.html#winxp
>
> Using Windows Explorer [Start > Programs > Accessories > Windows
> Explorer] navigate to
>
> WINDOWS\system32\CatRoot
>
> Right click CatRoot and choose Properties
> Click the Security tab
> Click on SYSTEM
> Under Permissions for SYSTEM, these boxes should be checked for Allow
>
> Full Control
> Modify
> Read & Execute
> List Folder Contents
> Read
> Write
>
> If they are all not checked, then do so and click the Apply button
> Then click the Advanced button
> The Permissions page should now be open
>
> Click on SYSTEM
> The 'Apply To' heading for SYSTEM should be showing
> " This folder, subfolders, and files "
>
> That's where the contents of the CatRoot folder derive their Permissions
> from
> With SYSTEM highlighted, click the Edit button
> All of the Permissions should be checked for SYSTEM
> IF SYSTEM is not showing " This folder, subfolders, and files ", then
> this where you can set it to that by clicking the dropdown window next
> to ' Apply onto: '
> All of the Permissions for SYSTEM should be checked
> If not, check them and click OK, then Apply, then OK once more
> If the Apply button is showing for the CatRoot Properties window,
> then click it and then click OK
> Restart the system back to normal Windows mode, if XP Home, or just
> restart the system if XP Pro.
>
> Did that resolve the Windows Installer installation isssue ?
>
> MowGreen [MVP 2003-2007]
> ===============
> *-343-* FDNY
> Never Forgotten
> ===============
>
>
> RandyH wrote:
>
> > Looks like registry update is failing for some reason - any clues?
> >
> >
> > 0.391: 2007/07/24 09:56:19.183 (local)
> > 0.391: c:\770f192fe847b94972bf6be452461c7b\UPDATE\update. exe (version
> > 6.1.22.4)
> > 0.407: Hotfix started with following command line: /quiet /norestart
> > 3.891: In Function TestVolatileFlag, line 11660, RegOpenKeyEx failed with
> > error 0x2
> > 3.891: In Function TestVolatileFlag, line 11692, RegOpenKeyEx failed with
> > error 0x2
> > 3.891: DoInstallation: CleanPFR failed: 0x2
> > 4.063: SetProductTypes: InfProductBuildType=BuildType.IP
> > 4.063: SetAltOsLoaderPath: No section uses DirId 65701; done.
> > 4.219: DoInstallation: FetchSourceURL for
> > c:\770f192fe847b94972bf6be452461c7b\update\update_ wxp.inf failed
> > 4.219: CreateUninstall = 1,Directory = C:\WINDOWS\$MSI31Uninstall_KB893803v2$
> > 4.219: LoadFileQueues: UpdSpGetSourceFileLocation for halaacpi.dll failed:
> > 0xe0000102
> > 4.235: BuildCabinetManifest: update.url absent
> > 4.235: Starting AnalyzeComponents
> > 4.235: AnalyzePhaseZero used 0 ticks
> > 4.235: No c:\windows\INF\updtblk.inf file.
> > 4.235: SetupFindFirstLine in LoadExclusionList Failed with error: 0xe0000102
> > 4.235: SetupFindFirstLine in LoadExclusionList Failed with error: 0xe0000102
> > 24.954: Third Party Provider = Intel for
> > PCI\VEN_8086&DEV_2448&SUBSYS_00000000&REV_D4\3&267 A616A&0&F0
> > 25.516: Third Party Provider = Intel for
> > PCI\VEN_8086&DEV_2590&SUBSYS_00000000&REV_03\3&267 A616A&0&00
> > 25.813: Third Party Provider = Intel for
> > PCI\VEN_8086&DEV_2591&SUBSYS_00000000&REV_03\3&267 A616A&0&08
> > 26.141: Third Party Provider = Intel for
> > PCI\VEN_8086&DEV_2641&SUBSYS_00000000&REV_04\3&267 A616A&0&F8
> > 26.766: Third Party Provider = Intel for
> > PCI\VEN_8086&DEV_2653&SUBSYS_81BA104D&REV_04\3&267 A616A&0&FA
> > 27.360: Third Party Provider = Intel for
> > PCI\VEN_8086&DEV_2658&SUBSYS_81B9104D&REV_04\3&267 A616A&0&E8
> > 27.579: Third Party Provider = Intel for
> > PCI\VEN_8086&DEV_2659&SUBSYS_81B9104D&REV_04\3&267 A616A&0&E9
> > 27.907: Third Party Provider = Intel for
> > PCI\VEN_8086&DEV_265A&SUBSYS_81B9104D&REV_04\3&267 A616A&0&EA
> > 28.329: Third Party Provider = Intel for
> > PCI\VEN_8086&DEV_265B&SUBSYS_81B9104D&REV_04\3&267 A616A&0&EB
> > 28.704: Third Party Provider = Intel for
> > PCI\VEN_8086&DEV_265C&SUBSYS_81B9104D&REV_04\3&267 A616A&0&EF
> > 29.063: Third Party Provider = Intel for
> > PCI\VEN_8086&DEV_266A&SUBSYS_81B9104D&REV_04\3&267 A616A&0&FB
> > 29.500: Third Party Provider = Intel for
> > PCI\VEN_8086&DEV_266F&SUBSYS_81B9104D&REV_04\3&267 A616A&0&F9
> > 30.844:
> > C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem15.CAT
> > trusts inf c:\windows\inf\oem15.inf of device ROOT\CNTX_VPCNETS2_MP\0000
> > 31.016:
> > C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem15.CAT
> > trusts inf c:\windows\inf\oem15.inf of device ROOT\CNTX_VPCNETS2_MP\0001
> > 31.188:
> > C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem15.CAT
> > trusts inf c:\windows\inf\oem15.inf of device ROOT\CNTX_VPCNETS2_MP\0002
> > 31.360:
> > C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem15.CAT
> > trusts inf c:\windows\inf\oem15.inf of device ROOT\CNTX_VPCNETS2_MP\0003
> > 31.954:
> > C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem18.CAT
> > trusts inf c:\windows\inf\oem18.inf of device ROOT\DNI_DNEMP\0000
> > 32.110:
> > C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem18.CAT
> > trusts inf c:\windows\inf\oem18.inf of device ROOT\DNI_DNEMP\0001
> > 32.297:
> > C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem18.CAT
> > trusts inf c:\windows\inf\oem18.inf of device ROOT\DNI_DNEMP\0002
> > 32.485:
> > C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem18.CAT
> > trusts inf c:\windows\inf\oem18.inf of device ROOT\DNI_DNEMP\0003
> > 32.797:
> > C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem18.CAT
> > trusts inf c:\windows\inf\oem18.inf of device ROOT\DNI_DNEMP\0004
> > 32.985:
> > C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem18.CAT
> > trusts inf c:\windows\inf\oem18.inf of device ROOT\DNI_DNEMP\0005
> > 33.094: Failed to query DriverPath of ROOT\LEGACY_GEARSECURITY\0000 0x2
> > 33.094: Failed to query DriverPath of ROOT\LEGACY_SYMIDSCO\0000 0x2
> > 33.094: Failed to query DriverPath of ROOT\LEGACY_V2IMOUNT\0000 0x2
> > 46.813: OEM file scan used 42578 ticks
> > 47.813: AnalyzePhaseOne: used 43578 ticks
> > 47.813: AnalyzeComponents: Hotpatch analysis disabled; skipping.
> > 47.813: AnalyzeComponents: Hotpatching is disabled.
> > 47.813: AnalyzePhaseTwo used 0 ticks
> > 47.813: AnalyzePhaseThree used 0 ticks
> > 47.813: AnalyzePhaseFive used 0 ticks
> > 47.813: AnalyzePhaseSix used 0 ticks
> > 47.813: AnalyzeComponents used 43578 ticks
> > 47.813: Downloading 0 files
> > 47.813: bPatchMode = FALSE
> > 47.813: Inventory complete: ReturnStatus=0, 43594 ticks
> > 47.813: Num Ticks for invent : 43594
> > 47.813: Conditional load of section MSI.Reg.Install.Condition succeeded
> > 47.813: Allocation size of drive C: is 4096 bytes, free space = 22812770304
> > bytes
> > 47.891: AnalyzeDiskUsage: Skipping EstimateDiskUsageForUninstall.
> > 47.891: Drive C: free 21755MB req: 5MB w/uninstall: NOT CALCULATED.
> > 47.891: CabinetBuild complete
> > 47.891: Num Ticks for Cabinet build : 78
> > 47.891: DynamicStrings section not defined or empty.
> > 47.938: FileInUse:: need to restart already, turn off
> > 47.938: FileInUse:: Add to list - Service Name: msiserver
> > 47.969: In order to successfully complete this installation, the following
> > services will automatically be stopped and restarted.
> > 47.969: Windows Installer.
> > 50.000: LoadFileQueues: UpdSpGetSourceFileLocation for halaacpi.dll failed:
> > 0xe0000102
> > 50.360: Num Ticks for Backup : 2469
> > 62.282: Num Ticks for creating uninst inf : 11922
> > 62.329: Registering Uninstall Program for -> KB893803v2, KB893803v2 , 0x0
> > 62.329: LoadFileQueues: UpdSpGetSourceFileLocation for halaacpi.dll failed:
> > 0xe0000102
> > 78.547: System Restore Point set.
> > 79.188: PFE2: Not avoiding Per File Exceptions.
> > 79.250: GetCatVersion: Failed to retrieve version information from
> > C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Tmp.0.KB893803v2_wxp.cat with error 0x57
> > 85.875: Copied file: C:\WINDOWS\system32\msi.dll
> > 86.297: Copied file: C:\WINDOWS\system32\msiexec.exe
> > 86.625: Copied file: C:\WINDOWS\system32\msihnd.dll
> > 87.079: Copied file: C:\WINDOWS\system32\msimsg.dll
> > 87.157: Copied file: C:\WINDOWS\system32\msisip.dll
> > 87.344: Copied file: C:\WINDOWS\system32\DllCache\msi.dll
> > 87.469: Copied file: C:\WINDOWS\system32\DllCache\msiexec.exe
> > 87.672: Copied file: C:\WINDOWS\system32\DllCache\msihnd.dll
> > 87.735: Copied file: C:\WINDOWS\system32\DllCache\msimsg.dll
> > 87.829: Copied file: C:\WINDOWS\system32\DllCache\msisip.dll
> > 87.829: DoInstallation: Installing assemblies with source root path:
> > c:\770f192fe847b94972bf6be452461c7b\
> > 87.875: Num Ticks for Copying files : 25547
> > 88.704: DoRegistryUpdates:UpdSpInstallFromInfSection Failed for
> > MSI.Reg.Install: 0x5
> > 88.704: DoInstallationoRegistryUpdates failed
> > 89.938: Access is denied.
> > 90.063: KB893803v2 installation did not complete.
> >
> > Select 'OK' to undo the changes that have been made.
> > 90.063: Starting process:
> > C:\WINDOWS\$MSI31Uninstall_KB893803v2$\spuninst\sp uninst.exe /~ -q -z
> > 105.110: Software Update Rollback has completed with return code 0xbc2.
> > This rollback requires a reboot.
> > 105.110: KB893803v2 installation did not complete.
> >
> > Windows Installer has been partially updated and may not work properly.
> > 105.110: Update.exe extended error code = 0x5
> > 105.110: Update.exe return code was masked to 0x643 for MSI custom action
> > compliance.
> >

>

Reply With Quote
Sponsored Links
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot update/install Windows Installer 3.1 Redistributable (v2). BlueIce microsoft.public.windowsupdate 12 02-02-2009 17:17
cant install/uninstall programs - windows installer services faile rynner microsoft.public.windows.vista.general 2 01-04-2008 07:16
Re: Windows Installer 3.1 Won't Install Sulian microsoft.public.windowsupdate 0 12-08-2007 15:35
Article ID: 925316 Error message when you install an .msu update package on a computer that is running Windows Vista: "The Windows Modules Installer must be updated before you can install this package" KBArticles English 0 10-22-2007 20:00
Article ID: 939397 The UAC shield icon does not appear on the Windows Installer native UI PushButton control during maintenance mode when you use Windows Installer 4.0 on a Windows Vista-based computer KBArticles English 0 10-22-2007 20:00




All times are GMT +1. The time now is 04:55.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120