Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

AU found no suitable session to launch client in.

microsoft.public.windowsupdate






Speedup My PC
Reply
  #1 (permalink)  
Old 10-30-2007
Andy Helsby
 

Posts: n/a
AU found no suitable session to launch client in.
On a company network where none of the users are administrators of
their local pc, I've started to get the "AU found no suitable session
to launch client in." (ever since I removed admin rights) and WSUS(3)
shows the computer with errors. In one particular case I have 11
failed to install - every single one of them are office patches
(although other office patches have installed. -
920103,919029,923097,925251,942571,940602,914455,9 34180,936048,924085,934181

If I log on as an administrator I am offered the patches and I can
then install them. However that defeats the point of an enterprise
patching system if I have to log into the pc's individually. Giving
users admin rights is not an option and shouldn't be necessary either.

As an example, the 934180 is installed on 36 machines, but failed on 5
- the same 5 machines that have failed on each of the patches.
What am I missing to get this working?

I have the log file if required (just todays entries were 64k so I
didn't want to post here)

Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 10-30-2007
Shenan Stanley
 

Posts: n/a
Re: AU found no suitable session to launch client in.
Andy Helsby wrote:
> On a company network where none of the users are administrators of
> their local pc, I've started to get the "AU found no suitable
> session to launch client in." (ever since I removed admin rights)
> and WSUS(3) shows the computer with errors. In one particular case
> I have 11 failed to install - every single one of them are office
> patches (although other office patches have installed. -
> 920103,919029,923097,925251,942571,940602,914455,9 34180,936048,924085,934181
>
> If I log on as an administrator I am offered the patches and I can
> then install them. However that defeats the point of an enterprise
> patching system if I have to log into the pc's individually. Giving
> users admin rights is not an option and shouldn't be necessary
> either.
>
> As an example, the 934180 is installed on 36 machines, but failed
> on 5 - the same 5 machines that have failed on each of the patches.
> What am I missing to get this working?
>
> I have the log file if required (just todays entries were 64k so I
> didn't want to post here)


In some cases, but not all, this can be due to group policy not being
configured properly or a corruption of the wuaueng.dll file/registration of
said file.

Try these commands on the machine:
regsvr32 /u wuaueng.dll
regsvr32 wuaueng.dll

Reboot - try again.

If that doesn't work - go a bit more to the extreme:

These commands...
net stop wuauserv
regsvr32 /u wuaueng.dll

Then delete the folder c:\windows\softwaredistibution and delete
c:\windows\windowsupdate.log (or move it.)

Then these commands...
regsvr32 wuaueng.dll
net start wuauserv
wuauclt.exe /resetauthorization /detectnow

Let us know!

--
Shenan Stanley
MS-MVP
--
How To Ask Questions The Smart Way
http://www.catb.org/~esr/faqs/smart-questions.html


Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel Next-Gen Wireless Wi-Fi Link 4965AGN card suitable for 801.1 tmwgray microsoft.public.windows.vista.networking sharing 15 03-27-2008 10:34
VPN Session Icon Disappears, so I can't close Session mcambrose microsoft.public.windows.vista.file management 0 11-29-2007 15:16
Vista can't find a suitable volume on which to install? Chris P Bacon microsoft.public.windows.vista.installation setup 6 09-09-2007 14:11
Vista cannot find a suitable driver for a "Generic Serial" port Juan I. Cahis microsoft.public.windows.vista.general 6 06-18-2007 23:28
Flaw found in Citrix server client Paul Security News 0 03-05-2007 21:43




All times are GMT +1. The time now is 04:38.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120