Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

manifest creation using mt.exe unrecognized element requestedPrivi

microsoft.public.windows.vista.security






Speedup My PC
Reply
  #1 (permalink)  
Old 06-06-2007
chasgl
 

Posts: n/a
manifest creation using mt.exe unrecognized element requestedPrivi
I want to "mark" an exe with a requestedPrivilege level. I have created a
manifest <below>. My target machine is, of course, Vista. My development
machine is XP Pro. When I run my built from Visual Studio 2005 I get a
manifest warning.

I am wondering "where" the DTF file is or is it another mechanism that
doesn't have the entry for where does it actually get
urn:schemas-microsoft-com:asm.v2?
Any ideas how this works?

Here is the manifest
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<assembly xmlns="urn:schemas-microsoft-com:asm.v2" manifestVersion="1.0">

<assemblyIdentity

version="1.0.0.0"

processorArchitecture="X86"

name="KofaxImageProducts.AscentCapture.QualityCont rol"

type="win32"

/>

<description>Ascent Capture - Quality Control</description>

<dependency>

<dependentAssembly>

<assemblyIdentity

type="win32"

name="Microsoft.Windows.Common-Controls"

version="6.0.0.0"

processorArchitecture="X86"

publicKeyToken="6595b64144ccf1df"

language="*"

/>

</dependentAssembly>

</dependency>

<ms_asmv2:trustInfo xmlns:ms_asmv2="urn:schemas-microsoft-com:asm.v2">
<ms_asmv2:security>
<ms_asmv2:requestedPrivileges>
<ms_asmv2:requestedExecutionLevel level="asInvoker">
</ms_asmv2:requestedExecutionLevel>
</ms_asmv2:requestedPrivileges>
</ms_asmv2:security>
</ms_asmv2:trustInfo>
</assembly>


Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 06-07-2007
Jimmy Brush
 

Posts: n/a
Re: manifest creation using mt.exe unrecognized element requestedPrivi
Hello,

Try changing this line:

<ms_asmv2:trustInfo xmlns:ms_asmv2="urn:schemas-microsoft-com:asm.v2">

To:

<ms_asmv2:trustInfo xmlns:ms_asmv2="urn:schemas-microsoft-com:asm.v3">


--
-JB
Microsoft MVP - Windows Shell/User
Windows Vista Support FAQ - http://www.jimmah.com/vista/
Reply With Quote
  #3 (permalink)  
Old 06-07-2007
chasgl
 

Posts: n/a
Re: manifest creation using mt.exe unrecognized element requestedP
Thanks, I will give it a try. It turns out that I can solve the problem by
using the version of mt.exe that comes with the Vista SDK which is diffent
from the Visual Studio program MARKED WITH THE SAME EXACT VERSION.
5.2.3790.2075

see
https://connect.microsoft.com/Visual...dbackID=258108

It also turns out that the warning is "harmless" in that the HTML does get
embedded into the manifest and recognized by Vista even with the warning.

THanks,
Chas
"Jimmy Brush" wrote:

> Hello,
>
> Try changing this line:
>
> <ms_asmv2:trustInfo xmlns:ms_asmv2="urn:schemas-microsoft-com:asm.v2">
>
> To:
>
> <ms_asmv2:trustInfo xmlns:ms_asmv2="urn:schemas-microsoft-com:asm.v3">
>
>
> --
> -JB
> Microsoft MVP - Windows Shell/User
> Windows Vista Support FAQ - http://www.jimmah.com/vista/
>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
slmgr.vbs -ckms gives Unrecognized Option Error =?Utf-8?B?c2M=?= microsoft.public.windows.vista.installation setup 4 01-22-2008 20:55
USB Mass Storage Devices Unrecognized (Vista) Jason microsoft.public.windows.vista hardware devices 9 06-01-2007 16:04
Unrecognized message 0xC03B received in VS 6.0 application Kak microsoft.public.windows.vista.installation setup 0 05-18-2007 22:00
Missing digital signatures for hkcmde.exe igfxtray.exe igfxpers.exe Michael Chare microsoft.public.windows.vista.general 5 03-25-2007 21:11
How to embed manifest in TCL binary? - mt.exe corrupting my binary =?Utf-8?B?S3NoaXRpag==?= microsoft.public.windows.vista.general 0 03-01-2007 14:54




All times are GMT +1. The time now is 23:23.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120