Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Cannot allow a programme I trust because Defender is blocking it

microsoft.public.windows.vista.security






Speedup My PC
Reply
  #1 (permalink)  
Old 03-17-2008
LanM
 

Posts: n/a
Cannot allow a programme I trust because Defender is blocking it
Hi

I have a back-up programme that is being blocked by Widows Defender and I
have to unblock it every time I power on.

The Windows deneder help tells me
"The next time Windows Defender alerts you about the software, on the Action
menu in the Alert dialog box, click Always Allow. If you are prompted for an
administrator password or confirmation, type the password or provide
confirmation."

But I cannot find the action menu in the alert box. The only menu I found are
- Remove or disable
- Unblock
- help.

When using software explorer in Widows defender, I can see the software but
the button "enable" remains inactive.

How can I declare that a software is allowed?

Thanks a lot for your help.

Cheers
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 03-17-2008
BillD
 

Posts: n/a
RE: Cannot allow a programme I trust because Defender is blocking it


"LanM" wrote:

> When using software explorer in Widows defender, I can see the software but
> the button "enable" remains inactive.


you have to click on the button "show for all users" with the shield icon,
in order to activate the other buttons
Reply With Quote
  #3 (permalink)  
Old 03-18-2008
JohnDavid
 

Posts: n/a
RE: Cannot allow a programme I trust because Defender is blocking it
When I encountered the problem you described, the only mechanism that worked
was to run Defender as Adminstrator. That then allowed the 'enable' button
to become active. I did not have any success with Billd's suggestion to
"show all users". Post back for everyone's benefit if running as
administrator resolves your problem.

"LanM" wrote:

> Hi
>
> I have a back-up programme that is being blocked by Widows Defender and I
> have to unblock it every time I power on.
>
> The Windows deneder help tells me
> "The next time Windows Defender alerts you about the software, on the Action
> menu in the Alert dialog box, click Always Allow. If you are prompted for an
> administrator password or confirmation, type the password or provide
> confirmation."
>
> But I cannot find the action menu in the alert box. The only menu I found are
> - Remove or disable
> - Unblock
> - help.
>
> When using software explorer in Widows defender, I can see the software but
> the button "enable" remains inactive.
>
> How can I declare that a software is allowed?
>
> Thanks a lot for your help.
>
> Cheers

Reply With Quote
  #4 (permalink)  
Old 03-18-2008
LanM
 

Posts: n/a
RE: Cannot allow a programme I trust because Defender is blocking
Indeed BillD's suggestion did not worked.
Yours did notworked either. The "Allways allow" message never appear indeed
and I suspect the source of the problem is at the level of access rights
because I have been obliged to enter into that topic when I fully reinstalled
my PC and a back-up of all data.
Does this triger an idea on your side?
Cheers

"JohnDavid" wrote:

> When I encountered the problem you described, the only mechanism that worked
> was to run Defender as Adminstrator. That then allowed the 'enable' button
> to become active. I did not have any success with Billd's suggestion to
> "show all users". Post back for everyone's benefit if running as
> administrator resolves your problem.
>
> "LanM" wrote:
>
> > Hi
> >
> > I have a back-up programme that is being blocked by Widows Defender and I
> > have to unblock it every time I power on.
> >
> > The Windows deneder help tells me
> > "The next time Windows Defender alerts you about the software, on the Action
> > menu in the Alert dialog box, click Always Allow. If you are prompted for an
> > administrator password or confirmation, type the password or provide
> > confirmation."
> >
> > But I cannot find the action menu in the alert box. The only menu I found are
> > - Remove or disable
> > - Unblock
> > - help.
> >
> > When using software explorer in Widows defender, I can see the software but
> > the button "enable" remains inactive.
> >
> > How can I declare that a software is allowed?
> >
> > Thanks a lot for your help.
> >
> > Cheers

Reply With Quote
  #5 (permalink)  
Old 03-18-2008
JohnDavid
 

Posts: n/a
RE: Cannot allow a programme I trust because Defender is blocking
I have another suggestion, but bear with me first. First, I went back to
Defender and was reminded that even running as Administrator, there are many
programs (including Vista internals) that I still cannot control there.
However, what I saw consistently was for those I CAN control
(enable/disable), the "Startup Type" is listed as 'Registry: Local Machine'.
And for those I CANNOT control, the "Startup Type" is listed as 'Registry:
Local Machine'.

That prompted me to look further into security ("access rights" as you
suggested) for EXEs in both categories. At first I seemed to be on to
something when I found that the owner for apps I CANNOT control in Defender
was System, whereas owner for those I CAN control was Administrators. But
then I found a couple where Owner was Administrators, but I still couldn't
control the app. Damn!

Anyway, here is something else to try: in Defender, choose Tools, then
Options. Scroll down to 'Advanced options'. There you can add the path to
files you don't want Defender to monitor (an Exclude list). I successfully
used this mechanism to prevent Defender from trying to stop the
implementation of a customized Hosts file that SpyBot does for me. Other
than that, I am at a loss. Please post back; I'll be curious to know if the
above resolves your issue.


"LanM" wrote:

> Indeed BillD's suggestion did not worked.
> Yours did notworked either. The "Allways allow" message never appear indeed
> and I suspect the source of the problem is at the level of access rights
> because I have been obliged to enter into that topic when I fully reinstalled
> my PC and a back-up of all data.
> Does this triger an idea on your side?
> Cheers
>
> "JohnDavid" wrote:
>
> > When I encountered the problem you described, the only mechanism that worked
> > was to run Defender as Adminstrator. That then allowed the 'enable' button
> > to become active. I did not have any success with Billd's suggestion to
> > "show all users". Post back for everyone's benefit if running as
> > administrator resolves your problem.
> >
> > "LanM" wrote:
> >
> > > Hi
> > >
> > > I have a back-up programme that is being blocked by Widows Defender and I
> > > have to unblock it every time I power on.
> > >
> > > The Windows deneder help tells me
> > > "The next time Windows Defender alerts you about the software, on the Action
> > > menu in the Alert dialog box, click Always Allow. If you are prompted for an
> > > administrator password or confirmation, type the password or provide
> > > confirmation."
> > >
> > > But I cannot find the action menu in the alert box. The only menu I found are
> > > - Remove or disable
> > > - Unblock
> > > - help.
> > >
> > > When using software explorer in Widows defender, I can see the software but
> > > the button "enable" remains inactive.
> > >
> > > How can I declare that a software is allowed?
> > >
> > > Thanks a lot for your help.
> > >
> > > Cheers

Reply With Quote
  #6 (permalink)  
Old 03-21-2008
PaulB
 

Posts: n/a
RE: Cannot allow a programme I trust because Defender is blocking it
I have a couple of programs that had the same issue and the only way I could
get them to run without intervention was to put them in the task scheduler to
run a startup and check "run with highest privileges". This works fine.
--
Paul


"LanM" wrote:

> Hi
>
> I have a back-up programme that is being blocked by Widows Defender and I
> have to unblock it every time I power on.
>
> The Windows deneder help tells me
> "The next time Windows Defender alerts you about the software, on the Action
> menu in the Alert dialog box, click Always Allow. If you are prompted for an
> administrator password or confirmation, type the password or provide
> confirmation."
>
> But I cannot find the action menu in the alert box. The only menu I found are
> - Remove or disable
> - Unblock
> - help.
>
> When using software explorer in Widows defender, I can see the software but
> the button "enable" remains inactive.
>
> How can I declare that a software is allowed?
>
> Thanks a lot for your help.
>
> Cheers

Reply With Quote
  #7 (permalink)  
Old 03-21-2008
LanM
 

Posts: n/a
RE: Cannot allow a programme I trust because Defender is blocking
Well done JohnDavid. Easy solution, even if it does not sound very
professional from a Microsoft viewpoint. Is this because that back-up
software is running under linux
;-)
Cheers
Marc

"JohnDavid" wrote:

> I have another suggestion, but bear with me first. First, I went back to
> Defender and was reminded that even running as Administrator, there are many
> programs (including Vista internals) that I still cannot control there.
> However, what I saw consistently was for those I CAN control
> (enable/disable), the "Startup Type" is listed as 'Registry: Local Machine'.
> And for those I CANNOT control, the "Startup Type" is listed as 'Registry:
> Local Machine'.
>
> That prompted me to look further into security ("access rights" as you
> suggested) for EXEs in both categories. At first I seemed to be on to
> something when I found that the owner for apps I CANNOT control in Defender
> was System, whereas owner for those I CAN control was Administrators. But
> then I found a couple where Owner was Administrators, but I still couldn't
> control the app. Damn!
>
> Anyway, here is something else to try: in Defender, choose Tools, then
> Options. Scroll down to 'Advanced options'. There you can add the path to
> files you don't want Defender to monitor (an Exclude list). I successfully
> used this mechanism to prevent Defender from trying to stop the
> implementation of a customized Hosts file that SpyBot does for me. Other
> than that, I am at a loss. Please post back; I'll be curious to know if the
> above resolves your issue.
>
>
> "LanM" wrote:
>
> > Indeed BillD's suggestion did not worked.
> > Yours did notworked either. The "Allways allow" message never appear indeed
> > and I suspect the source of the problem is at the level of access rights
> > because I have been obliged to enter into that topic when I fully reinstalled
> > my PC and a back-up of all data.
> > Does this triger an idea on your side?
> > Cheers
> >
> > "JohnDavid" wrote:
> >
> > > When I encountered the problem you described, the only mechanism that worked
> > > was to run Defender as Adminstrator. That then allowed the 'enable' button
> > > to become active. I did not have any success with Billd's suggestion to
> > > "show all users". Post back for everyone's benefit if running as
> > > administrator resolves your problem.
> > >
> > > "LanM" wrote:
> > >
> > > > Hi
> > > >
> > > > I have a back-up programme that is being blocked by Widows Defender and I
> > > > have to unblock it every time I power on.
> > > >
> > > > The Windows deneder help tells me
> > > > "The next time Windows Defender alerts you about the software, on the Action
> > > > menu in the Alert dialog box, click Always Allow. If you are prompted for an
> > > > administrator password or confirmation, type the password or provide
> > > > confirmation."
> > > >
> > > > But I cannot find the action menu in the alert box. The only menu I found are
> > > > - Remove or disable
> > > > - Unblock
> > > > - help.
> > > >
> > > > When using software explorer in Widows defender, I can see the software but
> > > > the button "enable" remains inactive.
> > > >
> > > > How can I declare that a software is allowed?
> > > >
> > > > Thanks a lot for your help.
> > > >
> > > > Cheers

Reply With Quote
  #8 (permalink)  
Old 03-21-2008
LanM
 

Posts: n/a
RE: Cannot allow a programme I trust because Defender is blocking
Hi JohnDavid,

Unfortunately, I was too confident. What you proposed was easy to be done,
but I reboot and ... Damned. This has no effect at all.

"JohnDavid" wrote:

> I have another suggestion, but bear with me first. First, I went back to
> Defender and was reminded that even running as Administrator, there are many
> programs (including Vista internals) that I still cannot control there.
> However, what I saw consistently was for those I CAN control
> (enable/disable), the "Startup Type" is listed as 'Registry: Local Machine'.
> And for those I CANNOT control, the "Startup Type" is listed as 'Registry:
> Local Machine'.
>
> That prompted me to look further into security ("access rights" as you
> suggested) for EXEs in both categories. At first I seemed to be on to
> something when I found that the owner for apps I CANNOT control in Defender
> was System, whereas owner for those I CAN control was Administrators. But
> then I found a couple where Owner was Administrators, but I still couldn't
> control the app. Damn!
>
> Anyway, here is something else to try: in Defender, choose Tools, then
> Options. Scroll down to 'Advanced options'. There you can add the path to
> files you don't want Defender to monitor (an Exclude list). I successfully
> used this mechanism to prevent Defender from trying to stop the
> implementation of a customized Hosts file that SpyBot does for me. Other
> than that, I am at a loss. Please post back; I'll be curious to know if the
> above resolves your issue.
>
>
> "LanM" wrote:
>
> > Indeed BillD's suggestion did not worked.
> > Yours did notworked either. The "Allways allow" message never appear indeed
> > and I suspect the source of the problem is at the level of access rights
> > because I have been obliged to enter into that topic when I fully reinstalled
> > my PC and a back-up of all data.
> > Does this triger an idea on your side?
> > Cheers
> >
> > "JohnDavid" wrote:
> >
> > > When I encountered the problem you described, the only mechanism that worked
> > > was to run Defender as Adminstrator. That then allowed the 'enable' button
> > > to become active. I did not have any success with Billd's suggestion to
> > > "show all users". Post back for everyone's benefit if running as
> > > administrator resolves your problem.
> > >
> > > "LanM" wrote:
> > >
> > > > Hi
> > > >
> > > > I have a back-up programme that is being blocked by Widows Defender and I
> > > > have to unblock it every time I power on.
> > > >
> > > > The Windows deneder help tells me
> > > > "The next time Windows Defender alerts you about the software, on the Action
> > > > menu in the Alert dialog box, click Always Allow. If you are prompted for an
> > > > administrator password or confirmation, type the password or provide
> > > > confirmation."
> > > >
> > > > But I cannot find the action menu in the alert box. The only menu I found are
> > > > - Remove or disable
> > > > - Unblock
> > > > - help.
> > > >
> > > > When using software explorer in Widows defender, I can see the software but
> > > > the button "enable" remains inactive.
> > > >
> > > > How can I declare that a software is allowed?
> > > >
> > > > Thanks a lot for your help.
> > > >
> > > > Cheers

Reply With Quote
  #9 (permalink)  
Old 03-21-2008
LanM
 

Posts: n/a
RE: Cannot allow a programme I trust because Defender is blocking
Hi PaulB
That seems OK now. Yoy brought me in an area I did not know. Thanks.
Perhaps I had that problem because the application concerned was running
under linux ;-) Who knows.
Cheers
Marc

"PaulB" wrote:

> I have a couple of programs that had the same issue and the only way I could
> get them to run without intervention was to put them in the task scheduler to
> run a startup and check "run with highest privileges". This works fine.
> --
> Paul
>
>
> "LanM" wrote:
>
> > Hi
> >
> > I have a back-up programme that is being blocked by Widows Defender and I
> > have to unblock it every time I power on.
> >
> > The Windows deneder help tells me
> > "The next time Windows Defender alerts you about the software, on the Action
> > menu in the Alert dialog box, click Always Allow. If you are prompted for an
> > administrator password or confirmation, type the password or provide
> > confirmation."
> >
> > But I cannot find the action menu in the alert box. The only menu I found are
> > - Remove or disable
> > - Unblock
> > - help.
> >
> > When using software explorer in Widows defender, I can see the software but
> > the button "enable" remains inactive.
> >
> > How can I declare that a software is allowed?
> >
> > Thanks a lot for your help.
> >
> > Cheers

Reply With Quote
  #10 (permalink)  
Old 03-21-2008
JohnDavid
 

Posts: n/a
RE: Cannot allow a programme I trust because Defender is blocking
Soirry my 'solution' did not work for you, but glad that PaulB found
something that works. Defender's behavior has seemed flukey at times; don't
know if it's the application or a hole in my knowledge.

"LanM" wrote:

> Hi PaulB
> That seems OK now. Yoy brought me in an area I did not know. Thanks.
> Perhaps I had that problem because the application concerned was running
> under linux ;-) Who knows.
> Cheers
> Marc
>
> "PaulB" wrote:
>
> > I have a couple of programs that had the same issue and the only way I could
> > get them to run without intervention was to put them in the task scheduler to
> > run a startup and check "run with highest privileges". This works fine.
> > --
> > Paul
> >
> >
> > "LanM" wrote:
> >
> > > Hi
> > >
> > > I have a back-up programme that is being blocked by Widows Defender and I
> > > have to unblock it every time I power on.
> > >
> > > The Windows deneder help tells me
> > > "The next time Windows Defender alerts you about the software, on the Action
> > > menu in the Alert dialog box, click Always Allow. If you are prompted for an
> > > administrator password or confirmation, type the password or provide
> > > confirmation."
> > >
> > > But I cannot find the action menu in the alert box. The only menu I found are
> > > - Remove or disable
> > > - Unblock
> > > - help.
> > >
> > > When using software explorer in Widows defender, I can see the software but
> > > the button "enable" remains inactive.
> > >
> > > How can I declare that a software is allowed?
> > >
> > > Thanks a lot for your help.
> > >
> > > Cheers

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
What is Defender blocking Michelle microsoft.public.windows.vista.general 2 01-28-2008 15:37
What is Defender blocking Michelle microsoft.public.windows.vista.installation setup 2 01-28-2008 15:37
What is Defender blocking Michelle microsoft.public.windows.vista.performance maintenance 2 01-28-2008 15:37
What is Defender blocking Michelle microsoft.public.windows.vista.security 2 01-28-2008 15:37
User Control blocking CCleaner.exe programme when Vista opens.... jenc6979 microsoft.public.windows.vista.general 8 10-18-2007 22:55




All times are GMT +1. The time now is 09:55.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120