Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

How to remove "Open File - Security Warning" window?

microsoft.public.windows.vista.security






Speedup My PC
Reply
  #1 (permalink)  
Old 01-06-2007
Echevil
 

Posts: n/a
How to remove "Open File - Security Warning" window?
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 7bit

Hi

After installing vista, almost all shortcuts that I put into the LINKS
folder prompts an "Open File - Security Warning" message window when
opened. These shortcuts point to safe local files and could be opened
directly in win xp.

It's getting annoying now. Is it possible to remove it? I guess it has
something to do with security setting of IE7.

BTW, I always like to put shortcuts in the Links folder and use them
instead of Quick Launch. The difference is, folders in Links folder are
opened as sub-menus when clicked on, while in quick launch, an explorer
window will open the folder itself.

____
Regards
Chen PANG
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 01-07-2007
Jimmy Brush
 

Posts: n/a
Re: How to remove "Open File - Security Warning" window?
Hello,

This does indeed have to do with the new security features of IE7 and
Windows Vista. The reason this extra prompt is in place is because IE7 can
create and modify files inside of your favorites folder, which includes the
links folder. Since a malicious website or IE plug-in could potentially
create a link in this folder that performs an unwanted action, Windows takes
greater care when opening files in this location.

Normally I would suggest just using another folder to store your links in,
but if you do that you no longer get the "menu" behavior that you are
wanting. If there is a way to change the behavior of the quick links or
custom toolbar to display folders as links, then that would be a much better
solution; however, I was not able to find a way to do this.

Instead, there is a way to change the security on the links folder so that
these prompts are not displayed.

** Instructions

NOTE: This procedure will change default security settings. See below for
details.

SIDE EFFECTS: After performing this procedure, you will have to go through
extra confirmation steps when using internet explorer's favorites pane to
delete items inside the links folder. This only affects IE (not Windows
Explorer or the links toolbar on your taskbar).

- Click start
- Type: cmd
- Right-click cmd.exe when it appears and click Run As Administrator
- Type the following commands exactly as shown, pressing enter after each
line:

cd %userprofile%\favorites
icacls links /setintegritylevel (CI)low

** Restoring default security settings

If you wish to restore the default security settings, follow these steps:

- Click start
- Type: cmd
- Right-click cmd.exe when it appears and click Run As Administrator
- Type the following commands exactly as shown, pressing enter after each
line:

cd %userprofile%\favorites
icacls links /setintegritylevel (OI)(CI)low

** More information

When IE7 is running in protected mode (default), it can only write files to
locations that have been marked as "low integrity". IE7 must ask for your
consent to write to any other locations. This helps to prevent hackers and
malware from taking over IE7 and using it to compromise your system.

Your favorites folder (and the links folder within) and most files that are
created, copied, or moved inside it are marked as "low integrity." This
allows IE7 to create and delete files inside of your favorites folder
without asking you for consent.

Since files marked with "low integrity" are modifiable by potentially
untrusted programs and webpages, Windows takes greater care when opening
these types of files, especially in the case of a shortcut.

The solution I gave will change the integrity level of items inside your
links folder from low to medium. This will allow them to open without
displaying the "Open File - Security Warning" prompt.


- JB
Microsoft MVP - Windows Shell/User

Windows Vista Support Faq
http://www.jimmah.com/vista/

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
XP Can't access Vista Share TedF microsoft.public.windows.vista.networking sharing 12 04-30-2010 14:12
Offline files cannot synchronize =?Utf-8?B?SW52aXNpYmxl?= microsoft.public.windows.vista.networking sharing 11 11-11-2008 11:14
Window media 11 can not play DivX file =?Utf-8?B?VG9ueSBUcmFu?= microsoft.public.windows.vista.music pictures video 1 02-27-2007 14:38
Re: SUID Kurt Harriger microsoft.public.windows.vista.security 7 12-18-2006 11:06
Vista file security =?Utf-8?B?cm9iX2xlc2xpZQ==?= microsoft.public.windows.vista.security 2 12-13-2006 23:07




All times are GMT +1. The time now is 08:53.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120