Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Performance problem in Vista Windows explorer if /SWAPRUN:NET is seton an executable.

microsoft.public.windows.vista.performance maintenance






Speedup My PC
Reply
  #1 (permalink)  
Old 12-09-2009
patrick.vancauteren
 

Posts: n/a
Performance problem in Vista Windows explorer if /SWAPRUN:NET is seton an executable.
I have rather big executables (about 25-35 MB). Because I want my
users to easily execute my application, I don't want them to install a
bunch of DLL's, just xcopy-install is OK for me (and my customers).
Because my software is often run from a network drive, and my
customers' networks are not always reliable, I link my executables
using the /SWAPRUN:NET option. This guarantees that the whole EXE is
loaded in memory before the application starts, and prevents crashes
if the network connection is dropped while my application is running.
This worked fine so far, BUT ... under Windows Vista, if a network
folder has lots of such executables (10, 50, 100, ...) then opening
this folder in the Windows explorer takes a lot of time (minutes!).
Especially, the visualization of the executables' icons takes a lot of
time. This problem did not appear on Windows XP.
Today, I found out that the problem is caused by the /SWAPRUN:NET
option. If I remove this linker option (or disable this flag with
EDITBIN), than the Vista Windows explorer immediately shows all icons.
Disabling this flag is not really an option (see reasons above).
Is there another way to tell Vista that it should not load the
complete executable file if it only needs to show the icon (or other
version information) in the explorer?

Thanks,
Patrick
Reply With Quote
Sponsored Links
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: Get Problem Free PC Performance With Windows Registry Cleaner Kayman microsoft.public.windowsupdate 0 04-26-2009 02:57
Vista Internet Explorer/Windows Explorer shortcut problem mgraham1964@gmail.com microsoft.public.windows.vista.general 0 08-27-2008 18:34
I have a problem with Vista - Windows Explorer keeps crashing =?Utf-8?B?TWljaGFlbA==?= microsoft.public.windows.vista.performance maintenance 28 06-29-2008 19:57
Seton hospitals upgrade emergency alert system Steve Security News 0 10-08-2007 17:51




All times are GMT +1. The time now is 12:29.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120