Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Processor Power Management

microsoft.public.windows.vista.performance maintenance






Speedup My PC
Reply
  #1 (permalink)  
Old 03-23-2009
luftwaffle
 

Posts: n/a
Processor Power Management

After reading multiple articles on various site regarding how the
processor power management works in Vista, I have yet to find a
resolution to my current situation.

I am running Vista Home Premium 32bit on my HP Pavilion tx 2110 with an
AMD X2 Mobile Tech TL-62 2.1Ghz and 3gb of RAM.

Whenever my laptop is unplugged from the wall and running on the
battery, Vista seems to limit the processor frequency to 38% of the max
(roughly 800mhz) no mater the power plan or processor load. While the
computer is plugged in however, everything runs beautifully with the
frequency at 100%.

Here is what the Resource Manager has to say about this:
[image:
http://i238.photobucket.com/albums/f...?t=1237840864]

The CPU graph on the left side is while the computer is plugged in, I
believe I was reading some of the power management articles. The right
side is after the power cord is removed, the spikes are when I was
rendering a small fractal just to push the processor past idling.

Current power plan looks like this:
[image:
http://i238.photobucket.com/albums/f...?t=1237841039]

This is the default High Performance plan. Now from my understanding,
while plugged in this should "force" the processor to maintain a 100%
frequency regardless of the load while unplugging the cord should allow
the cores to float anywhere between 5% and 100% load dependent, although
this remains at 38% consistently.


What I would like it to do is whenever it is unplugged, it should
retain either the 100% stable cap, or be allowed to range so that at
high utilization the frequency may be allowed to range. Through messing
with the "Minimum processor state" and "Maximum processor state" I have
found that the 38% limit does not ever change, even if both setting are
set to 15% or 100%, the while plugged in option however functions as it
should, if I move the upper and lower limits it will mirror this change
both in performance and in the resource manager.

Any suggestions on how to force my plan settings to take effect? Or is
there a way to disable the power management and completely disallow
processor states?


--
luftwaffle
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 03-26-2009
TheRealDeadApe
 

Posts: n/a
RE: Processor Power Management
You might try raising the minimum processor state or checking to see if there is a bios limit being imposed.


Post Originated from http://www.VistaForums.com Vista Support Forums
Reply With Quote
  #3 (permalink)  
Old 03-26-2009
roy69
 

Posts: n/a
Re: Processor Power Management

There are 2 things to look for in the bios c1e state and also speedstep
technology.


--
roy69

Dont PM people with questions, post them in the forums so others can
learn.
Reply With Quote
  #4 (permalink)  
Old 03-26-2009
luftwaffle
 

Posts: n/a
Re: Processor Power Management

TheRealDeadApe;1001706 Wrote:
> You might try raising the minimum processor state or checking to see if
> there is a bios limit being imposed.
>
>
> Post Originated from 'Windows Vista Forum' (http://www.VistaForums.com)
> Vista Support Forums


roy69;1001740 Wrote:
> There are 2 things to look for in the bios c1e state and also speedstep
> technology.


Checked in the bios (believe it is phoenix bios, very limited) and
there is a power management option which limits the frequency based on
whether or not it is plugged in. Changed that from the power saver to
"Performance". Now I am capped at 76% frequency (1600 Mhz), great
improvement. Changed the minimum now and it still caps to 76%, would
like to be able to run at 100%, but at least now I meet the minimum
system requirements for vista when I'm not plugged in.

Any other suggestions to completely release the cap?


--
luftwaffle
Reply With Quote
  #5 (permalink)  
Old 03-26-2009
Ian D
 

Posts: n/a
Re: Processor Power Management

"luftwaffle" <guest@unknown-email.com> wrote in message
news:e9d8d7258e965d20c7d457edbc833c51@nntp-gateway.com...
>
> TheRealDeadApe;1001706 Wrote:
>> You might try raising the minimum processor state or checking to see if
>> there is a bios limit being imposed.
>>
>>
>> Post Originated from 'Windows Vista Forum' (http://www.VistaForums.com)
>> Vista Support Forums

>
> roy69;1001740 Wrote:
>> There are 2 things to look for in the bios c1e state and also speedstep
>> technology.

>
> Checked in the bios (believe it is phoenix bios, very limited) and
> there is a power management option which limits the frequency based on
> whether or not it is plugged in. Changed that from the power saver to
> "Performance". Now I am capped at 76% frequency (1600 Mhz), great
> improvement. Changed the minimum now and it still caps to 76%, would
> like to be able to run at 100%, but at least now I meet the minimum
> system requirements for vista when I'm not plugged in.
>
> Any other suggestions to completely release the cap?
>
>
> --
> luftwaffle


I can't give any advice on how to achieve 100% of CPU
design frequency, but one thing to consider is that you
will now have shorter battery life for two reasons, one
being greater power consumption by the CPU, and the
other being increased cooling fan operation due to the
increased thermal load. This is probably of no concern,
unless there's an occasion where you need max battery
time, and then it's just a matter of adjusting the settings
back to default. I have found that, even with XP, you
can notice the difference between min/max clock speeds
when opening apps, switching windows, etc.



Reply With Quote
  #6 (permalink)  
Old 03-27-2009
luftwaffle
 

Posts: n/a
Re: Processor Power Management

Ian D;1002280 Wrote:
> "luftwaffle" <guest@xxxxxx-email.com> wrote in message
> news:e9d8d7258e965d20c7d457edbc833c51@xxxxxx-gateway.com...> > >
> > >
> > > TheRealDeadApe;1001706 Wrote:> > > > >
> > > >> You might try raising the minimum processor state or checking to see
> > > if
> > > >> there is a bios limit being imposed.
> > > >>
> > > >>
> > > >> Post Originated from 'Windows Vista Forum' ('Windows Vista Forum'
> > > (http://www.VistaForums.com))
> > > >> Vista Support Forums> > > > >
> > > roy69;1001740 Wrote:> > > > >
> > > >> There are 2 things to look for in the bios c1e state and also
> > > speedstep
> > > >> technology.> > > > >
> > > Checked in the bios (believe it is phoenix bios, very limited)

> > and
> > > there is a power management option which limits the frequency

> > based on
> > > whether or not it is plugged in. Changed that from the power

> > saver to
> > > "Performance". Now I am capped at 76% frequency (1600 Mhz),

> > great
> > > improvement. Changed the minimum now and it still caps to 76%,

> > would
> > > like to be able to run at 100%, but at least now I meet the

> > minimum
> > > system requirements for vista when I'm not plugged in.
> > >
> > > Any other suggestions to completely release the cap?
> > >
> > >
> > > --
> > > luftwaffle > > I can't give any advice on how to achieve 100% of CPU

> design frequency, but one thing to consider is that you
> will now have shorter battery life for two reasons, one
> being greater power consumption by the CPU, and the
> other being increased cooling fan operation due to the
> increased thermal load. This is probably of no concern,
> unless there's an occasion where you need max battery
> time, and then it's just a matter of adjusting the settings
> back to default. I have found that, even with XP, you
> can notice the difference between min/max clock speeds
> when opening apps, switching windows, etc.



Battery life is a non issue, even on all power saving options I can
"probably" browse the internet for, 2 hours maybe due to HPs terrible
battery design. When I unplug my machine it is usually to head to my
programming class compiling takes longer on low frequencies (of course)
and still consumes the battery.

For now I'm happy with 1600mhz unplugged. Thanks to all that helped.


--
luftwaffle
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel-processor-power jose microsoft.public.es.windowsvista 4 11-12-2008 07:08
processor power management features have been disabled due to a known firmware error EVENT ID 6 JAMES microsoft.public.windows.vista.general 1 10-27-2008 21:32
Power Management/Power Options in Vista MarkR microsoft.public.windows.vista.general 4 08-29-2008 17:33
What is minimum and maximum processor state in power management Rob microsoft.public.windows.vista.performance maintenance 6 10-07-2007 20:08
Power Management Issues (Underclocked Processor) Enix06 microsoft.public.windows.vista.performance maintenance 2 08-23-2007 07:48




All times are GMT +1. The time now is 23:47.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120