Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Installers freeze when creating system restore point

microsoft.public.windows.vista.performance maintenance






Speedup My PC
Reply
  #1 (permalink)  
Old 10-30-2008
gdwtch
 

Posts: n/a
Installers freeze when creating system restore point
I have an Acer Aspire 5920 laptop running Vista Home Premium and I'm having
problems installing any new software (even things as simple as WinZip); the
installations always freeze near the end and never complete. I posted this
question in another forum, and someone suggested a problem with System
Restore, since the installers generally try to create a restore point. I
turned on logging and sure enough, I see this as the last line in the log:

MSI (s) (4C:18) [21:56:53:241]: Calling SRSetRestorePoint API.
dwRestorePtType: 0, dwEventType: 102, llSequenceNumber: 0, szDescription:
"Installed iTunes".

and nothing more. I've let it run overnight, but it never completes.

I took a look at the properties for "System Protection" in Control Panel,
and sure enough, it appears to be hosed. The "System Restore..." and
"Create..." buttons are greyed out, and under Available Disks, it just says
"Searching...". If I let it run for at least an hour, eventually it finishes
searching, but then claims that for the C: drive, there are no restore points.

Worse, after the searching completes, and the various buttons on the dialog
ungrey themselves, I tried hitting the "System Restore..." button, hoping to
see some additional options, but nothing happens when I do that. Do it again,
and I
get "The System Restore Wizard is already running. The program will now exit."

It seems that somehow, I need to reset, reconfigure, or (horrors!) reinstall
at least the System Restore portion of the OS, or worse, the entire OS. Can
anybody provide any direction? I shudder at the thought of a complete
reinstall...

BTW, the system otherwise works fine. There is scads of free disk space
(over 100 GB on C and performance is fine.

(One other point: Acer includes its own system recovery software, called
e-recovery. I've used it to backup the restore partition, apps & drivers,
etc, so at least that much works fine. I do wonder, however, if somehow this
is conflicting with the built-in restore functionality in Windows...)
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 11-18-2008
Stephen
 

Posts: n/a
RE: Installers freeze when creating system restore point
I have the same problem.
Reply With Quote
  #3 (permalink)  
Old 11-19-2008
gdwtch
 

Posts: n/a
RE: Installers freeze when creating system restore point
In case you are curious: I gave up solving the problem and re-installed Vista
from scratch. This appears to have cured it; I have been able to install
everything I needed to since then, and the system restore dialog looks to be
working properly now.

My theory is that the problem was caused by Laplink's PCMover software,
which I used to move all my software and data from my old XP machine to
Vista. I did contact Laplink and they said they had heard of the problem
before, but never had enough information to solve it. I gave them all the
details, but they weren't able to provide a solution, unfortunately.
Reply With Quote
  #4 (permalink)  
Old 11-21-2008
Stephen
 

Posts: n/a
RE: Installers freeze when creating system restore point
Thanks. That helps. PC Mover was used on this system, too. I'll work on it
from that angle.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Creating a preserved restore point & restore a recovery CDs DanP microsoft.public.windowsupdate 3 05-26-2008 16:50
creating system restore point belsize B microsoft.public.windows.vista.performance maintenance 1 05-03-2008 23:33
Creating a restore point RichSall microsoft.public.windows.vista.general 1 11-20-2007 05:51
System restore hasn't held a restore point since I installed Vista CaptHerp microsoft.public.windows.vista.general 9 10-25-2007 19:54
system restore not creating system restore everyday =?Utf-8?B?R1Q=?= microsoft.public.windows.vista.general 3 02-23-2007 01:25




All times are GMT +1. The time now is 10:37.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120