Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Vista network sharing problem (access and permissions)

microsoft.public.windows.vista.networking sharing






Speedup My PC
Reply
  #1 (permalink)  
Old 10-03-2008
Jannoth
 

Posts: n/a
Vista network sharing problem (access and permissions)
3 PCs are in a workgroup via a router:

PC1 = Desktop, running Vista Home Premium, connection = wired.
User A/C = JPR but no password.

PC2 = Laptop, running Vista Ultimate, connection = wireless.
User A/C = ASC with a password.

PC3 = Laptop, running Vista Home Premium, connection = wireless.
User A/C = JPR with a password.

They're on the same workgroup, have identical network setups (ie Discovery
is on, File Sharing is on, Password setting is off) and IP numbers are all
Static and correct. They all access the internet fine, and whilst
troubleshooting, all firewalls are disabled.

Problem: PC1 needs to be accessed by PC2 and PC3 so relevant folders and the
E: drive on PC1 have been shared and full permissions allowed for Everyone.

While PC2 (with Vista Ultimate) accesses PC1 fine, PC3 (with Vista Home
Premium) is prompted for a username and password ... which works fine, but
I'm prompted again after rebooting PC3. Grrr - not what I want (

Can someone please guide me on tweaking things so that PC3 doesn't need a
password?

Thanks - I'm dispairing after playing for over a week now.
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 10-03-2008
Malke
 

Posts: n/a
Re: Vista network sharing problem (access and permissions)
Jannoth wrote:

> 3 PCs are in a workgroup via a router:
>
> PC1 = Desktop, running Vista Home Premium, connection = wired.
> User A/C = JPR but no password.
>
> PC2 = Laptop, running Vista Ultimate, connection = wireless.
> User A/C = ASC with a password.
>
> PC3 = Laptop, running Vista Home Premium, connection = wireless.
> User A/C = JPR with a password.
>
> They're on the same workgroup, have identical network setups (ie Discovery
> is on, File Sharing is on, Password setting is off) and IP numbers are all
> Static and correct. They all access the internet fine, and whilst
> troubleshooting, all firewalls are disabled.
>
> Problem: PC1 needs to be accessed by PC2 and PC3 so relevant folders and
> the E: drive on PC1 have been shared and full permissions allowed for
> Everyone.
>
> While PC2 (with Vista Ultimate) accesses PC1 fine, PC3 (with Vista Home
> Premium) is prompted for a username and password ... which works fine, but
> I'm prompted again after rebooting PC3. Grrr - not what I want (
>
> Can someone please guide me on tweaking things so that PC3 doesn't need a
> password?


I'm sorry, but you should create matching user accounts which have matching
passwords on all accounts. You should not need to disable any firewalls;
they just need to be configured correctly. See below for details.

Problems sharing files between computers on a network are generally caused
by 1) a misconfigured firewall or overlooked firewall (including a stateful
firewall in a VPN); or 2) inadvertently running two firewalls such as the
built-in Windows Firewall and a third-party firewall; and/or 3) not having
identical user accounts and passwords on all Workgroup machines; 4) trying
to create shares where the operating system does not permit it.

A. Configure firewalls on all machines to allow the Local Area Network (LAN)
traffic as trusted. With Windows Firewall, this means allowing File/Printer
Sharing on the Exceptions tab. Normally running the Network Setup Wizard on
XP will take care of this for those machines.The only "gotcha" is that this
will turn on the XPSP2 Windows Firewall. If you aren't running a
third-party firewall or have an antivirus with "Internet Worm
Protection" (like Norton 2006/07) which acts as a firewall, then you're
fine. With third-party firewalls, I usually configure the LAN allowance
with an IP range. Ex. would be 192.168.1.0-192.168.1.254. Obviously you
would substitute your correct subnet. Do not run more than one firewall. DO
NOT TURN OFF FIREWALLS; CONFIGURE THEM CORRECTLY.

B. For ease of organization, put all computers in the same Workgroup. This
is done from the System applet in Control Panel, Computer Name tab.

C. Create matching user accounts and passwords on all machines. You do not
need to be logged into the same account on all machines and the passwords
assigned to each user account can be different; the accounts/passwords just
need to exist and match on all machines. DO NOT NEGLECT TO CREATE
PASSWORDS, EVEN IF ONLY SIMPLE ONES. If you wish a machine to boot directly
to the Desktop (into one particular user's account) for convenience, you
can do this. The instructions at this link work for both XP and Vista:

Configure Windows to Automatically Login (MVP Ramesh) -
http://windowsxp.mvps.org/Autologon.htm

D. If one or more of the computers is XP Pro or Media Center, turn off
Simple File Sharing (Folder Options>View tab).

E. Create shares as desired. XP Home does not permit sharing of users' home
directories or Program Files, but you can share folders inside those
directories. A better choice is to simply use the Shared Documents folder.

Malke
--
MS-MVP
Elephant Boy Computers - Don't Panic!
FAQ - http://www.elephantboycomputers.com/#FAQ

Reply With Quote
  #3 (permalink)  
Old 10-03-2008
Jannoth
 

Posts: n/a
Re: Vista network sharing problem (access and permissions)
Hi Malke and thanks for the clear advice )

I only disabled the firewalls to see if they were causing the problems - the
firewalls are up all the time otherwise.

I'll try your suggestions shortly, but it's weird that PC2 (laptop with
Vista Ultimate) never requires a login even tho the user accounts differ,
whereas but PC3 (laptop with Vista Home Premium) does need a login - even tho
the same user account is on both PCs).

It sounds like I just need to add a password to PC1, when both laptops
should access it without login prompts.

Keep you fingers cross, but I'll post an update either way.

Ta again )

"Malke" wrote:

> Jannoth wrote:
>
> > 3 PCs are in a workgroup via a router:
> >
> > PC1 = Desktop, running Vista Home Premium, connection = wired.
> > User A/C = JPR but no password.
> >
> > PC2 = Laptop, running Vista Ultimate, connection = wireless.
> > User A/C = ASC with a password.
> >
> > PC3 = Laptop, running Vista Home Premium, connection = wireless.
> > User A/C = JPR with a password.
> >
> > They're on the same workgroup, have identical network setups (ie Discovery
> > is on, File Sharing is on, Password setting is off) and IP numbers are all
> > Static and correct. They all access the internet fine, and whilst
> > troubleshooting, all firewalls are disabled.
> >
> > Problem: PC1 needs to be accessed by PC2 and PC3 so relevant folders and
> > the E: drive on PC1 have been shared and full permissions allowed for
> > Everyone.
> >
> > While PC2 (with Vista Ultimate) accesses PC1 fine, PC3 (with Vista Home
> > Premium) is prompted for a username and password ... which works fine, but
> > I'm prompted again after rebooting PC3. Grrr - not what I want (
> >
> > Can someone please guide me on tweaking things so that PC3 doesn't need a
> > password?

>
> I'm sorry, but you should create matching user accounts which have matching
> passwords on all accounts. You should not need to disable any firewalls;
> they just need to be configured correctly. See below for details.
>
> Problems sharing files between computers on a network are generally caused
> by 1) a misconfigured firewall or overlooked firewall (including a stateful
> firewall in a VPN); or 2) inadvertently running two firewalls such as the
> built-in Windows Firewall and a third-party firewall; and/or 3) not having
> identical user accounts and passwords on all Workgroup machines; 4) trying
> to create shares where the operating system does not permit it.
>
> A. Configure firewalls on all machines to allow the Local Area Network (LAN)
> traffic as trusted. With Windows Firewall, this means allowing File/Printer
> Sharing on the Exceptions tab. Normally running the Network Setup Wizard on
> XP will take care of this for those machines.The only "gotcha" is that this
> will turn on the XPSP2 Windows Firewall. If you aren't running a
> third-party firewall or have an antivirus with "Internet Worm
> Protection" (like Norton 2006/07) which acts as a firewall, then you're
> fine. With third-party firewalls, I usually configure the LAN allowance
> with an IP range. Ex. would be 192.168.1.0-192.168.1.254. Obviously you
> would substitute your correct subnet. Do not run more than one firewall. DO
> NOT TURN OFF FIREWALLS; CONFIGURE THEM CORRECTLY.
>
> B. For ease of organization, put all computers in the same Workgroup. This
> is done from the System applet in Control Panel, Computer Name tab.
>
> C. Create matching user accounts and passwords on all machines. You do not
> need to be logged into the same account on all machines and the passwords
> assigned to each user account can be different; the accounts/passwords just
> need to exist and match on all machines. DO NOT NEGLECT TO CREATE
> PASSWORDS, EVEN IF ONLY SIMPLE ONES. If you wish a machine to boot directly
> to the Desktop (into one particular user's account) for convenience, you
> can do this. The instructions at this link work for both XP and Vista:
>
> Configure Windows to Automatically Login (MVP Ramesh) -
> http://windowsxp.mvps.org/Autologon.htm
>
> D. If one or more of the computers is XP Pro or Media Center, turn off
> Simple File Sharing (Folder Options>View tab).
>
> E. Create shares as desired. XP Home does not permit sharing of users' home
> directories or Program Files, but you can share folders inside those
> directories. A better choice is to simply use the Shared Documents folder.
>
> Malke
> --
> MS-MVP
> Elephant Boy Computers - Don't Panic!
> FAQ - http://www.elephantboycomputers.com/#FAQ
>
>

Reply With Quote
  #4 (permalink)  
Old 10-06-2008
Jannoth
 

Posts: n/a
RE: Vista network sharing problem (access and permissions)
Yippee - it's solved and the LAN now works perfectly )

The solution (Dell phone support helped - even tho I had to pay): the user
account on PC3 had to be different from PC1 to gain access. As soon as a
different user account was created (I created three to provei it) access was
perfectly - exactly what I needed.

Matching user accounts with matching passwords (with or without enabled
firewalls) did not work. I now have a different user account and password on
PC3 and firewalls are enabled - and it works fine.

I don't know why this is contrary to the general thinking - but thought I'd
share the solution anyway as proper protocol wasn't helping so others might
be in this boat!

Thanks a lot and hope this experience helps someone )

J

"Jannoth" wrote:

> 3 PCs are in a workgroup via a router:
>
> PC1 = Desktop, running Vista Home Premium, connection = wired.
> User A/C = JPR but no password.
>
> PC2 = Laptop, running Vista Ultimate, connection = wireless.
> User A/C = ASC with a password.
>
> PC3 = Laptop, running Vista Home Premium, connection = wireless.
> User A/C = JPR with a password.
>
> They're on the same workgroup, have identical network setups (ie Discovery
> is on, File Sharing is on, Password setting is off) and IP numbers are all
> Static and correct. They all access the internet fine, and whilst
> troubleshooting, all firewalls are disabled.
>
> Problem: PC1 needs to be accessed by PC2 and PC3 so relevant folders and the
> E: drive on PC1 have been shared and full permissions allowed for Everyone.
>
> While PC2 (with Vista Ultimate) accesses PC1 fine, PC3 (with Vista Home
> Premium) is prompted for a username and password ... which works fine, but
> I'm prompted again after rebooting PC3. Grrr - not what I want (
>
> Can someone please guide me on tweaking things so that PC3 doesn't need a
> password?
>
> Thanks - I'm dispairing after playing for over a week now.

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vista Network Problem / Sharing / Computers not Showing on Network =?Utf-8?B?Y3liM3JiMHlfZ3I=?= microsoft.public.windows.vista.networking sharing 6 06-07-2009 16:58
Vista HDD sharing problem in home network Rebeleleven microsoft.public.windows.vista.networking sharing 3 03-31-2008 07:39
Vista (Home Prem) Permissions - Multiple Access to a Network Share sauvagii microsoft.public.windows.vista.networking sharing 2 01-30-2008 20:45
Network Sharing Access XP to Vista Clayton microsoft.public.windows.vista.networking sharing 7 04-05-2007 01:54
Problem with sharing drives on Vista and XP network =?Utf-8?B?cGFybG91cw==?= microsoft.public.windows.vista.general 4 03-05-2007 04:35




All times are GMT +1. The time now is 11:32.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120