Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Don't Append Primary DNS Suffix

microsoft.public.windows.vista.networking sharing






Speedup My PC
Reply
  #1 (permalink)  
Old 09-30-2008
Victor S.
 

Posts: n/a
Don't Append Primary DNS Suffix
How can I configure Windows Vista to append the connection-specific DNS
suffix to DNS lookups but not the primary DNS suffix?

Here is the problem I am having. Laptops are joined to the AD domain so
their primary DNS suffix is the domain name. (I will use company.com as an
example.) Unfortunately, someone else registered our internal domain name on
the Internet and has a wildcard/catch-all DNS entry set so every hostname
resolves to the same IP address (e.g., 72.3.135.151). Internally, DNS
resolution works well because the internal DNS servers are authoritative for
the domain name. However, when not on the company network (such as when at a
client's site), all DNS lookups not using a FQDN return the same external IP
address (e.g., 72.3.135.151). Also, even if using the FQDN in nslookup,
everything always resolves to the same external IP address because nslookup
always appends the primary DNS suffix (e.g. hostname.test.com becomes
hostname.test.com.company.com, which returns 72.3.135.151).

I realize that there are workarounds (e.g. make the primary DNS suffix
different than the domain name, always use FQDNs, append a period at the end
of the FQDN in nslookup), but all of them have their problems and drawbacks.
For example, even if users get used to using FQDNs, some of our clients have
web-based applications that use just the hostnames. When using one of these
applications is accessed with one of our laptops, links to server2 get
redirected to server2.company.com, which brings up an external webpage and
breaks the app.

So, if it's possible, the only good solution I can see is to configure
Windows to ignore the primary DNS suffix and only append the
connection-specific suffix.
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 10-01-2008
Kerry Brown
 

Posts: n/a
Re: Don't Append Primary DNS Suffix
If it is just the company laptops with the problem adding the servers to the
hosts file on the laptops may work. This will only work if the servers are
only using a public IP address. If they have a private IP address that is
used internally then the laptops won't be able to access them while
connected to the internal network

--
Kerry Brown
MS-MVP - Windows Desktop Experience: Systems Administration
http://www.vistahelp.ca/phpBB2/
http://vistahelpca.blogspot.com/


"Victor S." <VictorS@discussions.microsoft.com> wrote in message
news:6ECC2523-B3BB-4B5C-A080-E9D4AF39EF80@microsoft.com...
> How can I configure Windows Vista to append the connection-specific DNS
> suffix to DNS lookups but not the primary DNS suffix?
>
> Here is the problem I am having. Laptops are joined to the AD domain so
> their primary DNS suffix is the domain name. (I will use company.com as
> an
> example.) Unfortunately, someone else registered our internal domain name
> on
> the Internet and has a wildcard/catch-all DNS entry set so every hostname
> resolves to the same IP address (e.g., 72.3.135.151). Internally, DNS
> resolution works well because the internal DNS servers are authoritative
> for
> the domain name. However, when not on the company network (such as when
> at a
> client's site), all DNS lookups not using a FQDN return the same external
> IP
> address (e.g., 72.3.135.151). Also, even if using the FQDN in nslookup,
> everything always resolves to the same external IP address because
> nslookup
> always appends the primary DNS suffix (e.g. hostname.test.com becomes
> hostname.test.com.company.com, which returns 72.3.135.151).
>
> I realize that there are workarounds (e.g. make the primary DNS suffix
> different than the domain name, always use FQDNs, append a period at the
> end
> of the FQDN in nslookup), but all of them have their problems and
> drawbacks.
> For example, even if users get used to using FQDNs, some of our clients
> have
> web-based applications that use just the hostnames. When using one of
> these
> applications is accessed with one of our laptops, links to server2 get
> redirected to server2.company.com, which brings up an external webpage and
> breaks the app.
>
> So, if it's possible, the only good solution I can see is to configure
> Windows to ignore the primary DNS suffix and only append the
> connection-specific suffix.


Reply With Quote
  #3 (permalink)  
Old 10-01-2008
Victor S.
 

Posts: n/a
Re: Don't Append Primary DNS Suffix
I'm not sure which servers you are suggesting should be added to the hosts
file or how it might prevent the primary DNS suffix from being appended. In
any case, almost everything uses internal IP addresses. Those servers that
do use external IP addresses are not a problem since the FQDN for them is
always specified.

If you can think of a way that your recommendation can be modified to
prevent the appending of the primary DNS suffix when using internal IP
address, please let me know. Any other suggestions would also be
appreciated.

Thanks,

Victor


"Kerry Brown" <kerry@kdbNOSPAMsys-tems.c*a*m> wrote in message
news:%23kpkLe1IJHA.2580@TK2MSFTNGP05.phx.gbl...
> If it is just the company laptops with the problem adding the servers to
> the hosts file on the laptops may work. This will only work if the servers
> are only using a public IP address. If they have a private IP address that
> is used internally then the laptops won't be able to access them while
> connected to the internal network
>
> --
> Kerry Brown
> MS-MVP - Windows Desktop Experience: Systems Administration
> http://www.vistahelp.ca/phpBB2/
> http://vistahelpca.blogspot.com/
>
>
> "Victor S." <VictorS@discussions.microsoft.com> wrote in message
> news:6ECC2523-B3BB-4B5C-A080-E9D4AF39EF80@microsoft.com...
>> How can I configure Windows Vista to append the connection-specific DNS
>> suffix to DNS lookups but not the primary DNS suffix?
>>
>> Here is the problem I am having. Laptops are joined to the AD domain so
>> their primary DNS suffix is the domain name. (I will use company.com as
>> an
>> example.) Unfortunately, someone else registered our internal domain
>> name on
>> the Internet and has a wildcard/catch-all DNS entry set so every hostname
>> resolves to the same IP address (e.g., 72.3.135.151). Internally, DNS
>> resolution works well because the internal DNS servers are authoritative
>> for
>> the domain name. However, when not on the company network (such as when
>> at a
>> client's site), all DNS lookups not using a FQDN return the same external
>> IP
>> address (e.g., 72.3.135.151). Also, even if using the FQDN in nslookup,
>> everything always resolves to the same external IP address because
>> nslookup
>> always appends the primary DNS suffix (e.g. hostname.test.com becomes
>> hostname.test.com.company.com, which returns 72.3.135.151).
>>
>> I realize that there are workarounds (e.g. make the primary DNS suffix
>> different than the domain name, always use FQDNs, append a period at the
>> end
>> of the FQDN in nslookup), but all of them have their problems and
>> drawbacks.
>> For example, even if users get used to using FQDNs, some of our clients
>> have
>> web-based applications that use just the hostnames. When using one of
>> these
>> applications is accessed with one of our laptops, links to server2 get
>> redirected to server2.company.com, which brings up an external webpage
>> and
>> breaks the app.
>>
>> So, if it's possible, the only good solution I can see is to configure
>> Windows to ignore the primary DNS suffix and only append the
>> connection-specific suffix.

>


Reply With Quote
  #4 (permalink)  
Old 10-01-2008
Kerry Brown
 

Posts: n/a
Re: Don't Append Primary DNS Suffix
If a name exists in the hosts file DNS is never used to resolve the name.
You would create entries like this:

192.168.2.1 servername
192.168.2.1 servername.domain.com

--
Kerry Brown
MS-MVP - Windows Desktop Experience: Systems Administration
http://www.vistahelp.ca/phpBB2/
http://vistahelpca.blogspot.com/


"Victor S." <VictorS@discussions.microsoft.com> wrote in message
news:57B3459C-E0F9-4A2D-8622-F861BA30549A@microsoft.com...
> I'm not sure which servers you are suggesting should be added to the hosts
> file or how it might prevent the primary DNS suffix from being appended.
> In any case, almost everything uses internal IP addresses. Those servers
> that do use external IP addresses are not a problem since the FQDN for
> them is always specified.
>
> If you can think of a way that your recommendation can be modified to
> prevent the appending of the primary DNS suffix when using internal IP
> address, please let me know. Any other suggestions would also be
> appreciated.
>
> Thanks,
>
> Victor
>
>
> "Kerry Brown" <kerry@kdbNOSPAMsys-tems.c*a*m> wrote in message
> news:%23kpkLe1IJHA.2580@TK2MSFTNGP05.phx.gbl...
>> If it is just the company laptops with the problem adding the servers to
>> the hosts file on the laptops may work. This will only work if the
>> servers are only using a public IP address. If they have a private IP
>> address that is used internally then the laptops won't be able to access
>> them while connected to the internal network
>>
>> --
>> Kerry Brown
>> MS-MVP - Windows Desktop Experience: Systems Administration
>> http://www.vistahelp.ca/phpBB2/
>> http://vistahelpca.blogspot.com/
>>
>>
>> "Victor S." <VictorS@discussions.microsoft.com> wrote in message
>> news:6ECC2523-B3BB-4B5C-A080-E9D4AF39EF80@microsoft.com...
>>> How can I configure Windows Vista to append the connection-specific DNS
>>> suffix to DNS lookups but not the primary DNS suffix?
>>>
>>> Here is the problem I am having. Laptops are joined to the AD domain so
>>> their primary DNS suffix is the domain name. (I will use company.com as
>>> an
>>> example.) Unfortunately, someone else registered our internal domain
>>> name on
>>> the Internet and has a wildcard/catch-all DNS entry set so every
>>> hostname
>>> resolves to the same IP address (e.g., 72.3.135.151). Internally, DNS
>>> resolution works well because the internal DNS servers are authoritative
>>> for
>>> the domain name. However, when not on the company network (such as when
>>> at a
>>> client's site), all DNS lookups not using a FQDN return the same
>>> external IP
>>> address (e.g., 72.3.135.151). Also, even if using the FQDN in nslookup,
>>> everything always resolves to the same external IP address because
>>> nslookup
>>> always appends the primary DNS suffix (e.g. hostname.test.com becomes
>>> hostname.test.com.company.com, which returns 72.3.135.151).
>>>
>>> I realize that there are workarounds (e.g. make the primary DNS suffix
>>> different than the domain name, always use FQDNs, append a period at the
>>> end
>>> of the FQDN in nslookup), but all of them have their problems and
>>> drawbacks.
>>> For example, even if users get used to using FQDNs, some of our clients
>>> have
>>> web-based applications that use just the hostnames. When using one of
>>> these
>>> applications is accessed with one of our laptops, links to server2 get
>>> redirected to server2.company.com, which brings up an external webpage
>>> and
>>> breaks the app.
>>>
>>> So, if it's possible, the only good solution I can see is to configure
>>> Windows to ignore the primary DNS suffix and only append the
>>> connection-specific suffix.

>>

>


Reply With Quote
  #5 (permalink)  
Old 10-01-2008
Victor S.
 

Posts: n/a
Re: Don't Append Primary DNS Suffix
OK. I understand now. It will definitely help in some situations but I'm
still hoping to find a way to have Vista bypass appending the primary DNS
suffix to lookups but still use the connection-specific DNS suffix. Your
response will work around the last of the situations that have come up, but
if I can replace all of the workarounds with one solution (one that is
easier on the users), I would prefer that.

Thanks,

Victor

"Kerry Brown" <kerry@kdbNOSPAMsys-tems.c*a*m> wrote in message
news:OlUNhc4IJHA.728@TK2MSFTNGP03.phx.gbl...
> If a name exists in the hosts file DNS is never used to resolve the name.
> You would create entries like this:
>
> 192.168.2.1 servername
> 192.168.2.1 servername.domain.com
>
> --
> Kerry Brown
> MS-MVP - Windows Desktop Experience: Systems Administration
> http://www.vistahelp.ca/phpBB2/
> http://vistahelpca.blogspot.com/
>
>
> "Victor S." <VictorS@discussions.microsoft.com> wrote in message
> news:57B3459C-E0F9-4A2D-8622-F861BA30549A@microsoft.com...
>> I'm not sure which servers you are suggesting should be added to the
>> hosts file or how it might prevent the primary DNS suffix from being
>> appended. In any case, almost everything uses internal IP addresses.
>> Those servers that do use external IP addresses are not a problem since
>> the FQDN for them is always specified.
>>
>> If you can think of a way that your recommendation can be modified to
>> prevent the appending of the primary DNS suffix when using internal IP
>> address, please let me know. Any other suggestions would also be
>> appreciated.


Reply With Quote
  #6 (permalink)  
Old 10-02-2008
Kerry Brown
 

Posts: n/a
Re: Don't Append Primary DNS Suffix
If your Active Directory domain name is the same as the public domain name
some one else has registered I don't think you will find one solution that
works in all cases. Even when you own the public domain name, having the
same AD domain name and public name is hard to manage for laptops that
travel outside the domain. If you do find a solution please post back with
how you did it.

--
Kerry Brown
MS-MVP - Windows Desktop Experience: Systems Administration
http://www.vistahelp.ca/phpBB2/
http://vistahelpca.blogspot.com/


"Victor S." <VictorS@discussions.microsoft.com> wrote in message
news:A65B50AA-FAD7-4554-95CA-9C26BA65BBA8@microsoft.com...
> OK. I understand now. It will definitely help in some situations but I'm
> still hoping to find a way to have Vista bypass appending the primary DNS
> suffix to lookups but still use the connection-specific DNS suffix. Your
> response will work around the last of the situations that have come up,
> but if I can replace all of the workarounds with one solution (one that is
> easier on the users), I would prefer that.
>
> Thanks,
>
> Victor
>
> "Kerry Brown" <kerry@kdbNOSPAMsys-tems.c*a*m> wrote in message
> news:OlUNhc4IJHA.728@TK2MSFTNGP03.phx.gbl...
>> If a name exists in the hosts file DNS is never used to resolve the name.
>> You would create entries like this:
>>
>> 192.168.2.1 servername
>> 192.168.2.1 servername.domain.com
>>
>> --
>> Kerry Brown
>> MS-MVP - Windows Desktop Experience: Systems Administration
>> http://www.vistahelp.ca/phpBB2/
>> http://vistahelpca.blogspot.com/
>>
>>
>> "Victor S." <VictorS@discussions.microsoft.com> wrote in message
>> news:57B3459C-E0F9-4A2D-8622-F861BA30549A@microsoft.com...
>>> I'm not sure which servers you are suggesting should be added to the
>>> hosts file or how it might prevent the primary DNS suffix from being
>>> appended. In any case, almost everything uses internal IP addresses.
>>> Those servers that do use external IP addresses are not a problem since
>>> the FQDN for them is always specified.
>>>
>>> If you can think of a way that your recommendation can be modified to
>>> prevent the appending of the primary DNS suffix when using internal IP
>>> address, please let me know. Any other suggestions would also be
>>> appreciated.

>


Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Connection-specific DNS Suffix (corrupt) Clar microsoft.public.windows.vista.networking sharing 0 11-28-2007 16:44
Attachments with .email suffix Ron microsoft.public.windows.vista.mail 6 08-23-2007 23:00
Append DNS suffix not enabled in UI..why? =?Utf-8?B?QnJ1Y2U=?= microsoft.public.windows.vista.networking sharing 0 04-24-2007 01:00
Problems with appending DNS suffix for name resolution =?Utf-8?B?VG9tNDcxMQ==?= microsoft.public.windows.vista.networking sharing 9 03-05-2007 16:23
DNS suffix and "change primary DNS suffix when domain membership c =?Utf-8?B?a3di?= microsoft.public.windows.vista.installation setup 0 03-01-2007 22:19




All times are GMT +1. The time now is 11:53.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120