Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Remote desktop can not use XP pro as host

microsoft.public.windows.vista.networking sharing






Speedup My PC
Reply
  #1 (permalink)  
Old 09-30-2008
chasgl
 

Posts: n/a
Remote desktop can not use XP pro as host
My home network is composed of XP pro computers. They are all on my
workgroup "Fred". I now have a Vista Home Premium 64 bit machine. I put in
on "Fred" too. All the computers can see each other. They can all access
each other's shared directories. When I start Remote Desktop on my Vista
machine I can browse to the XP computers. But when I get the message "This
computer can't connect to the remote computer .. try again" I just had one
success giving Remote Desktop the IP address of the computer instead of the
name it complained it couldn't verify the computer name but then let me. I
couldn't do that before. Vista has SP1 in it like a KB article said. The XP
computers have LLTD on them. The Name vs ip address may be a bit of a clue,
If I ping CTRAVEL (an XP computer) from another XP computer it pings
192.168.1.100 which is correct. But if I ping it from my Vista computer is
pings 207.69.131.10 which is wrong.
Any ideas?
Thanks
Chas
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 09-30-2008
Victor S.
 

Posts: n/a
RE: Remote desktop can not use XP pro as host
This looks like it's a DNS resolution issue.

At a command prompt, do "ipconfig /all" and look at the output. Verify that
the Vista PC's IP address starts with 192.168.1. If that is correct, verify
that your DNS server is set to the same one as on the XP PCs (probably
192.168.1.1).

If that does not help, when you try to ping the CTRAVEL computer by name,
does it say "Pinging ctravel [207.69.131.10] with 32 bytes of data" or is
there something after "ctravel"? If there is, do the same from an XP
computer and compare the two. If they are different, then you might have a
different primary DNS suffix set on the Vista computer. (It's set in the
same place that the computername is set.)
Reply With Quote
  #3 (permalink)  
Old 09-30-2008
Gordon
 

Posts: n/a
Re: Remote desktop can not use XP pro as host
"Victor S." <VictorS@discussions.microsoft.com> wrote in message
news:76B2CC39-19C1-4FBD-80E0-6328C204DA16@microsoft.com...
> This looks like it's a DNS resolution issue.
>
> At a command prompt, do "ipconfig /all" and look at the output. Verify
> that
> the Vista PC's IP address starts with 192.168.1. If that is correct,
> verify
> that your DNS server is set to the same one as on the XP PCs (probably
> 192.168.1.1).
>
> If that does not help, when you try to ping the CTRAVEL computer by name,
> does it say "Pinging ctravel [207.69.131.10] with 32 bytes of data" or is
> there something after "ctravel"? If there is, do the same from an XP
> computer and compare the two. If they are different, then you might have
> a
> different primary DNS suffix set on the Vista computer. (It's set in the
> same place that the computername is set.)



Please quote the post you are replying to - most regulars here do NOT use
the web interface.

http://dts-l.net/goodpost.htm
http://www.netmeister.org/news/learn2quote.html

Thank you.

Reply With Quote
  #4 (permalink)  
Old 10-01-2008
chas
 

Posts: n/a
Re: Remote desktop can not use XP pro as host
Original question
My home network is composed of XP pro computers. They are all on my
workgroup "Fred". I now have a Vista Home Premium 64 bit machine. I
put in
on "Fred" too. All the computers can see each other. They can all access
each other's shared directories. When I start Remote Desktop on my Vista
machine I can browse to the XP computers. But when I get the message "This
computer can't connect to the remote computer .. try again" I just had one
success giving Remote Desktop the IP address of the computer instead of the
name it complained it couldn't verify the computer name but then let me. I
couldn't do that before. Vista has SP1 in it like a KB article said.
The XP
computers have LLTD on them. The Name vs ip address may be a bit of a
clue,
If I ping CTRAVEL (an XP computer) from another XP computer it pings
192.168.1.100 which is correct. But if I ping it from my Vista computer is
pings 207.69.131.10 which is wrong.
Any ideas?
Thanks
Chas
Victor S. wrote:
> This looks like it's a DNS resolution issue.
>
> At a command prompt, do "ipconfig /all" and look at the output. Verify that
> the Vista PC's IP address starts with 192.168.1. If that is correct, verify
> that your DNS server is set to the same one as on the XP PCs (probably
> 192.168.1.1).
>
> If that does not help, when you try to ping the CTRAVEL computer by name,
> does it say "Pinging ctravel [207.69.131.10] with 32 bytes of data" or is
> there something after "ctravel"? If there is, do the same from an XP
> computer and compare the two. If they are different, then you might have a
> different primary DNS suffix set on the Vista computer. (It's set in the
> same place that the computername is set.)

I think you are on the right track. For the Vista machine ipconfig
/all shows IPv4 Address. . . . . . . . . . . : 192.168.1.102(Preferred)
so the address is OK. But is shows a connection specific DNS server
Connection-specific DNS Suffix . : san.rr.com
Description . . . . . . . . . . . : Marvell Yukon 88E8071 PCI-E
Gigabit Ether
net Controller
and pinging CTRAVEL shows
Pinging CTRAVEL.san.rr.com [207.69.131.10] with 32 bytes of data:

But pinging on an XP machine shows
Pinging ctravel [192.168.1.100] with 32 bytes of data:

But I couldn't find where to get rid of the suffix. I looked around
"where you change the computer name" several ways. And did some help
searches. How do I get rid of the suffix?
Thanks,
Chas
Reply With Quote
  #5 (permalink)  
Old 10-01-2008
Victor S.
 

Posts: n/a
Re: Remote desktop can not use XP pro as host
The connection-specific suffix can come from one of two places:
1. If your IP addresses is set via DHCP, the DHCP server usually hands it
out.
2. If you are using a static IP address, it is set in the network
connection's properties (Internet Protocol Version 4 / Advanced / DNS tab).

If you do an "ipconfig /all", it will list your DHCP server. If you have
control over your DHCP server (perhaps built into your router), then you can
remove it (or change it if you have an internal DNS server). Otherwise, you
can tell your DNS client not to append the primary and connection specific
suffixes. (It's also set on the DNS tab. You can just put a period in the
"Append these DNS suffixes" field.) This should force Windows to try other
means to resolve the name.


"chas" <noreply@newsgrouponly.com> wrote in message
news:hbGdnTvp-6hxTH7VnZ2dnUVZ_t_inZ2d@earthlink.com...
> Original question
> My home network is composed of XP pro computers. They are all on my
> workgroup "Fred". I now have a Vista Home Premium 64 bit machine. I put
> in
> on "Fred" too. All the computers can see each other. They can all access
> each other's shared directories. When I start Remote Desktop on my Vista
> machine I can browse to the XP computers. But when I get the message
> "This
> computer can't connect to the remote computer .. try again" I just had
> one
> success giving Remote Desktop the IP address of the computer instead of
> the
> name it complained it couldn't verify the computer name but then let me.
> I
> couldn't do that before. Vista has SP1 in it like a KB article said. The
> XP
> computers have LLTD on them. The Name vs ip address may be a bit of a
> clue,
> If I ping CTRAVEL (an XP computer) from another XP computer it pings
> 192.168.1.100 which is correct. But if I ping it from my Vista computer
> is
> pings 207.69.131.10 which is wrong.
> Any ideas?
> Thanks
> Chas
> Victor S. wrote:
>> This looks like it's a DNS resolution issue.
>>
>> At a command prompt, do "ipconfig /all" and look at the output. Verify
>> that the Vista PC's IP address starts with 192.168.1. If that is
>> correct, verify that your DNS server is set to the same one as on the XP
>> PCs (probably 192.168.1.1).
>>
>> If that does not help, when you try to ping the CTRAVEL computer by name,
>> does it say "Pinging ctravel [207.69.131.10] with 32 bytes of data" or is
>> there something after "ctravel"? If there is, do the same from an XP
>> computer and compare the two. If they are different, then you might have
>> a different primary DNS suffix set on the Vista computer. (It's set in
>> the same place that the computername is set.)

> I think you are on the right track. For the Vista machine ipconfig /all
> shows IPv4 Address. . . . . . . . . . . : 192.168.1.102(Preferred) so the
> address is OK. But is shows a connection specific DNS server
> Connection-specific DNS Suffix . : san.rr.com
> Description . . . . . . . . . . . : Marvell Yukon 88E8071 PCI-E Gigabit
> Ether
> net Controller
> and pinging CTRAVEL shows
> Pinging CTRAVEL.san.rr.com [207.69.131.10] with 32 bytes of data:
>
> But pinging on an XP machine shows
> Pinging ctravel [192.168.1.100] with 32 bytes of data:
>
> But I couldn't find where to get rid of the suffix. I looked around
> "where you change the computer name" several ways. And did some help
> searches. How do I get rid of the suffix?
> Thanks,
> Chas


Reply With Quote
  #6 (permalink)  
Old 10-02-2008
chas
 

Posts: n/a
Things just got stranger
When I put a period in the Append these DNS suffixes then sure enough
the ping happens correctly. But now when I go to browse to a computer
in my workgroup I get : The FRED domain/workgroup does not contain any
Terminal servers (never saw that before). Even if I remove the period
this still happens now. If I go to Network on the Vista machine the
other machines no longer show up (they did before). But if I view
Workgroup computers on the XP machines all the machines including the
Vista machine still show up. I haven't made any changes on the XP
machines since I put the Vista machine on but a long time ago I did put
Terminal servers on the XP machines.
Thanks,
Chas
Victor S. wrote:
> The connection-specific suffix can come from one of two places:
> 1. If your IP addresses is set via DHCP, the DHCP server usually hands
> it out.
> 2. If you are using a static IP address, it is set in the network
> connection's properties (Internet Protocol Version 4 / Advanced / DNS tab).
>
> If you do an "ipconfig /all", it will list your DHCP server. If you
> have control over your DHCP server (perhaps built into your router),
> then you can remove it (or change it if you have an internal DNS
> server). Otherwise, you can tell your DNS client not to append the
> primary and connection specific suffixes. (It's also set on the DNS
> tab. You can just put a period in the "Append these DNS suffixes"
> field.) This should force Windows to try other means to resolve the name.
>
>
> "chas" <noreply@newsgrouponly.com> wrote in message
> news:hbGdnTvp-6hxTH7VnZ2dnUVZ_t_inZ2d@earthlink.com...
>> Original question
>> My home network is composed of XP pro computers. They are all on my
>> workgroup "Fred". I now have a Vista Home Premium 64 bit machine. I
>> put in
>> on "Fred" too. All the computers can see each other. They can all access
>> each other's shared directories. When I start Remote Desktop on my
>> Vista
>> machine I can browse to the XP computers. But when I get the message
>> "This
>> computer can't connect to the remote computer .. try again" I just
>> had one
>> success giving Remote Desktop the IP address of the computer instead
>> of the
>> name it complained it couldn't verify the computer name but then let
>> me. I
>> couldn't do that before. Vista has SP1 in it like a KB article said.
>> The XP
>> computers have LLTD on them. The Name vs ip address may be a bit of a
>> clue,
>> If I ping CTRAVEL (an XP computer) from another XP computer it pings
>> 192.168.1.100 which is correct. But if I ping it from my Vista
>> computer is
>> pings 207.69.131.10 which is wrong.
>> Any ideas?
>> Thanks
>> Chas
>> Victor S. wrote:
>>> This looks like it's a DNS resolution issue.
>>>
>>> At a command prompt, do "ipconfig /all" and look at the output.
>>> Verify that the Vista PC's IP address starts with 192.168.1. If that
>>> is correct, verify that your DNS server is set to the same one as on
>>> the XP PCs (probably 192.168.1.1).
>>>
>>> If that does not help, when you try to ping the CTRAVEL computer by
>>> name, does it say "Pinging ctravel [207.69.131.10] with 32 bytes of
>>> data" or is there something after "ctravel"? If there is, do the
>>> same from an XP computer and compare the two. If they are different,
>>> then you might have a different primary DNS suffix set on the Vista
>>> computer. (It's set in the same place that the computername is set.)

>> I think you are on the right track. For the Vista machine ipconfig
>> /all shows IPv4 Address. . . . . . . . . . . :
>> 192.168.1.102(Preferred) so the address is OK. But is shows a
>> connection specific DNS server
>> Connection-specific DNS Suffix . : san.rr.com
>> Description . . . . . . . . . . . : Marvell Yukon 88E8071 PCI-E
>> Gigabit Ether
>> net Controller
>> and pinging CTRAVEL shows
>> Pinging CTRAVEL.san.rr.com [207.69.131.10] with 32 bytes of data:
>>
>> But pinging on an XP machine shows
>> Pinging ctravel [192.168.1.100] with 32 bytes of data:
>>
>> But I couldn't find where to get rid of the suffix. I looked around
>> "where you change the computer name" several ways. And did some help
>> searches. How do I get rid of the suffix?
>> Thanks,
>> Chas

>

Reply With Quote
  #7 (permalink)  
Old 10-02-2008
chas
 

Posts: n/a
Re: Things just got stranger
Oh yes, also the XP machines can still see the Vista machine. But now
when I select it from windows explorer I get a message about not having
rights to use it, I used to get a logon prompt.
Chas
chas wrote:
> When I put a period in the Append these DNS suffixes then sure enough
> the ping happens correctly. But now when I go to browse to a computer
> in my workgroup I get : The FRED domain/workgroup does not contain any
> Terminal servers (never saw that before). Even if I remove the period
> this still happens now. If I go to Network on the Vista machine the
> other machines no longer show up (they did before). But if I view
> Workgroup computers on the XP machines all the machines including the
> Vista machine still show up. I haven't made any changes on the XP
> machines since I put the Vista machine on but a long time ago I did put
> Terminal servers on the XP machines.
> Thanks,
> Chas
> Victor S. wrote:
>> The connection-specific suffix can come from one of two places:
>> 1. If your IP addresses is set via DHCP, the DHCP server usually hands
>> it out.
>> 2. If you are using a static IP address, it is set in the network
>> connection's properties (Internet Protocol Version 4 / Advanced / DNS
>> tab).
>>
>> If you do an "ipconfig /all", it will list your DHCP server. If you
>> have control over your DHCP server (perhaps built into your router),
>> then you can remove it (or change it if you have an internal DNS
>> server). Otherwise, you can tell your DNS client not to append the
>> primary and connection specific suffixes. (It's also set on the DNS
>> tab. You can just put a period in the "Append these DNS suffixes"
>> field.) This should force Windows to try other means to resolve the
>> name.
>>
>>
>> "chas" <noreply@newsgrouponly.com> wrote in message
>> news:hbGdnTvp-6hxTH7VnZ2dnUVZ_t_inZ2d@earthlink.com...
>>> Original question
>>> My home network is composed of XP pro computers. They are all on my
>>> workgroup "Fred". I now have a Vista Home Premium 64 bit machine.
>>> I put in
>>> on "Fred" too. All the computers can see each other. They can all
>>> access
>>> each other's shared directories. When I start Remote Desktop on my
>>> Vista
>>> machine I can browse to the XP computers. But when I get the message
>>> "This
>>> computer can't connect to the remote computer .. try again" I just
>>> had one
>>> success giving Remote Desktop the IP address of the computer instead
>>> of the
>>> name it complained it couldn't verify the computer name but then let
>>> me. I
>>> couldn't do that before. Vista has SP1 in it like a KB article said.
>>> The XP
>>> computers have LLTD on them. The Name vs ip address may be a bit of
>>> a clue,
>>> If I ping CTRAVEL (an XP computer) from another XP computer it pings
>>> 192.168.1.100 which is correct. But if I ping it from my Vista
>>> computer is
>>> pings 207.69.131.10 which is wrong.
>>> Any ideas?
>>> Thanks
>>> Chas
>>> Victor S. wrote:
>>>> This looks like it's a DNS resolution issue.
>>>>
>>>> At a command prompt, do "ipconfig /all" and look at the output.
>>>> Verify that the Vista PC's IP address starts with 192.168.1. If
>>>> that is correct, verify that your DNS server is set to the same one
>>>> as on the XP PCs (probably 192.168.1.1).
>>>>
>>>> If that does not help, when you try to ping the CTRAVEL computer by
>>>> name, does it say "Pinging ctravel [207.69.131.10] with 32 bytes of
>>>> data" or is there something after "ctravel"? If there is, do the
>>>> same from an XP computer and compare the two. If they are
>>>> different, then you might have a different primary DNS suffix set on
>>>> the Vista computer. (It's set in the same place that the
>>>> computername is set.)
>>> I think you are on the right track. For the Vista machine ipconfig
>>> /all shows IPv4 Address. . . . . . . . . . . :
>>> 192.168.1.102(Preferred) so the address is OK. But is shows a
>>> connection specific DNS server
>>> Connection-specific DNS Suffix . : san.rr.com
>>> Description . . . . . . . . . . . : Marvell Yukon 88E8071 PCI-E
>>> Gigabit Ether
>>> net Controller
>>> and pinging CTRAVEL shows
>>> Pinging CTRAVEL.san.rr.com [207.69.131.10] with 32 bytes of data:
>>>
>>> But pinging on an XP machine shows
>>> Pinging ctravel [192.168.1.100] with 32 bytes of data:
>>>
>>> But I couldn't find where to get rid of the suffix. I looked around
>>> "where you change the computer name" several ways. And did some help
>>> searches. How do I get rid of the suffix?
>>> Thanks,
>>> Chas

>>

Reply With Quote
  #8 (permalink)  
Old 10-06-2008
Victor S.
 

Posts: n/a
Re: Things just got stranger
Sorry I didn't get back to you sooner. I've been out sick.

If I understand everything correctly then at this point, I would go back to
your original configuration where DNS is set to append the primary and
connection-specific DNS suffixes. Then, if possible, I would set the domain
name that your DHCP server (which is probably running on your router) is
handing out to something like "myhome.internal". After doing that, you will
need to either reboot all of the computers or run "ipconfig /release" and
"ipconfig /renew" on them. This is the quickest and best resolution that I
can think of.

If you do not have access to your router's configuration or you cannot set
the domain name that it hands out, then you can do the following instead:
1. Set static IP addresses on all computers. It looks like DHCP hands out
addresses with the last octet in the 100's so use address below 100 but
don't use 1 (i.e., use 192.168.1.2 through 192.168.1.99). Look at the
output of "ipconfig /all" for the rest of the settings (i.e., subnet mask,
gateway, and DNS servers).
2. Either set the same primary DNS suffix or the same connection-specific
DNS suffix on all computers (for example, myhome.internal). (The primary
DNS suffix is set in the same place that you can change the computer name.
Just click on the More button to get to that option. The
connection-specific DNS suffix can be set in the same place that you set the
DNS servers.)
3. Add each computer to the hosts file on every other computer.
(C:\Windows\System32\drivers\etc\hosts) (Leave the localhost entries in
place.) For example:
127.0.0.1 localhost
::1 localhost
192.168.1.10 ctravel.myhome.internal
192.168.1.11 xp2.myhome.internal
192.168.1.12 vista1.myhome.internal

Assumtions:
- You do not have an internal DNS server
- Your environment does not change much

Downsides:
- More management is involved since any new computers need to be configured
correctly if they will be connecting to the other computers
- Laptops that are part of a Windows domain (e.g., work laptops) cannot be
reconfigured like this


Please let me know how it works out.


"chas" <no@emailreply.please> wrote in message
news:6IWdnZvHyIPYcXnVnZ2dnUVZ_uydnZ2d@earthlink.co m...
> Oh yes, also the XP machines can still see the Vista machine. But now
> when I select it from windows explorer I get a message about not having
> rights to use it, I used to get a logon prompt.
> Chas
> chas wrote:
>> When I put a period in the Append these DNS suffixes then sure enough the
>> ping happens correctly. But now when I go to browse to a computer in my
>> workgroup I get : The FRED domain/workgroup does not contain any Terminal
>> servers (never saw that before). Even if I remove the period this still
>> happens now. If I go to Network on the Vista machine the other machines
>> no longer show up (they did before). But if I view Workgroup computers
>> on the XP machines all the machines including the Vista machine still
>> show up. I haven't made any changes on the XP machines since I put the
>> Vista machine on but a long time ago I did put Terminal servers on the XP
>> machines.
>> Thanks,
>> Chas
>> Victor S. wrote:
>>> The connection-specific suffix can come from one of two places:
>>> 1. If your IP addresses is set via DHCP, the DHCP server usually hands
>>> it out.
>>> 2. If you are using a static IP address, it is set in the network
>>> connection's properties (Internet Protocol Version 4 / Advanced / DNS
>>> tab).
>>>
>>> If you do an "ipconfig /all", it will list your DHCP server. If you
>>> have control over your DHCP server (perhaps built into your router),
>>> then you can remove it (or change it if you have an internal DNS
>>> server). Otherwise, you can tell your DNS client not to append the
>>> primary and connection specific suffixes. (It's also set on the DNS
>>> tab. You can just put a period in the "Append these DNS suffixes"
>>> field.) This should force Windows to try other means to resolve the
>>> name.
>>>
>>>
>>> "chas" <noreply@newsgrouponly.com> wrote in message
>>> news:hbGdnTvp-6hxTH7VnZ2dnUVZ_t_inZ2d@earthlink.com...
>>>> Original question
>>>> My home network is composed of XP pro computers. They are all on my
>>>> workgroup "Fred". I now have a Vista Home Premium 64 bit machine. I
>>>> put in
>>>> on "Fred" too. All the computers can see each other. They can all
>>>> access
>>>> each other's shared directories. When I start Remote Desktop on my
>>>> Vista
>>>> machine I can browse to the XP computers. But when I get the message
>>>> "This
>>>> computer can't connect to the remote computer .. try again" I just had
>>>> one
>>>> success giving Remote Desktop the IP address of the computer instead of
>>>> the
>>>> name it complained it couldn't verify the computer name but then let
>>>> me. I
>>>> couldn't do that before. Vista has SP1 in it like a KB article said.
>>>> The XP
>>>> computers have LLTD on them. The Name vs ip address may be a bit of a
>>>> clue,
>>>> If I ping CTRAVEL (an XP computer) from another XP computer it pings
>>>> 192.168.1.100 which is correct. But if I ping it from my Vista
>>>> computer is
>>>> pings 207.69.131.10 which is wrong.
>>>> Any ideas?
>>>> Thanks
>>>> Chas
>>>> Victor S. wrote:
>>>>> This looks like it's a DNS resolution issue.
>>>>>
>>>>> At a command prompt, do "ipconfig /all" and look at the output.
>>>>> Verify that the Vista PC's IP address starts with 192.168.1. If that
>>>>> is correct, verify that your DNS server is set to the same one as on
>>>>> the XP PCs (probably 192.168.1.1).
>>>>>
>>>>> If that does not help, when you try to ping the CTRAVEL computer by
>>>>> name, does it say "Pinging ctravel [207.69.131.10] with 32 bytes of
>>>>> data" or is there something after "ctravel"? If there is, do the same
>>>>> from an XP computer and compare the two. If they are different, then
>>>>> you might have a different primary DNS suffix set on the Vista
>>>>> computer. (It's set in the same place that the computername is set.)
>>>> I think you are on the right track. For the Vista machine ipconfig
>>>> /all shows IPv4 Address. . . . . . . . . . . : 192.168.1.102(Preferred)
>>>> so the address is OK. But is shows a connection specific DNS server
>>>> Connection-specific DNS Suffix . : san.rr.com
>>>> Description . . . . . . . . . . . : Marvell Yukon 88E8071 PCI-E
>>>> Gigabit Ether
>>>> net Controller
>>>> and pinging CTRAVEL shows
>>>> Pinging CTRAVEL.san.rr.com [207.69.131.10] with 32 bytes of data:
>>>>
>>>> But pinging on an XP machine shows
>>>> Pinging ctravel [192.168.1.100] with 32 bytes of data:
>>>>
>>>> But I couldn't find where to get rid of the suffix. I looked around
>>>> "where you change the computer name" several ways. And did some help
>>>> searches. How do I get rid of the suffix?
>>>> Thanks,
>>>> Chas
>>>


Reply With Quote
  #9 (permalink)  
Old 10-15-2008
chas
 

Posts: n/a
Re: Things just got stranger
I hope you are feeling better. I changed the domain the DNS from the
router passes out to mystreet.home . Both the XP machine and the Vista
machine report the connection-specific DNS suffix as mystreet.home .
The XP sees the vista machine on my workgroup but can not connect to it.
When I ping the vista from the XP it has an address 207.69.131.9
instead of 192.168.1.102
and if I ping 192.168.1.102 the ping times out.
The Vista machine does not see the XP machine on the workgroup. Nor
does it see it anywhere on the network map. Pinging the XP machine by
name pings 207.69.131.10 but pinging by IP address 192.168.1.100 the
Vista machine successfully pings the XP machine. The subnet masks are
all 255.255.255.0 just like they should be.
Thanks,
Chas



Victor S. wrote:
> Sorry I didn't get back to you sooner. I've been out sick.
>
> If I understand everything correctly then at this point, I would go back
> to your original configuration where DNS is set to append the primary
> and connection-specific DNS suffixes. Then, if possible, I would set
> the domain name that your DHCP server (which is probably running on your
> router) is handing out to something like "myhome.internal". After doing
> that, you will need to either reboot all of the computers or run
> "ipconfig /release" and "ipconfig /renew" on them. This is the quickest
> and best resolution that I can think of.
>
> If you do not have access to your router's configuration or you cannot
> set the domain name that it hands out, then you can do the following
> instead:
> 1. Set static IP addresses on all computers. It looks like DHCP hands
> out addresses with the last octet in the 100's so use address below 100
> but don't use 1 (i.e., use 192.168.1.2 through 192.168.1.99). Look at
> the output of "ipconfig /all" for the rest of the settings (i.e., subnet
> mask, gateway, and DNS servers).
> 2. Either set the same primary DNS suffix or the same
> connection-specific DNS suffix on all computers (for example,
> myhome.internal). (The primary DNS suffix is set in the same place that
> you can change the computer name. Just click on the More button to get
> to that option. The connection-specific DNS suffix can be set in the
> same place that you set the DNS servers.)
> 3. Add each computer to the hosts file on every other computer.
> (C:\Windows\System32\drivers\etc\hosts) (Leave the localhost entries in
> place.) For example:
> 127.0.0.1 localhost
> ::1 localhost
> 192.168.1.10 ctravel.myhome.internal
> 192.168.1.11 xp2.myhome.internal
> 192.168.1.12 vista1.myhome.internal
>
> Assumtions:
> - You do not have an internal DNS server
> - Your environment does not change much
>
> Downsides:
> - More management is involved since any new computers need to be
> configured correctly if they will be connecting to the other computers
> - Laptops that are part of a Windows domain (e.g., work laptops) cannot
> be reconfigured like this
>
>
> Please let me know how it works out.
>
>
> "chas" <no@emailreply.please> wrote in message
> news:6IWdnZvHyIPYcXnVnZ2dnUVZ_uydnZ2d@earthlink.co m...
>> Oh yes, also the XP machines can still see the Vista machine. But now
>> when I select it from windows explorer I get a message about not
>> having rights to use it, I used to get a logon prompt.
>> Chas
>> chas wrote:
>>> When I put a period in the Append these DNS suffixes then sure enough
>>> the ping happens correctly. But now when I go to browse to a
>>> computer in my workgroup I get : The FRED domain/workgroup does not
>>> contain any Terminal servers (never saw that before). Even if I
>>> remove the period this still happens now. If I go to Network on the
>>> Vista machine the other machines no longer show up (they did
>>> before). But if I view Workgroup computers on the XP machines all
>>> the machines including the Vista machine still show up. I haven't
>>> made any changes on the XP machines since I put the Vista machine on
>>> but a long time ago I did put Terminal servers on the XP machines.
>>> Thanks,
>>> Chas
>>> Victor S. wrote:
>>>> The connection-specific suffix can come from one of two places:
>>>> 1. If your IP addresses is set via DHCP, the DHCP server usually
>>>> hands it out.
>>>> 2. If you are using a static IP address, it is set in the network
>>>> connection's properties (Internet Protocol Version 4 / Advanced /
>>>> DNS tab).
>>>>
>>>> If you do an "ipconfig /all", it will list your DHCP server. If you
>>>> have control over your DHCP server (perhaps built into your router),
>>>> then you can remove it (or change it if you have an internal DNS
>>>> server). Otherwise, you can tell your DNS client not to append the
>>>> primary and connection specific suffixes. (It's also set on the DNS
>>>> tab. You can just put a period in the "Append these DNS suffixes"
>>>> field.) This should force Windows to try other means to resolve the
>>>> name.
>>>>
>>>>
>>>> "chas" <noreply@newsgrouponly.com> wrote in message
>>>> news:hbGdnTvp-6hxTH7VnZ2dnUVZ_t_inZ2d@earthlink.com...
>>>>> Original question
>>>>> My home network is composed of XP pro computers. They are all on my
>>>>> workgroup "Fred". I now have a Vista Home Premium 64 bit
>>>>> machine. I put in
>>>>> on "Fred" too. All the computers can see each other. They can all
>>>>> access
>>>>> each other's shared directories. When I start Remote Desktop on my
>>>>> Vista
>>>>> machine I can browse to the XP computers. But when I get the
>>>>> message "This
>>>>> computer can't connect to the remote computer .. try again" I just
>>>>> had one
>>>>> success giving Remote Desktop the IP address of the computer
>>>>> instead of the
>>>>> name it complained it couldn't verify the computer name but then
>>>>> let me. I
>>>>> couldn't do that before. Vista has SP1 in it like a KB article
>>>>> said. The XP
>>>>> computers have LLTD on them. The Name vs ip address may be a bit
>>>>> of a clue,
>>>>> If I ping CTRAVEL (an XP computer) from another XP computer it pings
>>>>> 192.168.1.100 which is correct. But if I ping it from my Vista
>>>>> computer is
>>>>> pings 207.69.131.10 which is wrong.
>>>>> Any ideas?
>>>>> Thanks
>>>>> Chas
>>>>> Victor S. wrote:
>>>>>> This looks like it's a DNS resolution issue.
>>>>>>
>>>>>> At a command prompt, do "ipconfig /all" and look at the output.
>>>>>> Verify that the Vista PC's IP address starts with 192.168.1. If
>>>>>> that is correct, verify that your DNS server is set to the same
>>>>>> one as on the XP PCs (probably 192.168.1.1).
>>>>>>
>>>>>> If that does not help, when you try to ping the CTRAVEL computer
>>>>>> by name, does it say "Pinging ctravel [207.69.131.10] with 32
>>>>>> bytes of data" or is there something after "ctravel"? If there
>>>>>> is, do the same from an XP computer and compare the two. If they
>>>>>> are different, then you might have a different primary DNS suffix
>>>>>> set on the Vista computer. (It's set in the same place that the
>>>>>> computername is set.)
>>>>> I think you are on the right track. For the Vista machine
>>>>> ipconfig /all shows IPv4 Address. . . . . . . . . . . :
>>>>> 192.168.1.102(Preferred) so the address is OK. But is shows a
>>>>> connection specific DNS server
>>>>> Connection-specific DNS Suffix . : san.rr.com
>>>>> Description . . . . . . . . . . . : Marvell Yukon 88E8071 PCI-E
>>>>> Gigabit Ether
>>>>> net Controller
>>>>> and pinging CTRAVEL shows
>>>>> Pinging CTRAVEL.san.rr.com [207.69.131.10] with 32 bytes of data:
>>>>>
>>>>> But pinging on an XP machine shows
>>>>> Pinging ctravel [192.168.1.100] with 32 bytes of data:
>>>>>
>>>>> But I couldn't find where to get rid of the suffix. I looked
>>>>> around "where you change the computer name" several ways. And did
>>>>> some help searches. How do I get rid of the suffix?
>>>>> Thanks,
>>>>> Chas
>>>>

>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Remote Desktop Vista Ultimate SP1 host Bill microsoft.public.windows.vista.networking sharing 0 06-04-2008 18:45
Vista: how to enable Remote Desktop Host WITHOUT using Windows Fir Lanwarrior microsoft.public.windows.vista.networking sharing 2 01-08-2008 03:19
Vista Premium should be able to host Remote Desktop Wildwolf498 microsoft.public.windows.vista.networking sharing 4 10-11-2007 16:32
Remote Desktop Host for Vista Home Basic Joe Roux microsoft.public.windows.vista.performance maintenance 2 08-24-2007 11:36
Is there a program to use remote desktop, or remote assistance "host" on Vista Home? Tim microsoft.public.windows.vista.general 5 08-14-2007 11:14




All times are GMT +1. The time now is 09:05.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120