Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Remote Desktop port problem

microsoft.public.windows.vista.networking sharing






Speedup My PC
Reply
  #1 (permalink)  
Old 09-27-2008
Arif Khokar
 

Posts: n/a
Remote Desktop port problem
I recently installed Vista Enterprise. I haven't had any success
enabling remote desktop. First off, under the System Properties Remote
tab page, I've selected "Allow connections from computers running any
version of Remote Desktop (less secure)." Second, I made sure that I
enabled the Remote Desktop exception to Windows firewall. Third, all
Terminal Services related services are started. Fourth, running netstat
-an shows that the computer is listening on port 3389 on 0.0.0.0, but
not on 127.0.0.1, nor on my local network address assigned by the router.

Trying to probe the port from grc.com shows that it's stealth when
Windows Firewall is on but closed when Windows firewall is off. Trying
an unrelated program on a different port and allowing an exception
through the firewell showed that the port was open.

Is there anything that I may be overlooking?

TIA.
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 09-27-2008
fuzor_silverbolt
 

Posts: n/a
Re: Remote Desktop port problem

So I'm guessing you're trying to remote desktop from outside your lan.
Then you need to go into your router and route the ports used for remote
desktop to the destination computer's ip address forr remote desktop to
work outside your lan.


--
fuzor_silverbolt
Reply With Quote
  #3 (permalink)  
Old 09-27-2008
Arif Khokar
 

Posts: n/a
Re: Remote Desktop port problem
fuzor_silverbolt wrote:

> So I'm guessing you're trying to remote desktop from outside your lan.


Correct.

> Then you need to go into your router and route the ports used for remote
> desktop to the destination computer's ip address forr remote desktop to
> work outside your lan.


Which I have already done I believe. I have noticed that regardless of
whether I forward the port to the machine in question, running a port
probe on port 3389 shows that it's closed (as long as Windows firewall
is off). Also, attempting to telnet (from outside the LAN) into the
computer on port 3389 results in a connection refused error. The result
doesn't change regardless of which Remote Desktop connection option I
choose under the Remote tab of the System Properties dialog.
Reply With Quote
  #4 (permalink)  
Old 09-27-2008
Arif Khokar
 

Posts: n/a
Re: Remote Desktop port problem
fuzor_silverbolt wrote:

> So I'm guessing you're trying to remote desktop from outside your lan.


Correct.

> Then you need to go into your router and route the ports used for remote
> desktop to the destination computer's ip address forr remote desktop to
> work outside your lan.


Which I have already done I believe. I have noticed that regardless of
whether I forward the port to the machine in question, running a port
probe on port 3389 shows that it's closed (as long as Windows firewall
is off). Also, attempting to telnet (from outside the LAN) into the
computer on port 3389 results in a connection refused error. The result
doesn't change regardless of which Remote Desktop connection option I
choose under the Remote tab of the System Properties dialog.
Reply With Quote
  #5 (permalink)  
Old 09-27-2008
Arif Khokar
 

Posts: n/a
Re: Remote Desktop port problem
fuzor_silverbolt wrote:

<snip>

Anyway, I finally solved the problem. It turns out that there was a
problem with my router. I had to disable all the forwarded ports and
renable the ones I needed. That allowed port 3389 to be seen as open
from outside the LAN.

In any case, thanks for your help.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
remote desktop ip:port mimirbb@hotmail.com microsoft.public.windows.vista.networking sharing 3 03-18-2008 14:58
Remote Desktop unter anderem Port Markus Donath microsoft.public.de.windows.vista.netzwerk 1 01-11-2008 17:13
Remote Desktop sur vista + port random ??? Jac microsoft.public.fr.windows.vista.general 1 09-19-2007 21:50
Re: Cannot edit registry the change remote desktop port number =?Utf-8?B?TWlrZSBTY2htaWR0?= microsoft.public.windows.vista.general 0 03-01-2007 03:08
Remote Desktop problem with remote printers neworders@gmail.com microsoft.public.windows.vista.networking sharing 0 02-11-2007 17:55




All times are GMT +1. The time now is 11:54.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120