Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Cannot set up 3rd-party ftp server on VISTA

microsoft.public.windows.vista.networking sharing






Speedup My PC
Reply
  #1 (permalink)  
Old 07-24-2008
Fly
 

Posts: n/a
Cannot set up 3rd-party ftp server on VISTA
I have a problem setting up ftp server, such as serv-U or Bulletproof FTP on
my new computer running Vista. On my old one I could set it up in 5 min. This
is also still working, so my router is not the problem.
I have McAfee, but I gave the program full access, no other options
available, even when turning McAfee firewall off, no connection. Windows
firewall is turned off.

It has to be a Vista security issue. Does anybody have ANY idea. I do not at
this point. In Windows defender you can see networking component or something
like this, and the Serv-U, SmartFTP, or Bulletproof show up but it seems they
are not listening on a specific address. Just 0.0.0.0:50000 etc. and no
foreign address.

Can anyone help me?

Den Fly
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 07-24-2008
axelm
 

Posts: n/a
RE: Cannot set up 3rd-party ftp server on VISTA
0.0.0.0:50000 means it accepts connections from all the network adapters.

Have you tried moving it to port 21 just for testing purposes? Remember that
FTP uses two ports, and usually the firewall has to be FTP-aware.

Have you tried connecting to the FTP server from the LAN side? What about
localhost?

Axel

"Fly" wrote:

> I have a problem setting up ftp server, such as serv-U or Bulletproof FTP on
> my new computer running Vista. On my old one I could set it up in 5 min. This
> is also still working, so my router is not the problem.
> I have McAfee, but I gave the program full access, no other options
> available, even when turning McAfee firewall off, no connection. Windows
> firewall is turned off.
>
> It has to be a Vista security issue. Does anybody have ANY idea. I do not at
> this point. In Windows defender you can see networking component or something
> like this, and the Serv-U, SmartFTP, or Bulletproof show up but it seems they
> are not listening on a specific address. Just 0.0.0.0:50000 etc. and no
> foreign address.
>
> Can anyone help me?
>
> Den Fly

Reply With Quote
  #3 (permalink)  
Old 07-24-2008
Fly
 

Posts: n/a
RE: Cannot set up 3rd-party ftp server on VISTA
127.0.0.1 works, I see my files. (I assume this is what you meant by
localhost?)
But ftp://(my ISP address x.x.x.x) does not work, neither in the explorer,
nor in the FTP client SmartFTP.

Directly connected to the modem (without router) does not work.
But my other computer's FTP server is working fine, so the ports in the
router were set the right way.

It is also showing 0.0.0.0:21 and some other 50000-50004

Windows firewall is off, so no ports to be set there I suppose.
And even when turning off the McAfee firewall, I cannot get through.

Den

"axelm" wrote:

> 0.0.0.0:50000 means it accepts connections from all the network adapters.
>
> Have you tried moving it to port 21 just for testing purposes? Remember that
> FTP uses two ports, and usually the firewall has to be FTP-aware.
>
> Have you tried connecting to the FTP server from the LAN side? What about
> localhost?
>
> Axel
>
> "Fly" wrote:
>
> > I have a problem setting up ftp server, such as serv-U or Bulletproof FTP on
> > my new computer running Vista. On my old one I could set it up in 5 min. This
> > is also still working, so my router is not the problem.
> > I have McAfee, but I gave the program full access, no other options
> > available, even when turning McAfee firewall off, no connection. Windows
> > firewall is turned off.
> >
> > It has to be a Vista security issue. Does anybody have ANY idea. I do not at
> > this point. In Windows defender you can see networking component or something
> > like this, and the Serv-U, SmartFTP, or Bulletproof show up but it seems they
> > are not listening on a specific address. Just 0.0.0.0:50000 etc. and no
> > foreign address.
> >
> > Can anyone help me?
> >
> > Den Fly

Reply With Quote
  #4 (permalink)  
Old 07-24-2008
axelm
 

Posts: n/a
RE: Cannot set up 3rd-party ftp server on VISTA
What IP address does your ADSL modem serve via DHCP? Please post the output
from ipconfig /all. If your ADSL modem is in router mode instead of bridge
mode then you have to port forward that too.

Regarding your router, how do you configure the WAN adapter? DHCP or PPPOE?

"Fly" wrote:

> 127.0.0.1 works, I see my files. (I assume this is what you meant by
> localhost?)
> But ftp://(my ISP address x.x.x.x) does not work, neither in the explorer,
> nor in the FTP client SmartFTP.
>
> Directly connected to the modem (without router) does not work.
> But my other computer's FTP server is working fine, so the ports in the
> router were set the right way.
>
> It is also showing 0.0.0.0:21 and some other 50000-50004
>
> Windows firewall is off, so no ports to be set there I suppose.
> And even when turning off the McAfee firewall, I cannot get through.
>
> Den
>
> "axelm" wrote:
>
> > 0.0.0.0:50000 means it accepts connections from all the network adapters.
> >
> > Have you tried moving it to port 21 just for testing purposes? Remember that
> > FTP uses two ports, and usually the firewall has to be FTP-aware.
> >
> > Have you tried connecting to the FTP server from the LAN side? What about
> > localhost?
> >
> > Axel
> >
> > "Fly" wrote:
> >
> > > I have a problem setting up ftp server, such as serv-U or Bulletproof FTP on
> > > my new computer running Vista. On my old one I could set it up in 5 min. This
> > > is also still working, so my router is not the problem.
> > > I have McAfee, but I gave the program full access, no other options
> > > available, even when turning McAfee firewall off, no connection. Windows
> > > firewall is turned off.
> > >
> > > It has to be a Vista security issue. Does anybody have ANY idea. I do not at
> > > this point. In Windows defender you can see networking component or something
> > > like this, and the Serv-U, SmartFTP, or Bulletproof show up but it seems they
> > > are not listening on a specific address. Just 0.0.0.0:50000 etc. and no
> > > foreign address.
> > >
> > > Can anyone help me?
> > >
> > > Den Fly

Reply With Quote
  #5 (permalink)  
Old 07-24-2008
Fly
 

Posts: n/a
RE: Cannot set up 3rd-party ftp server on VISTA
You mean 192.168.0.102...(i set the ports for this also in the router).
I'll have to post the ipconfig /all later as I don't have access to my
computer at the moment.

I believe the router is DHCP configured, I would have to check that as well.

But wouldn't this also affect my other XP computer running on that router?

Thanks,

Den

"axelm" wrote:

> What IP address does your ADSL modem serve via DHCP? Please post the output
> from ipconfig /all. If your ADSL modem is in router mode instead of bridge
> mode then you have to port forward that too.
>
> Regarding your router, how do you configure the WAN adapter? DHCP or PPPOE?
>
> "Fly" wrote:
>
> > 127.0.0.1 works, I see my files. (I assume this is what you meant by
> > localhost?)
> > But ftp://(my ISP address x.x.x.x) does not work, neither in the explorer,
> > nor in the FTP client SmartFTP.
> >
> > Directly connected to the modem (without router) does not work.
> > But my other computer's FTP server is working fine, so the ports in the
> > router were set the right way.
> >
> > It is also showing 0.0.0.0:21 and some other 50000-50004
> >
> > Windows firewall is off, so no ports to be set there I suppose.
> > And even when turning off the McAfee firewall, I cannot get through.
> >
> > Den
> >
> > "axelm" wrote:
> >
> > > 0.0.0.0:50000 means it accepts connections from all the network adapters.
> > >
> > > Have you tried moving it to port 21 just for testing purposes? Remember that
> > > FTP uses two ports, and usually the firewall has to be FTP-aware.
> > >
> > > Have you tried connecting to the FTP server from the LAN side? What about
> > > localhost?
> > >
> > > Axel
> > >
> > > "Fly" wrote:
> > >
> > > > I have a problem setting up ftp server, such as serv-U or Bulletproof FTP on
> > > > my new computer running Vista. On my old one I could set it up in 5 min. This
> > > > is also still working, so my router is not the problem.
> > > > I have McAfee, but I gave the program full access, no other options
> > > > available, even when turning McAfee firewall off, no connection. Windows
> > > > firewall is turned off.
> > > >
> > > > It has to be a Vista security issue. Does anybody have ANY idea. I do not at
> > > > this point. In Windows defender you can see networking component or something
> > > > like this, and the Serv-U, SmartFTP, or Bulletproof show up but it seems they
> > > > are not listening on a specific address. Just 0.0.0.0:50000 etc. and no
> > > > foreign address.
> > > >
> > > > Can anyone help me?
> > > >
> > > > Den Fly

Reply With Quote
  #6 (permalink)  
Old 07-24-2008
axelm
 

Posts: n/a
RE: Cannot set up 3rd-party ftp server on VISTA
Definitely sounds like your ADSL modem is in router mode. You are adding an
extra (wifi?) router behind the ADSL modem, then you AT LEAST have a double
NAT.

You could have and additional NAT layer if your ISP is giving you a private
address (usually 10.x.x.x) instead of a public internet address. This is
usually not the case, but I have seen this happen woth some el-cheapo ISPs.

If this were my network I'd put the ADSL modem in bridge mode and set the
router to PPPOE and try from there. Do you have the password to change the
ADSL modem config? Do you know your PPPOE user and password? Maybe you can
contact you ISP and tell them that you have set up a wireless router and that
you want to reset the ADSL modem to bridge mode. They should be able to help
you if your contract allows more than one PC.

"Fly" wrote:

> You mean 192.168.0.102...(i set the ports for this also in the router).
> I'll have to post the ipconfig /all later as I don't have access to my
> computer at the moment.
>
> I believe the router is DHCP configured, I would have to check that as well.
>
> But wouldn't this also affect my other XP computer running on that router?
>
> Thanks,
>
> Den
>
> "axelm" wrote:
>
> > What IP address does your ADSL modem serve via DHCP? Please post the output
> > from ipconfig /all. If your ADSL modem is in router mode instead of bridge
> > mode then you have to port forward that too.
> >
> > Regarding your router, how do you configure the WAN adapter? DHCP or PPPOE?
> >
> > "Fly" wrote:
> >
> > > 127.0.0.1 works, I see my files. (I assume this is what you meant by
> > > localhost?)
> > > But ftp://(my ISP address x.x.x.x) does not work, neither in the explorer,
> > > nor in the FTP client SmartFTP.
> > >
> > > Directly connected to the modem (without router) does not work.
> > > But my other computer's FTP server is working fine, so the ports in the
> > > router were set the right way.
> > >
> > > It is also showing 0.0.0.0:21 and some other 50000-50004
> > >
> > > Windows firewall is off, so no ports to be set there I suppose.
> > > And even when turning off the McAfee firewall, I cannot get through.
> > >
> > > Den
> > >
> > > "axelm" wrote:
> > >
> > > > 0.0.0.0:50000 means it accepts connections from all the network adapters.
> > > >
> > > > Have you tried moving it to port 21 just for testing purposes? Remember that
> > > > FTP uses two ports, and usually the firewall has to be FTP-aware.
> > > >
> > > > Have you tried connecting to the FTP server from the LAN side? What about
> > > > localhost?
> > > >
> > > > Axel
> > > >
> > > > "Fly" wrote:
> > > >
> > > > > I have a problem setting up ftp server, such as serv-U or Bulletproof FTP on
> > > > > my new computer running Vista. On my old one I could set it up in 5 min. This
> > > > > is also still working, so my router is not the problem.
> > > > > I have McAfee, but I gave the program full access, no other options
> > > > > available, even when turning McAfee firewall off, no connection. Windows
> > > > > firewall is turned off.
> > > > >
> > > > > It has to be a Vista security issue. Does anybody have ANY idea. I do not at
> > > > > this point. In Windows defender you can see networking component or something
> > > > > like this, and the Serv-U, SmartFTP, or Bulletproof show up but it seems they
> > > > > are not listening on a specific address. Just 0.0.0.0:50000 etc. and no
> > > > > foreign address.
> > > > >
> > > > > Can anyone help me?
> > > > >
> > > > > Den Fly

Reply With Quote
  #7 (permalink)  
Old 07-24-2008
Fly
 

Posts: n/a
RE: Cannot set up 3rd-party ftp server on VISTA
sorry, i forgot to mention it is a cable modem. I do have a public IP
address, no need for a password. (the 192.168.0.102, is the address given to
my comp by the (wifi) router.)
I am not sure whether it is a static address or dynamic. But starts with
63.x.x.x

Still, don't understand why this would not affect my other computer, though,
if something was up with the router or the cable modem. hmm, puzzling.
Mind-boggling.

Thanks again.

Den

"axelm" wrote:

> Definitely sounds like your ADSL modem is in router mode. You are adding an
> extra (wifi?) router behind the ADSL modem, then you AT LEAST have a double
> NAT.
>
> You could have and additional NAT layer if your ISP is giving you a private
> address (usually 10.x.x.x) instead of a public internet address. This is
> usually not the case, but I have seen this happen woth some el-cheapo ISPs.
>
> If this were my network I'd put the ADSL modem in bridge mode and set the
> router to PPPOE and try from there. Do you have the password to change the
> ADSL modem config? Do you know your PPPOE user and password? Maybe you can
> contact you ISP and tell them that you have set up a wireless router and that
> you want to reset the ADSL modem to bridge mode. They should be able to help
> you if your contract allows more than one PC.
>
> "Fly" wrote:
>
> > You mean 192.168.0.102...(i set the ports for this also in the router).
> > I'll have to post the ipconfig /all later as I don't have access to my
> > computer at the moment.
> >
> > I believe the router is DHCP configured, I would have to check that as well.
> >
> > But wouldn't this also affect my other XP computer running on that router?
> >
> > Thanks,
> >
> > Den
> >
> > "axelm" wrote:
> >
> > > What IP address does your ADSL modem serve via DHCP? Please post the output
> > > from ipconfig /all. If your ADSL modem is in router mode instead of bridge
> > > mode then you have to port forward that too.
> > >
> > > Regarding your router, how do you configure the WAN adapter? DHCP or PPPOE?
> > >
> > > "Fly" wrote:
> > >
> > > > 127.0.0.1 works, I see my files. (I assume this is what you meant by
> > > > localhost?)
> > > > But ftp://(my ISP address x.x.x.x) does not work, neither in the explorer,
> > > > nor in the FTP client SmartFTP.
> > > >
> > > > Directly connected to the modem (without router) does not work.
> > > > But my other computer's FTP server is working fine, so the ports in the
> > > > router were set the right way.
> > > >
> > > > It is also showing 0.0.0.0:21 and some other 50000-50004
> > > >
> > > > Windows firewall is off, so no ports to be set there I suppose.
> > > > And even when turning off the McAfee firewall, I cannot get through.
> > > >
> > > > Den
> > > >
> > > > "axelm" wrote:
> > > >
> > > > > 0.0.0.0:50000 means it accepts connections from all the network adapters.
> > > > >
> > > > > Have you tried moving it to port 21 just for testing purposes? Remember that
> > > > > FTP uses two ports, and usually the firewall has to be FTP-aware.
> > > > >
> > > > > Have you tried connecting to the FTP server from the LAN side? What about
> > > > > localhost?
> > > > >
> > > > > Axel
> > > > >
> > > > > "Fly" wrote:
> > > > >
> > > > > > I have a problem setting up ftp server, such as serv-U or Bulletproof FTP on
> > > > > > my new computer running Vista. On my old one I could set it up in 5 min. This
> > > > > > is also still working, so my router is not the problem.
> > > > > > I have McAfee, but I gave the program full access, no other options
> > > > > > available, even when turning McAfee firewall off, no connection. Windows
> > > > > > firewall is turned off.
> > > > > >
> > > > > > It has to be a Vista security issue. Does anybody have ANY idea. I do not at
> > > > > > this point. In Windows defender you can see networking component or something
> > > > > > like this, and the Serv-U, SmartFTP, or Bulletproof show up but it seems they
> > > > > > are not listening on a specific address. Just 0.0.0.0:50000 etc. and no
> > > > > > foreign address.
> > > > > >
> > > > > > Can anyone help me?
> > > > > >
> > > > > > Den Fly

Reply With Quote
  #8 (permalink)  
Old 07-24-2008
axelm
 

Posts: n/a
RE: Cannot set up 3rd-party ftp server on VISTA
Tryport forwarding ports 20/tcp and 21/tcp. Sounds like your router is not
handling the ftp control port correctly. Check if your router has a "special
applications" section and if FTP is listed there use that instead of a manual
port forward.

The reason is the FTP has some issues with NAT and usually a special
nat-helper is required.

"Fly" wrote:

> sorry, i forgot to mention it is a cable modem. I do have a public IP
> address, no need for a password. (the 192.168.0.102, is the address given to
> my comp by the (wifi) router.)
> I am not sure whether it is a static address or dynamic. But starts with
> 63.x.x.x
>
> Still, don't understand why this would not affect my other computer, though,
> if something was up with the router or the cable modem. hmm, puzzling.
> Mind-boggling.
>
> Thanks again.
>
> Den
>
> "axelm" wrote:
>
> > Definitely sounds like your ADSL modem is in router mode. You are adding an
> > extra (wifi?) router behind the ADSL modem, then you AT LEAST have a double
> > NAT.
> >
> > You could have and additional NAT layer if your ISP is giving you a private
> > address (usually 10.x.x.x) instead of a public internet address. This is
> > usually not the case, but I have seen this happen woth some el-cheapo ISPs.
> >
> > If this were my network I'd put the ADSL modem in bridge mode and set the
> > router to PPPOE and try from there. Do you have the password to change the
> > ADSL modem config? Do you know your PPPOE user and password? Maybe you can
> > contact you ISP and tell them that you have set up a wireless router and that
> > you want to reset the ADSL modem to bridge mode. They should be able to help
> > you if your contract allows more than one PC.
> >
> > "Fly" wrote:
> >
> > > You mean 192.168.0.102...(i set the ports for this also in the router).
> > > I'll have to post the ipconfig /all later as I don't have access to my
> > > computer at the moment.
> > >
> > > I believe the router is DHCP configured, I would have to check that as well.
> > >
> > > But wouldn't this also affect my other XP computer running on that router?
> > >
> > > Thanks,
> > >
> > > Den
> > >
> > > "axelm" wrote:
> > >
> > > > What IP address does your ADSL modem serve via DHCP? Please post the output
> > > > from ipconfig /all. If your ADSL modem is in router mode instead of bridge
> > > > mode then you have to port forward that too.
> > > >
> > > > Regarding your router, how do you configure the WAN adapter? DHCP or PPPOE?
> > > >
> > > > "Fly" wrote:
> > > >
> > > > > 127.0.0.1 works, I see my files. (I assume this is what you meant by
> > > > > localhost?)
> > > > > But ftp://(my ISP address x.x.x.x) does not work, neither in the explorer,
> > > > > nor in the FTP client SmartFTP.
> > > > >
> > > > > Directly connected to the modem (without router) does not work.
> > > > > But my other computer's FTP server is working fine, so the ports in the
> > > > > router were set the right way.
> > > > >
> > > > > It is also showing 0.0.0.0:21 and some other 50000-50004
> > > > >
> > > > > Windows firewall is off, so no ports to be set there I suppose.
> > > > > And even when turning off the McAfee firewall, I cannot get through.
> > > > >
> > > > > Den
> > > > >
> > > > > "axelm" wrote:
> > > > >
> > > > > > 0.0.0.0:50000 means it accepts connections from all the network adapters.
> > > > > >
> > > > > > Have you tried moving it to port 21 just for testing purposes? Remember that
> > > > > > FTP uses two ports, and usually the firewall has to be FTP-aware.
> > > > > >
> > > > > > Have you tried connecting to the FTP server from the LAN side? What about
> > > > > > localhost?
> > > > > >
> > > > > > Axel
> > > > > >
> > > > > > "Fly" wrote:
> > > > > >
> > > > > > > I have a problem setting up ftp server, such as serv-U or Bulletproof FTP on
> > > > > > > my new computer running Vista. On my old one I could set it up in 5 min. This
> > > > > > > is also still working, so my router is not the problem.
> > > > > > > I have McAfee, but I gave the program full access, no other options
> > > > > > > available, even when turning McAfee firewall off, no connection. Windows
> > > > > > > firewall is turned off.
> > > > > > >
> > > > > > > It has to be a Vista security issue. Does anybody have ANY idea. I do not at
> > > > > > > this point. In Windows defender you can see networking component or something
> > > > > > > like this, and the Serv-U, SmartFTP, or Bulletproof show up but it seems they
> > > > > > > are not listening on a specific address. Just 0.0.0.0:50000 etc. and no
> > > > > > > foreign address.
> > > > > > >
> > > > > > > Can anyone help me?
> > > > > > >
> > > > > > > Den Fly

Reply With Quote
  #9 (permalink)  
Old 07-24-2008
axelm
 

Posts: n/a
RE: Cannot set up 3rd-party ftp server on VISTA
I read some of your previous posts again and if I understand correctly you
did this test:

1) Remove router.
2) Connect Vista machine directly to the cablemodem
3) Disable Windows Firewall.
4) Start FTP server listening on 0.0.0.0:21/tcp
5) Open ftp client and connected to 127.0.0.1:21 and it worked fine.
6) Using the same client you connected to your internet address (which is
the same address your network adapter has) and you were not able to establish
an ftp connection. Yo can check your external IP address by going to
http://www.whatismyip.org .

Are you sure your ftp server is configured to allow non-LAN connections? I
sometimes use Filezilla and IIRC the default config is to only allow
connection from your local subnet and localhost.


"axelm" wrote:

> Tryport forwarding ports 20/tcp and 21/tcp. Sounds like your router is not
> handling the ftp control port correctly. Check if your router has a "special
> applications" section and if FTP is listed there use that instead of a manual
> port forward.
>
> The reason is the FTP has some issues with NAT and usually a special
> nat-helper is required.
>
> "Fly" wrote:
>
> > sorry, i forgot to mention it is a cable modem. I do have a public IP
> > address, no need for a password. (the 192.168.0.102, is the address given to
> > my comp by the (wifi) router.)
> > I am not sure whether it is a static address or dynamic. But starts with
> > 63.x.x.x
> >
> > Still, don't understand why this would not affect my other computer, though,
> > if something was up with the router or the cable modem. hmm, puzzling.
> > Mind-boggling.
> >
> > Thanks again.
> >
> > Den
> >
> > "axelm" wrote:
> >
> > > Definitely sounds like your ADSL modem is in router mode. You are adding an
> > > extra (wifi?) router behind the ADSL modem, then you AT LEAST have a double
> > > NAT.
> > >
> > > You could have and additional NAT layer if your ISP is giving you a private
> > > address (usually 10.x.x.x) instead of a public internet address. This is
> > > usually not the case, but I have seen this happen woth some el-cheapo ISPs.
> > >
> > > If this were my network I'd put the ADSL modem in bridge mode and set the
> > > router to PPPOE and try from there. Do you have the password to change the
> > > ADSL modem config? Do you know your PPPOE user and password? Maybe you can
> > > contact you ISP and tell them that you have set up a wireless router and that
> > > you want to reset the ADSL modem to bridge mode. They should be able to help
> > > you if your contract allows more than one PC.
> > >
> > > "Fly" wrote:
> > >
> > > > You mean 192.168.0.102...(i set the ports for this also in the router).
> > > > I'll have to post the ipconfig /all later as I don't have access to my
> > > > computer at the moment.
> > > >
> > > > I believe the router is DHCP configured, I would have to check that as well.
> > > >
> > > > But wouldn't this also affect my other XP computer running on that router?
> > > >
> > > > Thanks,
> > > >
> > > > Den
> > > >
> > > > "axelm" wrote:
> > > >
> > > > > What IP address does your ADSL modem serve via DHCP? Please post the output
> > > > > from ipconfig /all. If your ADSL modem is in router mode instead of bridge
> > > > > mode then you have to port forward that too.
> > > > >
> > > > > Regarding your router, how do you configure the WAN adapter? DHCP or PPPOE?
> > > > >
> > > > > "Fly" wrote:
> > > > >
> > > > > > 127.0.0.1 works, I see my files. (I assume this is what you meant by
> > > > > > localhost?)
> > > > > > But ftp://(my ISP address x.x.x.x) does not work, neither in the explorer,
> > > > > > nor in the FTP client SmartFTP.
> > > > > >
> > > > > > Directly connected to the modem (without router) does not work.
> > > > > > But my other computer's FTP server is working fine, so the ports in the
> > > > > > router were set the right way.
> > > > > >
> > > > > > It is also showing 0.0.0.0:21 and some other 50000-50004
> > > > > >
> > > > > > Windows firewall is off, so no ports to be set there I suppose.
> > > > > > And even when turning off the McAfee firewall, I cannot get through.
> > > > > >
> > > > > > Den
> > > > > >
> > > > > > "axelm" wrote:
> > > > > >
> > > > > > > 0.0.0.0:50000 means it accepts connections from all the network adapters.
> > > > > > >
> > > > > > > Have you tried moving it to port 21 just for testing purposes? Remember that
> > > > > > > FTP uses two ports, and usually the firewall has to be FTP-aware.
> > > > > > >
> > > > > > > Have you tried connecting to the FTP server from the LAN side? What about
> > > > > > > localhost?
> > > > > > >
> > > > > > > Axel
> > > > > > >
> > > > > > > "Fly" wrote:
> > > > > > >
> > > > > > > > I have a problem setting up ftp server, such as serv-U or Bulletproof FTP on
> > > > > > > > my new computer running Vista. On my old one I could set it up in 5 min. This
> > > > > > > > is also still working, so my router is not the problem.
> > > > > > > > I have McAfee, but I gave the program full access, no other options
> > > > > > > > available, even when turning McAfee firewall off, no connection. Windows
> > > > > > > > firewall is turned off.
> > > > > > > >
> > > > > > > > It has to be a Vista security issue. Does anybody have ANY idea. I do not at
> > > > > > > > this point. In Windows defender you can see networking component or something
> > > > > > > > like this, and the Serv-U, SmartFTP, or Bulletproof show up but it seems they
> > > > > > > > are not listening on a specific address. Just 0.0.0.0:50000 etc. and no
> > > > > > > > foreign address.
> > > > > > > >
> > > > > > > > Can anyone help me?
> > > > > > > >
> > > > > > > > Den Fly

Reply With Quote
  #10 (permalink)  
Old 07-24-2008
Fly
 

Posts: n/a
RE: Cannot set up 3rd-party ftp server on VISTA
ok, here is the deal.

2 computers:
1= 192.168.0.101 (Win XP) running serv-U ftp at port 2121
2= 192.168.0.103 (Vista) running serv-U at port 2100

serv-U and router allowing to connect via UPnP.

In windows explorer:
typing ftp://62.x.x.x:2121 allows me to connect to computer 1 on both comp 1
and 2
typing ftp://62.x.x.x:2100 DOES NOT allow me to connect on either machines,
as if I do not have access to the folders.

A connection appears to be established (windows defender in Vista shows

TCP 192.168.0.103:2100 192.168.0.1:1320 ESTABLISHED
TCP 192.168.0.103:2100 192.168.0.1:1321 ESTABLISHED

In serv-U can see this:
[5] Thu 24Jul08 21:45:07 - (000070) Connected to 192.168.0.1 (Local address
192.168.0.103)
[5] Thu 24Jul08 21:45:07 - (000070) User PUBLIC logged in

The SmartFTP client doesn't allow me to access either 1 or 2 on comp 2 (Vista)
[21:45:43] SSL/TLS client handshake failed (Error = 0x80090308).
[21:45:43] QUIT
[21:45:43] The system detected an invalid pointer address in attempting to
use a pointer argument in a call

My ipconfig on comp 2:

Microsoft Windows [Version 6.0.6000]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

C:\Users\Den Fly>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Fly
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros AR5007EG Wireless Network
Adapter

Physical Address. . . . . . . . . : 00-16-44-A4-9E-C5
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::e900:54c0:c01f:4b5f%9(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.103(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Thursday, July 24, 2008 7:42:08 PM
Lease Expires . . . . . . . . . . : Thursday, July 31, 2008 7:46:18 PM
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 218109508
DNS Servers . . . . . . . . . . . : 192.168.0.1
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : arnhem.chello.nl
Description . . . . . . . . . . . : Realtek RTL8101E Family PCI-E Fast
Ethern
et NIC (NDIS 6.0)
Physical Address. . . . . . . . . : 00-03-0D-87-24-60
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 6:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : isatap.arnhem.chello.nl
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 7:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 02-00-54-55-4E-01
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . :
2001:0:d5c7:a2ca:307f:1687:3f57:ff98(Pref
erred)
Link-local IPv6 Address . . . . . : fe80::307f:1687:3f57:ff98%10(Preferred)
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Local Area Connection* 9:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . :
isatap.{8F261D34-F2AC-4290-BBDD-0255BD304
E6D}
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::5efe:192.168.0.103%11(Preferred)
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : 192.168.0.1
NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Users\Den Fly>
"axelm" wrote:

> I read some of your previous posts again and if I understand correctly you
> did this test:
>
> 1) Remove router.
> 2) Connect Vista machine directly to the cablemodem
> 3) Disable Windows Firewall.
> 4) Start FTP server listening on 0.0.0.0:21/tcp
> 5) Open ftp client and connected to 127.0.0.1:21 and it worked fine.
> 6) Using the same client you connected to your internet address (which is
> the same address your network adapter has) and you were not able to establish
> an ftp connection. Yo can check your external IP address by going to
> http://www.whatismyip.org .
>
> Are you sure your ftp server is configured to allow non-LAN connections? I
> sometimes use Filezilla and IIRC the default config is to only allow
> connection from your local subnet and localhost.
>
>
> "axelm" wrote:
>
> > Tryport forwarding ports 20/tcp and 21/tcp. Sounds like your router is not
> > handling the ftp control port correctly. Check if your router has a "special
> > applications" section and if FTP is listed there use that instead of a manual
> > port forward.
> >
> > The reason is the FTP has some issues with NAT and usually a special
> > nat-helper is required.
> >
> > "Fly" wrote:
> >
> > > sorry, i forgot to mention it is a cable modem. I do have a public IP
> > > address, no need for a password. (the 192.168.0.102, is the address given to
> > > my comp by the (wifi) router.)
> > > I am not sure whether it is a static address or dynamic. But starts with
> > > 63.x.x.x
> > >
> > > Still, don't understand why this would not affect my other computer, though,
> > > if something was up with the router or the cable modem. hmm, puzzling.
> > > Mind-boggling.
> > >
> > > Thanks again.
> > >
> > > Den
> > >
> > > "axelm" wrote:
> > >
> > > > Definitely sounds like your ADSL modem is in router mode. You are adding an
> > > > extra (wifi?) router behind the ADSL modem, then you AT LEAST have a double
> > > > NAT.
> > > >
> > > > You could have and additional NAT layer if your ISP is giving you a private
> > > > address (usually 10.x.x.x) instead of a public internet address. This is
> > > > usually not the case, but I have seen this happen woth some el-cheapo ISPs.
> > > >
> > > > If this were my network I'd put the ADSL modem in bridge mode and set the
> > > > router to PPPOE and try from there. Do you have the password to change the
> > > > ADSL modem config? Do you know your PPPOE user and password? Maybe you can
> > > > contact you ISP and tell them that you have set up a wireless router and that
> > > > you want to reset the ADSL modem to bridge mode. They should be able to help
> > > > you if your contract allows more than one PC.
> > > >
> > > > "Fly" wrote:
> > > >
> > > > > You mean 192.168.0.102...(i set the ports for this also in the router).
> > > > > I'll have to post the ipconfig /all later as I don't have access to my
> > > > > computer at the moment.
> > > > >
> > > > > I believe the router is DHCP configured, I would have to check that as well.
> > > > >
> > > > > But wouldn't this also affect my other XP computer running on that router?
> > > > >
> > > > > Thanks,
> > > > >
> > > > > Den
> > > > >
> > > > > "axelm" wrote:
> > > > >
> > > > > > What IP address does your ADSL modem serve via DHCP? Please post the output
> > > > > > from ipconfig /all. If your ADSL modem is in router mode instead of bridge
> > > > > > mode then you have to port forward that too.
> > > > > >
> > > > > > Regarding your router, how do you configure the WAN adapter? DHCP or PPPOE?
> > > > > >
> > > > > > "Fly" wrote:
> > > > > >
> > > > > > > 127.0.0.1 works, I see my files. (I assume this is what you meant by
> > > > > > > localhost?)
> > > > > > > But ftp://(my ISP address x.x.x.x) does not work, neither in the explorer,
> > > > > > > nor in the FTP client SmartFTP.
> > > > > > >
> > > > > > > Directly connected to the modem (without router) does not work.
> > > > > > > But my other computer's FTP server is working fine, so the ports in the
> > > > > > > router were set the right way.
> > > > > > >
> > > > > > > It is also showing 0.0.0.0:21 and some other 50000-50004
> > > > > > >
> > > > > > > Windows firewall is off, so no ports to be set there I suppose.
> > > > > > > And even when turning off the McAfee firewall, I cannot get through.
> > > > > > >
> > > > > > > Den
> > > > > > >
> > > > > > > "axelm" wrote:
> > > > > > >
> > > > > > > > 0.0.0.0:50000 means it accepts connections from all the network adapters.
> > > > > > > >
> > > > > > > > Have you tried moving it to port 21 just for testing purposes? Remember that
> > > > > > > > FTP uses two ports, and usually the firewall has to be FTP-aware.
> > > > > > > >
> > > > > > > > Have you tried connecting to the FTP server from the LAN side? What about
> > > > > > > > localhost?
> > > > > > > >
> > > > > > > > Axel
> > > > > > > >
> > > > > > > > "Fly" wrote:
> > > > > > > >
> > > > > > > > > I have a problem setting up ftp server, such as serv-U or Bulletproof FTP on
> > > > > > > > > my new computer running Vista. On my old one I could set it up in 5 min. This
> > > > > > > > > is also still working, so my router is not the problem.
> > > > > > > > > I have McAfee, but I gave the program full access, no other options
> > > > > > > > > available, even when turning McAfee firewall off, no connection. Windows
> > > > > > > > > firewall is turned off.
> > > > > > > > >
> > > > > > > > > It has to be a Vista security issue. Does anybody have ANY idea. I do not at
> > > > > > > > > this point. In Windows defender you can see networking component or something
> > > > > > > > > like this, and the Serv-U, SmartFTP, or Bulletproof show up but it seems they
> > > > > > > > > are not listening on a specific address. Just 0.0.0.0:50000 etc. and no
> > > > > > > > > foreign address.
> > > > > > > > >
> > > > > > > > > Can anyone help me?
> > > > > > > > >
> > > > > > > > > Den Fly

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Australia wild party child turns party pro Steve General Technology News 0 01-24-2008 17:50
Australia wild party child turns party pro Steve General Technology News 0 01-24-2008 12:20
Mediaroom Personal Server not so personal, a development tool for 3rd-party developers Steve Windows Vista Blogs Forum 0 10-29-2007 16:20
Party Mode in Vista Ultimate or WMP vaughan microsoft.public.windows.vista.music pictures video 3 07-18-2007 15:18
Vista slowed by 3rd party software Romane microsoft.public.windows.vista.general 4 06-30-2007 15:30




All times are GMT +1. The time now is 08:12.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120