Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Can't make ICS work with Vista and XP

microsoft.public.windows.vista.networking sharing






Speedup My PC
Reply
  #1 (permalink)  
Old 02-28-2007
=?Utf-8?B?TWlrZSBpbiBGbG9yaWRh?=
 

Posts: n/a
Can't make ICS work with Vista and XP
I'm sorry for posting another thread on this subject, but I have read other
posts and I can't find a solution that works for me.

I have 2 machines, one with Vista Home Basic and the other with XP Pro,
connected as follows: DSL plugs into modem, modem cabled to Vista LAN1,
shared, Vista LAN2 cabled to switch and then to XP LAN. This is the same
setup I have used for 5 years, the difference being that the Vista machine is
new.

Computers can see each other, file sharing and Remote Desktop work fine, but
XP cannot access the Internet.

I have manually configured TCP/IP for both machines because otherwise all I
could get was the Windows-generated 169.x.x.x.

I have had the Vista machine for 3 weeks and I have had both Internet and
file sharing working for most of that time, but it would come and go (i.e.,
after reboot). I was advised that Vista NIC #2 was not Vista compatible, so I
bought one that is, and that's where I am now. File sharing fine, no Internet
on XP.

Here are ipconfig results for Vista:


Windows IP Configuration

Host Name . . . . . . . . . . . . : MRB-Vista
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 3:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8169/8110 Family PCI
Gigabit Ethernet NIC (NDIS 6.0)
Physical Address. . . . . . . . . : 00-18-4D-76-B4-F3
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . :
fe80::8096:c357:bc74:9a9d%13(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.1(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast
Ethernet NIC
Physical Address. . . . . . . . . : 00-19-D1-2C-47-46
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.1.1(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Wednesday, February 28, 2007 10:52:19
AM
Lease Expires . . . . . . . . . . : Wednesday, February 28, 2007 1:52:19 PM
Default Gateway . . . . . . . . . : 192.168.1.254
DHCP Server . . . . . . . . . . . : 192.168.1.254
DNS Servers . . . . . . . . . . . : 192.168.1.254
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 6:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 02-00-54-55-4E-01
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . :
2001:0:4136:e38c:1cbe:310e:b51e:bad6(Preferred)
Link-local IPv6 Address . . . . . : fe80::1cbe:310e:b51e:bad6%9(Preferred)
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Local Area Connection* 7:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . :
isatap.{852B24A4-9689-49CE-A284-E877770E7448}
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::5efe:192.168.1.1%12(Preferred)
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : 192.168.1.254
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Local Area Connection* 9:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . :
isatap.{214E3999-FF6A-4804-9F57-36BFDE0E35E2}
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::5efe:192.168.0.1%14(Preferred)
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Local Area Connection* 10:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : 6TO4 Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

ipconfig results for XP:



Windows IP Configuration



Host Name . . . . . . . . . . . . : DSB

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Mixed

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No



Ethernet adapter Local Area Connection:



Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet Adapter

Physical Address. . . . . . . . . : 00-0A-E6-21-74-DA

Dhcp Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 192.168.0.3

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.0.1

DNS Servers . . . . . . . . . . . : 192.168.0.1

Can anyone help? Hopefully before I lose what's left of my mind!

Thanks,

Mike

Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 03-13-2007
=?Utf-8?B?UmF2aSBL?=
 

Posts: n/a
RE: Can't make ICS work with Vista and XP
Hi,

You have mentioned that you have manually configured TCP/IP for both
machines. When you enabled ICS on Vista machine, it is supposed to assign
static IP address (192.168.0.1) to one of the NICs. Didn’t it happen?

Are you using default Windows firewall in Vista machine? If so, can you
check if “internet connection sharing” is enabled in exceptions tab in
firewall (control panel->Windows Firewall -> Change Settings)? If it is
enabled, please collect following traces while accessing any internet site:

In an elevated command prompt in ICS host machine, run:
ipconfig flushdns
netsh ras diag set rastra ipnathlp ena
Access internet from ICS client.
Netsh ras diag set rastra ipnathlp dis
Goto %windir%\tracing

Send ipnathlp.log and ipnathlp.old files to kraviics@hotmail.com

Also please check if disabling firewall in ICS host makes ICS clients to
connect to internet.


"Mike in Florida" wrote:

> I'm sorry for posting another thread on this subject, but I have read other
> posts and I can't find a solution that works for me.
>
> I have 2 machines, one with Vista Home Basic and the other with XP Pro,
> connected as follows: DSL plugs into modem, modem cabled to Vista LAN1,
> shared, Vista LAN2 cabled to switch and then to XP LAN. This is the same
> setup I have used for 5 years, the difference being that the Vista machine is
> new.
>
> Computers can see each other, file sharing and Remote Desktop work fine, but
> XP cannot access the Internet.
>
> I have manually configured TCP/IP for both machines because otherwise all I
> could get was the Windows-generated 169.x.x.x.
>
> I have had the Vista machine for 3 weeks and I have had both Internet and
> file sharing working for most of that time, but it would come and go (i.e.,
> after reboot). I was advised that Vista NIC #2 was not Vista compatible, so I
> bought one that is, and that's where I am now. File sharing fine, no Internet
> on XP.
>
> Here are ipconfig results for Vista:
>
>
> Windows IP Configuration
>
> Host Name . . . . . . . . . . . . : MRB-Vista
> Primary Dns Suffix . . . . . . . :
> Node Type . . . . . . . . . . . . : Hybrid
> IP Routing Enabled. . . . . . . . : No
> WINS Proxy Enabled. . . . . . . . : No
>
> Ethernet adapter Local Area Connection 3:
>
> Connection-specific DNS Suffix . :
> Description . . . . . . . . . . . : Realtek RTL8169/8110 Family PCI
> Gigabit Ethernet NIC (NDIS 6.0)
> Physical Address. . . . . . . . . : 00-18-4D-76-B4-F3
> DHCP Enabled. . . . . . . . . . . : No
> Autoconfiguration Enabled . . . . : Yes
> Link-local IPv6 Address . . . . . :
> fe80::8096:c357:bc74:9a9d%13(Preferred)
> IPv4 Address. . . . . . . . . . . : 192.168.0.1(Preferred)
> Subnet Mask . . . . . . . . . . . : 255.255.255.0
> Default Gateway . . . . . . . . . :
> DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
> fec0:0:0:ffff::2%1
> fec0:0:0:ffff::3%1
> NetBIOS over Tcpip. . . . . . . . : Enabled
>
> Ethernet adapter Local Area Connection:
>
> Connection-specific DNS Suffix . :
> Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast
> Ethernet NIC
> Physical Address. . . . . . . . . : 00-19-D1-2C-47-46
> DHCP Enabled. . . . . . . . . . . : Yes
> Autoconfiguration Enabled . . . . : Yes
> IPv4 Address. . . . . . . . . . . : 192.168.1.1(Preferred)
> Subnet Mask . . . . . . . . . . . : 255.255.255.0
> Lease Obtained. . . . . . . . . . : Wednesday, February 28, 2007 10:52:19
> AM
> Lease Expires . . . . . . . . . . : Wednesday, February 28, 2007 1:52:19 PM
> Default Gateway . . . . . . . . . : 192.168.1.254
> DHCP Server . . . . . . . . . . . : 192.168.1.254
> DNS Servers . . . . . . . . . . . : 192.168.1.254
> NetBIOS over Tcpip. . . . . . . . : Enabled
>
> Tunnel adapter Local Area Connection* 6:
>
> Connection-specific DNS Suffix . :
> Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
> Physical Address. . . . . . . . . : 02-00-54-55-4E-01
> DHCP Enabled. . . . . . . . . . . : No
> Autoconfiguration Enabled . . . . : Yes
> IPv6 Address. . . . . . . . . . . :
> 2001:0:4136:e38c:1cbe:310e:b51e:bad6(Preferred)
> Link-local IPv6 Address . . . . . : fe80::1cbe:310e:b51e:bad6%9(Preferred)
> Default Gateway . . . . . . . . . : ::
> NetBIOS over Tcpip. . . . . . . . : Disabled
>
> Tunnel adapter Local Area Connection* 7:
>
> Connection-specific DNS Suffix . :
> Description . . . . . . . . . . . :
> isatap.{852B24A4-9689-49CE-A284-E877770E7448}
> Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
> DHCP Enabled. . . . . . . . . . . : No
> Autoconfiguration Enabled . . . . : Yes
> Link-local IPv6 Address . . . . . : fe80::5efe:192.168.1.1%12(Preferred)
> Default Gateway . . . . . . . . . :
> DNS Servers . . . . . . . . . . . : 192.168.1.254
> NetBIOS over Tcpip. . . . . . . . : Disabled
>
> Tunnel adapter Local Area Connection* 9:
>
> Connection-specific DNS Suffix . :
> Description . . . . . . . . . . . :
> isatap.{214E3999-FF6A-4804-9F57-36BFDE0E35E2}
> Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
> DHCP Enabled. . . . . . . . . . . : No
> Autoconfiguration Enabled . . . . : Yes
> Link-local IPv6 Address . . . . . : fe80::5efe:192.168.0.1%14(Preferred)
> Default Gateway . . . . . . . . . :
> DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
> fec0:0:0:ffff::2%1
> fec0:0:0:ffff::3%1
> NetBIOS over Tcpip. . . . . . . . : Disabled
>
> Tunnel adapter Local Area Connection* 10:
>
> Media State . . . . . . . . . . . : Media disconnected
> Connection-specific DNS Suffix . :
> Description . . . . . . . . . . . : 6TO4 Adapter
> Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
> DHCP Enabled. . . . . . . . . . . : No
> Autoconfiguration Enabled . . . . : Yes
>
> ipconfig results for XP:
>
>
>
> Windows IP Configuration
>
>
>
> Host Name . . . . . . . . . . . . : DSB
>
> Primary Dns Suffix . . . . . . . :
>
> Node Type . . . . . . . . . . . . : Mixed
>
> IP Routing Enabled. . . . . . . . : No
>
> WINS Proxy Enabled. . . . . . . . : No
>
>
>
> Ethernet adapter Local Area Connection:
>
>
>
> Connection-specific DNS Suffix . :
>
> Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet Adapter
>
> Physical Address. . . . . . . . . : 00-0A-E6-21-74-DA
>
> Dhcp Enabled. . . . . . . . . . . : No
>
> IP Address. . . . . . . . . . . . : 192.168.0.3
>
> Subnet Mask . . . . . . . . . . . : 255.255.255.0
>
> Default Gateway . . . . . . . . . : 192.168.0.1
>
> DNS Servers . . . . . . . . . . . : 192.168.0.1
>
> Can anyone help? Hopefully before I lose what's left of my mind!
>
> Thanks,
>
> Mike
>

Reply With Quote
  #3 (permalink)  
Old 03-13-2007
=?Utf-8?B?TWlrZSBpbiBGbG9yaWRh?=
 

Posts: n/a
RE: Can't make ICS work with Vista and XP
Thanks for your reply, Ravi. I did get it working. It seems that I had to
do things in just the right order to get them to work. First I made sure
ICS was OFF on Vista. Then I set Vista NIC #2 to use DHCP. Reboot Vista.
Then I enabled Vista ICS which, as you say, establishes a static IP of
192.168.0.1 on NIC #2. Then I set XP to use DHCP, which returns a 169.x.x.x
address. Shut down XP, reboot Vista, and when that reboot is complete start
XP again. Voila!

I mentioned in my first post that I had a NIC that was incompatible with
Vista. I would have everything working fine, but after reboot I would be
back to APIPA addresses on both Vista NIC #2 and XP. In case anyone wants to
know, the NIC I replaced was a Linksys LNE100TX Ver 4.1

"Ravi K" wrote:

> Hi,
>
> You have mentioned that you have manually configured TCP/IP for both
> machines. When you enabled ICS on Vista machine, it is supposed to assign
> static IP address (192.168.0.1) to one of the NICs. Didn’t it happen?
>
> Are you using default Windows firewall in Vista machine? If so, can you
> check if “internet connection sharing” is enabled in exceptions tab in
> firewall (control panel->Windows Firewall -> Change Settings)? If it is
> enabled, please collect following traces while accessing any internet site:
>
> In an elevated command prompt in ICS host machine, run:
> ipconfig flushdns
> netsh ras diag set rastra ipnathlp ena
> Access internet from ICS client.
> Netsh ras diag set rastra ipnathlp dis
> Goto %windir%\tracing
>
> Send ipnathlp.log and ipnathlp.old files to kraviics@hotmail.com
>
> Also please check if disabling firewall in ICS host makes ICS clients to
> connect to internet.
>
>
> "Mike in Florida" wrote:
>
> > I'm sorry for posting another thread on this subject, but I have read other
> > posts and I can't find a solution that works for me.
> >
> > I have 2 machines, one with Vista Home Basic and the other with XP Pro,
> > connected as follows: DSL plugs into modem, modem cabled to Vista LAN1,
> > shared, Vista LAN2 cabled to switch and then to XP LAN. This is the same
> > setup I have used for 5 years, the difference being that the Vista machine is
> > new.
> >
> > Computers can see each other, file sharing and Remote Desktop work fine, but
> > XP cannot access the Internet.
> >
> > I have manually configured TCP/IP for both machines because otherwise all I
> > could get was the Windows-generated 169.x.x.x.
> >
> > I have had the Vista machine for 3 weeks and I have had both Internet and
> > file sharing working for most of that time, but it would come and go (i.e.,
> > after reboot). I was advised that Vista NIC #2 was not Vista compatible, so I
> > bought one that is, and that's where I am now. File sharing fine, no Internet
> > on XP.
> >
> > Here are ipconfig results for Vista:
> >
> >
> > Windows IP Configuration
> >
> > Host Name . . . . . . . . . . . . : MRB-Vista
> > Primary Dns Suffix . . . . . . . :
> > Node Type . . . . . . . . . . . . : Hybrid
> > IP Routing Enabled. . . . . . . . : No
> > WINS Proxy Enabled. . . . . . . . : No
> >
> > Ethernet adapter Local Area Connection 3:
> >
> > Connection-specific DNS Suffix . :
> > Description . . . . . . . . . . . : Realtek RTL8169/8110 Family PCI
> > Gigabit Ethernet NIC (NDIS 6.0)
> > Physical Address. . . . . . . . . : 00-18-4D-76-B4-F3
> > DHCP Enabled. . . . . . . . . . . : No
> > Autoconfiguration Enabled . . . . : Yes
> > Link-local IPv6 Address . . . . . :
> > fe80::8096:c357:bc74:9a9d%13(Preferred)
> > IPv4 Address. . . . . . . . . . . : 192.168.0.1(Preferred)
> > Subnet Mask . . . . . . . . . . . : 255.255.255.0
> > Default Gateway . . . . . . . . . :
> > DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
> > fec0:0:0:ffff::2%1
> > fec0:0:0:ffff::3%1
> > NetBIOS over Tcpip. . . . . . . . : Enabled
> >
> > Ethernet adapter Local Area Connection:
> >
> > Connection-specific DNS Suffix . :
> > Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast
> > Ethernet NIC
> > Physical Address. . . . . . . . . : 00-19-D1-2C-47-46
> > DHCP Enabled. . . . . . . . . . . : Yes
> > Autoconfiguration Enabled . . . . : Yes
> > IPv4 Address. . . . . . . . . . . : 192.168.1.1(Preferred)
> > Subnet Mask . . . . . . . . . . . : 255.255.255.0
> > Lease Obtained. . . . . . . . . . : Wednesday, February 28, 2007 10:52:19
> > AM
> > Lease Expires . . . . . . . . . . : Wednesday, February 28, 2007 1:52:19 PM
> > Default Gateway . . . . . . . . . : 192.168.1.254
> > DHCP Server . . . . . . . . . . . : 192.168.1.254
> > DNS Servers . . . . . . . . . . . : 192.168.1.254
> > NetBIOS over Tcpip. . . . . . . . : Enabled
> >
> > Tunnel adapter Local Area Connection* 6:
> >
> > Connection-specific DNS Suffix . :
> > Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
> > Physical Address. . . . . . . . . : 02-00-54-55-4E-01
> > DHCP Enabled. . . . . . . . . . . : No
> > Autoconfiguration Enabled . . . . : Yes
> > IPv6 Address. . . . . . . . . . . :
> > 2001:0:4136:e38c:1cbe:310e:b51e:bad6(Preferred)
> > Link-local IPv6 Address . . . . . : fe80::1cbe:310e:b51e:bad6%9(Preferred)
> > Default Gateway . . . . . . . . . : ::
> > NetBIOS over Tcpip. . . . . . . . : Disabled
> >
> > Tunnel adapter Local Area Connection* 7:
> >
> > Connection-specific DNS Suffix . :
> > Description . . . . . . . . . . . :
> > isatap.{852B24A4-9689-49CE-A284-E877770E7448}
> > Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
> > DHCP Enabled. . . . . . . . . . . : No
> > Autoconfiguration Enabled . . . . : Yes
> > Link-local IPv6 Address . . . . . : fe80::5efe:192.168.1.1%12(Preferred)
> > Default Gateway . . . . . . . . . :
> > DNS Servers . . . . . . . . . . . : 192.168.1.254
> > NetBIOS over Tcpip. . . . . . . . : Disabled
> >
> > Tunnel adapter Local Area Connection* 9:
> >
> > Connection-specific DNS Suffix . :
> > Description . . . . . . . . . . . :
> > isatap.{214E3999-FF6A-4804-9F57-36BFDE0E35E2}
> > Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
> > DHCP Enabled. . . . . . . . . . . : No
> > Autoconfiguration Enabled . . . . : Yes
> > Link-local IPv6 Address . . . . . : fe80::5efe:192.168.0.1%14(Preferred)
> > Default Gateway . . . . . . . . . :
> > DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
> > fec0:0:0:ffff::2%1
> > fec0:0:0:ffff::3%1
> > NetBIOS over Tcpip. . . . . . . . : Disabled
> >
> > Tunnel adapter Local Area Connection* 10:
> >
> > Media State . . . . . . . . . . . : Media disconnected
> > Connection-specific DNS Suffix . :
> > Description . . . . . . . . . . . : 6TO4 Adapter
> > Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
> > DHCP Enabled. . . . . . . . . . . : No
> > Autoconfiguration Enabled . . . . : Yes
> >
> > ipconfig results for XP:
> >
> >
> >
> > Windows IP Configuration
> >
> >
> >
> > Host Name . . . . . . . . . . . . : DSB
> >
> > Primary Dns Suffix . . . . . . . :
> >
> > Node Type . . . . . . . . . . . . : Mixed
> >
> > IP Routing Enabled. . . . . . . . : No
> >
> > WINS Proxy Enabled. . . . . . . . : No
> >
> >
> >
> > Ethernet adapter Local Area Connection:
> >
> >
> >
> > Connection-specific DNS Suffix . :
> >
> > Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet Adapter
> >
> > Physical Address. . . . . . . . . : 00-0A-E6-21-74-DA
> >
> > Dhcp Enabled. . . . . . . . . . . : No
> >
> > IP Address. . . . . . . . . . . . : 192.168.0.3
> >
> > Subnet Mask . . . . . . . . . . . : 255.255.255.0
> >
> > Default Gateway . . . . . . . . . : 192.168.0.1
> >
> > DNS Servers . . . . . . . . . . . : 192.168.0.1
> >
> > Can anyone help? Hopefully before I lose what's left of my mind!
> >
> > Thanks,
> >
> > Mike
> >

Reply With Quote
  #4 (permalink)  
Old 03-13-2007
=?Utf-8?B?UGhpbCBmcm9tIE96?=
 

Posts: n/a
RE: Can't make ICS work with Vista and XP
Hi Ravi,

I am interested to see you could help Mike from Folroda and I am hoping you
can help me.

I am not as computer literate as I probably should be but here goes ......

No matter what I do no matter how many MS support articles I read I cannot
file share or printer share on my home network which is running a modem
connected to a Belkin wireless router with an ethernet connection to my
desktop PC running XP Home and a wireless connection to my new laptop running
Vista Home Premium. I keep getting "MY NETWORK" is not accessible. You might
not have permission to use the network resource. Contact the admin etc etc. I
cannot see the laptop from the dektop nor vice versa. I have tried to shared
drives and folders - nothing seems to work. Have read a MS support articel
that tells me to tirn on netbios over TCP/IP -nothing works. About to give
up in disgust. Phil from Australia


"Ravi K" wrote:

> Hi,
>
> You have mentioned that you have manually configured TCP/IP for both
> machines. When you enabled ICS on Vista machine, it is supposed to assign
> static IP address (192.168.0.1) to one of the NICs. Didn’t it happen?
>
> Are you using default Windows firewall in Vista machine? If so, can you
> check if “internet connection sharing” is enabled in exceptions tab in
> firewall (control panel->Windows Firewall -> Change Settings)? If it is
> enabled, please collect following traces while accessing any internet site:
>
> In an elevated command prompt in ICS host machine, run:
> ipconfig flushdns
> netsh ras diag set rastra ipnathlp ena
> Access internet from ICS client.
> Netsh ras diag set rastra ipnathlp dis
> Goto %windir%\tracing
>
> Send ipnathlp.log and ipnathlp.old files to kraviics@hotmail.com
>
> Also please check if disabling firewall in ICS host makes ICS clients to
> connect to internet.
>
>
> "Mike in Florida" wrote:
>
> > I'm sorry for posting another thread on this subject, but I have read other
> > posts and I can't find a solution that works for me.
> >
> > I have 2 machines, one with Vista Home Basic and the other with XP Pro,
> > connected as follows: DSL plugs into modem, modem cabled to Vista LAN1,
> > shared, Vista LAN2 cabled to switch and then to XP LAN. This is the same
> > setup I have used for 5 years, the difference being that the Vista machine is
> > new.
> >
> > Computers can see each other, file sharing and Remote Desktop work fine, but
> > XP cannot access the Internet.
> >
> > I have manually configured TCP/IP for both machines because otherwise all I
> > could get was the Windows-generated 169.x.x.x.
> >
> > I have had the Vista machine for 3 weeks and I have had both Internet and
> > file sharing working for most of that time, but it would come and go (i.e.,
> > after reboot). I was advised that Vista NIC #2 was not Vista compatible, so I
> > bought one that is, and that's where I am now. File sharing fine, no Internet
> > on XP.
> >
> > Here are ipconfig results for Vista:
> >
> >
> > Windows IP Configuration
> >
> > Host Name . . . . . . . . . . . . : MRB-Vista
> > Primary Dns Suffix . . . . . . . :
> > Node Type . . . . . . . . . . . . : Hybrid
> > IP Routing Enabled. . . . . . . . : No
> > WINS Proxy Enabled. . . . . . . . : No
> >
> > Ethernet adapter Local Area Connection 3:
> >
> > Connection-specific DNS Suffix . :
> > Description . . . . . . . . . . . : Realtek RTL8169/8110 Family PCI
> > Gigabit Ethernet NIC (NDIS 6.0)
> > Physical Address. . . . . . . . . : 00-18-4D-76-B4-F3
> > DHCP Enabled. . . . . . . . . . . : No
> > Autoconfiguration Enabled . . . . : Yes
> > Link-local IPv6 Address . . . . . :
> > fe80::8096:c357:bc74:9a9d%13(Preferred)
> > IPv4 Address. . . . . . . . . . . : 192.168.0.1(Preferred)
> > Subnet Mask . . . . . . . . . . . : 255.255.255.0
> > Default Gateway . . . . . . . . . :
> > DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
> > fec0:0:0:ffff::2%1
> > fec0:0:0:ffff::3%1
> > NetBIOS over Tcpip. . . . . . . . : Enabled
> >
> > Ethernet adapter Local Area Connection:
> >
> > Connection-specific DNS Suffix . :
> > Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast
> > Ethernet NIC
> > Physical Address. . . . . . . . . : 00-19-D1-2C-47-46
> > DHCP Enabled. . . . . . . . . . . : Yes
> > Autoconfiguration Enabled . . . . : Yes
> > IPv4 Address. . . . . . . . . . . : 192.168.1.1(Preferred)
> > Subnet Mask . . . . . . . . . . . : 255.255.255.0
> > Lease Obtained. . . . . . . . . . : Wednesday, February 28, 2007 10:52:19
> > AM
> > Lease Expires . . . . . . . . . . : Wednesday, February 28, 2007 1:52:19 PM
> > Default Gateway . . . . . . . . . : 192.168.1.254
> > DHCP Server . . . . . . . . . . . : 192.168.1.254
> > DNS Servers . . . . . . . . . . . : 192.168.1.254
> > NetBIOS over Tcpip. . . . . . . . : Enabled
> >
> > Tunnel adapter Local Area Connection* 6:
> >
> > Connection-specific DNS Suffix . :
> > Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
> > Physical Address. . . . . . . . . : 02-00-54-55-4E-01
> > DHCP Enabled. . . . . . . . . . . : No
> > Autoconfiguration Enabled . . . . : Yes
> > IPv6 Address. . . . . . . . . . . :
> > 2001:0:4136:e38c:1cbe:310e:b51e:bad6(Preferred)
> > Link-local IPv6 Address . . . . . : fe80::1cbe:310e:b51e:bad6%9(Preferred)
> > Default Gateway . . . . . . . . . : ::
> > NetBIOS over Tcpip. . . . . . . . : Disabled
> >
> > Tunnel adapter Local Area Connection* 7:
> >
> > Connection-specific DNS Suffix . :
> > Description . . . . . . . . . . . :
> > isatap.{852B24A4-9689-49CE-A284-E877770E7448}
> > Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
> > DHCP Enabled. . . . . . . . . . . : No
> > Autoconfiguration Enabled . . . . : Yes
> > Link-local IPv6 Address . . . . . : fe80::5efe:192.168.1.1%12(Preferred)
> > Default Gateway . . . . . . . . . :
> > DNS Servers . . . . . . . . . . . : 192.168.1.254
> > NetBIOS over Tcpip. . . . . . . . : Disabled
> >
> > Tunnel adapter Local Area Connection* 9:
> >
> > Connection-specific DNS Suffix . :
> > Description . . . . . . . . . . . :
> > isatap.{214E3999-FF6A-4804-9F57-36BFDE0E35E2}
> > Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
> > DHCP Enabled. . . . . . . . . . . : No
> > Autoconfiguration Enabled . . . . : Yes
> > Link-local IPv6 Address . . . . . : fe80::5efe:192.168.0.1%14(Preferred)
> > Default Gateway . . . . . . . . . :
> > DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
> > fec0:0:0:ffff::2%1
> > fec0:0:0:ffff::3%1
> > NetBIOS over Tcpip. . . . . . . . : Disabled
> >
> > Tunnel adapter Local Area Connection* 10:
> >
> > Media State . . . . . . . . . . . : Media disconnected
> > Connection-specific DNS Suffix . :
> > Description . . . . . . . . . . . : 6TO4 Adapter
> > Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
> > DHCP Enabled. . . . . . . . . . . : No
> > Autoconfiguration Enabled . . . . : Yes
> >
> > ipconfig results for XP:
> >
> >
> >
> > Windows IP Configuration
> >
> >
> >
> > Host Name . . . . . . . . . . . . : DSB
> >
> > Primary Dns Suffix . . . . . . . :
> >
> > Node Type . . . . . . . . . . . . : Mixed
> >
> > IP Routing Enabled. . . . . . . . : No
> >
> > WINS Proxy Enabled. . . . . . . . : No
> >
> >
> >
> > Ethernet adapter Local Area Connection:
> >
> >
> >
> > Connection-specific DNS Suffix . :
> >
> > Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet Adapter
> >
> > Physical Address. . . . . . . . . : 00-0A-E6-21-74-DA
> >
> > Dhcp Enabled. . . . . . . . . . . : No
> >
> > IP Address. . . . . . . . . . . . : 192.168.0.3
> >
> > Subnet Mask . . . . . . . . . . . : 255.255.255.0
> >
> > Default Gateway . . . . . . . . . : 192.168.0.1
> >
> > DNS Servers . . . . . . . . . . . : 192.168.0.1
> >
> > Can anyone help? Hopefully before I lose what's left of my mind!
> >
> > Thanks,
> >
> > Mike
> >

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
do any TV tuner cards actually work in Vista? kevin forsythe microsoft.public.windows.vista.music pictures video 8 05-04-2007 23:41
Is Vista crippled by DRM? Eddie Bauer microsoft.public.windows.vista.general 11 03-03-2007 03:50
Vista backup question for MVPs Malcolm H microsoft.public.windows.vista.general 13 03-02-2007 05:36
Dave Pogue Reviews Vista in the NYT "Vista Wins on Looks. As for lacks..." Chad Harris microsoft.public.windows.vista.general 28 03-01-2007 20:46
CreateIpForwardEntry doesn't work on Vista =?Utf-8?B?YmVnaW5uZXI=?= microsoft.public.windows.vista.networking sharing 0 02-05-2007 21:33




All times are GMT +1. The time now is 05:14.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120