Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

NTLM Passwords Linux NAS passwords

microsoft.public.windows.vista.networking sharing






Speedup My PC
Reply
  #1 (permalink)  
Old 01-31-2007
=?Utf-8?B?U3RldmVL?=
 

Posts: n/a
NTLM Passwords Linux NAS passwords
in RC2 this forum gave me the following solution to a problem accessing linux
devices - i.e. password format was not accepted due NTLM.

- Click Start
- Click Control Panel
- Click System and Maintenance
- Click Administrative Tools
- Double-Click Local Security Policy
- In the left pane, click the triangle next to Local Policy
- In the left pane, click Security Options
- In the right pane near the bottom, double-click "Network security: LAN
manager authentication level"
- Click the drop-down box, and click "Send LM & NTLM - use NTLMv2 session
security if negotiated"
- Click OK

The solution worked perfectly - BUT now I have a the final version (Vista
Home - bought in a shop) I have the same problem except that when I try to
follow the procedure above there is no 'Local Security Policy' option in the
Administrative Tools section of the control panel.

Can anyone tell me where I can access the 'Local Security Policy' settings??

Thanks, SteveK
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 01-31-2007
=?Utf-8?B?U3RldmVL?=
 

Posts: n/a
RE: NTLM Passwords Linux NAS passwords
The implications are it seems that if you have any Linux based NAS devices
(which probably accounts for the majority) they will not work (passwords)
with Vista Home Edition. There are going to be a lot of very unhappy people
out there! You'll have to pay another £144 to upgrade to Ultimate!

Any comments, input, work arounds or donations towards a copy of Ultimate
greatly appreciated.

"SteveK" wrote:

> in RC2 this forum gave me the following solution to a problem accessing linux
> devices - i.e. password format was not accepted due NTLM.
>
> - Click Start
> - Click Control Panel
> - Click System and Maintenance
> - Click Administrative Tools
> - Double-Click Local Security Policy
> - In the left pane, click the triangle next to Local Policy
> - In the left pane, click Security Options
> - In the right pane near the bottom, double-click "Network security: LAN
> manager authentication level"
> - Click the drop-down box, and click "Send LM & NTLM - use NTLMv2 session
> security if negotiated"
> - Click OK
>
> The solution worked perfectly - BUT now I have a the final version (Vista
> Home - bought in a shop) I have the same problem except that when I try to
> follow the procedure above there is no 'Local Security Policy' option in the
> Administrative Tools section of the control panel.
>
> Can anyone tell me where I can access the 'Local Security Policy' settings??
>
> Thanks, SteveK

Reply With Quote
  #3 (permalink)  
Old 01-31-2007
Dave R.
 

Posts: n/a
Re: NTLM Passwords Linux NAS passwords

"SteveK" <SteveK@discussions.microsoft.com> wrote in message
news:793DDDAC-D5CB-41D7-821A-3CC09B2EF34A@microsoft.com...
> "SteveK" wrote:
>
>> in RC2 this forum gave me the following solution to a problem
>> accessing linux
>> devices - i.e. password format was not accepted due NTLM.
>>
>> - Click Start
>> - Click Control Panel
>> - Click System and Maintenance
>> - Click Administrative Tools
>> - Double-Click Local Security Policy
>> - In the left pane, click the triangle next to Local Policy
>> - In the left pane, click Security Options
>> - In the right pane near the bottom, double-click "Network security:
>> LAN
>> manager authentication level"
>> - Click the drop-down box, and click "Send LM & NTLM - use NTLMv2
>> session
>> security if negotiated"
>> - Click OK
>>
>> The solution worked perfectly - BUT now I have a the final version
>> (Vista
>> Home - bought in a shop) I have the same problem except that when I
>> try to
>> follow the procedure above there is no 'Local Security Policy' option
>> in the
>> Administrative Tools section of the control panel.
>>
>> Can anyone tell me where I can access the 'Local Security Policy'
>> settings??
>>
>> Thanks, SteveK


> The implications are it seems that if you have any Linux based NAS
> devices
> (which probably accounts for the majority) they will not work
> (passwords)
> with Vista Home Edition. There are going to be a lot of very unhappy
> people
> out there! You'll have to pay another £144 to upgrade to Ultimate!
>
> Any comments, input, work arounds or donations towards a copy of
> Ultimate
> greatly appreciated.
>


Two thoughts: One, perhaps there is a way to upgrade the NAS devices to
support NTLMv2 authentication. Two, perhaps there are registry settings
that can achieve the same effect as using the Local Security Policy
settings.

In XP Pro, changing from "Send LM & NTLM responses" to "Send LM & NTLM -
use NTLMv2 session security if negotiated" changes
"lmcompatibilitylevel" in
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Lsa from
dword:00000000 to dword:00000001

If someone with a Business or Ultimate version had time and inclination,
they could run a registry compare before & after changing the
authentication level and see what surfaces. Unfortunately I don't yet
have access to a copy of Business or Ultimate or I'd do it - I'll
eventually have to anyway so I can automate a couple of deployment
scenarios.

Hope this helps.

Regards,

Dave


Reply With Quote
  #4 (permalink)  
Old 02-01-2007
Jimmy Brush
 

Posts: n/a
Re: NTLM Passwords Linux NAS passwords
This is the correct registry key and value to change.


--
- JB
Microsoft MVP - Windows Shell/User

Windows Vista Support Faq
http://www.jimmah.com/vista/
Reply With Quote
  #5 (permalink)  
Old 02-01-2007
Dave R.
 

Posts: n/a
Re: NTLM Passwords Linux NAS passwords

"Jimmy Brush" <JimmyBrush@discussions.microsoft.com> wrote in message
news:33EF922A-9182-49A4-B097-E15E4272DA6E@microsoft.com...
> This is the correct registry key and value to change.
>
>
> --


Thanks for the confirmation.

Best Regards,

Dave


Reply With Quote
  #6 (permalink)  
Old 02-02-2007
=?Utf-8?B?U3RldmVL?=
 

Posts: n/a
Re: NTLM Passwords Linux NAS passwords
Worked a treat - thanks
BTW, the existing value in my registry was 00000003 and not 00000000. But I
set it to 00000001 and it works a treat.

"Jimmy Brush" wrote:

> This is the correct registry key and value to change.
>
>
> --
> - JB
> Microsoft MVP - Windows Shell/User
>
> Windows Vista Support Faq
> http://www.jimmah.com/vista/

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Roy's Linux Powered Testicles Have Been Located !! roys.testicles@yahoo.com microsoft.public.windows.vista.general 3 03-02-2007 09:21
Storing Passwords =?Utf-8?B?Smlt?= microsoft.public.windows.vista.mail 4 02-23-2007 03:41




All times are GMT +1. The time now is 14:41.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120