Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Vista and Fortigate SSL VPN

microsoft.public.windows.vista.networking sharing






Speedup My PC
Reply
  #1 (permalink)  
Old 09-19-2007
Hurricane Andrew
 

Posts: n/a
Vista and Fortigate SSL VPN
My company uses a Fortigate SSL VPN for remote access. The clinet intalls an
ActiveX control to create the VPN Tunnell. This works very differently on
Vista than it does in XP. In XP, the ActX control can be installed easily
from an account with administrative privileges. Once connected, all traffic
flows through the VPN. You minimize the browser, and can use all standard
tools, from ping to remote desktop sessions, and all flows through the VPN.

In Vista, the first issue is that even from an administrative account, you
still need to manually elevate and run IE as an admistrator to both install
the ActX control, as well as to connect to the VPN once the control is
installed. Further, nothing seems to flow through the VPN by default.
Pinging machines on the remote end returns "host unreachable" messages, and
remote desktop sessions just flat out don't work. The VPN itself is
connected, and ipconfig confirms the assigned IP, and DNS settings for it.
Also, though the fortigate VPN itself has some tools that can be used from
the browser, most are disabled, except for ping. Using the ping tool from
the browser (in the admin session, of course) reches the destination fine.

I'm thought this was related to a user rights issue, though I did try to
elevate my RDP session and see if it would work that way, but it did not.
Perhaps something to do with IE's protected mode? I'm almost certain now
that it has something to do with the Vista isolates certain processes and
features.

Any thoughts or potential workarounds?


--
"Hurricane" Andrew
Milford, DE
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 09-20-2007
Steve Riley [MSFT]
 

Posts: n/a
Re: Vista and Fortigate SSL VPN
Not what you want to hear, but it's up to Fortigate to create a
Vista-compatible version of their VPN control. Have you contacted them?

--
Steve Riley
steve.riley@microsoft.com
http://blogs.technet.com/steriley
http://www.protectyourwindowsnetwork.com


"Hurricane Andrew" <HurricaneAndrew@discussions.microsoft.com> wrote in
message news:C627AD07-1EB8-4535-BD97-F2E840156BB5@microsoft.com...
> My company uses a Fortigate SSL VPN for remote access. The clinet intalls
> an
> ActiveX control to create the VPN Tunnell. This works very differently on
> Vista than it does in XP. In XP, the ActX control can be installed easily
> from an account with administrative privileges. Once connected, all
> traffic
> flows through the VPN. You minimize the browser, and can use all standard
> tools, from ping to remote desktop sessions, and all flows through the
> VPN.
>
> In Vista, the first issue is that even from an administrative account, you
> still need to manually elevate and run IE as an admistrator to both
> install
> the ActX control, as well as to connect to the VPN once the control is
> installed. Further, nothing seems to flow through the VPN by default.
> Pinging machines on the remote end returns "host unreachable" messages,
> and
> remote desktop sessions just flat out don't work. The VPN itself is
> connected, and ipconfig confirms the assigned IP, and DNS settings for it.
> Also, though the fortigate VPN itself has some tools that can be used from
> the browser, most are disabled, except for ping. Using the ping tool from
> the browser (in the admin session, of course) reches the destination fine.
>
> I'm thought this was related to a user rights issue, though I did try to
> elevate my RDP session and see if it would work that way, but it did not.
> Perhaps something to do with IE's protected mode? I'm almost certain now
> that it has something to do with the Vista isolates certain processes and
> features.
>
> Any thoughts or potential workarounds?
>
>
> --
> "Hurricane" Andrew
> Milford, DE


Reply With Quote
  #3 (permalink)  
Old 09-20-2007
Hurricane Andrew
 

Posts: n/a
Re: Vista and Fortigate SSL VPN
Yeah, I was afraid of that being the answer. We'll open a ticket with them
today.


--
"Hurricane" Andrew
Milford, DE

"Steve Riley [MSFT]" <steve.riley@microsoft.com> wrote in message
news:eJPgfk0%23HHA.1208@TK2MSFTNGP03.phx.gbl...
> Not what you want to hear, but it's up to Fortigate to create a
> Vista-compatible version of their VPN control. Have you contacted them?
>
> --
> Steve Riley
> steve.riley@microsoft.com
> http://blogs.technet.com/steriley
> http://www.protectyourwindowsnetwork.com
>
>
> "Hurricane Andrew" <HurricaneAndrew@discussions.microsoft.com> wrote in
> message news:C627AD07-1EB8-4535-BD97-F2E840156BB5@microsoft.com...
>> My company uses a Fortigate SSL VPN for remote access. The clinet
>> intalls an
>> ActiveX control to create the VPN Tunnell. This works very differently
>> on
>> Vista than it does in XP. In XP, the ActX control can be installed
>> easily
>> from an account with administrative privileges. Once connected, all
>> traffic
>> flows through the VPN. You minimize the browser, and can use all
>> standard
>> tools, from ping to remote desktop sessions, and all flows through the
>> VPN.
>>
>> In Vista, the first issue is that even from an administrative account,
>> you
>> still need to manually elevate and run IE as an admistrator to both
>> install
>> the ActX control, as well as to connect to the VPN once the control is
>> installed. Further, nothing seems to flow through the VPN by default.
>> Pinging machines on the remote end returns "host unreachable" messages,
>> and
>> remote desktop sessions just flat out don't work. The VPN itself is
>> connected, and ipconfig confirms the assigned IP, and DNS settings for
>> it.
>> Also, though the fortigate VPN itself has some tools that can be used
>> from
>> the browser, most are disabled, except for ping. Using the ping tool
>> from
>> the browser (in the admin session, of course) reches the destination
>> fine.
>>
>> I'm thought this was related to a user rights issue, though I did try to
>> elevate my RDP session and see if it would work that way, but it did not.
>> Perhaps something to do with IE's protected mode? I'm almost certain now
>> that it has something to do with the Vista isolates certain processes and
>> features.
>>
>> Any thoughts or potential workarounds?
>>
>>
>> --
>> "Hurricane" Andrew
>> Milford, DE

>


Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
F5 Rolls Out New SSL VPN Version Paul Security News 0 09-18-2007 17:40
Alcatel-Lucent Deploys SSL VPN Paul Security News 0 07-30-2007 16:00
Insurer Deploys NeoAccel's SSL VPN-Plus Paul Security News 0 07-09-2007 14:06
AIF Deploys NeoAccel SSL VPN Paul Security News 0 05-02-2007 15:08
F5 claims Vista SSL VPN first Paul Security News 0 02-28-2007 19:32




All times are GMT +1. The time now is 03:35.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120