Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Help...This Missing CODEC thing is making me crazy

microsoft.public.windows.vista.music pictures video






Speedup My PC
Reply
  #1 (permalink)  
Old 09-30-2007
Bellamar
 

Posts: n/a
Help...This Missing CODEC thing is making me crazy
One of my programs tells me that I am missing a MP3 Codec or the one I have
is inappropiate. I contacted the Phone tools people, they said I need to
download CODEC. I dont know a trusted wite to do this from and don't know
how to install.

Before Vista and the new Office, I could whip around and actually did IT
work for a small clinic. Now, I feel like I did when I first started
computers 15 years ago!
--
Any Help would be SOO appreciated!
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 09-30-2007
Adam Albright
 

Posts: n/a
Re: Help...This Missing CODEC thing is making me crazy
On Sat, 29 Sep 2007 17:11:02 -0700, Bellamar
<Bellamar@discussions.microsoft.com> wrote:

>One of my programs tells me that I am missing a MP3 Codec or the one I have
>is inappropiate. I contacted the Phone tools people, they said I need to
>download CODEC. I dont know a trusted wite to do this from and don't know
>how to install.
>
>Before Vista and the new Office, I could whip around and actually did IT
>work for a small clinic. Now, I feel like I did when I first started
>computers 15 years ago!


The MP3 Codec like MPEG-2 is licensed. So generally you need to
install something on your system that includes one.

Could also be you have some conflict where you have multiple MP3
codecs installed and that's messing things up.

One thing you could try even if you're not into video is do a quick
download of G-spot. Once installed click on View Codec database,
installed audio codecs and it will show you all your audio codecs on
your system. Ditto if anyone wants to check all their video codecs.

I just checked mine and I see only one entry named mp3dmod.dll
authored by Microsoft which does not mean it came with Windows.

Reply With Quote
  #3 (permalink)  
Old 10-01-2007
Jume
 

Posts: n/a
Re: Help...This Missing CODEC thing is making me crazy
vista, as well as xp and a bunch of older windows, already have included a
mp3 codec, as well as mpg & mpg2 (vista here)

if the program is telling you that there is not an available mp3 codec on
the system, either it is wrong (and subject of some incompatibility making
it believe so), or a codec pack you installed may be interfering with the
default codec

just try a little test:
- in wmp 11, open the submenu of the button "rip" and choose mp3 as the
format for ripping, leave the bitrate as is since it is just a test
- insert a music cd and rip a couple of songs
- try to play the songs after

im not sure in wmp11 encodes with the default system mp3 codec, but im
pretty sure it uses the default for decoding, so if you cant listen the mp3
songs (even if the ripping does work fine) you may have a problem with the
codecs installed on your system (and so, try uninstalling any codec pack
previously installed)
finally, if it plays fine, then the problem would be on the program itself,
either it does not work with the default mp3 codec (meaning it requires a
special codec) or the program is not able to work fully properly in vista

Reply With Quote
  #4 (permalink)  
Old 10-10-2007
brady lee
 

Posts: n/a
a fix for vista codec problem
Not sure if you ever figured this one out but I have the fix..... hopefully it'll help somebody else too. This problem was driving me nuts!!
On Vista-
Go to Computer
C:
Windows
System32
Look for a file called l3codecp.acm (you'll probably find l3codeca.acm which is why you're having the error)
If you find l3codeca.acm continue on........
Close out of that
Go to start
Run
Type regedit
Click the arrow next to Hkey_Local_machine
Then click the arrow next to Software
Arrow next to Microsoft
Arrow next to Windows NT
Arrow next to Current Version
Then highlight or click once on the name Drivers32
On the list to the right it will say msacm.l3acm then to the right of that under "Data" it should read C:\Windows\System32\l3codecp.acm(will probably say l3codeca.acm)
If it reads l3codeca.acm you need to right click on msacm.l3acm and click MODIFY

Once in there, leave the data that's already there, just find the spot where it says
l3codeca.acm and replace it with l3codecp.acm- (you're only changing one letter the A after codec to a P) click ok restart your computer and it WILL work!! It sounds complicated but if you follow everything I say, it will work like a charm and you won't have the problem again. If you know of anyone else having the same problem direct them to this and have them run through it.



EggHeadCafe - .NET Developer Portal of Choice
http://www.eggheadcafe.com
Reply With Quote
  #5 (permalink)  
Old 10-10-2007
Rob
 

Posts: n/a
Re: a fix for vista codec problem


"brady lee" wrote in message news:2007101011625bradylee2007@yahoo.com...
> Not sure if you ever figured this one out but I have the fix.....
> hopefully it'll help somebody else too. This problem was driving me nuts!!
> On Vista-
> Go to Computer
> C:
> Windows
> System32
> Look for a file called l3codecp.acm (you'll probably find l3codeca.acm
> which is why you're having the error)
> If you find l3codeca.acm continue on........
> Close out of that
> Go to start
> Run
> Type regedit
> Click the arrow next to Hkey_Local_machine
> Then click the arrow next to Software
> Arrow next to Microsoft
> Arrow next to Windows NT
> Arrow next to Current Version
> Then highlight or click once on the name Drivers32
> On the list to the right it will say msacm.l3acm then to the right of that
> under "Data" it should read C:\Windows\System32\l3codecp.acm(will probably
> say l3codeca.acm)
> If it reads l3codeca.acm you need to right click on msacm.l3acm and click
> MODIFY
>
> Once in there, leave the data that's already there, just find the spot
> where it says
> l3codeca.acm and replace it with l3codecp.acm- (you're only changing one
> letter the A after codec to a P) click ok restart your computer and it
> WILL work!! It sounds complicated but if you follow everything I say, it
> will work like a charm and you won't have the problem again. If you know
> of anyone else having the same problem direct them to this and have them
> run through it.
>
>
>
> EggHeadCafe - .NET Developer Portal of Choice
> http://www.eggheadcafe.com


Hey,

Thanks for posting the fix. It's always very helpful when people do that.
However for us that haven't been following this, what specific problem does
this refer to.

cheers

Rob

--
Red meat isn't bad for you....Blue, Green fuzzy meat is bad for you.

Reply With Quote
  #6 (permalink)  
Old 11-01-2007
ww4wiz
 

Posts: n/a
RE: Help...This Missing CODEC thing is making me crazy


"Bellamar" wrote:

> One of my programs tells me that I am missing a MP3 Codec or the one I have
> is inappropiate. I contacted the Phone tools people, they said I need to
> download CODEC. I dont know a trusted wite to do this from and don't know
> how to install.
>
> Before Vista and the new Office, I could whip around and actually did IT
> work for a small clinic. Now, I feel like I did when I first started
> computers 15 years ago!
> --
> Any Help would be SOO appreciated!

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
GSM 6.10 codec missing Swede microsoft.public.windows.vista.general 1 09-16-2007 14:37
Missing Codec smo67 microsoft.public.windows.vista.music pictures video 4 08-24-2007 16:22
funny image making my vista go crazy Maciej So│tysiak microsoft.public.windows.vista.general 3 05-22-2007 15:30
Missing Codec =?Utf-8?B?dXBzcHJ1Y2VjcmVlaw==?= microsoft.public.windows.vista.music pictures video 3 03-28-2007 22:53
Missing Codec? Jack B microsoft.public.windows.vista.general 15 03-03-2007 06:50




All times are GMT +1. The time now is 08:18.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120