Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Problem with unattended installation

microsoft.public.windows.vista.installation setup






Speedup My PC
Reply
  #1 (permalink)  
Old 05-05-2008
Vuong Nguyen
 

Posts: n/a
Problem with unattended installation
When I try to do an unattended installation on a specialized computer that we
have built, the Vista installation gets to the Copy files section, and then
gives the following error:

Windows could not prepare the computer to boot into the next phase of
installation

I know that the setup has partitioned and formatted my harddrive because I
start with a blank hard drive, and when I get to that error message and
reboot, I see that the drive is now formatted.

However, if I do the installation manually on the exact same computer, I
don't get this error, and the installation will finish successfully. I am
using the new OEM Vista SP1 installation disk. Below are the contents of my
autounattend.xml file (with the product key modified). Any suggestions would
be appreciated.

<?xml version="1.0" encoding="utf-8" ?>
- <unattend xmlns="urn:schemas-microsoft-com:unattend">
- <settings pass="windowsPE">
- <component name="Microsoft-Windows-Setup" processorArchitecture="x86"
publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS"
xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <DiskConfiguration>
- <Disk wcm:action="add">
- <CreatePartitions>
- <CreatePartition wcm:action="add">
<Order>1</Order>
<Type>Primary</Type>
<Extend>true</Extend>
</CreatePartition>
</CreatePartitions>
- <ModifyPartitions>
- <ModifyPartition wcm:action="add">
<Active>true</Active>
<Extend>false</Extend>
<Format>NTFS</Format>
<Label>ELOVISTA</Label>
<Letter>C</Letter>
<Order>1</Order>
<PartitionID>1</PartitionID>
</ModifyPartition>
</ModifyPartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
</Disk>
<WillShowUI>OnError</WillShowUI>
</DiskConfiguration>
- <UserData>
- <ProductKey>
<Key>XXXXX-XXXXX-XXXXX-4f48j-cfbbc</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<AcceptEula>true</AcceptEula>
</UserData>
- <ImageInstall>
- <OSImage>
- <InstallTo>
<DiskID>0</DiskID>
<PartitionID>1</PartitionID>
</InstallTo>
<WillShowUI>OnError</WillShowUI>
<InstallToAvailablePartition>true</InstallToAvailablePartition>
</OSImage>
</ImageInstall>
- <Display>
<HorizontalResolution>800</HorizontalResolution>
<VerticalResolution>600</VerticalResolution>
<ColorDepth>32</ColorDepth>
</Display>
</component>
- <component name="Microsoft-Windows-International-Core-WinPE"
processorArchitecture="x86" publicKeyToken="31bf3856ad364e35"
language="neutral" versionScope="nonSxS"
xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <SetupUILanguage>
<UILanguage>en-us</UILanguage>
</SetupUILanguage>
<InputLocale>0409:00000409</InputLocale>
<SystemLocale>en-us</SystemLocale>
<UILanguage>en-us</UILanguage>
<UserLocale>en-US</UserLocale>
</component>
</settings>
- <settings pass="oobeSystem">
- <component name="Microsoft-Windows-Deployment" processorArchitecture="x86"
publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS"
xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <Reseal>
<Mode>Audit</Mode>
<ForceShutdownNow>false</ForceShutdownNow>
</Reseal>
</component>
</settings>
- <settings pass="specialize">
- <component name="Microsoft-Windows-Shell-Setup"
processorArchitecture="x86" publicKeyToken="31bf3856ad364e35"
language="neutral" versionScope="nonSxS"
xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <OEMInformation>
<Manufacturer>Elo TouchSystems</Manufacturer>
<Model>ESY17A2</Model>
<SupportHours>9AM - 5PM PST</SupportHours>
<SupportPhone>1-800-ELOTOUCH</SupportPhone>
<SupportURL>www.elotouch.com</SupportURL>
</OEMInformation>
- <Display>
<HorizontalResolution>800</HorizontalResolution>
<VerticalResolution>600</VerticalResolution>
<ColorDepth>32</ColorDepth>
</Display>
</component>
</settings>
<cpifflineImage cpi:source="catalog:z:/sbc6/vista image
files/install_windows vista ultimate.clg"
xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 05-06-2008
Darrell Gorter[MSFT]
 

Posts: n/a
RE: Problem with unattended installation
Hello,
Take a look at this article it seems to apply to your scenario:
942975 Error message when you specify the value of the
InstallToAvailablePartition XML element as "true" in the Unattend.xml file
to install Windows Vista: "Windows could not prepare the computer to boot
into the next phase of installation"
http://support.microsoft.com/default...b;EN-US;942975


Thanks,
Darrell Gorter[MSFT]

This posting is provided "AS IS" with no warranties, and confers no rights
--------------------
| >Thread-Topic: Problem with unattended installation
| >thread-index: Aciu5ozGAWqpltrRRv+h+pBeP2aH8w==
| >X-WBNR-Posting-Host: 198.175.154.213
| >From: =?Utf-8?B?VnVvbmcgTmd1eWVu?=
<VuongNguyen@discussions.microsoft.com>
| >Subject: Problem with unattended installation
| >Date: Mon, 5 May 2008 12:31:00 -0700
| >Lines: 121
| >Message-ID: <BC1F26A1-1A46-4E69-BE80-BC6A7957D0D2@microsoft.com>
| >MIME-Version: 1.0
| >Content-Type: text/plain;
| > charset="Utf-8"
| >Content-Transfer-Encoding: 7bit
| >X-Newsreader: Microsoft CDO for Windows 2000
| >Content-Class: urn:content-classes:message
| >Importance: normal
| >Priority: normal
| >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2992
| >Newsgroups: microsoft.public.windows.vista.installation_setup
| >Path: TK2MSFTNGHUB02.phx.gbl
| >Xref: TK2MSFTNGHUB02.phx.gbl
microsoft.public.windows.vista.installation_setup: 39420
| >NNTP-Posting-Host: tk2msftibfm01.phx.gbl 10.40.244.149
| >X-Tomcat-NG: microsoft.public.windows.vista.installation_setup
| >
| >When I try to do an unattended installation on a specialized computer
that we
| >have built, the Vista installation gets to the Copy files section, and
then
| >gives the following error:
| >
| >Windows could not prepare the computer to boot into the next phase of
| >installation
| >
| >I know that the setup has partitioned and formatted my harddrive because
I
| >start with a blank hard drive, and when I get to that error message and
| >reboot, I see that the drive is now formatted.
| >
| >However, if I do the installation manually on the exact same computer, I
| >don't get this error, and the installation will finish successfully. I
am
| >using the new OEM Vista SP1 installation disk. Below are the contents of
my
| >autounattend.xml file (with the product key modified). Any suggestions
would
| >be appreciated.
| >
| > <?xml version="1.0" encoding="utf-8" ?>
| >- <unattend xmlns="urn:schemas-microsoft-com:unattend">
| >- <settings pass="windowsPE">
| >- <component name="Microsoft-Windows-Setup" processorArchitecture="x86"
| >publicKeyToken="31bf3856ad364e35" language="neutral"
versionScope="nonSxS"
| >xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"
| >xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
| >- <DiskConfiguration>
| >- <Disk wcm:action="add">
| >- <CreatePartitions>
| >- <CreatePartition wcm:action="add">
| > <Order>1</Order>
| > <Type>Primary</Type>
| > <Extend>true</Extend>
| > </CreatePartition>
| > </CreatePartitions>
| >- <ModifyPartitions>
| >- <ModifyPartition wcm:action="add">
| > <Active>true</Active>
| > <Extend>false</Extend>
| > <Format>NTFS</Format>
| > <Label>ELOVISTA</Label>
| > <Letter>C</Letter>
| > <Order>1</Order>
| > <PartitionID>1</PartitionID>
| > </ModifyPartition>
| > </ModifyPartitions>
| > <DiskID>0</DiskID>
| > <WillWipeDisk>true</WillWipeDisk>
| > </Disk>
| > <WillShowUI>OnError</WillShowUI>
| > </DiskConfiguration>
| >- <UserData>
| >- <ProductKey>
| > <Key>XXXXX-XXXXX-XXXXX-4f48j-cfbbc</Key>
| > <WillShowUI>OnError</WillShowUI>
| > </ProductKey>
| > <AcceptEula>true</AcceptEula>
| > </UserData>
| >- <ImageInstall>
| >- <OSImage>
| >- <InstallTo>
| > <DiskID>0</DiskID>
| > <PartitionID>1</PartitionID>
| > </InstallTo>
| > <WillShowUI>OnError</WillShowUI>
| > <InstallToAvailablePartition>true</InstallToAvailablePartition>
| > </OSImage>
| > </ImageInstall>
| >- <Display>
| > <HorizontalResolution>800</HorizontalResolution>
| > <VerticalResolution>600</VerticalResolution>
| > <ColorDepth>32</ColorDepth>
| > </Display>
| > </component>
| >- <component name="Microsoft-Windows-International-Core-WinPE"
| >processorArchitecture="x86" publicKeyToken="31bf3856ad364e35"
| >language="neutral" versionScope="nonSxS"
| >xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"
| >xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
| >- <SetupUILanguage>
| > <UILanguage>en-us</UILanguage>
| > </SetupUILanguage>
| > <InputLocale>0409:00000409</InputLocale>
| > <SystemLocale>en-us</SystemLocale>
| > <UILanguage>en-us</UILanguage>
| > <UserLocale>en-US</UserLocale>
| > </component>
| > </settings>
| >- <settings pass="oobeSystem">
| >- <component name="Microsoft-Windows-Deployment"
processorArchitecture="x86"
| >publicKeyToken="31bf3856ad364e35" language="neutral"
versionScope="nonSxS"
| >xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"
| >xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
| >- <Reseal>
| > <Mode>Audit</Mode>
| > <ForceShutdownNow>false</ForceShutdownNow>
| > </Reseal>
| > </component>
| > </settings>
| >- <settings pass="specialize">
| >- <component name="Microsoft-Windows-Shell-Setup"
| >processorArchitecture="x86" publicKeyToken="31bf3856ad364e35"
| >language="neutral" versionScope="nonSxS"
| >xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"
| >xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
| >- <OEMInformation>
| > <Manufacturer>Elo TouchSystems</Manufacturer>
| > <Model>ESY17A2</Model>
| > <SupportHours>9AM - 5PM PST</SupportHours>
| > <SupportPhone>1-800-ELOTOUCH</SupportPhone>
| > <SupportURL>www.elotouch.com</SupportURL>
| > </OEMInformation>
| >- <Display>
| > <HorizontalResolution>800</HorizontalResolution>
| > <VerticalResolution>600</VerticalResolution>
| > <ColorDepth>32</ColorDepth>
| > </Display>
| > </component>
| > </settings>
| > <cpifflineImage cpi:source="catalog:z:/sbc6/vista image
| >files/install_windows vista ultimate.clg"
| >xmlns:cpi="urn:schemas-microsoft-com:cpi" />
| > </unattend>
| >

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unattended Software installation Eldingo microsoft.public.windows.vista.administration accounts passwords 1 10-25-2007 15:46
Unattended Software installation Eldingo microsoft.public.windows.vista.general 1 10-25-2007 15:46
Joining domain via unattended installation =?Utf-8?B?S2FyaW4gRE0=?= microsoft.public.windows.vista.installation setup 0 03-28-2007 01:55
unattended installation over the network? XXX microsoft.public.windows.vista.installation setup 1 03-09-2007 12:50




All times are GMT +1. The time now is 09:05.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120