Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Sysprep Image and automating Computer Name

microsoft.public.windows.vista.installation setup






Speedup My PC
Reply
  #1 (permalink)  
Old 04-21-2008
Gareth Jefferies
 

Posts: n/a
Sysprep Image and automating Computer Name
Hi,

We would like to deploy a sysprep'd Vista x64 image and we would like the
computer name automatically set, based on the asset number in the BIOS.

Does anyone know how to do this?

I have used a tool called WSName for Windows XP, using the WMI
SMBIOSAssetTag info, but this doesn't work in Vista.

Could Powershell or vbscript be used?

Thanks

Gareth
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 04-22-2008
Joe Morris
 

Posts: n/a
Re: Sysprep Image and automating Computer Name
"Gareth Jefferies" wrote:

> We would like to deploy a sysprep'd Vista x64 image and we would like the
> computer name automatically set, based on the asset number in the BIOS.
>
> Does anyone know how to do this?
>
> I have used a tool called WSName for Windows XP, using the WMI
> SMBIOSAssetTag info, but this doesn't work in Vista.


I've not seen WSName before, but the author's web page flags it as "not
tested on Vista" and doesn't include Vista support in the section "What's in
the works." How does it fail for you? And perhaps more to the point, are
you running it as administrator, or with normal privileges? (UAC strikes
again...)


> Could Powershell or vbscript be used?


You'll probably need to be recovering the string from WMI, so any tool which
can issue a WMI call, manipulate the response, and store it into the
Registry should be OK...as long as you don't let the UAC alligator chomp
down on your fingers. And assuming that Vista doesn't require some
completely new waving-of-hands to change the hostname programmatically.

The asset tag info is stored in the same WMI property in XP and Vista, so
that part of the code won't change.

Joe Morris


Reply With Quote
  #3 (permalink)  
Old 04-23-2008
Grey
 

Posts: n/a
Re: Sysprep Image and automating Computer Name
Be aware - if the machinery you are deploying TO isn't exactly the same as
the machinery where the image was CREATED (eg, every machine exactly the
same), then it wont work.

"Gareth Jefferies" <GarethJefferies@discussions.microsoft.com> wrote in
message news:B8847AD8-5575-40A3-9A9E-598AE70DBCD6@microsoft.com...
> Hi,
>
> We would like to deploy a sysprep'd Vista x64 image and we would like the
> computer name automatically set, based on the asset number in the BIOS.
>
> Does anyone know how to do this?
>
> I have used a tool called WSName for Windows XP, using the WMI
> SMBIOSAssetTag info, but this doesn't work in Vista.
>
> Could Powershell or vbscript be used?
>
> Thanks
>
> Gareth


Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Article ID: 926175 L'OOBE Wizard ne risque pas fonctionner lorsque vous utilisez Sysprep.exe pour dployer une image Windows Vista KBArticles French 0 10-23-2007 20:00
Article ID: 929828 Wenn Sie ausführen, tritt eine Fehlermeldung auf " Sysprep / Sie verallgemeinern ": "bei dem Computer auftrat ein schwerwiegender Fehler zu Sysprep" in Windows Vista KBArticles German 0 10-22-2007 21:20
Article ID: 926175 The OOBE Wizard may not run when you use Sysprep.exe to deploy a Windows Vista image KBArticles English 0 10-22-2007 20:00
How to do sysprep to make a image for my users and maintain the count on KMS server ? Motor Wu microsoft.public.windows.vista.installation setup 6 03-20-2007 06:33
How to do sysprep to make a image for my users and maintain the count on KMS server ? Motor Wu microsoft.public.windows.vista.general 2 03-16-2007 03:07




All times are GMT +1. The time now is 11:53.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120