Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Printers not accessible if UAC is on and Office app is run in elevated mode

microsoft.public.windows.vista.installation setup






Speedup My PC
Reply
  #1 (permalink)  
Old 01-16-2008
Tech_vs_Life
 

Posts: n/a
Printers not accessible if UAC is on and Office app is run in elevated mode
Is there any workaround for this problem, in Vista x64, and also in Windows
Server x64 2008 RC1:

With UAC on, if any Office 2007 app is run with admin elevation (Excel and
Access tested), then you cannot print from the app (get error "no printers
defined").

Furthermore, when the apps are set to always run with admin elevation, you
cannot open an office document from Windows explorer ("file not found" even
when double-clicking on it). However, you can run the Office app and then
open the document from within the app.

These seem like fairly major bugs with Vista and/or Office.
Note: I'm running the apps with admin elevation in order that command-line
scripts that are called by VBA also run with admin elevation (and they
require admin elevation).

Thanks.








Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 01-16-2008
Tech_vs_Life
 

Posts: n/a
Printers not accessible if UAC is on and Office app is run in elevated mode
Is there any workaround for this problem, in Vista x64, and also in Windows
Server x64 2008 RC1:

> With UAC on, if any Office 2007 app is run with admin elevation (Excel and
> Access tested), then you cannot print from the app (get error "no printers
> defined").
>
> Furthermore, when the apps are set to always run with admin elevation, you
> cannot open an office document from Windows explorer ("file not found"
> even when double-clicking on it). However, you can run the Office app and
> then open the document from within the app.
>
> These seem like fairly major bugs with Vista and/or Office.
> Note: I'm running the apps with admin elevation in order that command-line
> scripts that are called by VBA also run with admin elevation (and they
> require admin elevation).
>

Thanks.

Reply With Quote
  #3 (permalink)  
Old 01-21-2008
Fred
 

Posts: n/a
RE: Printers not accessible if UAC is on and Office app is run in elev
Maybe I'm dumb enough to have a smart answer ....upgrade from Vista to XP.



"Tech_vs_Life" wrote:

> Is there any workaround for this problem, in Vista x64, and also in Windows
> Server x64 2008 RC1:
>
> > With UAC on, if any Office 2007 app is run with admin elevation (Excel and
> > Access tested), then you cannot print from the app (get error "no printers
> > defined").
> >
> > Furthermore, when the apps are set to always run with admin elevation, you
> > cannot open an office document from Windows explorer ("file not found"
> > even when double-clicking on it). However, you can run the Office app and
> > then open the document from within the app.
> >
> > These seem like fairly major bugs with Vista and/or Office.
> > Note: I'm running the apps with admin elevation in order that command-line
> > scripts that are called by VBA also run with admin elevation (and they
> > require admin elevation).
> >

> Thanks.
>
>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Printers not accessible if UAC is on and Office app is run in elevated mode Tech_vs_Life microsoft.public.windows.vista.general 2 01-21-2008 21:05
run a legacy CPL elevated message Mentos microsoft.public.windows.vista.security 2 11-12-2007 02:18
start an application in elevated mode after logon =?Utf-8?B?bHVrZXNo?= microsoft.public.windows.vista.installation setup 7 03-11-2007 17:21
One from the logical driver of HDD is not accessible with UAC on Michael Nemtsev microsoft.public.windows.vista.general 0 02-28-2007 17:45




All times are GMT +1. The time now is 10:53.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120