Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Error code 0x80070017

microsoft.public.windows.vista.installation setup






Speedup My PC
Reply
  #1 (permalink)  
Old 11-08-2007
Viv
 

Posts: n/a
Error code 0x80070017
I am trying to install Vista Business, 32 bit, on my computer. The
installation was successful using this DVD on my original MoBo but then I
decided to flash the BIOS and destroyed it. I now have an MSI K9N SLI board
with the latest BIOS, a 160Gb HDD as secondary master on the IDE cable and an
8x MSI DVD RW as primary master and 1st boot device. There is 1024Mb of RAM
and an AMD Athlon 64x2 Dual Core Processor 4800+.

Installation starts successfully then when it gets to expanding files the
first 1% takes about 15 minutes, the next 1% over 30 minutes and I get this
message :-
Windows cannot install required files. The file may be corrupt or missing.
Make sure all files required for installation are available, and restart the
installation. Error code 0x80070017

There is no indication what file is missing, (and as installing from this
DVD worked once I cannot believe that there are missing files).

Can anyone advise what the problem is, and how to overcome it? All advice
gratefully received.
Viv
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 11-08-2007
Richard G. Harper
 

Posts: n/a
Re: Error code 0x80070017
Have you checked for damage to the DVD and/or cleaned the drive that reports
the error condition?

--
Richard G. Harper [MVP Shell/User] rgharper@gmail.com
* NEW! Catch my blog ... http://msmvps.com/blogs/rgharper/
* PLEASE post all messages and replies in the newsgroups
* The Website - http://rgharper.mvps.org/
* HELP us help YOU ... http://www.dts-l.org/goodpost.htm


"Viv" <Viv@discussions.microsoft.com> wrote in message
news:03A3ACFB-C00C-4C2C-A898-3878C3955AE2@microsoft.com...
>I am trying to install Vista Business, 32 bit, on my computer. The
> installation was successful using this DVD on my original MoBo but then I
> decided to flash the BIOS and destroyed it. I now have an MSI K9N SLI
> board
> with the latest BIOS, a 160Gb HDD as secondary master on the IDE cable and
> an
> 8x MSI DVD RW as primary master and 1st boot device. There is 1024Mb of
> RAM
> and an AMD Athlon 64x2 Dual Core Processor 4800+.
>
> Installation starts successfully then when it gets to expanding files the
> first 1% takes about 15 minutes, the next 1% over 30 minutes and I get
> this
> message :-
> Windows cannot install required files. The file may be corrupt or
> missing.
> Make sure all files required for installation are available, and restart
> the
> installation. Error code 0x80070017
>
> There is no indication what file is missing, (and as installing from this
> DVD worked once I cannot believe that there are missing files).
>
> Can anyone advise what the problem is, and how to overcome it? All advice
> gratefully received.
> Viv


Reply With Quote
  #3 (permalink)  
Old 11-08-2007
Mike Hall - MVP
 

Posts: n/a
Re: Error code 0x80070017
First, recable your DVD and hard drive, ensuring that the hard drive is
master. Then run either Memtest 86, Windows Memory Diagnostic, or use the
memory test in BIOS if there is one available.

Also, set your BIOS to 'optimal' settings..

--
Mike Hall - MVP
http://msmvps.com/blogs/mikehall/default.aspx
Posting Productively.. http://www.dts-l.org/goodpost.htm



"Viv" <Viv@discussions.microsoft.com> wrote in message
news:03A3ACFB-C00C-4C2C-A898-3878C3955AE2@microsoft.com...
>I am trying to install Vista Business, 32 bit, on my computer. The
> installation was successful using this DVD on my original MoBo but then I
> decided to flash the BIOS and destroyed it. I now have an MSI K9N SLI
> board
> with the latest BIOS, a 160Gb HDD as secondary master on the IDE cable and
> an
> 8x MSI DVD RW as primary master and 1st boot device. There is 1024Mb of
> RAM
> and an AMD Athlon 64x2 Dual Core Processor 4800+.
>
> Installation starts successfully then when it gets to expanding files the
> first 1% takes about 15 minutes, the next 1% over 30 minutes and I get
> this
> message :-
> Windows cannot install required files. The file may be corrupt or
> missing.
> Make sure all files required for installation are available, and restart
> the
> installation. Error code 0x80070017
>
> There is no indication what file is missing, (and as installing from this
> DVD worked once I cannot believe that there are missing files).
>
> Can anyone advise what the problem is, and how to overcome it? All advice
> gratefully received.
> Viv


Reply With Quote
  #4 (permalink)  
Old 11-08-2007
Viv
 

Posts: n/a
Re: Error code 0x80070017
Thanks, Mike.

I have changed the HDD to be master and the DVD to be slave, reset the BIOS
to optimal settings, ensuring that the DVD is the first boot device.

There does not seem to be a method to check the memory using BIOS so I tried
the other options you mentioned. Neither the Windows Memory Diagnostic nor
Memtest86 will run as they both give a message 'Bootmgr is missing'.

However I decided to try the installation again and it seems to be working
as expanding files is up to 85% and zipping through quite quickly. It looks
as if changing the HDD to master has solved the problem.

Viv



"Mike Hall - MVP" wrote:

> First, recable your DVD and hard drive, ensuring that the hard drive is
> master. Then run either Memtest 86, Windows Memory Diagnostic, or use the
> memory test in BIOS if there is one available.
>
> Also, set your BIOS to 'optimal' settings..
>
> --
> Mike Hall - MVP
> http://msmvps.com/blogs/mikehall/default.aspx
> Posting Productively.. http://www.dts-l.org/goodpost.htm
>
>
>
> "Viv" <Viv@discussions.microsoft.com> wrote in message
> news:03A3ACFB-C00C-4C2C-A898-3878C3955AE2@microsoft.com...
> >I am trying to install Vista Business, 32 bit, on my computer. The
> > installation was successful using this DVD on my original MoBo but then I
> > decided to flash the BIOS and destroyed it. I now have an MSI K9N SLI
> > board
> > with the latest BIOS, a 160Gb HDD as secondary master on the IDE cable and
> > an
> > 8x MSI DVD RW as primary master and 1st boot device. There is 1024Mb of
> > RAM
> > and an AMD Athlon 64x2 Dual Core Processor 4800+.
> >
> > Installation starts successfully then when it gets to expanding files the
> > first 1% takes about 15 minutes, the next 1% over 30 minutes and I get
> > this
> > message :-
> > Windows cannot install required files. The file may be corrupt or
> > missing.
> > Make sure all files required for installation are available, and restart
> > the
> > installation. Error code 0x80070017
> >
> > There is no indication what file is missing, (and as installing from this
> > DVD worked once I cannot believe that there are missing files).
> >
> > Can anyone advise what the problem is, and how to overcome it? All advice
> > gratefully received.
> > Viv

>
>

Reply With Quote
  #5 (permalink)  
Old 11-08-2007
Viv
 

Posts: n/a
Re: Error code 0x80070017

Thanks for the suggestion Richard. The DVD does not appear to be damaged
and I do not have a drive cleaner but it looks as if Mike's suggestion has
solved the problem.

Viv


"Richard G. Harper" wrote:

> Have you checked for damage to the DVD and/or cleaned the drive that reports
> the error condition?
>
> --
> Richard G. Harper [MVP Shell/User] rgharper@gmail.com
> * NEW! Catch my blog ... http://msmvps.com/blogs/rgharper/
> * PLEASE post all messages and replies in the newsgroups
> * The Website - http://rgharper.mvps.org/
> * HELP us help YOU ... http://www.dts-l.org/goodpost.htm
>
>
> "Viv" <Viv@discussions.microsoft.com> wrote in message
> news:03A3ACFB-C00C-4C2C-A898-3878C3955AE2@microsoft.com...
> >I am trying to install Vista Business, 32 bit, on my computer. The
> > installation was successful using this DVD on my original MoBo but then I
> > decided to flash the BIOS and destroyed it. I now have an MSI K9N SLI
> > board
> > with the latest BIOS, a 160Gb HDD as secondary master on the IDE cable and
> > an
> > 8x MSI DVD RW as primary master and 1st boot device. There is 1024Mb of
> > RAM
> > and an AMD Athlon 64x2 Dual Core Processor 4800+.
> >
> > Installation starts successfully then when it gets to expanding files the
> > first 1% takes about 15 minutes, the next 1% over 30 minutes and I get
> > this
> > message :-
> > Windows cannot install required files. The file may be corrupt or
> > missing.
> > Make sure all files required for installation are available, and restart
> > the
> > installation. Error code 0x80070017
> >
> > There is no indication what file is missing, (and as installing from this
> > DVD worked once I cannot believe that there are missing files).
> >
> > Can anyone advise what the problem is, and how to overcome it? All advice
> > gratefully received.
> > Viv

>

Reply With Quote
  #6 (permalink)  
Old 02-05-2009
oldwizard
 

Posts: n/a
Re: Error code 0x80070017

Hello,
I had the same problem, after running setup 5 times, using 3 different
dvds, (which I had used before with no problems), and reading this post,
I realised it was the dvd drive, Solution: take the hard drive out and
install it in another machine, run setup completely, until you are in
the desktop, take the hard drive out and put it back in the original
machine, voila!!, you have windows!!, or replace the dvd drive..... as a
quick solution, if you have another one....


--
oldwizard
Reply With Quote
  #7 (permalink)  
Old 02-05-2009
oldwizard
 

Posts: n/a
Re: Error code 0x80070017

oldwizard;958774 Wrote:
Hello,
I had the same problem, after running setup 5 times, using 3 different
dvds, (which I had used before with no problems), and reading this post,
I realised it was the dvd drive, Solution: take the hard drive out and
install it in another machine, run setup completely, until you are in
the desktop, take the hard drive out and put it back in the original
machine, voila!!, you have windows!!, or replace the dvd drive..... as a
quick solution, if you have another one....


--
oldwizard
Reply With Quote
  #8 (permalink)  
Old 02-09-2009
Eliv07302
 

Posts: n/a
Re: Error code 0x80070017

This site truly helped me upgrade to Windows 7 Beta. First I downloaded
Beta on a dvd and tried installing it however did it not respond and
kept on giving me the "Error code 0x80070017" I burned a second copy of
the upgrade and it worked!! This upgrade is amazing!! For the first time
since I have my laptop is it actually functioning with no problems. Its
way faster and user friendly!! Dont give up. Keep on trying. Vista
sucked but Microsoft came around and fixed it!! Thanks


--
Eliv07302
Reply With Quote
  #9 (permalink)  
Old 06-23-2009
DMDil
 

Posts: n/a
Re: Error code 0x80070017

guys, i was having same problem with same error code...i just wanted to
know how to make my HDD slave to master? i am kind of new to this


--
DMDil
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error 0x800CCC0E error code 10060 steveie85 microsoft.public.windows.vista.mail 3 04-04-2009 20:56
Article ID: 939727 Error message when you use Windows Vista Setup to try to create a partition: "Error code: 0xE0000100" KBArticles English 0 10-22-2007 20:00
error code 0x80070017 with retail vista version =?Utf-8?B?bWFkYW14?= microsoft.public.windows.vista.installation setup 1 04-05-2007 12:19
Error Code 0X80070017 =?Utf-8?B?bWFkYW14?= microsoft.public.windows.vista.general 4 03-31-2007 23:55
error code 0xc004c015 the activation server experienced an error =?Utf-8?B?em9tYml4?= microsoft.public.windows.vista.installation setup 8 02-17-2007 04:01




All times are GMT +1. The time now is 14:57.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120