Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Uninstalled network adapter immediately re-installs

microsoft.public.windows.vista hardware devices






Speedup My PC
Reply
  #1 (permalink)  
Old 02-05-2007
=?Utf-8?B?RG91Z2Fs?=
 

Posts: n/a
Uninstalled network adapter immediately re-installs
Can anyone explain why, when uninstalling a network adapter class device, the
OS immediately reinstalls it. Sometimes even while the uninstall is still in
progress?

Furthermore, does anyone know how to stop this from happening?

It doesn't appear to happen with any other device class - just network
adapters. Uninstalling any other class makes it's instance disappear from
Device Manager. With network adapters though, it looks like there is a PnP
refresh and it re-detects the hardware.
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 02-05-2007
Richard Urban
 

Posts: n/a
Re: Uninstalled network adapter immediately re-installs
Remove the network adapter or turn it off in the bios.

--


Regards,

Richard Urban
Microsoft MVP Windows Shell/User
(For email, remove the obvious from my address)

Quote from George Ankner:
If you knew as much as you think you know,
You would realize that you don't know what you thought you knew!



"Dougal" <Dougal@discussions.microsoft.com> wrote in message
news:02247868-1E30-4A0C-8B3A-0F5007B28451@microsoft.com...
> Can anyone explain why, when uninstalling a network adapter class device,
> the
> OS immediately reinstalls it. Sometimes even while the uninstall is still
> in
> progress?
>
> Furthermore, does anyone know how to stop this from happening?
>
> It doesn't appear to happen with any other device class - just network
> adapters. Uninstalling any other class makes it's instance disappear from
> Device Manager. With network adapters though, it looks like there is a PnP
> refresh and it re-detects the hardware.


Reply With Quote
  #3 (permalink)  
Old 02-06-2007
=?Utf-8?B?UGF2ZWwgQS4=?=
 

Posts: n/a
RE: Uninstalled network adapter immediately re-installs
"Dougal" wrote:
> Can anyone explain why, when uninstalling a network adapter class device, the
> OS immediately reinstalls it. Sometimes even while the uninstall is still in
> progress?
>
> Furthermore, does anyone know how to stop this from happening?
>
> It doesn't appear to happen with any other device class - just network
> adapters. Uninstalling any other class makes it's instance disappear from
> Device Manager. With network adapters though, it looks like there is a PnP
> refresh and it re-detects the hardware.


This seems to be a Vista bug.
Please ask in microsoft.public.development.device.drivers if you need more
details or workarounds.

Regards,
--PA

Reply With Quote
  #4 (permalink)  
Old 02-06-2007
=?Utf-8?B?RG91Z2Fs?=
 

Posts: n/a
RE: Uninstalled network adapter immediately re-installs
Thanks Pavel. I've posted in the other forum.

"Pavel A." wrote:

> "Dougal" wrote:
> > Can anyone explain why, when uninstalling a network adapter class device, the
> > OS immediately reinstalls it. Sometimes even while the uninstall is still in
> > progress?
> >
> > Furthermore, does anyone know how to stop this from happening?
> >
> > It doesn't appear to happen with any other device class - just network
> > adapters. Uninstalling any other class makes it's instance disappear from
> > Device Manager. With network adapters though, it looks like there is a PnP
> > refresh and it re-detects the hardware.

>
> This seems to be a Vista bug.
> Please ask in microsoft.public.development.device.drivers if you need more
> details or workarounds.
>
> Regards,
> --PA
>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Uninstalled Hold Em... now can't get it back =?Utf-8?B?d2V0ZmVycmV0?= microsoft.public.windows.vista.games 1 02-28-2007 14:07
Re: uninstalled progs not being removed from start menu Rick Rogers microsoft.public.windows.vista.general 2 02-19-2007 23:50
Intel PROSet Network Adapter Driver Set 11.2 =?Utf-8?B?a20=?= microsoft.public.windows.vista hardware devices 0 12-17-2006 17:43




All times are GMT +1. The time now is 05:40.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120