Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Dlink DWA-552 under Windows 7 - 64-bit

microsoft.public.windows.vista hardware devices






Speedup My PC
Reply
  #1 (permalink)  
Old 02-09-2009
Administrator
 

Posts: n/a
Dlink DWA-552 under Windows 7 - 64-bit
Hi,

I've been having software driver problems with my Dlink DWA-552 under Vista.
When I booted my Windows 7 64-bit partition, Windows effortlessly installed
the correct driver set and I have no problems.

I looked into this magic a bit further and discovered that Windows 7 had
installed two drivers for my DWA-552, both from system32/drivers:

athrx.sys by Atheros and

vwifibus.sys by Microsoft.

Under Vista only athrx.sys is installed, which explains why my DWA-552 does
not work properly under Vista. I have not been able to get a correct driver
install under Vista, driver update is clueless and Vista update is equally
clueless as is software from Dlink.

How do I manually install vwifibus.sys for my DWA-552 under Vista?

Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 02-09-2009
Tyro
 

Posts: n/a
Re: Dlink DWA-552 under Windows 7 - 64-bit
Download it from Dlink and install.

Tyro

"Administrator" <Jimmy@aol.com> wrote in message
newslNjl.4593$5B.2566@newsfe20.iad...
> Hi,
>
> I've been having software driver problems with my Dlink DWA-552 under
> Vista. When I booted my Windows 7 64-bit partition, Windows effortlessly
> installed the correct driver set and I have no problems.
>
> I looked into this magic a bit further and discovered that Windows 7 had
> installed two drivers for my DWA-552, both from system32/drivers:
>
> athrx.sys by Atheros and
>
> vwifibus.sys by Microsoft.
>
> Under Vista only athrx.sys is installed, which explains why my DWA-552
> does not work properly under Vista. I have not been able to get a correct
> driver install under Vista, driver update is clueless and Vista update is
> equally clueless as is software from Dlink.
>
> How do I manually install vwifibus.sys for my DWA-552 under Vista?
>

Reply With Quote
  #3 (permalink)  
Old 02-09-2009
Administrator
 

Posts: n/a
Re: Dlink DWA-552 under Windows 7 - 64-bit
Can you not read, moron? Go back and read what I said, creep.

"Tyro" <Tyro@Tyros.com> wrote in message
news:YuNjl.4198$%54.1650@nlpi070.nbdc.sbc.com...
> Download it from Dlink and install.
>
> Tyro
>
> "Administrator" <Jimmy@aol.com> wrote in message
> newslNjl.4593$5B.2566@newsfe20.iad...
>> Hi,
>>
>> I've been having software driver problems with my Dlink DWA-552 under
>> Vista. When I booted my Windows 7 64-bit partition, Windows effortlessly
>> installed the correct driver set and I have no problems.
>>
>> I looked into this magic a bit further and discovered that Windows 7 had
>> installed two drivers for my DWA-552, both from system32/drivers:
>>
>> athrx.sys by Atheros and
>>
>> vwifibus.sys by Microsoft.
>>
>> Under Vista only athrx.sys is installed, which explains why my DWA-552
>> does not work properly under Vista. I have not been able to get a correct
>> driver install under Vista, driver update is clueless and Vista update is
>> equally clueless as is software from Dlink.
>>
>> How do I manually install vwifibus.sys for my DWA-552 under Vista?
>>


Reply With Quote
  #4 (permalink)  
Old 02-09-2009
David Vair
 

Posts: n/a
Re: Dlink DWA-552 under Windows 7 - 64-bit
Dowload the zip file from D-Link that contains the driver, just unzip it do
not run the setup program. If you installed the D-Link Network Manager
before, uninstall it from the control panel. After all of this is done, go
to the Device Manager, select your DWA-522, right click and select update
drivers. Select that you want to udpdate drivers manually and point it to
the drivers in the unzipped folder. Then let Windows Manage the Wireless
Connection.

--
David Vair
CNE, CNA, MCP, A+, N+



"Administrator" <Jimmy@aol.com> wrote in message
news:4xPjl.4334$_A2.2126@newsfe22.iad...
> Can you not read, moron? Go back and read what I said, creep.
>
> "Tyro" <Tyro@Tyros.com> wrote in message
> news:YuNjl.4198$%54.1650@nlpi070.nbdc.sbc.com...
>> Download it from Dlink and install.
>>
>> Tyro
>>
>> "Administrator" <Jimmy@aol.com> wrote in message
>> newslNjl.4593$5B.2566@newsfe20.iad...
>>> Hi,
>>>
>>> I've been having software driver problems with my Dlink DWA-552 under
>>> Vista. When I booted my Windows 7 64-bit partition, Windows effortlessly
>>> installed the correct driver set and I have no problems.
>>>
>>> I looked into this magic a bit further and discovered that Windows 7 had
>>> installed two drivers for my DWA-552, both from system32/drivers:
>>>
>>> athrx.sys by Atheros and
>>>
>>> vwifibus.sys by Microsoft.
>>>
>>> Under Vista only athrx.sys is installed, which explains why my DWA-552
>>> does not work properly under Vista. I have not been able to get a
>>> correct driver install under Vista, driver update is clueless and Vista
>>> update is equally clueless as is software from Dlink.
>>>
>>> How do I manually install vwifibus.sys for my DWA-552 under Vista?
>>>

>


Reply With Quote
  #5 (permalink)  
Old 02-10-2009
aprentice@hushmail.com
 

Posts: n/a
Re: Dlink DWA-552 under Windows 7 - 64-bit
On Feb 9, 4:41*am, "David Vair" <dv...@nycap.rr.com> wrote:
> Dowload the zip file from D-Link that contains the driver, just unzip it do
> not run the setup program. *If you installed the D-Link Network Manager
> before, uninstall it from the control panel. *After all of this is done, go
> to the Device Manager, select your DWA-522, right click and select update
> drivers. *Select that you want to udpdate drivers manually and point itto
> the drivers in the unzipped folder. *Then let Windows Manage the Wireless
> Connection.
>
> --
> David Vair
> CNE, CNA, MCP, A+, N+
>
> "Administrator" <Ji...@aol.com> wrote in message
>
> news:4xPjl.4334$_A2.2126@newsfe22.iad...
>
>
>
> > Can you not read, moron? Go back and read what I said, creep.

>
> > "Tyro" <T...@Tyros.com> wrote in message
> >news:YuNjl.4198$%54.1650@nlpi070.nbdc.sbc.com.. .
> >> Download it from Dlink and install.

>
> >> Tyro

>
> >> "Administrator" <Ji...@aol.com> wrote in message
> >>newslNjl.4593$5B.2566@newsfe20.iad...
> >>> Hi,

>
> >>> I've been having software driver problems with my Dlink DWA-552 under
> >>> Vista. When I booted my Windows 7 64-bit partition, Windows effortlessly
> >>> installed the correct driver set and I have no problems.

>
> >>> I looked into this magic a bit further and discovered that Windows 7 had
> >>> installed two drivers for my DWA-552, both from system32/drivers:

>
> >>> athrx.sys by Atheros and

>
> >>> vwifibus.sys by Microsoft.

>
> >>> Under Vista only athrx.sys is installed, which explains why my DWA-552
> >>> does not work properly under Vista. I have not been able to get a
> >>> correct driver install under Vista, driver update is clueless and Vista
> >>> update is equally clueless as is software from Dlink.

>
> >>> How do I manually install vwifibus.sys for my DWA-552 under Vista?- Hide quoted text -

>
> - Show quoted text -


I'm in the same boat as the OP. I've researched your recipe. The
driver package from Dlink does not contain the vital driver
vwifibus.sys. I am posting from Windows 7 using a DWA552 to connect to
the internet.

I cannot get my DWA552 to work reliably in Vista, like it does in
Windows 7 because I cannot find a way to manually install
vwifibus.sys. Dlink only provides athrx.sys

I think you guys are running around in cicles because you did not take
the OP seriously.

I'll check back in a week to see if you guys can find a solution.
Reply With Quote
  #6 (permalink)  
Old 02-10-2009
Administrator
 

Posts: n/a
Re: Dlink DWA-552 under Windows 7 - 64-bit
What the software "gurus" are talking about is a low quality solution for
newbies that does not work.

To get to where they are talking about is even easier than they suggest. I
uninstalled my DWA552 drivers and rebooted. Like magic, a DWA552 driver was
installed, athrx.sys; I did not need to do a manual install of this driver.

Here are the details for this driver prior to driver update:

Provider: Atheros Communications Inc.

File version: 7.6.1.204 build by WinDDK

But there is still no vwifibus.sys

I'm not even going to bother with driver update because it is pointless
unless vwifibus.sys is provided.

I'm posting from my Vista-32 partition.

The internet connection is low bandwidth and unreliable. It craps out under
high bandwidth demands and it craps out on its own within a few minutes just
idle.

Windows 7 with both athrx.sys and vwifibus.sys, provides rock solid high
bandwidth internet connectivity.

The problem is that Windows 7 is a piece of crap which is to be expected of
beta software.

When is some software "guru" going to migrate the DWA552 solution from
Windows 7 to Vista?


<aprentice@hushmail.com> wrote in message
news:dd7fe45f-52dd-441e-812e-b185e0cafeeb@l33g2000pri.googlegroups.com...
On Feb 9, 4:41 am, "David Vair" <dv...@nycap.rr.com> wrote:
> Dowload the zip file from D-Link that contains the driver, just unzip it
> do
> not run the setup program. If you installed the D-Link Network Manager
> before, uninstall it from the control panel. After all of this is done, go
> to the Device Manager, select your DWA-522, right click and select update
> drivers. Select that you want to udpdate drivers manually and point it to
> the drivers in the unzipped folder. Then let Windows Manage the Wireless
> Connection.
>
> --
> David Vair
> CNE, CNA, MCP, A+, N+
>
> "Administrator" <Ji...@aol.com> wrote in message
>
> news:4xPjl.4334$_A2.2126@newsfe22.iad...
>
>
>
> > Can you not read, moron? Go back and read what I said, creep.

>
> > "Tyro" <T...@Tyros.com> wrote in message
> >news:YuNjl.4198$%54.1650@nlpi070.nbdc.sbc.com.. .
> >> Download it from Dlink and install.

>
> >> Tyro

>
> >> "Administrator" <Ji...@aol.com> wrote in message
> >>newslNjl.4593$5B.2566@newsfe20.iad...
> >>> Hi,

>
> >>> I've been having software driver problems with my Dlink DWA-552 under
> >>> Vista. When I booted my Windows 7 64-bit partition, Windows
> >>> effortlessly
> >>> installed the correct driver set and I have no problems.

>
> >>> I looked into this magic a bit further and discovered that Windows 7
> >>> had
> >>> installed two drivers for my DWA-552, both from system32/drivers:

>
> >>> athrx.sys by Atheros and

>
> >>> vwifibus.sys by Microsoft.

>
> >>> Under Vista only athrx.sys is installed, which explains why my DWA-552
> >>> does not work properly under Vista. I have not been able to get a
> >>> correct driver install under Vista, driver update is clueless and
> >>> Vista
> >>> update is equally clueless as is software from Dlink.

>
> >>> How do I manually install vwifibus.sys for my DWA-552 under Vista?-
> >>> Hide quoted text -

>
> - Show quoted text -


I'm in the same boat as the OP. I've researched your recipe. The
driver package from Dlink does not contain the vital driver
vwifibus.sys. I am posting from Windows 7 using a DWA552 to connect to
the internet.

I cannot get my DWA552 to work reliably in Vista, like it does in
Windows 7 because I cannot find a way to manually install
vwifibus.sys. Dlink only provides athrx.sys

I think you guys are running around in cicles because you did not take
the OP seriously.

I'll check back in a week to see if you guys can find a solution.

Reply With Quote
  #7 (permalink)  
Old 02-11-2009
Pavel A.
 

Posts: n/a
Re: Dlink DWA-552 under Windows 7 - 64-bit
The vwifibus.sys is a new component of Win7 (provided by MS,
not present in Vista).
So Atheros is not responsible for this file and can't provide it for
other OS. But they are known to make pretty good drivers and have enough
"gurus" to sort this out (-_-)

-- pa


Administrator wrote:
> What the software "gurus" are talking about is a low quality solution
> for newbies that does not work.
>
> To get to where they are talking about is even easier than they suggest.
> I uninstalled my DWA552 drivers and rebooted. Like magic, a DWA552
> driver was installed, athrx.sys; I did not need to do a manual install
> of this driver.
>
> Here are the details for this driver prior to driver update:
>
> Provider: Atheros Communications Inc.
>
> File version: 7.6.1.204 build by WinDDK
>
> But there is still no vwifibus.sys
>
> I'm not even going to bother with driver update because it is pointless
> unless vwifibus.sys is provided.
>
> I'm posting from my Vista-32 partition.
>
> The internet connection is low bandwidth and unreliable. It craps out
> under high bandwidth demands and it craps out on its own within a few
> minutes just idle.
>
> Windows 7 with both athrx.sys and vwifibus.sys, provides rock solid high
> bandwidth internet connectivity.
>
> The problem is that Windows 7 is a piece of crap which is to be expected
> of beta software.
>
> When is some software "guru" going to migrate the DWA552 solution from
> Windows 7 to Vista?
>
>
> <aprentice@hushmail.com> wrote in message
> news:dd7fe45f-52dd-441e-812e-b185e0cafeeb@l33g2000pri.googlegroups.com...
> On Feb 9, 4:41 am, "David Vair" <dv...@nycap.rr.com> wrote:
>> Dowload the zip file from D-Link that contains the driver, just unzip
>> it do
>> not run the setup program. If you installed the D-Link Network Manager
>> before, uninstall it from the control panel. After all of this is
>> done, go
>> to the Device Manager, select your DWA-522, right click and select update
>> drivers. Select that you want to udpdate drivers manually and point it to
>> the drivers in the unzipped folder. Then let Windows Manage the Wireless
>> Connection.
>>
>> --
>> David Vair
>> CNE, CNA, MCP, A+, N+
>>
>> "Administrator" <Ji...@aol.com> wrote in message
>>
>> news:4xPjl.4334$_A2.2126@newsfe22.iad...
>>
>>
>>
>> > Can you not read, moron? Go back and read what I said, creep.

>>
>> > "Tyro" <T...@Tyros.com> wrote in message
>> >news:YuNjl.4198$%54.1650@nlpi070.nbdc.sbc.com.. .
>> >> Download it from Dlink and install.

>>
>> >> Tyro

>>
>> >> "Administrator" <Ji...@aol.com> wrote in message
>> >>newslNjl.4593$5B.2566@newsfe20.iad...
>> >>> Hi,

>>
>> >>> I've been having software driver problems with my Dlink DWA-552 under
>> >>> Vista. When I booted my Windows 7 64-bit partition, Windows >>>

>> effortlessly
>> >>> installed the correct driver set and I have no problems.

>>
>> >>> I looked into this magic a bit further and discovered that Windows

>> 7 >>> had
>> >>> installed two drivers for my DWA-552, both from system32/drivers:

>>
>> >>> athrx.sys by Atheros and

>>
>> >>> vwifibus.sys by Microsoft.

>>
>> >>> Under Vista only athrx.sys is installed, which explains why my

>> DWA-552
>> >>> does not work properly under Vista. I have not been able to get a
>> >>> correct driver install under Vista, driver update is clueless and
>> >>> Vista
>> >>> update is equally clueless as is software from Dlink.

>>
>> >>> How do I manually install vwifibus.sys for my DWA-552 under

>> Vista?- >>> Hide quoted text -
>>
>> - Show quoted text -

>
> I'm in the same boat as the OP. I've researched your recipe. The
> driver package from Dlink does not contain the vital driver
> vwifibus.sys. I am posting from Windows 7 using a DWA552 to connect to
> the internet.
>
> I cannot get my DWA552 to work reliably in Vista, like it does in
> Windows 7 because I cannot find a way to manually install
> vwifibus.sys. Dlink only provides athrx.sys
>
> I think you guys are running around in cicles because you did not take
> the OP seriously.
>
> I'll check back in a week to see if you guys can find a solution.

Reply With Quote
  #8 (permalink)  
Old 02-12-2009
prochemica@hushmail.com
 

Posts: n/a
Re: Dlink DWA-552 under Windows 7 - 64-bit
On Feb 11, 6:56*am, "Pavel A." <pave...@NOfastmailNO.fm> wrote:
> The vwifibus.sys is a new component of Win7 (provided by MS,
> not present in Vista).
> So Atheros is not responsible for this file and can't provide it for
> other OS. But they are known to make pretty good drivers and have enough
> "gurus" to sort this out (-_-)
>
> -- pa
>
>
>
> Administrator wrote:
> > What the software "gurus" are talking about is a low quality solution
> > for newbies that does not work.

>
> > To get to where they are talking about is even easier than they suggest..
> > I uninstalled my DWA552 drivers and rebooted. Like magic, a DWA552
> > driver was installed, athrx.sys; I did not need to do a manual install
> > of this driver.

>
> > Here are the details for this driver prior to driver update:

>
> > Provider: Atheros Communications Inc.

>
> > File version: 7.6.1.204 build by WinDDK

>
> > But there is still no vwifibus.sys

>
> > I'm not even going to bother with driver update because it is pointless
> > unless vwifibus.sys is provided.

>
> > I'm posting from my Vista-32 partition.

>
> > The internet connection is low bandwidth and unreliable. It craps out
> > under high bandwidth demands and it craps out on its own within a few
> > minutes just idle.

>
> > Windows 7 with both athrx.sys and vwifibus.sys, provides rock solid high
> > bandwidth internet connectivity.

>
> > The problem is that Windows 7 is a piece of crap which is to be expected
> > of beta software.

>
> > When is some software "guru" going to migrate the DWA552 solution from
> > Windows 7 to Vista?

>
> > <aprent...@hushmail.com> wrote in message
> >news:dd7fe45f-52dd-441e-812e-b185e0cafeeb@l33g2000pri.googlegroups.com....
> > On Feb 9, 4:41 am, "David Vair" <dv...@nycap.rr.com> wrote:
> >> Dowload the zip file from D-Link that contains the driver, just unzip
> >> it do
> >> not run the setup program. If you installed the D-Link Network Manager
> >> before, uninstall it from the control panel. After all of this is
> >> done, go
> >> to the Device Manager, select your DWA-522, right click and select update
> >> drivers. Select that you want to udpdate drivers manually and point itto
> >> the drivers in the unzipped folder. Then let Windows Manage the Wireless
> >> Connection.

>
> >> --
> >> David Vair
> >> CNE, CNA, MCP, A+, N+

>
> >> "Administrator" <Ji...@aol.com> wrote in message

>
> >>news:4xPjl.4334$_A2.2126@newsfe22.iad...

>
> >> > Can you not read, moron? Go back and read what I said, creep.

>
> >> > "Tyro" <T...@Tyros.com> wrote in message
> >> >news:YuNjl.4198$%54.1650@nlpi070.nbdc.sbc.com.. .
> >> >> Download it from Dlink and install.

>
> >> >> Tyro

>
> >> >> "Administrator" <Ji...@aol.com> wrote in message
> >> >>newslNjl.4593$5B.2566@newsfe20.iad...
> >> >>> Hi,

>
> >> >>> I've been having software driver problems with my Dlink DWA-552 under
> >> >>> Vista. When I booted my Windows 7 64-bit partition, Windows >>>
> >> effortlessly
> >> >>> installed the correct driver set and I have no problems.

>
> >> >>> I looked into this magic a bit further and discovered that Windows
> >> 7 >>> had
> >> >>> installed two drivers for my DWA-552, both from system32/drivers:

>
> >> >>> athrx.sys by Atheros and

>
> >> >>> vwifibus.sys by Microsoft.

>
> >> >>> Under Vista only athrx.sys is installed, which explains why my
> >> DWA-552
> >> >>> does not work properly under Vista. I have not been able to get a
> >> >>> correct driver install under Vista, driver update is clueless and
> >> >>> Vista
> >> >>> update is equally clueless as is software from Dlink.

>
> >> >>> How do I manually install vwifibus.sys for my DWA-552 under
> >> Vista?- >>> Hide quoted text -

>
> >> - Show quoted text -

>
> > I'm in the same boat as the OP. I've researched your recipe. The
> > driver package from Dlink does not contain the vital driver
> > vwifibus.sys. I am posting from Windows 7 using a DWA552 to connect to
> > the internet.

>
> > I cannot get my DWA552 to work reliably in Vista, like it does in
> > Windows 7 because I cannot find a way to manually install
> > vwifibus.sys. Dlink only provides athrx.sys

>
> > I think you guys are running around in cicles because you did not take
> > the OP seriously.

>
> > I'll check back in a week to see if you guys can find a solution.- Hidequoted text -

>
> - Show quoted text -


Thanks.

I can testify to the fact that vwifibus.sys is also not present in
Vista 64-bit and that the quality of wireless internet connectivity is
below professional standards.

I hope this problem is resolved because it interfers with my enjoyment
of internet TV.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dlink DWA-552 under Windows 7 - 64-bit Administrator microsoft.public.windows.vista.general 5 02-10-2009 02:29
Vista is not seeing my DI 624 DLink router dpbuettner Hardware Problems 1 01-03-2009 19:41
Dlink DI-524UP and HP Officejet 4355 with Windows Vista Ultimate admamy microsoft.public.windows.vista.print fax scan 0 06-09-2007 06:52
RE: Dlink DWL 520+ crashes windows Vista =?Utf-8?B?TGFyc0g=?= microsoft.public.windows.vista.networking sharing 1 12-12-2006 09:46
RE: Dlink DWL 520+ crashes windows Vista =?Utf-8?B?bWFkbWF4Nzc3?= microsoft.public.windows.vista.networking sharing 0 12-04-2006 07:36




All times are GMT +1. The time now is 06:19.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120