Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

WD external drive works with XP, not with Vista

microsoft.public.windows.vista hardware devices






Speedup My PC
Reply
  #1 (permalink)  
Old 01-07-2009
Andy G
 

Posts: n/a
WD external drive works with XP, not with Vista
I have a WD 250GB external hard drive, the MyBook. It works absolutely fine
on a HP laptop running XP, but on another HP laptop running Vista Basic does
not work properly. Symptoms as follows. Does not show in Explorer. Shows
in Device Manager and claims it's running properly, but shows no Volume
under the volumes tab. Shows in Computer Management, but no details and
cannot perform any operation on it, such as Change Drive Letter or Delete
and Create Volume. In Computer Management it shows as Disk 1, but has no
Drive Letter, and no status such as "Healthy".

Any help appreciated, I have no idea how to get the drive back again.

Andy G

Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 01-07-2009
Curious
 

Posts: n/a
Re: WD external drive works with XP, not with Vista
When I upgraded from XP to Vista I had to get Vista drivers for my MyBook
from the Western Digital Website.
"Andy G" <georgi66@otenet.gr> wrote in message
news:ekQJlpNcJHA.5092@TK2MSFTNGP02.phx.gbl...
>I have a WD 250GB external hard drive, the MyBook. It works absolutely
>fine on a HP laptop running XP, but on another HP laptop running Vista
>Basic does not work properly. Symptoms as follows. Does not show in
>Explorer. Shows in Device Manager and claims it's running properly, but
>shows no Volume under the volumes tab. Shows in Computer Management, but
>no details and cannot perform any operation on it, such as Change Drive
>Letter or Delete and Create Volume. In Computer Management it shows as
>Disk 1, but has no Drive Letter, and no status such as "Healthy".
>
> Any help appreciated, I have no idea how to get the drive back again.
>
> Andy G


Reply With Quote
  #3 (permalink)  
Old 01-08-2009
Andy G
 

Posts: n/a
Re: WD external drive works with XP, not with Vista
Thanks for the suggestion but I already checked the WD website. There are
no Vista drivers for my particular model. There are about a dozen different
MyBook models. Mine is the "Essential".


"Curious" <mailmenot@nomail.com> wrote in message
news:%23Mvav5OcJHA.4664@TK2MSFTNGP06.phx.gbl...
> When I upgraded from XP to Vista I had to get Vista drivers for my MyBook
> from the Western Digital Website.
> "Andy G" <georgi66@otenet.gr> wrote in message
> news:ekQJlpNcJHA.5092@TK2MSFTNGP02.phx.gbl...
>>I have a WD 250GB external hard drive, the MyBook. It works absolutely
>>fine on a HP laptop running XP, but on another HP laptop running Vista
>>Basic does not work properly. Symptoms as follows. Does not show in
>>Explorer. Shows in Device Manager and claims it's running properly, but
>>shows no Volume under the volumes tab. Shows in Computer Management, but
>>no details and cannot perform any operation on it, such as Change Drive
>>Letter or Delete and Create Volume. In Computer Management it shows as
>>Disk 1, but has no Drive Letter, and no status such as "Healthy".
>>
>> Any help appreciated, I have no idea how to get the drive back again.
>>
>> Andy G

>


Reply With Quote
  #4 (permalink)  
Old 01-08-2009
GTS
 

Posts: n/a
Re: WD external drive works with XP, not with Vista
Here are 2 items to try -

1. Delete the file c:\windows\inf\infcache.1

2. Check that the DevicePath registry key is present in
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion
and that it's value includes '%SystemRoot%\System32'
--

"Andy G" <georgi66@otenet.gr> wrote in message
news:ekQJlpNcJHA.5092@TK2MSFTNGP02.phx.gbl...
>I have a WD 250GB external hard drive, the MyBook. It works absolutely
>fine on a HP laptop running XP, but on another HP laptop running Vista
>Basic does not work properly. Symptoms as follows. Does not show in
>Explorer. Shows in Device Manager and claims it's running properly, but
>shows no Volume under the volumes tab. Shows in Computer Management, but
>no details and cannot perform any operation on it, such as Change Drive
>Letter or Delete and Create Volume. In Computer Management it shows as
>Disk 1, but has no Drive Letter, and no status such as "Healthy".
>
> Any help appreciated, I have no idea how to get the drive back again.
>
> Andy G


Reply With Quote
  #5 (permalink)  
Old 01-08-2009
Andy G
 

Posts: n/a
Re: WD external drive works with XP, not with Vista
Many thanks for that suggestion. Things are better but still something not
right!

I can now see the drive in Explorer under "Computer", but it's shown as a
Removable Disk and claims to have no media.... So if I right click on it
and try to Open or Format, system tells me there is no disk and to insert
one...

In Computer Management things have changed a bit too. The drive now seems
to have two listings in the lower half of the window. It is shown as Disk 1
(Removable G, No Media. To the right there is no information.

Secondly it is listed as Disk 2, Basic, 232 Gb, Online. To the right there
is the blue bar that denotes a primary partition and below a hatched block
showing the size, 232 Gb. Again I cannot perform any operations on it in
Disk management which gives a variety of obscure error messages when I try
to format or change drive letter.

None of this means much to me but I'm hoping something might ring a bell
with you? Any help much appreciated.

Andy G.



"GTS" <x@y.net> wrote in message
news:%233AZ6kacJHA.1528@TK2MSFTNGP03.phx.gbl...
> Here are 2 items to try -
>
> 1. Delete the file c:\windows\inf\infcache.1
>
> 2. Check that the DevicePath registry key is present in
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion
> and that it's value includes '%SystemRoot%\System32'
> --
>
> "Andy G" <georgi66@otenet.gr> wrote in message
> news:ekQJlpNcJHA.5092@TK2MSFTNGP02.phx.gbl...
>>I have a WD 250GB external hard drive, the MyBook. It works absolutely
>>fine on a HP laptop running XP, but on another HP laptop running Vista
>>Basic does not work properly. Symptoms as follows. Does not show in
>>Explorer. Shows in Device Manager and claims it's running properly, but
>>shows no Volume under the volumes tab. Shows in Computer Management, but
>>no details and cannot perform any operation on it, such as Change Drive
>>Letter or Delete and Create Volume. In Computer Management it shows as
>>Disk 1, but has no Drive Letter, and no status such as "Healthy".
>>
>> Any help appreciated, I have no idea how to get the drive back again.
>>
>> Andy G

>


Reply With Quote
  #6 (permalink)  
Old 01-08-2009
Steve Pearce
 

Posts: n/a
Re: WD external drive works with XP, not with Vista
On Thu, 8 Jan 2009 18:53:29 +0200, "Andy G" <georgi66@otenet.gr>
wrote:

>In Computer Management things have changed a bit too. The drive now seems
>to have two listings in the lower half of the window. It is shown as Disk 1
>(Removable G, No Media. To the right there is no information.


If you right click on the leftmost section (where is says "Disk 0",
"Disk 1" etc) and select properties and then select the "Volumes" tab;
what does it say the "Partition style" is?

I had a flaash drive that act in a similar way and I couldn't use it
in Vista at all, however Windows XP had no problems with it. This was
because the "Partition style" was "GUID Partition Table". When I
reformatted it in XP, it changed to "Master Boot Record(MBR)" and
Vista was then able to use it.
Reply With Quote
  #7 (permalink)  
Old 01-08-2009
GTS
 

Posts: n/a
Re: WD external drive works with XP, not with Vista
You're welcome. I suggest you now delete both partitions (Volumes), create
a new partition and then format it. I think you can probably do it all in
Vista, but if any problem, delete them on the XP machine.
--

"Andy G" <georgi66@otenet.gr> wrote in message
news:OhkskGbcJHA.3708@TK2MSFTNGP06.phx.gbl...
> Many thanks for that suggestion. Things are better but still something
> not right!
>
> I can now see the drive in Explorer under "Computer", but it's shown as a
> Removable Disk and claims to have no media.... So if I right click on it
> and try to Open or Format, system tells me there is no disk and to insert
> one...
>
> In Computer Management things have changed a bit too. The drive now seems
> to have two listings in the lower half of the window. It is shown as Disk
> 1 (Removable G, No Media. To the right there is no information.
>
> Secondly it is listed as Disk 2, Basic, 232 Gb, Online. To the right
> there is the blue bar that denotes a primary partition and below a hatched
> block showing the size, 232 Gb. Again I cannot perform any operations on
> it in Disk management which gives a variety of obscure error messages when
> I try to format or change drive letter.
>
> None of this means much to me but I'm hoping something might ring a bell
> with you? Any help much appreciated.
>
> Andy G.
>
>
>
> "GTS" <x@y.net> wrote in message
> news:%233AZ6kacJHA.1528@TK2MSFTNGP03.phx.gbl...
>> Here are 2 items to try -
>>
>> 1. Delete the file c:\windows\inf\infcache.1
>>
>> 2. Check that the DevicePath registry key is present in
>> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion
>> and that it's value includes '%SystemRoot%\System32'
>> --
>>
>> "Andy G" <georgi66@otenet.gr> wrote in message
>> news:ekQJlpNcJHA.5092@TK2MSFTNGP02.phx.gbl...
>>>I have a WD 250GB external hard drive, the MyBook. It works absolutely
>>>fine on a HP laptop running XP, but on another HP laptop running Vista
>>>Basic does not work properly. Symptoms as follows. Does not show in
>>>Explorer. Shows in Device Manager and claims it's running properly, but
>>>shows no Volume under the volumes tab. Shows in Computer Management, but
>>>no details and cannot perform any operation on it, such as Change Drive
>>>Letter or Delete and Create Volume. In Computer Management it shows as
>>>Disk 1, but has no Drive Letter, and no status such as "Healthy".
>>>
>>> Any help appreciated, I have no idea how to get the drive back again.
>>>
>>> Andy G

>>

>


Reply With Quote
  #8 (permalink)  
Old 01-08-2009
David Vair
 

Posts: n/a
Re: WD external drive works with XP, not with Vista
If it was formatted with NTFS there may be some ownership issues. Google
taking ownership of a drive and there are several step by step walkthroughs
to show how to take ownership of the drive.

--
David Vair
CNE, CNA, MCP, A+, N+



"Andy G" <georgi66@otenet.gr> wrote in message
news:OhkskGbcJHA.3708@TK2MSFTNGP06.phx.gbl...
> Many thanks for that suggestion. Things are better but still something
> not right!
>
> I can now see the drive in Explorer under "Computer", but it's shown as a
> Removable Disk and claims to have no media.... So if I right click on it
> and try to Open or Format, system tells me there is no disk and to insert
> one...
>
> In Computer Management things have changed a bit too. The drive now seems
> to have two listings in the lower half of the window. It is shown as Disk
> 1 (Removable G, No Media. To the right there is no information.
>
> Secondly it is listed as Disk 2, Basic, 232 Gb, Online. To the right
> there is the blue bar that denotes a primary partition and below a hatched
> block showing the size, 232 Gb. Again I cannot perform any operations on
> it in Disk management which gives a variety of obscure error messages when
> I try to format or change drive letter.
>
> None of this means much to me but I'm hoping something might ring a bell
> with you? Any help much appreciated.
>
> Andy G.
>
>
>
> "GTS" <x@y.net> wrote in message
> news:%233AZ6kacJHA.1528@TK2MSFTNGP03.phx.gbl...
>> Here are 2 items to try -
>>
>> 1. Delete the file c:\windows\inf\infcache.1
>>
>> 2. Check that the DevicePath registry key is present in
>> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion
>> and that it's value includes '%SystemRoot%\System32'
>> --
>>
>> "Andy G" <georgi66@otenet.gr> wrote in message
>> news:ekQJlpNcJHA.5092@TK2MSFTNGP02.phx.gbl...
>>>I have a WD 250GB external hard drive, the MyBook. It works absolutely
>>>fine on a HP laptop running XP, but on another HP laptop running Vista
>>>Basic does not work properly. Symptoms as follows. Does not show in
>>>Explorer. Shows in Device Manager and claims it's running properly, but
>>>shows no Volume under the volumes tab. Shows in Computer Management, but
>>>no details and cannot perform any operation on it, such as Change Drive
>>>Letter or Delete and Create Volume. In Computer Management it shows as
>>>Disk 1, but has no Drive Letter, and no status such as "Healthy".
>>>
>>> Any help appreciated, I have no idea how to get the drive back again.
>>>
>>> Andy G

>>

>


Reply With Quote
  #9 (permalink)  
Old 01-09-2009
Andy G
 

Posts: n/a
Re: WD external drive works with XP, not with Vista
Cheers Steve, but the Partition Style is already set to "MBR". At least I
now know you can right click on the left section!

Andy G


"Steve Pearce" <*stevepearce@btinternet.com*> wrote in message
news:qrecm49t8dh1cosddpo72ngacu3l36llp2@4ax.com...
> On Thu, 8 Jan 2009 18:53:29 +0200, "Andy G" <georgi66@otenet.gr>
> wrote:
>
>>In Computer Management things have changed a bit too. The drive now seems
>>to have two listings in the lower half of the window. It is shown as Disk
>>1
>>(Removable G, No Media. To the right there is no information.

>
> If you right click on the leftmost section (where is says "Disk 0",
> "Disk 1" etc) and select properties and then select the "Volumes" tab;
> what does it say the "Partition style" is?
>
> I had a flaash drive that act in a similar way and I couldn't use it
> in Vista at all, however Windows XP had no problems with it. This was
> because the "Partition style" was "GUID Partition Table". When I
> reformatted it in XP, it changed to "Master Boot Record(MBR)" and
> Vista was then able to use it.


Reply With Quote
  #10 (permalink)  
Old 01-09-2009
Andy G
 

Posts: n/a
Re: WD external drive works with XP, not with Vista
AAArgh. Prior to getting your latest post, I powered off the external
drive, ejected it, and rebooted the PC. When I reconnected the drive I'm
back to where I was before, it no longer shows in Computer and disk
management only shows one disk!!!!

Does this suggest anything to you?

I've tried deleting the volume in disk management, although it looks to me
like no actual volume is being recognised as it does not show in the list at
the top of the Disk Management window. After churning away for a while it
comes back with a message about "Cannot complete operation as Disk
Management Console is not up to date".

None of the actions it suggests achieve anything.

Andy G.



"GTS" <x@y.net> wrote in message
news:u8GB10ccJHA.5092@TK2MSFTNGP02.phx.gbl...
> You're welcome. I suggest you now delete both partitions (Volumes),
> create a new partition and then format it. I think you can probably do it
> all in Vista, but if any problem, delete them on the XP machine.


Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't access broken Vista OS drive as an external drive on XP mynameisstolen microsoft.public.windows.vista hardware devices 8 08-27-2008 13:01
Can't access external drive on XP - previous Vista Boot Drive mariaceleste358@gmail.com microsoft.public.windows.vista.general 4 08-22-2008 17:29
External Hard Drive works with USB but not Firewire TargetPractice31785 microsoft.public.windows.vista hardware devices 3 10-15-2007 17:37
Converting my external USB FAT external hard drive to NFTS =?Utf-8?B?bGFkeW1zdmVl?= microsoft.public.windows.vista hardware devices 2 02-22-2007 07:25




All times are GMT +1. The time now is 16:00.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120