Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Portable Hard Drive Problems

microsoft.public.windows.vista hardware devices






Speedup My PC
Reply
  #1 (permalink)  
Old 05-23-2008
Dre Carter
 

Posts: n/a
Portable Hard Drive Problems
ok so i will try again and try and get a response.

i have 3 portable hard drives:
a WD My Book
a Vantec
and a Noontec

all 3 are Sata to USB drives.

everytime i install one i get a:

"The drivers for this device are not installed. (Code 28)

A service installation section in this INF is invalid."

now these are plug and play for xp, but why not for vista? am i missing a
driver? because every time i install one i get the above message. what makes
it worse is that as far as i can tell is that there are no drivers for these
drives as they are plug and play! :P as you can see this is doing my head in.

I have always had problems with these drives and now that my desktop
computer (running XP which never had problems) has died, i can't get them to
run!

i am currently running Vista Home Premium (32 bit) with 1 gig of ram.


HELP
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 05-23-2008
propman
 

Posts: n/a
Re: Portable Hard Drive Problems
Dre Carter wrote:
> ok so i will try again and try and get a response.
>
> i have 3 portable hard drives:
> a WD My Book
> a Vantec
> and a Noontec
>
> all 3 are Sata to USB drives.
>
> everytime i install one i get a:
>
> "The drivers for this device are not installed. (Code 28)
>
> A service installation section in this INF is invalid."
>
> now these are plug and play for xp, but why not for vista? am i missing a
> driver? because every time i install one i get the above message. what makes
> it worse is that as far as i can tell is that there are no drivers for these
> drives as they are plug and play! :P as you can see this is doing my head in.



Even though it's "plug 'n play" the applicable usb drivers for each unit
that is hooked up to a system must be present and installed properly.
Now as you state you have no drivers for the harddrive units but Vista
should come with either generic USB drivers or specific drivers from the
manufacturer. I would suspect that Vista is trying to install the
drivers (from it's collection of usb drivers on your system hard drive)
when you hook up the external units....it's reading the INF file to see
what drivers are needed but it can't get past a certain section in the
INF due to an error....therefore it barfs and generates the error
message you are seeing.


>
> I have always had problems with these drives


Typo???


and now that my desktop
> computer (running XP which never had problems) has died, i can't get them to
> run!
>



Here's a similar situation to yours which I think maybe applicable to
solving your problem.


<quote on>

I could fix this problem
by tushar43 - 6/20/07 12:00 PM
In reply to: A service installation section in the INF is invalid by
Richard N

I had similar problem while installing USB network device on my machine
with windows XP. I was getting same error "a service installation
section in this inf is invalid"

What i did was i opened the .inf driver file, went to "XP" section of
the driver skipping 98,ME, 2000 portions and then saw a line
"ServiceBinary = %12%\usb8023.sys" when i went to
windows\system32\drivers folder, i saw that there was an existing file
usb8023x.sys so i replaced the line in the .inf driver file which i had
(of course backed up original one) and changed the line to usb8023x.sys
from usb8023.sys and then tried providing the same driver again and
Wooohaaa.. it worked. Right now my devices works awesome.

This is 100% working fix, let me know if it works for you which i am
sure will.

Reply
Permalink
Report offensive post
Post 5 of 9
woked for my issue - "service installation section invalid"
by destoo - 7/1/07 5:38 PM
In reply to: I could fix this problem by tushar43

Worked for me.
I'm using a "stripped to the bone" version of XP Pro, and it's been
happening on my camera driver. (Kodak C633 Easyshare)
It was looking for usbscan.sys.
I had copied it to the /system32/ folder, but the %12% stands for
/system32/drivers

worked like a charm. (for my problem. Thanks!)

Reply
Permalink
Report offensive post
Post 6 of 9
How do I open the .inf file for the driver
by tstewar - 1/28/08 10:48 AM
In reply to: I could fix this problem by tushar43

How do I open the .inf file for the driver?

Reply
Permalink
Report offensive post
Post 7 of 9
Open .inf file
by onzey - 2/2/08 2:04 PM
In reply to: How do I open the .inf file for the driver by tstewar

Right click on the file and then click Open.

Reply
Permalink
Report offensive post


<quote off>


Reply With Quote
  #3 (permalink)  
Old 06-26-2008
pjay24
 

Posts: n/a
Re: Portable Hard Drive Problems
I have same problems as Dre Carter with Vista Home Premium, service pack 1.
> > "The drivers for this device are not installed. (Code 28)
> > A service installation section in this INF is invalid."


Seems that I too am unable to Install my new external hard drive SimpleDrive
SP-U35/320, or for that matter run kodak easy share camera, or mp3) thru
computer USB 2.0 ports. VIsta says I need to update drivers, but nothing
will update or download (even with disk in DVD drive).

I read thru thread and suggested fixes are referenced for XP, but not for
Vista. Are fixes any different for Vista? Seems that Vista does not have
explorer as earlier Window OPS, so how do I go about finding related .inf
files in Vista?
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Driver to install portable hard drive No longer like vista microsoft.public.windows.vista hardware devices 8 01-05-2008 22:02
New hard drive problems Craig008 microsoft.public.windows.vista hardware devices 6 11-09-2007 20:47
Security World: New Fujitsu secure 300GB 2.5" portable external hard disk drive Steve Security News 0 07-02-2007 22:16
Hard Drive Problems. Jay In Denver microsoft.public.windows.vista hardware devices 4 05-31-2007 17:22
Security World: iQBioDrive portable biometric hard drive with CryptoLokr AES 256 bit Steve Security News 0 03-12-2007 23:39




All times are GMT +1. The time now is 07:07.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120