Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

nVidia nForce Realtek audio SPDIF is not detected or working

microsoft.public.windows.vista hardware devices






Speedup My PC
Reply
  #1 (permalink)  
Old 03-05-2007
=?Utf-8?B?TmVyZEJyaWNr?=
 

Posts: n/a
nVidia nForce Realtek audio SPDIF is not detected or working
I have a nForce4 GA-K8NF-9 motherboard with a built in Realtek audio.

The trouble is it worked fine with MCE 2005, but when I moved to Vista the
SPDIF is no longer functional. I have audio, but only 2 channel through the
regular audio jack. I have looked all the settings in the Gigabyte UI that
Vista installed, and the Speaker control panel, but nothing allows me to turn
on the SPDIF jack.

I went to the Realtek site to get new drivers, but Vista didn't want to
install them because it said I already had current audio drivers.

Any help?
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 03-05-2007
Cari \(MS-MVP\)
 

Posts: n/a
Re: nVidia nForce Realtek audio SPDIF is not detected or working
Do you have the latest nForce drivers from the www.nvidia.com website?
--
Cari (MS-MVP)
Windows Technologies - Printing & Imaging
http://www.coribright.com/windows

"NerdBrick" <NerdBrick@discussions.microsoft.com> wrote in message
news:F2F45065-E097-434C-9BE9-657979308B1B@microsoft.com...
>I have a nForce4 GA-K8NF-9 motherboard with a built in Realtek audio.
>
> The trouble is it worked fine with MCE 2005, but when I moved to Vista the
> SPDIF is no longer functional. I have audio, but only 2 channel through
> the
> regular audio jack. I have looked all the settings in the Gigabyte UI that
> Vista installed, and the Speaker control panel, but nothing allows me to
> turn
> on the SPDIF jack.
>
> I went to the Realtek site to get new drivers, but Vista didn't want to
> install them because it said I already had current audio drivers.
>
> Any help?


Reply With Quote
  #3 (permalink)  
Old 03-06-2007
=?Utf-8?B?TmVyZEJyaWNr?=
 

Posts: n/a
Re: nVidia nForce Realtek audio SPDIF is not detected or working
I just got it to work by installing the latest RealTek drivers.

Now I'm trying to figure out why my external USB HD is no longer being
detected after getting the S/PDIF working.

Arg!


"Cari (MS-MVP)" wrote:

> Do you have the latest nForce drivers from the www.nvidia.com website?
> --
> Cari (MS-MVP)
> Windows Technologies - Printing & Imaging
> http://www.coribright.com/windows
>
> "NerdBrick" <NerdBrick@discussions.microsoft.com> wrote in message
> news:F2F45065-E097-434C-9BE9-657979308B1B@microsoft.com...
> >I have a nForce4 GA-K8NF-9 motherboard with a built in Realtek audio.
> >
> > The trouble is it worked fine with MCE 2005, but when I moved to Vista the
> > SPDIF is no longer functional. I have audio, but only 2 channel through
> > the
> > regular audio jack. I have looked all the settings in the Gigabyte UI that
> > Vista installed, and the Speaker control panel, but nothing allows me to
> > turn
> > on the SPDIF jack.
> >
> > I went to the Realtek site to get new drivers, but Vista didn't want to
> > install them because it said I already had current audio drivers.
> >
> > Any help?

>
>

Reply With Quote
  #4 (permalink)  
Old 04-02-2007
ssuper2k
 

Posts: n/a
Re: nVidia nForce Realtek audio SPDIF is not detected or working

I HAVE SENT THIS EMAIL TO REALTEK with NO LUCK yet:
> Hello, I'm writing to all of you because I don't know exactly who to
> contact...
>
> Firstly, I should tell you that I have an Asus MoBo with a realtek
> sound chip that includes both s/pdif (s) coaxial+optical outputs...
>
> I've always connected my external amplifier throught the optical to get
> pure digital sound...
>
> With Windows XP, it works flawlesly, once I select S/Pdif output on the
> correcponding application.. my amplifier then detects either DTS/Dolby
> or whatever...
>
> The problem is with Windows Vista(32b), I am not able to get it work
> properly, I've tried it a lot of times, several versions of drivers,
> with same results:
> I get only Stereo S/Pdif output..
>
> The most important clue for me is that PowerDVD 7.3 does NOT detect my
> S/Pdif output (under XP it does)
>
> I've selected my speakers as SPDIF, and 5.1... (the latest driver adds
> a new digital output)and the test does OK througt DTS/Dolby5.1 test,
> using all 6 speakers...
>
> But when I test usung the realtek application it only uses 2
> speakers...
>
> I use the computer to play digital media (as MKV videos) with digital
> audio tracks, usualy configuring AC3 filter to use SPDIF as
> well..working fine on XP...playing it with any kind of media player, as
> Windows Media player or VLC or any other..
>
> So I'm pretty sure I'm doing right but still not able to get 5.1 soung
> through any media player under Windows Vista..
>
> I just would like to know if I am wasting my time, or else is/will be
> it posible under Vista...
>
> By the way, if it were relevant, my mobo is A8V Deluxe, CPU 4600+, and
> 2GB ram, so It runs Vista pretty fast..
>
> I hope I can get an answer soon or else I'm going crazy..
>
>
> Thanks in advance.
>
>
> Regards, ssuper2k.
>



--
ssuper2k
------------------------------------------------------------------------
ssuper2k's Profile: http://forums.techarena.in/member.php?userid=24159
View this thread: http://forums.techarena.in/showthread.php?t=698473

http://forums.techarena.in

Reply With Quote
  #5 (permalink)  
Old 04-02-2007
=?Utf-8?B?TmVyZEJyaWNr?=
 

Posts: n/a
Re: nVidia nForce Realtek audio SPDIF is not detected or working
Thank you.

I think many of my problems were trying to run Vista64, so I moved back to
Vista32. The most recet RelTek driver got my SPDIF working, and I see I can
have regular audio out or SDIF out; however, you can't have both active. When
I was running XP Media Center I was able to have both active so I can rout my
audio out on the back panel to different devices in my rack. Now I have to
make as choice which device I want to use.

Is this a bug or a feature that you can only choose one type of output?

"ssuper2k" wrote:

>
> I HAVE SENT THIS EMAIL TO REALTEK with NO LUCK yet:
> > Hello, I'm writing to all of you because I don't know exactly who to
> > contact...
> >
> > Firstly, I should tell you that I have an Asus MoBo with a realtek
> > sound chip that includes both s/pdif (s) coaxial+optical outputs...
> >
> > I've always connected my external amplifier throught the optical to get
> > pure digital sound...
> >
> > With Windows XP, it works flawlesly, once I select S/Pdif output on the
> > correcponding application.. my amplifier then detects either DTS/Dolby
> > or whatever...
> >
> > The problem is with Windows Vista(32b), I am not able to get it work
> > properly, I've tried it a lot of times, several versions of drivers,
> > with same results:
> > I get only Stereo S/Pdif output..
> >
> > The most important clue for me is that PowerDVD 7.3 does NOT detect my
> > S/Pdif output (under XP it does)
> >
> > I've selected my speakers as SPDIF, and 5.1... (the latest driver adds
> > a new digital output)and the test does OK througt DTS/Dolby5.1 test,
> > using all 6 speakers...
> >
> > But when I test usung the realtek application it only uses 2
> > speakers...
> >
> > I use the computer to play digital media (as MKV videos) with digital
> > audio tracks, usualy configuring AC3 filter to use SPDIF as
> > well..working fine on XP...playing it with any kind of media player, as
> > Windows Media player or VLC or any other..
> >
> > So I'm pretty sure I'm doing right but still not able to get 5.1 soung
> > through any media player under Windows Vista..
> >
> > I just would like to know if I am wasting my time, or else is/will be
> > it posible under Vista...
> >
> > By the way, if it were relevant, my mobo is A8V Deluxe, CPU 4600+, and
> > 2GB ram, so It runs Vista pretty fast..
> >
> > I hope I can get an answer soon or else I'm going crazy..
> >
> >
> > Thanks in advance.
> >
> >
> > Regards, ssuper2k.
> >

>
>
> --
> ssuper2k
> ------------------------------------------------------------------------
> ssuper2k's Profile: http://forums.techarena.in/member.php?userid=24159
> View this thread: http://forums.techarena.in/showthread.php?t=698473
>
> http://forums.techarena.in
>
>

Reply With Quote
  #6 (permalink)  
Old 04-03-2007
ssuper2k
 

Posts: n/a
Re: nVidia nForce Realtek audio SPDIF is not detected or working

NerdBrick;2719106 Wrote:
>
> I think many of my problems were trying to run Vista64, so I moved back
> to
> Vista32. The most recet RelTek driver got my SPDIF working, and I see I
> can
> have regular audio out or SDIF out; however, you can't have both
> active. When
>
[/color]
I know Vista64 is 'special' with drivers, because of that I just tried
Vista32 on this box...
I know Vista very well since first betas, but may be there is a 32bit
driver that I didn't try yet... *Could you post here a link to that
driver please??* ... or else send a a mail to that...

Do you know if powerdvd detects your S/Pdif on vista32?


THANKS

ssuper2k [@] hotmail dot com


--
ssuper2k
------------------------------------------------------------------------
ssuper2k's Profile: http://forums.techarena.in/member.php?userid=24159
View this thread: http://forums.techarena.in/showthread.php?t=698473

http://forums.techarena.in

Reply With Quote
  #7 (permalink)  
Old 03-27-2009
vulcanda
 

Posts: n/a
Re: nVidia nForce Realtek audio SPDIF is not detected or working

This actually may not be a problem with Vista and the audio drivers. I
was having similar problems and through my reading I discovered that
Power DVD version 7.3 doesn't support multi-channel audio output via
HDMI. I know you are trying to use the SPDIF output and to be honest I
cant remember if the version 7.3 issue was multi-channel audio all
together or if it was just an HDMI issue. It is something you might
look into. I had to either upgrade to version 9 (version 9 ultra for
HDMI in fact) or look at using another player. I went with another
player (Arcsoft TotalMedia theater) and I have not had a problem since.


--
vulcanda
------------------------------------------------------------------------
vulcanda's Profile: http://forums.techarena.in/members/85673.htm
View this thread: http://forums.techarena.in/vista-har...ces/698473.htm

http://forums.techarena.in

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nforce Audio Drivers Vista edde microsoft.public.windows.vista.general 1 03-22-2007 21:36
Vista Ultimate + nForce 4 = Unacceptable Audio =?Utf-8?B?TmV3Ymll?= microsoft.public.windows.vista hardware devices 4 03-07-2007 19:31
nVidia nForce4 Realtek/Gigabyte SPDIF is not working in Vista. =?Utf-8?B?TmVyZEJyaWNr?= microsoft.public.windows.vista.general 2 03-05-2007 19:44
Realtek AC'97 audio driver provided by Microsoft. Audio error MCE =?Utf-8?B?R1Q=?= microsoft.public.windows.vista hardware devices 1 03-03-2007 22:54
Bug with Realtek ACL850 driver and nForce3 motherboard (SPDIF rela =?Utf-8?B?SmVhbi1DaHJpc3RvcGhl?= microsoft.public.windows.vista hardware devices 0 12-30-2006 09:50




All times are GMT +1. The time now is 22:36.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120