Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Two error messages upon boot - wlanapi.dll

microsoft.public.windows.vista hardware devices






Speedup My PC
Reply
  #1 (permalink)  
Old 01-09-2008
Sir James
 

Posts: n/a
Two error messages upon boot - wlanapi.dll
When Windows Vista Ultimate 32 bit loads to the desktop I am greeted by two
error messages.

"The proceedure entry point apsInitialize could not be located in the
dynamic link library wlanapi.dll"
"The proceedure entry point asSearchInterface could not be located in the
dynamic link library wlanapi.dll"

I have done a lot of research to solve this problem, however to little
avail. My wireless connection seems unaffected and still works normally. My
drivers are up to date. The dll does in fact exist under C:/Windows/System32.
After trying installing different drivers, and re-installing the network
device, I then attempted to register wlanapi.dll. When I used the command

Regsvr32 "C:\Windows\System32\wlanapi.dll"

I had this error message appear: "The module Regsvr32
"C:\Windows\System32\wlanapi.dll" was loaded but the entry-point
DllRegisterServer was not found. Make sure that Regsvr32
"C:\Windows\System32\wlanapi.dll" is a valid DLL or OCX file and then try
again."


I think that maybe wlanapi.dll is corrupt. If so, I am not sure how to
repair this on Windows Vista Ultimate 32 bit.

My wireless device is Dlink DWL-G510 Airplus G 2.4 GHZ.

If anyone could help me fix this issue, it would be greatly appreciated.
Thanks.
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 01-09-2008
Cal Bear '66
 

Posts: n/a
Re: Two error messages upon boot - wlanapi.dll
Did you try to register the dll from an "elevated" command prompt?

Type cmd in the Start Search box above the Start Orb. When cmd.exe appears at
the top of the Start Menu, right click on it and select "Run as Administrator",
and then run the registration command.


I Bleed Blue and Gold
GO BEARS!


"Sir James" <Sir James@discussions.microsoft.com> wrote in message
news0F0A557-1F7A-420E-9716-30C40DAFC5E1@microsoft.com...
> When Windows Vista Ultimate 32 bit loads to the desktop I am greeted by two
> error messages.
>
> "The proceedure entry point apsInitialize could not be located in the
> dynamic link library wlanapi.dll"
> "The proceedure entry point asSearchInterface could not be located in the
> dynamic link library wlanapi.dll"
>
> I have done a lot of research to solve this problem, however to little
> avail. My wireless connection seems unaffected and still works normally. My
> drivers are up to date. The dll does in fact exist under C:/Windows/System32.
> After trying installing different drivers, and re-installing the network
> device, I then attempted to register wlanapi.dll. When I used the command
>
> Regsvr32 "C:\Windows\System32\wlanapi.dll"
>
> I had this error message appear: "The module Regsvr32
> "C:\Windows\System32\wlanapi.dll" was loaded but the entry-point
> DllRegisterServer was not found. Make sure that Regsvr32
> "C:\Windows\System32\wlanapi.dll" is a valid DLL or OCX file and then try
> again."
>
>
> I think that maybe wlanapi.dll is corrupt. If so, I am not sure how to
> repair this on Windows Vista Ultimate 32 bit.
>
> My wireless device is Dlink DWL-G510 Airplus G 2.4 GHZ.
>
> If anyone could help me fix this issue, it would be greatly appreciated.
> Thanks.



Reply With Quote
  #3 (permalink)  
Old 01-09-2008
Sir James
 

Posts: n/a
Re: Two error messages upon boot - wlanapi.dll

Yes I just tried what you mentioned. But the same error appears.

"The module Regsvr32
"C:\Windows\System32\wlanapi.dll" was loaded but the entry-point
DllRegisterServer was not found. Make sure that Regsvr32
"C:\Windows\System32\wlanapi.dll" is a valid DLL or OCX file and then try
again."



"Cal Bear '66" wrote:

> Did you try to register the dll from an "elevated" command prompt?
>
> Type cmd in the Start Search box above the Start Orb. When cmd.exe appears at
> the top of the Start Menu, right click on it and select "Run as Administrator",
> and then run the registration command.
>
>
> I Bleed Blue and Gold
> GO BEARS!
>
>
> "Sir James" <Sir James@discussions.microsoft.com> wrote in message
> news0F0A557-1F7A-420E-9716-30C40DAFC5E1@microsoft.com...
> > When Windows Vista Ultimate 32 bit loads to the desktop I am greeted by two
> > error messages.
> >
> > "The proceedure entry point apsInitialize could not be located in the
> > dynamic link library wlanapi.dll"
> > "The proceedure entry point asSearchInterface could not be located in the
> > dynamic link library wlanapi.dll"
> >
> > I have done a lot of research to solve this problem, however to little
> > avail. My wireless connection seems unaffected and still works normally. My
> > drivers are up to date. The dll does in fact exist under C:/Windows/System32.
> > After trying installing different drivers, and re-installing the network
> > device, I then attempted to register wlanapi.dll. When I used the command
> >
> > Regsvr32 "C:\Windows\System32\wlanapi.dll"
> >
> > I had this error message appear: "The module Regsvr32
> > "C:\Windows\System32\wlanapi.dll" was loaded but the entry-point
> > DllRegisterServer was not found. Make sure that Regsvr32
> > "C:\Windows\System32\wlanapi.dll" is a valid DLL or OCX file and then try
> > again."
> >
> >
> > I think that maybe wlanapi.dll is corrupt. If so, I am not sure how to
> > repair this on Windows Vista Ultimate 32 bit.
> >
> > My wireless device is Dlink DWL-G510 Airplus G 2.4 GHZ.
> >
> > If anyone could help me fix this issue, it would be greatly appreciated.
> > Thanks.

>
>

Reply With Quote
  #4 (permalink)  
Old 04-13-2008
gerald1378
 

Posts: n/a
RE: Two error messages upon boot - wlanapi.dll
I have the same problem as u did below, but with windows xp. I did u fix
this problem, if so how? any help would be gratefull. Gearld
When Windows Vista Ultimate 32 bit loads to the desktop I am greeted by two
error messages.

"The proceedure entry point apsInitialize could not be located in the
dynamic link library wlanapi.dll"
"The proceedure entry point asSearchInterface could not be located in the
dynamic link library wlanapi.dll"

I have done a lot of research to solve this problem, however to little
avail. My wireless connection seems unaffected and still works normally. My
drivers are up to date. The dll does in fact exist under C:/Windows/System32.
After trying installing different drivers, and re-installing the network
device, I then attempted to register wlanapi.dll. When I used the command

Regsvr32 "C:\Windows\System32\wlanapi.dll"

I had this error message appear: "The module Regsvr32
"C:\Windows\System32\wlanapi.dll" was loaded but the entry-point
DllRegisterServer was not found. Make sure that Regsvr32
"C:\Windows\System32\wlanapi.dll" is a valid DLL or OCX file and then try
again."


I think that maybe wlanapi.dll is corrupt. If so, I am not sure how to
repair this on Windows Vista Ultimate 32 bit.

My wireless device is Dlink DWL-G510 Airplus G 2.4 GHZ.

If anyone could help me fix this issue, it would be greatly appreciated.
Thanks.
"Sir James" wrote:

> When Windows Vista Ultimate 32 bit loads to the desktop I am greeted by two
> error messages.
>
> "The proceedure entry point apsInitialize could not be located in the
> dynamic link library wlanapi.dll"
> "The proceedure entry point asSearchInterface could not be located in the
> dynamic link library wlanapi.dll"
>
> I have done a lot of research to solve this problem, however to little
> avail. My wireless connection seems unaffected and still works normally. My
> drivers are up to date. The dll does in fact exist under C:/Windows/System32.
> After trying installing different drivers, and re-installing the network
> device, I then attempted to register wlanapi.dll. When I used the command
>
> Regsvr32 "C:\Windows\System32\wlanapi.dll"
>
> I had this error message appear: "The module Regsvr32
> "C:\Windows\System32\wlanapi.dll" was loaded but the entry-point
> DllRegisterServer was not found. Make sure that Regsvr32
> "C:\Windows\System32\wlanapi.dll" is a valid DLL or OCX file and then try
> again."
>
>
> I think that maybe wlanapi.dll is corrupt. If so, I am not sure how to
> repair this on Windows Vista Ultimate 32 bit.
>
> My wireless device is Dlink DWL-G510 Airplus G 2.4 GHZ.
>
> If anyone could help me fix this issue, it would be greatly appreciated.
> Thanks.

Reply With Quote
  #5 (permalink)  
Old 04-13-2008
Sir James
 

Posts: n/a
RE: Two error messages upon boot - wlanapi.dll
I have not been able to resolve this issue yet.

I recently installed Service Pack 1 for Windows Vista 32 bit. I also
installed an updated driver for my device. The error messages are still
appearing upon boot.

"gerald1378" wrote:

> I have the same problem as u did below, but with windows xp. I did u fix
> this problem, if so how? any help would be gratefull. Gearld
> When Windows Vista Ultimate 32 bit loads to the desktop I am greeted by two
> error messages.
>
> "The proceedure entry point apsInitialize could not be located in the
> dynamic link library wlanapi.dll"
> "The proceedure entry point asSearchInterface could not be located in the
> dynamic link library wlanapi.dll"
>
> I have done a lot of research to solve this problem, however to little
> avail. My wireless connection seems unaffected and still works normally. My
> drivers are up to date. The dll does in fact exist under C:/Windows/System32.
> After trying installing different drivers, and re-installing the network
> device, I then attempted to register wlanapi.dll. When I used the command
>
> Regsvr32 "C:\Windows\System32\wlanapi.dll"
>
> I had this error message appear: "The module Regsvr32
> "C:\Windows\System32\wlanapi.dll" was loaded but the entry-point
> DllRegisterServer was not found. Make sure that Regsvr32
> "C:\Windows\System32\wlanapi.dll" is a valid DLL or OCX file and then try
> again."
>
>
> I think that maybe wlanapi.dll is corrupt. If so, I am not sure how to
> repair this on Windows Vista Ultimate 32 bit.
>
> My wireless device is Dlink DWL-G510 Airplus G 2.4 GHZ.
>
> If anyone could help me fix this issue, it would be greatly appreciated.
> Thanks.
> "Sir James" wrote:
>
> > When Windows Vista Ultimate 32 bit loads to the desktop I am greeted by two
> > error messages.
> >
> > "The proceedure entry point apsInitialize could not be located in the
> > dynamic link library wlanapi.dll"
> > "The proceedure entry point asSearchInterface could not be located in the
> > dynamic link library wlanapi.dll"
> >
> > I have done a lot of research to solve this problem, however to little
> > avail. My wireless connection seems unaffected and still works normally. My
> > drivers are up to date. The dll does in fact exist under C:/Windows/System32.
> > After trying installing different drivers, and re-installing the network
> > device, I then attempted to register wlanapi.dll. When I used the command
> >
> > Regsvr32 "C:\Windows\System32\wlanapi.dll"
> >
> > I had this error message appear: "The module Regsvr32
> > "C:\Windows\System32\wlanapi.dll" was loaded but the entry-point
> > DllRegisterServer was not found. Make sure that Regsvr32
> > "C:\Windows\System32\wlanapi.dll" is a valid DLL or OCX file and then try
> > again."
> >
> >
> > I think that maybe wlanapi.dll is corrupt. If so, I am not sure how to
> > repair this on Windows Vista Ultimate 32 bit.
> >
> > My wireless device is Dlink DWL-G510 Airplus G 2.4 GHZ.
> >
> > If anyone could help me fix this issue, it would be greatly appreciated.
> > Thanks.

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error loading NvMcTray.dll and NvCpl.dll Aaron microsoft.public.windows.vista.general 8 05-02-2009 17:57
apsInitialize-wlanapi.dll =?Utf-8?B?SnVsZmxhbg==?= microsoft.public.windows.vista.general 10 11-10-2008 12:38
wlanapi.dll Frans microsoft.public.nl.windows.vista 0 10-19-2007 13:21
wlanapi.dll Frans microsoft.public.nl.windows.vista 1 10-19-2007 12:49
hal.dll error on vista SINLGE boot cycomiko microsoft.public.windows.vista.general 5 07-01-2007 08:06




All times are GMT +1. The time now is 18:41.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120