Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

cd rom problems in x64 vista

microsoft.public.windows.vista hardware devices






Speedup My PC
Reply
  #1 (permalink)  
Old 02-20-2007
=?Utf-8?B?QG5nZUxDRA==?=
 

Posts: n/a
cd rom problems in x64 vista
Windows cannot access either of my dvd rom drives, the following message is
displayed in device manager.

Windows cannot load the device driver for this hardware. The driver may be
corrupted or missing. (Code 39)

It seemed to happen after I installed Nvidia's Nforce4 drivers. I
uninstalled the nvidia drivers and the problem still exists. I also tried
replacing the cdrom.sys file to no avail. Any thoughts??
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 02-20-2007
=?Utf-8?B?R0Fkb2c=?=
 

Posts: n/a
RE: cd rom problems in x64 vista


"@ngeLCD" wrote:

> Windows cannot access either of my dvd rom drives, the following message is
> displayed in device manager.
>
> Windows cannot load the device driver for this hardware. The driver may be
> corrupted or missing. (Code 39)
>
> It seemed to happen after I installed Nvidia's Nforce4 drivers. I
> uninstalled the nvidia drivers and the problem still exists. I also tried
> replacing the cdrom.sys file to no avail. Any thoughts??


I just bought a Gateway GT5412 and it has the same issue with the factory
installed DVD drive. Actually, I bought the first at Fry's, then took it
back because I thought it was a hardware failure...got a new one at Circuit
(Fry's was out) and it has the same issue. Gateway suggested I could 'try'
restoring the sytem and that just teed me off...not good, bad product.
Reply With Quote
  #3 (permalink)  
Old 02-21-2007
=?Utf-8?B?RG91Zw==?=
 

Posts: n/a
RE: cd rom problems in x64 vista
I had this problem with my 32 bit Vista. I fixed it with system restore. I
went back to the day before I noticed the problem.
--


"@ngeLCD" wrote:

> Windows cannot access either of my dvd rom drives, the following message is
> displayed in device manager.
>
> Windows cannot load the device driver for this hardware. The driver may be
> corrupted or missing. (Code 39)
>
> It seemed to happen after I installed Nvidia's Nforce4 drivers. I
> uninstalled the nvidia drivers and the problem still exists. I also tried
> replacing the cdrom.sys file to no avail. Any thoughts??

Reply With Quote
  #4 (permalink)  
Old 02-22-2007
=?Utf-8?B?TUJTNTQw?=
 

Posts: n/a
RE: cd rom problems in x64 vista
I have a very similar problem to you, I have a dvd burner- Lite-ON DVDRW
SHW-160P6S ATA, and a DVD drive - JLMS XJ-HD166S, both have up to date
drivers and are recognized by device manager and in bios, although neither
one will appear in "my computer" or will pick up when a cd is put(when
windows is running), any help would be appreciated! Thanks
Reply With Quote
  #5 (permalink)  
Old 02-27-2007
bop123@prodigy.net
 

Posts: n/a
Re: cd rom problems in x64 vista
On Feb 19, 11:47 pm, GAdog <G...@discussions.microsoft.com> wrote:
> "@ngeLCD" wrote:
> >Windowscannot access either of mydvdromdrives, the following message is
> > displayed in device manager.

>
> >Windowscannot load the device driver for this hardware. The driver may be
> > corrupted or missing. (Code 39)

>
> > It seemed to happen after I installed Nvidia's Nforce4 drivers. I
> > uninstalled the nvidia drivers and the problem still exists. I also tried
> > replacing the cdrom.sys file to no avail. Any thoughts??

>
> I just bought a Gateway GT5412 and it has the same issue with the factory
> installedDVDdrive. Actually, I bought the first at Fry's, then took it
> back because I thought it was a hardware failure...got a new one at Circuit
> (Fry's was out) and it has the same issue. Gateway suggested I could 'try'
> restoring the sytem and that just teed me off...not good, bad product.


I went throught the same problem with a computer I built. All
functions worked until I downloaded the updates then the dvd drivers
became corrupted on my new and old computer. You have to reload vista
and do not update until the driver problem is fixed and who knows how
long that is going to be. It took me many reloads and much frustration
to find a way to use vista. Microsoft appears to have a big problem
brewing in this area.

Reply With Quote
  #6 (permalink)  
Old 04-05-2007
=?Utf-8?B?YXBwcmVudGljZSBpZGlvdA==?=
 

Posts: n/a
Re: cd rom problems in x64 vista
I have a similar problem: I have an XPC Barebones SD37P2 with a PIONEER
DVD-RW DVD-111D ATA installed. During a recent Vista update the driver (or
registry) had become corrupted. Microsoft Vista could not find an online
solution. A volume error check did not resolve the problem. The problem
however is that the driver is Microsoft's (cdrom.sys), generic and undamaged
; as I am able to copy the driver into another folder; yet Windows will not
let me recopy the driver back into the System32\drivers folder. This is then,
by all evidence, a registry problem.

I tried finding
"HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/Class/{4d36e965-e325-11ce-bfc1-08002be10318}" in Regedit, but no such animal.

I also have the same problem with the Teredo Tunneling Pseudo Interface
driver which is MS's Tun Miniport Adapter.

Hasn't anyone a solution hereto?
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Canon mp830 rmslantc.dll error (MP Navigator scan failed) (Vista x64) Problems... markm75 microsoft.public.windows.vista.general 2 06-20-2008 10:32
problems with dv camcorder and vista x64 =?Utf-8?B?RG9taQ==?= microsoft.public.windows.vista.general 0 03-01-2007 14:53
DVD/CD-Rom Drivers =?Utf-8?B?cm9iaW5qYW1lc3Vr?= microsoft.public.windows.vista.general 6 02-28-2007 17:46
Writing to DVD-ROM? Iron Feliks microsoft.public.windows.vista.general 5 02-27-2007 22:38
RE: SATA DVD-RW Problems with Vista RTM x64 =?Utf-8?B?R2Vycnk=?= microsoft.public.windows.vista hardware devices 3 01-03-2007 06:03




All times are GMT +1. The time now is 05:49.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120