Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Notepad starts with "[.ShellClassInfo] computer starts in Vista

microsoft.public.windows.vista.general






Speedup My PC
Reply
  #1 (permalink)  
Old 03-06-2007
=?Utf-8?B?b3RobzY5?=
 

Posts: n/a
Notepad starts with "[.ShellClassInfo] computer starts in Vista
I have set up a dual boot system with Vista and XP on separate partitions of
a single hard drive, with a second physical drive for shared folders. After
sucessfully installing some legacy programs under XP I rebooted into Vista.
When the computer booted Notepad opened up a text document displaying the
following:

[.ShellClassInfo]LocalizedResourceName=@%systemRoot%\System32\Shell 32.dll,-21787".

I have found a KB article that addresses this in XP (KB/330132), instructing
me to remove the desktop.ini file that was causing this. I did check my XP
installation and found such files and removed them (oddly i did not
experience the problem in XP), but this did not solve the problem in Vista.

My question - will this solution work for Vista as well? Is this being
caused by an incorrect desktop.ini in the Vista partition?

Thanks very much!

otho69
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 03-06-2007
 

Posts: n/a
Re: Notepad starts with "[.ShellClassInfo] computer starts in Vista
It happens becaise the file should be hidden and someone (like you) removed
the hidden attribute. The fix is to make it hidden not delete (although
delete doesn't hurt much on ENGLISH LANGUAGE versions of window). This and
the All User's desktop.ini are the only 2 desktop.ini that must be hidden or
wierd thing happen..
"otho69" <otho69@discussions.microsoft.com> wrote in message
news:597F5615-79F4-4455-8AEB-C8791AFC771E@microsoft.com...
>I have set up a dual boot system with Vista and XP on separate partitions
>of
> a single hard drive, with a second physical drive for shared folders.
> After
> sucessfully installing some legacy programs under XP I rebooted into
> Vista.
> When the computer booted Notepad opened up a text document displaying the
> following:
>
> [.ShellClassInfo]LocalizedResourceName=@%systemRoot%\System32\Shell 32.dll,-21787".
>
> I have found a KB article that addresses this in XP (KB/330132),
> instructing
> me to remove the desktop.ini file that was causing this. I did check my
> XP
> installation and found such files and removed them (oddly i did not
> experience the problem in XP), but this did not solve the problem in
> Vista.
>
> My question - will this solution work for Vista as well? Is this being
> caused by an incorrect desktop.ini in the Vista partition?
>
> Thanks very much!
>
> otho69


Reply With Quote
  #3 (permalink)  
Old 03-06-2007
=?Utf-8?B?b3RobzY5?=
 

Posts: n/a
Re: Notepad starts with "[.ShellClassInfo] computer starts in Vist
Me?! I would never do such a thing - perish the thought!

While I do not know how I managed to change the desktop.ini file's hidden
attribute, it sounds as though it is an easy enough problem to fix. I'll
have a bash at it and let you know how I fare.

Thanks!

otho69

"." wrote:

> It happens becaise the file should be hidden and someone (like you) removed
> the hidden attribute. The fix is to make it hidden not delete (although
> delete doesn't hurt much on ENGLISH LANGUAGE versions of window). This and
> the All User's desktop.ini are the only 2 desktop.ini that must be hidden or
> wierd thing happen..


Reply With Quote
  #4 (permalink)  
Old 03-06-2007
 

Posts: n/a
Re: Notepad starts with "[.ShellClassInfo] computer starts in Vist
What that file in that location does (as others have other non language
related functions) is give the folder it name. In English the directory name
and display name is the same. With the file there you see the name coming
from the language resource. In German Windows it says something like Hande
Hoch (or some babble). So if you delete it in english all looks the same but
you see the real folder name not the language translation.

"otho69" <otho69@discussions.microsoft.com> wrote in message
news:9A6F2D30-3BA7-4B24-9DDF-C2B8B95899FB@microsoft.com...
> Me?! I would never do such a thing - perish the thought!
>
> While I do not know how I managed to change the desktop.ini file's hidden
> attribute, it sounds as though it is an easy enough problem to fix. I'll
> have a bash at it and let you know how I fare.
>
> Thanks!
>
> otho69
>
> "." wrote:
>
>> It happens becaise the file should be hidden and someone (like you)
>> removed
>> the hidden attribute. The fix is to make it hidden not delete (although
>> delete doesn't hurt much on ENGLISH LANGUAGE versions of window). This
>> and
>> the All User's desktop.ini are the only 2 desktop.ini that must be hidden
>> or
>> wierd thing happen..

>


Reply With Quote
  #5 (permalink)  
Old 03-07-2007
=?Utf-8?B?b3RobzY5?=
 

Posts: n/a
Re: Notepad starts with "[.ShellClassInfo] computer starts in Vist
I would love to give this a try but I have yet to be able to access my
"Documents and Settings" folder to look for the necessary desktop.ini to
correct its attributes. I am logged in as an administrator, but Vista denies
me access to the folder. I have looked at the permissions but cannot figure
out how to grant myself access.

I am quite new to Vista (obviously). I understand why the new security
protocols are in place, but I do not understand how to work with them as yet.
Can you explain to me how I can get permission to access the system folders
and fix the desktop.ini files? Any help is greatlty appreciated!

otho69

"." wrote:

> What that file in that location does (as others have other non language
> related functions) is give the folder it name. In English the directory name
> and display name is the same. With the file there you see the name coming
> from the language resource. In German Windows it says something like Hande
> Hoch (or some babble). So if you delete it in english all looks the same but
> you see the real folder name not the language translation.
>
> "otho69" <otho69@discussions.microsoft.com> wrote in message
> news:9A6F2D30-3BA7-4B24-9DDF-C2B8B95899FB@microsoft.com...
> > Me?! I would never do such a thing - perish the thought!
> >
> > While I do not know how I managed to change the desktop.ini file's hidden
> > attribute, it sounds as though it is an easy enough problem to fix. I'll
> > have a bash at it and let you know how I fare.
> >
> > Thanks!
> >
> > otho69
> >
> > "." wrote:
> >
> >> It happens becaise the file should be hidden and someone (like you)
> >> removed
> >> the hidden attribute. The fix is to make it hidden not delete (although
> >> delete doesn't hurt much on ENGLISH LANGUAGE versions of window). This
> >> and
> >> the All User's desktop.ini are the only 2 desktop.ini that must be hidden
> >> or
> >> wierd thing happen..

> >

>
>

Reply With Quote
  #6 (permalink)  
Old 03-07-2007
 

Posts: n/a
Re: Notepad starts with "[.ShellClassInfo] computer starts in Vist
Replace Users for Documents and Settings. D&S isn't a real folder but a
redirect signs for install programs looking for the old names. Or just right
click the folder on Start and choose Open.

"otho69" <otho69@discussions.microsoft.com> wrote in message
news:5F5771B4-AF70-46D2-8856-4742906B4E62@microsoft.com...
>I would love to give this a try but I have yet to be able to access my
> "Documents and Settings" folder to look for the necessary desktop.ini to
> correct its attributes. I am logged in as an administrator, but Vista
> denies
> me access to the folder. I have looked at the permissions but cannot
> figure
> out how to grant myself access.
>
> I am quite new to Vista (obviously). I understand why the new security
> protocols are in place, but I do not understand how to work with them as
> yet.
> Can you explain to me how I can get permission to access the system
> folders
> and fix the desktop.ini files? Any help is greatlty appreciated!
>
> otho69
>
> "." wrote:
>
>> What that file in that location does (as others have other non language
>> related functions) is give the folder it name. In English the directory
>> name
>> and display name is the same. With the file there you see the name coming
>> from the language resource. In German Windows it says something like
>> Hande
>> Hoch (or some babble). So if you delete it in english all looks the same
>> but
>> you see the real folder name not the language translation.
>>
>> "otho69" <otho69@discussions.microsoft.com> wrote in message
>> news:9A6F2D30-3BA7-4B24-9DDF-C2B8B95899FB@microsoft.com...
>> > Me?! I would never do such a thing - perish the thought!
>> >
>> > While I do not know how I managed to change the desktop.ini file's
>> > hidden
>> > attribute, it sounds as though it is an easy enough problem to fix.
>> > I'll
>> > have a bash at it and let you know how I fare.
>> >
>> > Thanks!
>> >
>> > otho69
>> >
>> > "." wrote:
>> >
>> >> It happens becaise the file should be hidden and someone (like you)
>> >> removed
>> >> the hidden attribute. The fix is to make it hidden not delete
>> >> (although
>> >> delete doesn't hurt much on ENGLISH LANGUAGE versions of window). This
>> >> and
>> >> the All User's desktop.ini are the only 2 desktop.ini that must be
>> >> hidden
>> >> or
>> >> wierd thing happen..
>> >

>>
>>


Reply With Quote
  #7 (permalink)  
Old 03-07-2007
=?Utf-8?B?RGVhbi1EZWFu?=
 

Posts: n/a
RE: Notepad starts with "[.ShellClassInfo] computer starts in Vista
In the following two folders (the paths may be hidden)

C:\Users\(YOUR NAME)\AppData\Roaming\Microsoft\Windows\Start
Menu\Programs\Startup

and

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup

confirm that in each of the above two folders, that there is a desktop.ini
file with the following contents (nothing more, nothing less), as seen in
Notepad:

----------------------------------(below this
line)-------------------------------

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell 32.dll,-21787

----------------------------------(above this
line)-------------------------------


Now, in Windows Explorer (which should be "Run as Administrator"), go to:

C:\Users\(YOUR NAME)\AppData\Roaming\Microsoft\Windows\Start
Menu\Programs

Select the Startup folder. While holding down the Shift key, right click on
the Startup folder, and choose "Open Command Window Here". In the Command
Window, at the prompt, type (or copy and paste):

attrib +H +S -R desktop.ini

Press Enter on your keyboard.

Now go to:

C:\ProgramData\Microsoft\Windows\Start Menu\Programs

Select the Startup folder. While holding down the Shift key, right click on
the Startup folder, and choose "Open Command Window Here". In the Command
Window, at the prompt, type (or copy and paste):

attrib +H +S -R desktop.ini

Press Enter on your keyboard.

These are the only two desktop.ini's that could be causing your problem.
(Any other desktop.ini's in other folders should be left alone.)

Hope this helps,
Dean


"otho69" wrote:

> I have set up a dual boot system with Vista and XP on separate partitions of
> a single hard drive, with a second physical drive for shared folders. After
> sucessfully installing some legacy programs under XP I rebooted into Vista.
> When the computer booted Notepad opened up a text document displaying the
> following:
>
> [.ShellClassInfo]LocalizedResourceName=@%systemRoot%\System32\Shell 32.dll,-21787".
>
> I have found a KB article that addresses this in XP (KB/330132), instructing
> me to remove the desktop.ini file that was causing this. I did check my XP
> installation and found such files and removed them (oddly i did not
> experience the problem in XP), but this did not solve the problem in Vista.
>
> My question - will this solution work for Vista as well? Is this being
> caused by an incorrect desktop.ini in the Vista partition?
>
> Thanks very much!
>
> otho69

Reply With Quote
  #8 (permalink)  
Old 03-10-2007
=?Utf-8?B?b3RobzY5?=
 

Posts: n/a
RE: Notepad starts with "[.ShellClassInfo] computer starts in Vist
Fellows,

Thanks very much for your responses - they were extremely helpful and had
allowed me to resolve the problem. The problem did re-arise after a day or
so, after I had booted into Windows XP a few times, so I suspect there is
something amiss with my dual boot arrangement that is causing this problem.
Also, Vista will no longer allow me to change the "read only" attribute on
the C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup folder,
which prevents me from reapplying the solution you had outlined.

It is a little frustrating, but progress is being made at least in that I am
starting to feel more comfortable working in Vista and am finding my way
around!

Your help has been greatly appreciated!

otho69

"Dean-Dean" wrote:

> In the following two folders (the paths may be hidden)
>
> C:\Users\(YOUR NAME)\AppData\Roaming\Microsoft\Windows\Start
> Menu\Programs\Startup
>
> and
>
> C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
>
> confirm that in each of the above two folders, that there is a desktop.ini
> file with the following contents (nothing more, nothing less), as seen in
> Notepad:
>
> ----------------------------------(below this
> line)-------------------------------
>
> [.ShellClassInfo]
> LocalizedResourceName=@%SystemRoot%\system32\shell 32.dll,-21787
>
> ----------------------------------(above this
> line)-------------------------------
>
>
> Now, in Windows Explorer (which should be "Run as Administrator"), go to:
>
> C:\Users\(YOUR NAME)\AppData\Roaming\Microsoft\Windows\Start
> Menu\Programs
>
> Select the Startup folder. While holding down the Shift key, right click on
> the Startup folder, and choose "Open Command Window Here". In the Command
> Window, at the prompt, type (or copy and paste):
>
> attrib +H +S -R desktop.ini
>
> Press Enter on your keyboard.
>
> Now go to:
>
> C:\ProgramData\Microsoft\Windows\Start Menu\Programs
>
> Select the Startup folder. While holding down the Shift key, right click on
> the Startup folder, and choose "Open Command Window Here". In the Command
> Window, at the prompt, type (or copy and paste):
>
> attrib +H +S -R desktop.ini
>
> Press Enter on your keyboard.
>
> These are the only two desktop.ini's that could be causing your problem.
> (Any other desktop.ini's in other folders should be left alone.)
>
> Hope this helps,
> Dean
>
>
> "otho69" wrote:
>
> > I have set up a dual boot system with Vista and XP on separate partitions of
> > a single hard drive, with a second physical drive for shared folders. After
> > sucessfully installing some legacy programs under XP I rebooted into Vista.
> > When the computer booted Notepad opened up a text document displaying the
> > following:
> >
> > [.ShellClassInfo]LocalizedResourceName=@%systemRoot%\System32\Shell 32.dll,-21787".
> >
> > I have found a KB article that addresses this in XP (KB/330132), instructing
> > me to remove the desktop.ini file that was causing this. I did check my XP
> > installation and found such files and removed them (oddly i did not
> > experience the problem in XP), but this did not solve the problem in Vista.
> >
> > My question - will this solution work for Vista as well? Is this being
> > caused by an incorrect desktop.ini in the Vista partition?
> >
> > Thanks very much!
> >
> > otho69

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
"this operation has been canceled due to restrictions on this computer" Phil microsoft.public.windows.vista.security 11 04-28-2009 13:59
The 'Duh' Starts Now: Weighing In on the Vista Launch MICHAEL microsoft.public.windows.vista.general 9 03-01-2007 07:45
The wow starts 'really' here... =?Utf-8?B?VGVjaG5vbG9neTIwMDc=?= microsoft.public.windows.vista.general 3 03-01-2007 04:30
Audio Watermark Web Spider Starts Crawling Steve General Technology News 0 03-01-2007 02:28
Shut down and software required re-starts =?Utf-8?B?U3ludGF4MjExMg==?= microsoft.public.windows.vista hardware devices 0 02-17-2007 20:29




All times are GMT +1. The time now is 20:39.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120