Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Twain driver user account issue

microsoft.public.windows.vista.administration accounts passwords






Speedup My PC
Reply
  #1 (permalink)  
Old 06-14-2007
Dan
 

Posts: n/a
Twain driver user account issue
I posted this in the scanner and printer forum but never got a response.
Since this issue appears to be related to user account permissions I'll post
it here instead.

Brand new HP desktop, stand alone not networked, Vista home premium, set up
one user account with admin privileges on start up. I installed a 3 year old
Cannon flatbed scanner with the latest Vista 32 bit drivers downloaded from
the Cannon site. The install was successful but I was only able to scan from
MS office apps Word, Excel, PP, not in any programs using the twain drivers.
Photoshop Elements 5.0.2 with the Vista patch and the Canon scanner software
showed no twain devices. The scanner drivers in the device mgr and control
panel were all good.

Cannon tech support had me try various things with no results; selective
start ups with msconfig, un-installing, re-downloading, re-installing. Then
they had me create another admin user account and re-install the drivers. The
scanner worked, all programs could access the twain drivers, until I
rebooted, after that both admin users could not access the scanner, except
with the MS office apps. Cannon support said the problem was with user
account permissions and since it was a Vista issue they could not provide any
help.

Contacted HP support and received no help. Spoke with two different techs,
both were clueless about how to help and said it must be a diver issue and
would have to go back to Cannon for support. Cannon suggested that I dump and
re-load Vista, a ton of work and since the only backup is the recovery disk I
created after the initial boot up chances are the issue would still be
there. Cannon rep claims they have tested the drivers on all versions of
Vista with many hardware configurations and have had no issues and my problem
is with my Vista
permissions only.

In the mean time I activated the hidden administrator account and the twain
drivers are fully functional in all programs, scanner works fine. I removed
the scanner drivers and re-installed through the hidden admin account and the
scanner is still unusable in the original admin user account. I have checked
all of
the twain files for permissions and the original admin user account shows full
permissions for all of the files in the twain32 folder.

There are no other twain devices on this system and no other twain devices
have ever been installed. Obviously I shouldn’t have to use the hidden admin
account to use the twain drivers but I can’t seem to find an answer to the
user account permission issue.

Cannon and HP support has washed their hands of this issue. Hardware is
cheap and I’d be tempted to go buy a new all in one, but I’m afraid that the
twain driver issue would still be there.

Any suggestions would be greatly appreciated.

Thanks,
Dan
Reply With Quote
Sponsored Links
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange twain driver issue Dan microsoft.public.windows.vista.print fax scan 1 06-16-2007 00:03
Scanner driver installed, but TWAIN panel says "XP Only" Noozer microsoft.public.windows.vista hardware devices 2 04-04-2007 08:54
Disabled User Account Control and disabled Administrator account. =?Utf-8?B?Q3JhaWcgTCBEYXZpZXM=?= microsoft.public.windows.vista.administration accounts passwords 2 03-11-2007 20:38
User Account Control issue =?Utf-8?B?UGF0Qml6NzI=?= microsoft.public.windows.vista.general 2 03-01-2007 03:07
Scanner Twain Driver Medion 4394 =?Utf-8?B?TWFyc2Rlbmc=?= microsoft.public.windows.vista.general 0 02-28-2007 22:21




All times are GMT +1. The time now is 19:37.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120