Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Can't get write permissions for files transferred from W2K

microsoft.public.windows.vista.administration accounts passwords






Speedup My PC
Reply
  #1 (permalink)  
Old 04-11-2007
=?Utf-8?B?SC4gQnJvd25l?=
 

Posts: n/a
Can't get write permissions for files transferred from W2K
I recently installed Vista Home Premium, and transferred a lot of
(non-system) files from a w2k installation over my wireless network. I can
access the files, change folder names (although not via the document tree. Is
this a Vista thing?), but every time I try to edit a file, I get "Cannot
create the <path\filename>. Make sure the path and filename are correct"
unless I run notepad as an administrator. I have tried:

1. Taking ownership, both through the properties dialog and through the
takeown cmd. Both occasions specified that should be applied to all
sub-folders etc (recursive)
2. Changing permissions. I am the only user in vista and my user name has
all the allow boxes except Special Permissions checked, and no deny boxes
checked. In advanced options, it says "Allow MyUserName Full Control
inherited from C:\Users\UserName Apply to Folder, sub-folders etc.
3. The Read-Only box for the folder where all the files and sub-folders are
contained is filled (not checked). I have tried unchecking it, running
explorer as administrator. This doesn't seem to stick. Sub-folders also have
the read-only box filled, but the read-only property for files is empty.

There are ~20000 files in about 100 sub-folders, and I need to edit them on
a daily basis. Everything else in vista is working, but this is driving me
crazy!

Any help would be gratefully received.

Thanks.
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 04-13-2007
bdzyub@gmail.com
 

Posts: n/a
Re: Can't get write permissions for files transferred from W2K
I don't really know, but could this be caused by the UAC? I tried
copying files in to the root drive, and even though I was an admin, I
did not get permissions.
Turned off User Account Control, and everything worked like a charm.
Might this help?

--Boris

Reply With Quote
  #3 (permalink)  
Old 04-13-2007
GTS
 

Posts: n/a
Re: Can't get write permissions for files transferred from W2K
You might try running this is a command prompt. You could substitute your
user name for Everyone if you prefer. I'd be interested to know if it
helps.

icacls "c:\MyFolder\*.*" /t /grant Everyone:F


"H. Browne" <HBrowne@discussions.microsoft.com> wrote in message
news:64AB73FC-8B04-4F63-B5BC-7EE9263D6C38@microsoft.com...
>I recently installed Vista Home Premium, and transferred a lot of
> (non-system) files from a w2k installation over my wireless network. I can
> access the files, change folder names (although not via the document tree.
> Is
> this a Vista thing?), but every time I try to edit a file, I get "Cannot
> create the <path\filename>. Make sure the path and filename are correct"
> unless I run notepad as an administrator. I have tried:
>
> 1. Taking ownership, both through the properties dialog and through the
> takeown cmd. Both occasions specified that should be applied to all
> sub-folders etc (recursive)
> 2. Changing permissions. I am the only user in vista and my user name has
> all the allow boxes except Special Permissions checked, and no deny boxes
> checked. In advanced options, it says "Allow MyUserName Full Control
> inherited from C:\Users\UserName Apply to Folder, sub-folders etc.
> 3. The Read-Only box for the folder where all the files and sub-folders
> are
> contained is filled (not checked). I have tried unchecking it, running
> explorer as administrator. This doesn't seem to stick. Sub-folders also
> have
> the read-only box filled, but the read-only property for files is empty.
>
> There are ~20000 files in about 100 sub-folders, and I need to edit them
> on
> a daily basis. Everything else in vista is working, but this is driving me
> crazy!
>
> Any help would be gratefully received.
>
> Thanks.


Reply With Quote
  #4 (permalink)  
Old 04-13-2007
=?Utf-8?B?SC4gQnJvd25l?=
 

Posts: n/a
Re: Can't get write permissions for files transferred from W2K
Thanks for your suggestions; sorry it's taken me a while to get back.

Boris: I hadn't thought of switching off UAC. Unfortunately, it didn't work
this time, but it's probably the solution to most of the other problems I've
had.

GTS: I tried the command you suggested. Unfortunately, it didn't seem to
make a difference either, although surely it *should*?

I've just noticed something a bit odd about this: almost all of the files
are HTML, and I can't edit/change them at all (when opened in notepad).
However, the few .doc and .txt files, I can save with no problems. I don't
understand this at all. I've had a quick google, and haven't found anything
yet.


Reply With Quote
  #5 (permalink)  
Old 04-13-2007
GTS
 

Posts: n/a
Re: Can't get write permissions for files transferred from W2K
That's an interesting (and baffling) finding. It sure seems like rights
must be set correctly. I just edited and saved an html file in notepad
normally. Are you running any 3rd party security type software that could
be involved? What is the folder path, i.e.. is it off the root or under
your user documents?


"H. Browne" <HBrowne@discussions.microsoft.com> wrote in message
news:E21A30D5-40A7-4D54-B98B-B2D446E8C240@microsoft.com...
> Thanks for your suggestions; sorry it's taken me a while to get back.
>
> Boris: I hadn't thought of switching off UAC. Unfortunately, it didn't
> work
> this time, but it's probably the solution to most of the other problems
> I've
> had.
>
> GTS: I tried the command you suggested. Unfortunately, it didn't seem to
> make a difference either, although surely it *should*?
>
> I've just noticed something a bit odd about this: almost all of the files
> are HTML, and I can't edit/change them at all (when opened in notepad).
> However, the few .doc and .txt files, I can save with no problems. I don't
> understand this at all. I've had a quick google, and haven't found
> anything
> yet.
>
>


Reply With Quote
  #6 (permalink)  
Old 04-14-2007
=?Utf-8?B?SC4gQnJvd25l?=
 

Posts: n/a
Re: Can't get write permissions for files transferred from W2K
I have AVG Anti Virus installed, and the Windows Firewall with default
settings.I tried switching them both off, but got the same result.

This is pretty weird, though. I can open up notepad, write an html file, and
save it to the root of the folder. However, when I open up the html file
again, it doesn't let me edit and save it even running notepad as
administrator, giving the same error message. Surely I should have rights on
a file I've just created in Vista.

The folder path is : C:\Users\UserName\Documents\Folder with a lot of
sub-folders and sub-sub-folders under it.

When I copy files from other areas in XP, I can edit them in vista. However,
even if I copy single files over from this particular folder, I can't change
them. I've tried changing their location to C:\Users\UserName\blah in case it
was an issue with the original top-level folder, but no change.

I'm thinking of just burning them to a cd and copying them that way - would
it make any difference?

"GTS" wrote:

> That's an interesting (and baffling) finding. It sure seems like rights
> must be set correctly. I just edited and saved an html file in notepad
> normally. Are you running any 3rd party security type software that could
> be involved? What is the folder path, i.e.. is it off the root or under
> your user documents?
>
>
> "H. Browne" <HBrowne@discussions.microsoft.com> wrote in message
> news:E21A30D5-40A7-4D54-B98B-B2D446E8C240@microsoft.com...
> > Thanks for your suggestions; sorry it's taken me a while to get back.
> >
> > Boris: I hadn't thought of switching off UAC. Unfortunately, it didn't
> > work
> > this time, but it's probably the solution to most of the other problems
> > I've
> > had.
> >
> > GTS: I tried the command you suggested. Unfortunately, it didn't seem to
> > make a difference either, although surely it *should*?
> >
> > I've just noticed something a bit odd about this: almost all of the files
> > are HTML, and I can't edit/change them at all (when opened in notepad).
> > However, the few .doc and .txt files, I can save with no problems. I don't
> > understand this at all. I've had a quick google, and haven't found
> > anything
> > yet.
> >
> >

>
>

Reply With Quote
  #7 (permalink)  
Old 04-14-2007
GTS
 

Posts: n/a
Re: Can't get write permissions for files transferred from W2K
Stranger and stranger. Your idea of copying via a CD could be worth a try.
It would remove any NTFS attributes or permissions carried in the transfer.
I know there are some differences in the NTFS implementations, but can't see
why it would affect only html files. I would maybe try running a chkdsk /f
also on the long shot chance that it might find an index or MFT problem.
I have a Win 2K machine here in the shop, and may see later if I can
duplicate the problem.

"H. Browne" <HBrowne@discussions.microsoft.com> wrote in message
news53432F8-AD17-48F1-B25C-CDAD838F9174@microsoft.com...
>I have AVG Anti Virus installed, and the Windows Firewall with default
> settings.I tried switching them both off, but got the same result.
>
> This is pretty weird, though. I can open up notepad, write an html file,
> and
> save it to the root of the folder. However, when I open up the html file
> again, it doesn't let me edit and save it even running notepad as
> administrator, giving the same error message. Surely I should have rights
> on
> a file I've just created in Vista.
>
> The folder path is : C:\Users\UserName\Documents\Folder with a lot of
> sub-folders and sub-sub-folders under it.
>
> When I copy files from other areas in XP, I can edit them in vista.
> However,
> even if I copy single files over from this particular folder, I can't
> change
> them. I've tried changing their location to C:\Users\UserName\blah in case
> it
> was an issue with the original top-level folder, but no change.
>
> I'm thinking of just burning them to a cd and copying them that way -
> would
> it make any difference?
>
> "GTS" wrote:
>
>> That's an interesting (and baffling) finding. It sure seems like rights


<snip>

Reply With Quote
  #8 (permalink)  
Old 04-16-2007
=?Utf-8?B?SC4gQnJvd25l?=
 

Posts: n/a
Re: Can't get write permissions for files transferred from W2K
Okay, so much for copying on a CD - the CD drive on the W2K machine isn't
working! Tried chkdsk - reported no errors. I'm going to have one more go at
copying files to another username (i'm not hopeful), then I think I'll try
copying with a few FAT usb drives.

"GTS" wrote:

> Stranger and stranger. Your idea of copying via a CD could be worth a try.
> It would remove any NTFS attributes or permissions carried in the transfer.
> I know there are some differences in the NTFS implementations, but can't see
> why it would affect only html files. I would maybe try running a chkdsk /f
> also on the long shot chance that it might find an index or MFT problem.
> I have a Win 2K machine here in the shop, and may see later if I can
> duplicate the problem.
>
> "H. Browne" <HBrowne@discussions.microsoft.com> wrote in message
> news53432F8-AD17-48F1-B25C-CDAD838F9174@microsoft.com...
> >I have AVG Anti Virus installed, and the Windows Firewall with default
> > settings.I tried switching them both off, but got the same result.
> >
> > This is pretty weird, though. I can open up notepad, write an html file,
> > and
> > save it to the root of the folder. However, when I open up the html file
> > again, it doesn't let me edit and save it even running notepad as
> > administrator, giving the same error message. Surely I should have rights
> > on
> > a file I've just created in Vista.
> >
> > The folder path is : C:\Users\UserName\Documents\Folder with a lot of
> > sub-folders and sub-sub-folders under it.
> >
> > When I copy files from other areas in XP, I can edit them in vista.
> > However,
> > even if I copy single files over from this particular folder, I can't
> > change
> > them. I've tried changing their location to C:\Users\UserName\blah in case
> > it
> > was an issue with the original top-level folder, but no change.
> >
> > I'm thinking of just burning them to a cd and copying them that way -
> > would
> > it make any difference?
> >
> > "GTS" wrote:
> >
> >> That's an interesting (and baffling) finding. It sure seems like rights

>
> <snip>
>
>

Reply With Quote
  #9 (permalink)  
Old 04-16-2007
GTS
 

Posts: n/a
Re: Can't get write permissions for files transferred from W2K
I'm out of ideas. Please keep up posted. Good luck.

"H. Browne" <HBrowne@discussions.microsoft.com> wrote in message
news:9DABE3F6-5B15-4811-A011-1782B733FB01@microsoft.com...
> Okay, so much for copying on a CD - the CD drive on the W2K machine isn't
> working! Tried chkdsk - reported no errors. I'm going to have one more go
> at
> copying files to another username (i'm not hopeful), then I think I'll try
> copying with a few FAT usb drives.
>
> "GTS" wrote:
>
>> Stranger and stranger. Your idea of copying via a CD could be worth a
>> try.
>> It would remove any NTFS attributes or permissions carried in the
>> transfer.
>> I know there are some differences in the NTFS implementations, but can't
>> see
>> why it would affect only html files. I would maybe try running a chkdsk
>> /f
>> also on the long shot chance that it might find an index or MFT problem.
>> I have a Win 2K machine here in the shop, and may see later if I can
>> duplicate the problem.
>>
>> "H. Browne" <HBrowne@discussions.microsoft.com> wrote in message
>> news53432F8-AD17-48F1-B25C-CDAD838F9174@microsoft.com...
>> >I have AVG Anti Virus installed, and the Windows Firewall with default
>> > settings.I tried switching them both off, but got the same result.
>> >
>> > This is pretty weird, though. I can open up notepad, write an html
>> > file,
>> > and
>> > save it to the root of the folder. However, when I open up the html
>> > file
>> > again, it doesn't let me edit and save it even running notepad as
>> > administrator, giving the same error message. Surely I should have
>> > rights
>> > on
>> > a file I've just created in Vista.
>> >
>> > The folder path is : C:\Users\UserName\Documents\Folder with a lot of
>> > sub-folders and sub-sub-folders under it.
>> >
>> > When I copy files from other areas in XP, I can edit them in vista.
>> > However,
>> > even if I copy single files over from this particular folder, I can't
>> > change
>> > them. I've tried changing their location to C:\Users\UserName\blah in
>> > case
>> > it
>> > was an issue with the original top-level folder, but no change.
>> >
>> > I'm thinking of just burning them to a cd and copying them that way -
>> > would
>> > it make any difference?
>> >
>> > "GTS" wrote:
>> >
>> >> That's an interesting (and baffling) finding. It sure seems like
>> >> rights

>>
>> <snip>
>>
>>


Reply With Quote
  #10 (permalink)  
Old 04-17-2007
=?Utf-8?B?SC4gQnJvd25l?=
 

Posts: n/a
Re: Can't get write permissions for files transferred from W2K
Well. I found a workaround (not a solution, unfortunately). Copy the files
from the Vista hard drive to a flash USB drive formatted as FAT, then back
onto the hard disk. This seems to have resolved the permissions issue, and
was faster and more reliable than CDs (which Vista didn't like). Also, easier
than transferring the files manually from computer to computer via USB.
Unfortunately, this does seem to wipe the properties associated with some of
the files, so it's not ideal.

Thanks for all your help.

H

"GTS" wrote:

> I'm out of ideas. Please keep up posted. Good luck.
>
> "H. Browne" <HBrowne@discussions.microsoft.com> wrote in message
> news:9DABE3F6-5B15-4811-A011-1782B733FB01@microsoft.com...
> > Okay, so much for copying on a CD - the CD drive on the W2K machine isn't
> > working! Tried chkdsk - reported no errors. I'm going to have one more go
> > at
> > copying files to another username (i'm not hopeful), then I think I'll try
> > copying with a few FAT usb drives.
> >
> > "GTS" wrote:
> >
> >> Stranger and stranger. Your idea of copying via a CD could be worth a
> >> try.
> >> It would remove any NTFS attributes or permissions carried in the
> >> transfer.
> >> I know there are some differences in the NTFS implementations, but can't
> >> see
> >> why it would affect only html files. I would maybe try running a chkdsk
> >> /f
> >> also on the long shot chance that it might find an index or MFT problem.
> >> I have a Win 2K machine here in the shop, and may see later if I can
> >> duplicate the problem.
> >>
> >> "H. Browne" <HBrowne@discussions.microsoft.com> wrote in message
> >> news53432F8-AD17-48F1-B25C-CDAD838F9174@microsoft.com...
> >> >I have AVG Anti Virus installed, and the Windows Firewall with default
> >> > settings.I tried switching them both off, but got the same result.
> >> >
> >> > This is pretty weird, though. I can open up notepad, write an html
> >> > file,
> >> > and
> >> > save it to the root of the folder. However, when I open up the html
> >> > file
> >> > again, it doesn't let me edit and save it even running notepad as
> >> > administrator, giving the same error message. Surely I should have
> >> > rights
> >> > on
> >> > a file I've just created in Vista.
> >> >
> >> > The folder path is : C:\Users\UserName\Documents\Folder with a lot of
> >> > sub-folders and sub-sub-folders under it.
> >> >
> >> > When I copy files from other areas in XP, I can edit them in vista.
> >> > However,
> >> > even if I copy single files over from this particular folder, I can't
> >> > change
> >> > them. I've tried changing their location to C:\Users\UserName\blah in
> >> > case
> >> > it
> >> > was an issue with the original top-level folder, but no change.
> >> >
> >> > I'm thinking of just burning them to a cd and copying them that way -
> >> > would
> >> > it make any difference?
> >> >
> >> > "GTS" wrote:
> >> >
> >> >> That's an interesting (and baffling) finding. It sure seems like
> >> >> rights
> >>
> >> <snip>
> >>
> >>

>
>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to write files to iPod or external hard drive. Kevin Commins microsoft.public.windows.vista.general 3 04-03-2007 19:13
Unable to write files to iPod or external hard drive. Kevin Commins microsoft.public.windows.vista hardware devices 0 03-31-2007 03:06
Unable to write files to iPod or external hard drive. Kevin Commins microsoft.public.windows.vista.file management 0 03-31-2007 03:04
is there some location (c.f. [CommonAppData]) where even limited users can modify/write files? Bob Eaton microsoft.public.windows.vista.general 15 03-20-2007 09:25
Registry Read/Write Security/Permissions =?Utf-8?B?YWxhbg==?= microsoft.public.windows.vista.general 0 03-13-2007 21:10




All times are GMT +1. The time now is 21:02.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120