Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Links on my website don't work

microsoft.public.internetexplorer.general






Speedup My PC
Reply
  #1 (permalink)  
Old 04-03-2010
kfoxweatherfox
 

Posts: n/a
Links on my website don't work
With IE 8 my links *to go from one page to a different page* on my website do
not show up however the website works just fine in chrome, firefox and
earlier versions of IE. Any clues how to fix this?

IF you need the website it is www.kfoxweatherfox.com. On the left hand side
should be a whole list of pages to go to such as knowledge, photos etc.
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 04-03-2010
G. R. Woodring
 

Posts: n/a
Re: Links on my website don't work
Date: 4/3/2010 10:20 AM, Author: kfoxweatherfox Wrote:
> With IE 8 my links *to go from one page to a different page* on my website do
> not show up however the website works just fine in chrome, firefox and
> earlier versions of IE. Any clues how to fix this?
>
> IF you need the website it is www.kfoxweatherfox.com. On the left hand side
> should be a whole list of pages to go to such as knowledge, photos etc.


OK, it does seem to display better in Firefox than in IE8, even compatibility mode
doesn't help. The page has 100 errors, not the worst I've seen but bad for such a
simple page. The page has 115 lines just in the head, that would be more than enough
to display what is on the page. The whole page has 1300 lines.

With all of the crap in the head element it still does not identify the page editor
<META NAME="Generator" CONTENT="...">

Find a real web page authoring program and re-write the page, I don't think that one
can be fixed. Notepad would be better than what you used (and entirely adequate for
the complexity of the page).


--
G. R. Woodring
Reply With Quote
  #3 (permalink)  
Old 04-03-2010
Twayne
 

Posts: n/a
Re: Links on my website don't work
In news:E9ED9B7E-65D0-41C6-8ABD-2B898197A8A3@microsoft.com,
kfoxweatherfox <kfoxweatherfox@discussions.microsoft.com>
typed:
> With IE 8 my links *to go from one page to a different
> page* on my website do not show up however the website
> works just fine in chrome, firefox and earlier versions of
> IE. Any clues how to fix this?
>
> IF you need the website it is www.kfoxweatherfox.com. On
> the left hand side should be a whole list of pages to go to
> such as knowledge, photos etc.


Well, for starters, they seem to work OK from here with XP Pro
SP3 and IE8. There are a total of 13 links in the left menu
list.

However, you have apparently written the site using MSO:
--------
<html xmlns:v="urn:schemas-microsoft-com:vml"
xmlns="urn:schemas-microsoft-comfficeffice"
xmlns:dt="uuid:C2F41010-65B3-11d1-A29F-00AA00C14882"
xmlns="http://www.w3.org/TR/REC-html40">
-------
Using Office to write web sites creates terrible code bloat
that's entirely unnecesary and makes the site very slow to
load where something as simple as you have should literally
"snap" to the screen with the slowest DSL and even be usable
to 56k users, which is is not; it would take forever to load a
page with 56k analog connections.
The "story" MS likes to tell if you call them on it, is
that it's not intended to write web sites for the internet,
but for an intranet - that's why it has all that extraneous
bload in it.

The site needs to be rewritten and re-uploaded. You might be
able to accomplish what you need by simply loading it into
something like N|VU which will remove extraneious code, then
run Tidy on it; that at least would get around a complete
rewrite if it worked.

NVU is free and works well, especially if you aren't good at
HTML. It's a wysiwyg editor and fully capable of doing a site
like yours. You can download it from here. I used it when I
was getting started and it's a great program for the beginner
or even some experts.

HTH,

Twayne`


Reply With Quote
  #4 (permalink)  
Old 04-04-2010
PA Bear [MS MVP]
 

Posts: n/a
Re: Links on my website don't work
Dunno what your mean be "don't work" but Developer-specific resources
include:

MSDN IE Development Forum (post such questions here instead)
http://social.msdn.microsoft.com/For...opment/threads

Tip: When posting in Developer forums, always include a link to your web
site or test pages in your first post.

IE Developer Center
http://msdn.microsoft.com/en-us/ie/default.aspx

Learn IE8
http://msdn.microsoft.com/en-us/ie/aa740473.aspx

HTML and DHTML Overviews and Tutorials
http://msdn.microsoft.com/en-us/library/ms537623.aspx and

Cascading Style Sheets (CSS)
http://msdn2.microsoft.com/en-us/ie/aa740476.aspx

Expression Web SuperPreview for Internet Explorer (free, stand-alone visual
debugging tool for IE6, IE7, and IE8)
http://www.microsoft.com/downloads/d...b-dccff3fae677

Expression Web SuperPreview Release Notes
http://www.microsoft.com/expression/...easeNotes.aspx

Validators:
http://validator.w3.org/
http://jigsaw.w3.org/css-validator/


kfoxweatherfox wrote:
> With IE 8 my links *to go from one page to a different page* on my website
> do not show up however the website works just fine in chrome, firefox and
> earlier versions of IE. Any clues how to fix this?
>
> IF you need the website it is www.kfoxweatherfox.com. On the left hand
> side
> should be a whole list of pages to go to such as knowledge, photos etc.


Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
website links in IE8 fjs69xr7 microsoft.public.internetexplorer.general 3 03-30-2010 18:41
How to separate Explorer taskbar links and IE7 toolbar links (break the link to work independently) icandoitto Internet 0 03-26-2010 06:12
Website email links not working Dovie microsoft.public.windows.vista.mail 4 06-14-2009 23:09
Links to Website don't work Dotty microsoft.public.windows.vista.mail 5 07-29-2008 07:39
Major pirate website tv-links.co.uk shut down Steve Security News 0 10-22-2007 02:24




All times are GMT +1. The time now is 10:52.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120