Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

IE not able to display documents with invalid certificate. Fix?

microsoft.public.internetexplorer.general






Speedup My PC
Reply
  #1 (permalink)  
Old 03-22-2010
Michael Moser
 

Posts: n/a
IE not able to display documents with invalid certificate. Fix?
I suddenly have again the effect that IE suddenly is unable to display
documents that come with an invalid certificate (it's IE8 in my case now,
but I had that very same effect already about a year ago with IE7 and it
drove me nuts since many of our company internal webpages use invalid SLL
certificates and they were suddenly not usable any more with IE).

The effect manifest such, that there is first the warning page stating that
"There is a problem with the website's security certificate". If I then
click on the red "continue to this website" link I DO NOT get the requested
webpage but rather I see a page "Internet Explorer can not display the
webpage" with a URL that reads "res://ieframe.dll".

My suspicion is, that this has to do with an apparently failed or half-baken
uninstallation of Google Chrome (which I had given another test run last
week and then de-installed it. I now recall, that I had done that also last
year without realizing that connection). After Chrome's deinstall last week
in many applications (e.g. Outlook) clicking onto URLs didn't work any more.
I then had to manually fix this by editing the registry and manually
replacing a few entries left over by Chrome with pointers to IE.

My suspicion now is, that this sudden bad handling of non-valid webpages is
also due to some Chrome leftovers.

Any ideas? Suggestions? Have others encountered that as well and maybe found
ways to fix this?
Michael



Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 03-22-2010
rob^_^
 

Posts: n/a
Re: IE not able to display documents with invalid certificate. Fix?
Hi Michael,

Chrome has a habit of hijacking the Windows default web browser settings
(there is a setting to prompt before, but you may have turned it off)

Not knowing your Windows version we cannot give specific instructions, but
the aim is to reset IE as your default browser... this will reset the
registry keys that determine what programs to open links and the like with.

From IE try Tools>Internet Options - Programs tab, there are settings there
to prompt if IE is not the default browser. Enabling that, then the next
time you start IE you should see a prompt and accepting it will
automatically re-establish IE as the default.

Vista and Win7 have control panel applets to manage default programs and
associations.

Invalid certs.... you have probably playing around with IE's security zone
settings (in the hope of "getting things to work")....
"My suspicion now is, that this sudden bad handling of non-valid webpages
is
> also due to some Chrome leftovers." - no... you have probably changed
> things in IE after the fact in the hope of fixing the first issue with
> links not working.


Tools>Internet Options - Security tab, click "Reset all zones to default"

Check your Intranet zone settings.... the default security setting for
certificates in that zone allow invalid certs. Usually you let IE
automatically detect sites that are in the Intranet zone. Your company may
have a Group Policy in effect. Consult your Network administrators before
customizing the list of sites in the Intranet zone.

Also ensure that you do not have any intranet sites(servers) in the Trusted
Sites zone. Remove them from there.

Any public web sites that present invalid certs, be aware of. Click on the
Smart Address bar security icon to view the details. I am not going to tell
you how to turn off the warning, because you shouldn't. Web sites have to
make their sites safe and secure. IE issues those warnings for public sites
for good reason.

Most companies have stipsteam builds of IE and can reset your browser quite
easily. They may be able to save you the bother and get your PC and browser
back to the way it was.

Lucky you did not try the new Opera.

"Michael Moser" <michael.nospam.moser@nospam.freesurf.ch> wrote in message
news:66135303-324B-40A2-BCB1-73E64C3B4CE2@microsoft.com...
> I suddenly have again the effect that IE suddenly is unable to display
> documents that come with an invalid certificate (it's IE8 in my case now,
> but I had that very same effect already about a year ago with IE7 and it
> drove me nuts since many of our company internal webpages use invalid SLL
> certificates and they were suddenly not usable any more with IE).
>
> The effect manifest such, that there is first the warning page stating
> that "There is a problem with the website's security certificate". If I
> then click on the red "continue to this website" link I DO NOT get the
> requested webpage but rather I see a page "Internet Explorer can not
> display the webpage" with a URL that reads "res://ieframe.dll".
>
> My suspicion is, that this has to do with an apparently failed or
> half-baken uninstallation of Google Chrome (which I had given another test
> run last week and then de-installed it. I now recall, that I had done that
> also last year without realizing that connection). After Chrome's
> deinstall last week in many applications (e.g. Outlook) clicking onto URLs
> didn't work any more. I then had to manually fix this by editing the
> registry and manually replacing a few entries left over by Chrome with
> pointers to IE.
>
> My suspicion now is, that this sudden bad handling of non-valid webpages
> is also due to some Chrome leftovers.
>
> Any ideas? Suggestions? Have others encountered that as well and maybe
> found ways to fix this?
> Michael
>
>
>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Old or invalid data on browser display Al Froeschl microsoft.public.internetexplorer.general 4 08-18-2008 01:44
Google using invalid security certificate Steve Security News 0 06-20-2008 22:20
Re: Can only display PDF documents when protected mode is off PA Bear [MS MVP] microsoft.public.windows.vista.security 1 01-26-2008 08:47
Display Excel and Word Documents in Web Browser? plamoise microsoft.public.windows.vista.general 1 01-23-2008 05:48
Article ID: 932156 You cannot view certificate information in Windows Internet Explorer 7 or in Certificate Manager after you successfully import a certificate on a Windows Vista-based computer KBArticles English 0 10-22-2007 20:00




All times are GMT +1. The time now is 05:00.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120