Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

mappoint control on IE7 problem

microsoft.public.internetexplorer.general






Speedup My PC
Reply
  #1 (permalink)  
Old 10-22-2009
vcname
 

Posts: n/a
mappoint control on IE7 problem
Hello,

I have a problem to load mappoint activeX control on IE7. I have this small
html file:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html
xmlns="http://www.w3.org/1999/xhtml"
xmlns:v="urn:schemas-microsoft-com:vml"><head><meta
http-equiv="Content-Type" content="text/html; charset=iso-8859-1"
/><title>Hidden Map Window</title><script language="javascript"
src="/lib/modalWindow.js"></script>

<script language="javascript">


function initMap() {


objMappointControl.NewMap(1);

}

</script>

</head>
<body >

<object classid='CLSID:8F78D7FC-BAE4-46A4-A79A-052356AB3DD4'
id="objMappointControl" height='100%' width='100%'>
<param name=BorderStyle value=0>
<param name=MousePointer value=0>
<param name=TabStop value=-1>
<param name=Appearance value=1>
<param name=PaneState value=3>
<param name=UnitsOfMeasure value=0>
</object>

<SCRIPT language="javascript">
setTimeout("initMap();",2000);
</SCRIPT>


</body>
</html>

its working fine on IE6, but not on IE7. Have blank page.

Also I set security Settings for Internet zone to be enabled for "Initialize
and script ActiveX controls not marked as safe for scripting(not secure)",
its help for IE6, but not for IE7. Can you help me with this problem?

Thanks in advance.


Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 10-22-2009
rob^_^
 

Posts: n/a
Re: mappoint control on IE7 problem
Hi VC,

Your body is headless.

See W3schools.com or validate your markup at validator.w3.org. Also note
that native VML is no longer supported in IE8.

Regards.

"vcname" <vchichkina@digimap.com> wrote in message
news:urGnrqyUKHA.1092@TK2MSFTNGP02.phx.gbl...
> Hello,
>
> I have a problem to load mappoint activeX control on IE7. I have this
> small html file:
>
> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
> "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html
> xmlns="http://www.w3.org/1999/xhtml"
> xmlns:v="urn:schemas-microsoft-com:vml"><head><meta
> http-equiv="Content-Type" content="text/html; charset=iso-8859-1"
> /><title>Hidden Map Window</title><script language="javascript"
> src="/lib/modalWindow.js"></script>
>
> <script language="javascript">
>
>
> function initMap() {
>
>
> objMappointControl.NewMap(1);
>
> }
>
> </script>
>
> </head>
> <body >
>
> <object classid='CLSID:8F78D7FC-BAE4-46A4-A79A-052356AB3DD4'
> id="objMappointControl" height='100%' width='100%'>
> <param name=BorderStyle value=0>
> <param name=MousePointer value=0>
> <param name=TabStop value=-1>
> <param name=Appearance value=1>
> <param name=PaneState value=3>
> <param name=UnitsOfMeasure value=0>
> </object>
>
> <SCRIPT language="javascript">
> setTimeout("initMap();",2000);
> </SCRIPT>
>
>
> </body>
> </html>
>
> its working fine on IE6, but not on IE7. Have blank page.
>
> Also I set security Settings for Internet zone to be enabled for
> "Initialize and script ActiveX controls not marked as safe for
> scripting(not secure)", its help for IE6, but not for IE7. Can you help me
> with this problem?
>
> Thanks in advance.
>

Reply With Quote
  #3 (permalink)  
Old 10-22-2009
Donald Anadell
 

Posts: n/a
Re: mappoint control on IE7 problem

"vcname" <vchichkina@digimap.com> wrote in message
news:urGnrqyUKHA.1092@TK2MSFTNGP02.phx.gbl...
> Hello,
>
> I have a problem to load mappoint activeX control on IE7. I have this
> small html file:
>
> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
> "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html
> xmlns="http://www.w3.org/1999/xhtml"
> xmlns:v="urn:schemas-microsoft-com:vml"><head><meta
> http-equiv="Content-Type" content="text/html; charset=iso-8859-1"
> /><title>Hidden Map Window</title><script language="javascript"
> src="/lib/modalWindow.js"></script>
>
> <script language="javascript">
>
>
> function initMap() {
>
>
> objMappointControl.NewMap(1);
>
> }
>
> </script>
>
> </head>
> <body >
>
> <object classid='CLSID:8F78D7FC-BAE4-46A4-A79A-052356AB3DD4'
> id="objMappointControl" height='100%' width='100%'>
> <param name=BorderStyle value=0>
> <param name=MousePointer value=0>
> <param name=TabStop value=-1>
> <param name=Appearance value=1>
> <param name=PaneState value=3>
> <param name=UnitsOfMeasure value=0>
> </object>
>
> <SCRIPT language="javascript">
> setTimeout("initMap();",2000);
> </SCRIPT>
>
>
> </body>
> </html>
>
> its working fine on IE6, but not on IE7. Have blank page.
>


> Also I set security Settings for Internet zone to be enabled for
> "Initialize and script ActiveX controls not marked as safe for
> scripting(not secure)", its help for IE6, but not for IE7. Can you help me
> with this problem?


Have you also tried enabling "Binary and Script Behaviors" in the Internet
Zone. VML will not render unless that item is enabled.

Good luck,

Donald Anadell


>
> Thanks in advance.
>



Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Printing, UAC, and Mappoint 2009 BrianB microsoft.public.windows.vista.general 1 06-19-2009 16:52
MapPoint - No printers are installed (but they are) BrianB microsoft.public.windows.vista.general 4 06-11-2009 07:05
Error trying to re-install MapPoint rmducks Windows Vista General 0 06-19-2008 22:10
Error trying to re-install MapPoint rmducks Windows Vista General 0 06-19-2008 22:01
mappoint 2004 and vista home greenmachine microsoft.public.windows.vista.general 1 09-28-2007 21:15




All times are GMT +1. The time now is 17:50.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120