Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Open With List Problem

microsoft.public.internetexplorer.general






Speedup My PC
Reply
  #1 (permalink)  
Old 04-24-2009
HTFiddler
 

Posts: n/a
Open With List Problem
This problem with the Open List crops up every few months, and I would
like to get it solved. Internet Explorer normally ignores the Open
With List for security reasons, and instead opens files based on
content, not file extension. This is known as "MIME sniffing" or
"type sniffing". I appreciate the security measures, however this
wreaks havoc when certain ill-behaved applications usurp file
extensions.

In this most recent nasty, my .ogg audio files are set to open with
Windows Media Player (WMP), which they do, if I open the file from my
hard drive. And until recently if I clicked on a webpage with an
"AudioFile.ogg" link, Explorer would also open with WMP. However I
recently installed the rogue "Sony Vegas Pro" which has rudely taken
over the .ogg extension, and did so without asking or notifying me!
So my .ogg's still open fine from the hard drive, but from webpages,
they now open with Vegas! Yuck!

I've checked the Vegas Options: Preferences dialog, all tabs. I've
checked Vegas Help, all menus, and Users Manual. I've edited the
OpenWithList in the Registry (Win XP Pro SP2). All to no avail. I
can't find anything in the registry that gives Vegas control over
file extensions. When I delete the Vegas key from the OpenWithList,
something keeps popping that key back in!

My attempts at getting support from Sony haven't been unsuccessful,
and I'm thinking there must be something I can do to fix this with the
registry, but what? It seems that Windows should have some way of
blocking these rogue beasts from usurping file extensions without
permission!

Incidentally, I did try disabling the content type sniffing in
Internet Properties, rebooted, and that doesn't work either. NOTHING
WORKS!!!

Any info greatly appreciated and please email me offlist if you reply
here: htfiddler@gmail.com

Thanks everyone,
Henry Fiddler
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 04-24-2009
Leonard Grey
 

Posts: n/a
Re: Open With List Problem
There's a few more newsgroups you forgot to cross-post to.
---
Leonard Grey
Errare humanum est

HTFiddler wrote:
> This problem with the Open List crops up every few months, and I would
> like to get it solved. Internet Explorer normally ignores the Open
> With List for security reasons, and instead opens files based on
> content, not file extension. This is known as "MIME sniffing" or
> "type sniffing". I appreciate the security measures, however this
> wreaks havoc when certain ill-behaved applications usurp file
> extensions.
>
> In this most recent nasty, my .ogg audio files are set to open with
> Windows Media Player (WMP), which they do, if I open the file from my
> hard drive. And until recently if I clicked on a webpage with an
> "AudioFile.ogg" link, Explorer would also open with WMP. However I
> recently installed the rogue "Sony Vegas Pro" which has rudely taken
> over the .ogg extension, and did so without asking or notifying me!
> So my .ogg's still open fine from the hard drive, but from webpages,
> they now open with Vegas! Yuck!
>
> I've checked the Vegas Options: Preferences dialog, all tabs. I've
> checked Vegas Help, all menus, and Users Manual. I've edited the
> OpenWithList in the Registry (Win XP Pro SP2). All to no avail. I
> can't find anything in the registry that gives Vegas control over
> file extensions. When I delete the Vegas key from the OpenWithList,
> something keeps popping that key back in!
>
> My attempts at getting support from Sony haven't been unsuccessful,
> and I'm thinking there must be something I can do to fix this with the
> registry, but what? It seems that Windows should have some way of
> blocking these rogue beasts from usurping file extensions without
> permission!
>
> Incidentally, I did try disabling the content type sniffing in
> Internet Properties, rebooted, and that doesn't work either. NOTHING
> WORKS!!!
>
> Any info greatly appreciated and please email me offlist if you reply
> here: htfiddler@gmail.com
>
> Thanks everyone,
> Henry Fiddler

Reply With Quote
  #3 (permalink)  
Old 04-24-2009
Bill in Co.
 

Posts: n/a
Re: Open With List Problem
Well, he clearly thinks HIS problems are so important that they transcend
all newsgroups! Typical newager attitude.

Leonard Grey wrote:
> There's a few more newsgroups you forgot to cross-post to.
> ---
> Leonard Grey
> Errare humanum est
>
> HTFiddler wrote:
>> This problem with the Open List crops up every few months, and I would
>> like to get it solved. Internet Explorer normally ignores the Open
>> With List for security reasons, and instead opens files based on
>> content, not file extension. This is known as "MIME sniffing" or
>> "type sniffing". I appreciate the security measures, however this
>> wreaks havoc when certain ill-behaved applications usurp file
>> extensions.
>>
>> In this most recent nasty, my .ogg audio files are set to open with
>> Windows Media Player (WMP), which they do, if I open the file from my
>> hard drive. And until recently if I clicked on a webpage with an
>> "AudioFile.ogg" link, Explorer would also open with WMP. However I
>> recently installed the rogue "Sony Vegas Pro" which has rudely taken
>> over the .ogg extension, and did so without asking or notifying me!
>> So my .ogg's still open fine from the hard drive, but from webpages,
>> they now open with Vegas! Yuck!
>>
>> I've checked the Vegas Options: Preferences dialog, all tabs. I've
>> checked Vegas Help, all menus, and Users Manual. I've edited the
>> OpenWithList in the Registry (Win XP Pro SP2). All to no avail. I
>> can't find anything in the registry that gives Vegas control over
>> file extensions. When I delete the Vegas key from the OpenWithList,
>> something keeps popping that key back in!
>>
>> My attempts at getting support from Sony haven't been unsuccessful,
>> and I'm thinking there must be something I can do to fix this with the
>> registry, but what? It seems that Windows should have some way of
>> blocking these rogue beasts from usurping file extensions without
>> permission!
>>
>> Incidentally, I did try disabling the content type sniffing in
>> Internet Properties, rebooted, and that doesn't work either. NOTHING
>> WORKS!!!
>>
>> Any info greatly appreciated and please email me offlist if you reply
>> here: htfiddler@gmail.com
>>
>> Thanks everyone,
>> Henry Fiddler



Reply With Quote
  #4 (permalink)  
Old 04-25-2009
Jonathan Harker
 

Posts: n/a
Re: Open With List Problem
On Fri, 24 Apr 2009 16:50:06 -0600, "Bill in Co."
<not_really_here@earthlink.net> wrote:

>Well, he clearly thinks HIS problems are so important that they transcend
>all newsgroups! Typical newager attitude.


What's a "newager". You use that frequently.

Is it everyone younger than you (easy to do) that thinks a little
differently than you (easy to do)?
Reply With Quote
  #5 (permalink)  
Old 04-25-2009
The Real Truth [MS MVP]
 

Posts: n/a
Re: Open With List Problem
Spoken like a true troll.



--
The Real Truth http://pcbutts1-therealtruth.blogspot.com/
*WARNING* Do NOT follow any advice given by the people listed below.
They do NOT have the expertise or knowledge to fix your issue. Do not waste
your time.
David H Lipman, Malke, PA Bear, Beauregard T. Shagnasty, Leythos.




"Leonard Grey" <l.grey@invalid.invalid> wrote in message
news:ux2oT0SxJHA.4856@TK2MSFTNGP02.phx.gbl...
> There's a few more newsgroups you forgot to cross-post to.
> ---
> Leonard Grey
> Errare humanum est
>
> HTFiddler wrote:
>> This problem with the Open List crops up every few months, and I would
>> like to get it solved. Internet Explorer normally ignores the Open
>> With List for security reasons, and instead opens files based on
>> content, not file extension. This is known as "MIME sniffing" or
>> "type sniffing". I appreciate the security measures, however this
>> wreaks havoc when certain ill-behaved applications usurp file
>> extensions.
>>
>> In this most recent nasty, my .ogg audio files are set to open with
>> Windows Media Player (WMP), which they do, if I open the file from my
>> hard drive. And until recently if I clicked on a webpage with an
>> "AudioFile.ogg" link, Explorer would also open with WMP. However I
>> recently installed the rogue "Sony Vegas Pro" which has rudely taken
>> over the .ogg extension, and did so without asking or notifying me!
>> So my .ogg's still open fine from the hard drive, but from webpages,
>> they now open with Vegas! Yuck!
>>
>> I've checked the Vegas Options: Preferences dialog, all tabs. I've
>> checked Vegas Help, all menus, and Users Manual. I've edited the
>> OpenWithList in the Registry (Win XP Pro SP2). All to no avail. I
>> can't find anything in the registry that gives Vegas control over
>> file extensions. When I delete the Vegas key from the OpenWithList,
>> something keeps popping that key back in!
>>
>> My attempts at getting support from Sony haven't been unsuccessful,
>> and I'm thinking there must be something I can do to fix this with the
>> registry, but what? It seems that Windows should have some way of
>> blocking these rogue beasts from usurping file extensions without
>> permission!
>>
>> Incidentally, I did try disabling the content type sniffing in
>> Internet Properties, rebooted, and that doesn't work either. NOTHING
>> WORKS!!!
>>
>> Any info greatly appreciated and please email me offlist if you reply
>> here: htfiddler@gmail.com
>>
>> Thanks everyone,
>> Henry Fiddler


Reply With Quote
  #6 (permalink)  
Old 04-25-2009
The Real Truth [MS MVP]
 

Posts: n/a
Re: Open With List Problem
Spoken like a true troll.

--
The Real Truth http://pcbutts1-therealtruth.blogspot.com/
*WARNING* Do NOT follow any advice given by the people listed below.
They do NOT have the expertise or knowledge to fix your issue. Do not waste
your time.
David H Lipman, Malke, PA Bear, Beauregard T. Shagnasty, Leythos.




"Bill in Co." <not_really_here@earthlink.net> wrote in message
news:Or0LG8SxJHA.5592@TK2MSFTNGP04.phx.gbl...
> Well, he clearly thinks HIS problems are so important that they transcend
> all newsgroups! Typical newager attitude.
>
> Leonard Grey wrote:
>> There's a few more newsgroups you forgot to cross-post to.
>> ---
>> Leonard Grey
>> Errare humanum est
>>
>> HTFiddler wrote:
>>> This problem with the Open List crops up every few months, and I would
>>> like to get it solved. Internet Explorer normally ignores the Open
>>> With List for security reasons, and instead opens files based on
>>> content, not file extension. This is known as "MIME sniffing" or
>>> "type sniffing". I appreciate the security measures, however this
>>> wreaks havoc when certain ill-behaved applications usurp file
>>> extensions.
>>>
>>> In this most recent nasty, my .ogg audio files are set to open with
>>> Windows Media Player (WMP), which they do, if I open the file from my
>>> hard drive. And until recently if I clicked on a webpage with an
>>> "AudioFile.ogg" link, Explorer would also open with WMP. However I
>>> recently installed the rogue "Sony Vegas Pro" which has rudely taken
>>> over the .ogg extension, and did so without asking or notifying me!
>>> So my .ogg's still open fine from the hard drive, but from webpages,
>>> they now open with Vegas! Yuck!
>>>
>>> I've checked the Vegas Options: Preferences dialog, all tabs. I've
>>> checked Vegas Help, all menus, and Users Manual. I've edited the
>>> OpenWithList in the Registry (Win XP Pro SP2). All to no avail. I
>>> can't find anything in the registry that gives Vegas control over
>>> file extensions. When I delete the Vegas key from the OpenWithList,
>>> something keeps popping that key back in!
>>>
>>> My attempts at getting support from Sony haven't been unsuccessful,
>>> and I'm thinking there must be something I can do to fix this with the
>>> registry, but what? It seems that Windows should have some way of
>>> blocking these rogue beasts from usurping file extensions without
>>> permission!
>>>
>>> Incidentally, I did try disabling the content type sniffing in
>>> Internet Properties, rebooted, and that doesn't work either. NOTHING
>>> WORKS!!!
>>>
>>> Any info greatly appreciated and please email me offlist if you reply
>>> here: htfiddler@gmail.com
>>>
>>> Thanks everyone,
>>> Henry Fiddler

>
>


Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I open Distribution list once its in the email? milamo microsoft.public.windows.vista.mail 2 03-02-2009 20:32
Problem copying list of contacts into a new group list Terry Fenimore microsoft.public.windows.vista.mail 1 02-28-2009 19:47
remove list of files from open dialog box js microsoft.public.windows.vista.general 0 11-01-2007 10:29
Open file drop menu List Phil [300003] microsoft.public.windows.vista.general 0 02-22-2007 21:13




All times are GMT +1. The time now is 15:07.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120