Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Opening Intranet webpage with Host Header

microsoft.public.internetexplorer.general






Speedup My PC
Reply
  #1 (permalink)  
Old 03-17-2009
jmarks
 

Posts: n/a
Opening Intranet webpage with Host Header
I wasn't sure whether to post this under the Vista section, in the server
section, or in IE7 because I'm not sure where the problem resides.

We are hosting a sharepoint website on a server 2003 computer running IIS 6.
I set up host headers in IIS and Access Mappings in WSS, and everything works
perfectly for workstations with XP Pro. The workstations that are running
Windows Vista Business cannot connect to the site via the host header name.

All clients are running IE7, and are up to date. I have added
http://intranet.company.net to all intranet zones and trusted zones on the
vista workstations. The IP address of the server is being resolved just fine
when using the host header value.

I'm lost. =P
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 03-17-2009
jmarks
 

Posts: n/a
RE: Opening Intranet webpage with Host Header
We modified the hosts file on the vista machine, we just added:

server.ip.address.x intranet.company.net

And the freaking thing worked! It isn't the fix I'm looking for though,
because it is a rigged way to fix that problem. Is there any way I can set
something to make the website work without having to modify the hosts file on
every Vista workstation we have?

"jmarks" wrote:

> I wasn't sure whether to post this under the Vista section, in the server
> section, or in IE7 because I'm not sure where the problem resides.
>
> We are hosting a sharepoint website on a server 2003 computer running IIS 6.
> I set up host headers in IIS and Access Mappings in WSS, and everything works
> perfectly for workstations with XP Pro. The workstations that are running
> Windows Vista Business cannot connect to the site via the host header name.
>
> All clients are running IE7, and are up to date. I have added
> http://intranet.company.net to all intranet zones and trusted zones on the
> vista workstations. The IP address of the server is being resolved just fine
> when using the host header value.
>
> I'm lost. =P

Reply With Quote
  #3 (permalink)  
Old 03-18-2009
Daniel Crichton
 

Posts: n/a
Re: Opening Intranet webpage with Host Header
You need to add the server IP and it's host name to your DNS servers.

Dan

jmarks wrote on Tue, 17 Mar 2009 13:27:02 -0700:

> We modified the hosts file on the vista machine, we just added:


> server.ip.address.x intranet.company.net


> And the freaking thing worked! It isn't the fix I'm looking for though,
> because it is a rigged way to fix that problem. Is there any way I can
> set something to make the website work without having to modify the
> hosts file on every Vista workstation we have?


> "jmarks" wrote:


>> I wasn't sure whether to post this under the Vista section, in the
>> server section, or in IE7 because I'm not sure where the problem
>> resides.


>> We are hosting a sharepoint website on a server 2003 computer running
>> IIS 6.
>> I set up host headers in IIS and Access Mappings in WSS, and
>> everything works perfectly for workstations with XP Pro. The
>> workstations that are running
>> Windows Vista Business cannot connect to the site via the host header
>> name.


>> All clients are running IE7, and are up to date. I have added
>> http://intranet.company.net to all intranet zones and trusted zones
>> on the vista workstations. The IP address of the server is being
>> resolved just fine when using the host header value.


>> I'm lost. =P



Reply With Quote
  #4 (permalink)  
Old 03-18-2009
jmarks
 

Posts: n/a
Re: Opening Intranet webpage with Host Header
I already did that. I told you that the workstation is resolving the hostname
to the IP address just fine. I can open up command prompt, run nslookup, and
type in intranet.company.net and it resolves to the proper ip address just
fine.

If it was a DNS issue, the XP workstations would be having the same issue...

"Daniel Crichton" wrote:

> You need to add the server IP and it's host name to your DNS servers.
>
> Dan
>
> jmarks wrote on Tue, 17 Mar 2009 13:27:02 -0700:
>
> > We modified the hosts file on the vista machine, we just added:

>
> > server.ip.address.x intranet.company.net

>
> > And the freaking thing worked! It isn't the fix I'm looking for though,
> > because it is a rigged way to fix that problem. Is there any way I can
> > set something to make the website work without having to modify the
> > hosts file on every Vista workstation we have?

>
> > "jmarks" wrote:

>
> >> I wasn't sure whether to post this under the Vista section, in the
> >> server section, or in IE7 because I'm not sure where the problem
> >> resides.

>
> >> We are hosting a sharepoint website on a server 2003 computer running
> >> IIS 6.
> >> I set up host headers in IIS and Access Mappings in WSS, and
> >> everything works perfectly for workstations with XP Pro. The
> >> workstations that are running
> >> Windows Vista Business cannot connect to the site via the host header
> >> name.

>
> >> All clients are running IE7, and are up to date. I have added
> >> http://intranet.company.net to all intranet zones and trusted zones
> >> on the vista workstations. The IP address of the server is being
> >> resolved just fine when using the host header value.

>
> >> I'm lost. =P

>
>
>

Reply With Quote
  #5 (permalink)  
Old 03-18-2009
Robert Aldwinckle
 

Posts: n/a
Re: Opening Intranet webpage with Host Header

"jmarks" <jmarks@discussions.microsoft.com> wrote in message news:27BF3E34-43F9-48FA-A982-74F0D1320826@microsoft.com...
>I already did that. I told you that the workstation is resolving the hostname
> to the IP address just fine. I can open up command prompt, run nslookup, and
> type in intranet.company.net and it resolves to the proper ip address just
> fine.
>
> If it was a DNS issue, the XP workstations would be having the same issue...



It can still be a "DNS issue" if the timings are different.
You would use netmon to trace to the two cases and compare
the timings. You could also trace the two cases of with
and without HOSTS entries.

BTW provided the TTL value of the DNS A record is high
enough for you to make use of a cached lookup you could
also do this:
1. ping -n 1 the host server name
2. ping -n 1 any alias name involved
3. use ipconfig /displaydns to confirm that there is
a usable A record for accessing the host server cached
and that you have enough time for IE to use it.
Then there would be no difference between having IE use a
hardcoded entry in the HOSTS file or that one. You could
trace the timings involved for those cases too.


Good luck

Robert Aldwinckle
---


>
> "Daniel Crichton" wrote:
>
>> You need to add the server IP and it's host name to your DNS servers.
>>
>> Dan
>>
>> jmarks wrote on Tue, 17 Mar 2009 13:27:02 -0700:
>>
>> > We modified the hosts file on the vista machine, we just added:

>>
>> > server.ip.address.x intranet.company.net

>>
>> > And the freaking thing worked! It isn't the fix I'm looking for though,
>> > because it is a rigged way to fix that problem. Is there any way I can
>> > set something to make the website work without having to modify the
>> > hosts file on every Vista workstation we have?

>>
>> > "jmarks" wrote:

>>
>> >> I wasn't sure whether to post this under the Vista section, in the
>> >> server section, or in IE7 because I'm not sure where the problem
>> >> resides.

>>
>> >> We are hosting a sharepoint website on a server 2003 computer running
>> >> IIS 6.
>> >> I set up host headers in IIS and Access Mappings in WSS, and
>> >> everything works perfectly for workstations with XP Pro. The
>> >> workstations that are running
>> >> Windows Vista Business cannot connect to the site via the host header
>> >> name.

>>
>> >> All clients are running IE7, and are up to date. I have added
>> >> http://intranet.company.net to all intranet zones and trusted zones
>> >> on the vista workstations. The IP address of the server is being
>> >> resolved just fine when using the host header value.

>>
>> >> I'm lost. =P

>>
>>
>>



Reply With Quote
  #6 (permalink)  
Old 03-18-2009
jmarks
 

Posts: n/a
Re: Opening Intranet webpage with Host Header
So,

I think I figured out the real question here.
When I set up the DNS entry for my intranet site, it just set it up under my
domain (company.local). This makes the FQDN for the site
(intranet.company.net.company.local).
The XP machines resolve intranet.company.net, and automatically assume it is
..company.local at the end.
The Vista machines will only resolve the name if it is
intranet.company.net.company.local.
How do I get the Vista machines to do that?


---------
-JMarks


"Robert Aldwinckle" wrote:

>
> "jmarks" <jmarks@discussions.microsoft.com> wrote in message news:27BF3E34-43F9-48FA-A982-74F0D1320826@microsoft.com...
> >I already did that. I told you that the workstation is resolving the hostname
> > to the IP address just fine. I can open up command prompt, run nslookup, and
> > type in intranet.company.net and it resolves to the proper ip address just
> > fine.
> >
> > If it was a DNS issue, the XP workstations would be having the same issue...

>
>
> It can still be a "DNS issue" if the timings are different.
> You would use netmon to trace to the two cases and compare
> the timings. You could also trace the two cases of with
> and without HOSTS entries.
>
> BTW provided the TTL value of the DNS A record is high
> enough for you to make use of a cached lookup you could
> also do this:
> 1. ping -n 1 the host server name
> 2. ping -n 1 any alias name involved
> 3. use ipconfig /displaydns to confirm that there is
> a usable A record for accessing the host server cached
> and that you have enough time for IE to use it.
> Then there would be no difference between having IE use a
> hardcoded entry in the HOSTS file or that one. You could
> trace the timings involved for those cases too.
>
>
> Good luck
>
> Robert Aldwinckle
> ---
>
>
> >
> > "Daniel Crichton" wrote:
> >
> >> You need to add the server IP and it's host name to your DNS servers.
> >>
> >> Dan
> >>
> >> jmarks wrote on Tue, 17 Mar 2009 13:27:02 -0700:
> >>
> >> > We modified the hosts file on the vista machine, we just added:
> >>
> >> > server.ip.address.x intranet.company.net
> >>
> >> > And the freaking thing worked! It isn't the fix I'm looking for though,
> >> > because it is a rigged way to fix that problem. Is there any way I can
> >> > set something to make the website work without having to modify the
> >> > hosts file on every Vista workstation we have?
> >>
> >> > "jmarks" wrote:
> >>
> >> >> I wasn't sure whether to post this under the Vista section, in the
> >> >> server section, or in IE7 because I'm not sure where the problem
> >> >> resides.
> >>
> >> >> We are hosting a sharepoint website on a server 2003 computer running
> >> >> IIS 6.
> >> >> I set up host headers in IIS and Access Mappings in WSS, and
> >> >> everything works perfectly for workstations with XP Pro. The
> >> >> workstations that are running
> >> >> Windows Vista Business cannot connect to the site via the host header
> >> >> name.
> >>
> >> >> All clients are running IE7, and are up to date. I have added
> >> >> http://intranet.company.net to all intranet zones and trusted zones
> >> >> on the vista workstations. The IP address of the server is being
> >> >> resolved just fine when using the host header value.
> >>
> >> >> I'm lost. =P
> >>
> >>
> >>

>
>
>

Reply With Quote
  #7 (permalink)  
Old 03-18-2009
Daniel Crichton
 

Posts: n/a
Re: Opening Intranet webpage with Host Header
So it is a DNS issue, despite your other reply to me. Why did you put the
hostname intranet.company.net in the company.local domain? Why didn't you
create a new domain called company.net and put a host called intranet in
there? Or why didn't you use intranet for the host name so it's FQDN would
be intranet.company.local? I'd personally never rely on automatic domain
suffix searching, there's always a chance it won't work.

Apparently in Vista you will need to make some registry adjustments to get
it to work like it does on XP. Assuming you have put the domain into your
Vista TCP/IP settings, you will also need to enable the option using one, or
possibly both, of the following:

1. start>run>"gpedit.msc"
2. navigate to "Computer Config>Administrative Templates>Network>DNS Client"
3. enable the following two entries
-allow dns suffix appending to unqualified multi-label name queries
-Primary DNS Suffix Devolution.

and/or

Find HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient" and
change/create a dword value called "AppendToMultiLabelName" and set it to 1,
you may need to restart

However, before doing either of these I'd suggest that you check up to make
sure the information I've provided is correct. I do not have a Vista machine
to test either of these on.

Dan

jmarks wrote on Wed, 18 Mar 2009 07:14:16 -0700:

> So,


> I think I figured out the real question here.
> When I set up the DNS entry for my intranet site, it just set it up
> under my domain (company.local). This makes the FQDN for the site
> (intranet.company.net.company.local).
> The XP machines resolve intranet.company.net, and automatically assume
> it is .company.local at the end.
> The Vista machines will only resolve the name if it is
> intranet.company.net.company.local.
> How do I get the Vista machines to do that?



> ---------
> -JMarks



> "Robert Aldwinckle" wrote:



>> "jmarks" <jmarks@discussions.microsoft.com> wrote in message
>> news:27BF3E34-43F9-48FA-A982-74F0D1320826@microsoft.com...
>>> I already did that. I told you that the workstation is resolving the
>>> hostname to the IP address just fine. I can open up command prompt,
>>> run nslookup, and type in intranet.company.net and it resolves to
>>> the proper ip address just fine.


>>> If it was a DNS issue, the XP workstations would be having the same
>>> issue...



>> It can still be a "DNS issue" if the timings are different.
>> You would use netmon to trace to the two cases and compare the
>> timings. You could also trace the two cases of with and without
>> HOSTS entries.


>> BTW provided the TTL value of the DNS A record is high enough for you
>> to make use of a cached lookup you could also do this:
>> 1. ping -n 1 the host server name
>> 2. ping -n 1 any alias name involved
>> 3. use ipconfig /displaydns to confirm that there is
>> a usable A record for accessing the host server cached and
>> that you have enough time for IE to use it.
>> Then there would be no difference between having IE use a hardcoded
>> entry in the HOSTS file or that one. You could trace the timings
>> involved for those cases too.



>> Good luck


>> Robert Aldwinckle ---




>>> "Daniel Crichton" wrote:


>>>> You need to add the server IP and it's host name to your DNS
>>>> servers.


>>>> Dan


>>>> jmarks wrote on Tue, 17 Mar 2009 13:27:02 -0700:


>>>>> We modified the hosts file on the vista machine, we just added:


>>>>> server.ip.address.x intranet.company.net


>>>>> And the freaking thing worked! It isn't the fix I'm looking for
>>>>> though, because it is a rigged way to fix that problem. Is there
>>>>> any way I can set something to make the website work without
>>>>> having to modify the hosts file on every Vista workstation we
>>>>> have?


>>>>> "jmarks" wrote:


>>>>>> I wasn't sure whether to post this under the Vista section, in
>>>>>> the server section, or in IE7 because I'm not sure where the
>>>>>> problem resides.


>>>>>> We are hosting a sharepoint website on a server 2003 computer
>>>>>> running
>>>>>> IIS 6.
>>>>>> I set up host headers in IIS and Access Mappings in WSS, and
>>>>>> everything works perfectly for workstations with XP Pro. The
>>>>>> workstations that are running
>>>>>> Windows Vista Business cannot connect to the site via the host
>>>>>> header name.


>>>>>> All clients are running IE7, and are up to date. I have added
>>>>>> http://intranet.company.net to all intranet zones and trusted
>>>>>> zones on the vista workstations. The IP address of the server is
>>>>>> being resolved just fine when using the host header value.


>>>>>> I'm lost. =P







Reply With Quote
  #8 (permalink)  
Old 03-18-2009
jmarks
 

Posts: n/a
Closed
You guys were right. It was a DNS issue. I figured it out just before you
responded Daniel. I had to make a new DNS forwarding zone for company.net,
and just add a Host record for Intranet that pointed to the server IP address.

No worries about editing the registry. Thanks for the info though!

Problem solved.

---------
-JMarks


"Daniel Crichton" wrote:

> So it is a DNS issue, despite your other reply to me. Why did you put the
> hostname intranet.company.net in the company.local domain? Why didn't you
> create a new domain called company.net and put a host called intranet in
> there? Or why didn't you use intranet for the host name so it's FQDN would
> be intranet.company.local? I'd personally never rely on automatic domain
> suffix searching, there's always a chance it won't work.
>
> Apparently in Vista you will need to make some registry adjustments to get
> it to work like it does on XP. Assuming you have put the domain into your
> Vista TCP/IP settings, you will also need to enable the option using one, or
> possibly both, of the following:
>
> 1. start>run>"gpedit.msc"
> 2. navigate to "Computer Config>Administrative Templates>Network>DNS Client"
> 3. enable the following two entries
> -allow dns suffix appending to unqualified multi-label name queries
> -Primary DNS Suffix Devolution.
>
> and/or
>
> Find HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient" and
> change/create a dword value called "AppendToMultiLabelName" and set it to 1,
> you may need to restart
>
> However, before doing either of these I'd suggest that you check up to make
> sure the information I've provided is correct. I do not have a Vista machine
> to test either of these on.
>
> Dan
>
> jmarks wrote on Wed, 18 Mar 2009 07:14:16 -0700:
>
> > So,

>
> > I think I figured out the real question here.
> > When I set up the DNS entry for my intranet site, it just set it up
> > under my domain (company.local). This makes the FQDN for the site
> > (intranet.company.net.company.local).
> > The XP machines resolve intranet.company.net, and automatically assume
> > it is .company.local at the end.
> > The Vista machines will only resolve the name if it is
> > intranet.company.net.company.local.
> > How do I get the Vista machines to do that?

>
>
> > ---------
> > -JMarks

>
>
> > "Robert Aldwinckle" wrote:

>
>
> >> "jmarks" <jmarks@discussions.microsoft.com> wrote in message
> >> news:27BF3E34-43F9-48FA-A982-74F0D1320826@microsoft.com...
> >>> I already did that. I told you that the workstation is resolving the
> >>> hostname to the IP address just fine. I can open up command prompt,
> >>> run nslookup, and type in intranet.company.net and it resolves to
> >>> the proper ip address just fine.

>
> >>> If it was a DNS issue, the XP workstations would be having the same
> >>> issue...

>
>
> >> It can still be a "DNS issue" if the timings are different.
> >> You would use netmon to trace to the two cases and compare the
> >> timings. You could also trace the two cases of with and without
> >> HOSTS entries.

>
> >> BTW provided the TTL value of the DNS A record is high enough for you
> >> to make use of a cached lookup you could also do this:
> >> 1. ping -n 1 the host server name
> >> 2. ping -n 1 any alias name involved
> >> 3. use ipconfig /displaydns to confirm that there is
> >> a usable A record for accessing the host server cached and
> >> that you have enough time for IE to use it.
> >> Then there would be no difference between having IE use a hardcoded
> >> entry in the HOSTS file or that one. You could trace the timings
> >> involved for those cases too.

>
>
> >> Good luck

>
> >> Robert Aldwinckle ---

>
>
>
> >>> "Daniel Crichton" wrote:

>
> >>>> You need to add the server IP and it's host name to your DNS
> >>>> servers.

>
> >>>> Dan

>
> >>>> jmarks wrote on Tue, 17 Mar 2009 13:27:02 -0700:

>
> >>>>> We modified the hosts file on the vista machine, we just added:

>
> >>>>> server.ip.address.x intranet.company.net

>
> >>>>> And the freaking thing worked! It isn't the fix I'm looking for
> >>>>> though, because it is a rigged way to fix that problem. Is there
> >>>>> any way I can set something to make the website work without
> >>>>> having to modify the hosts file on every Vista workstation we
> >>>>> have?

>
> >>>>> "jmarks" wrote:

>
> >>>>>> I wasn't sure whether to post this under the Vista section, in
> >>>>>> the server section, or in IE7 because I'm not sure where the
> >>>>>> problem resides.

>
> >>>>>> We are hosting a sharepoint website on a server 2003 computer
> >>>>>> running
> >>>>>> IIS 6.
> >>>>>> I set up host headers in IIS and Access Mappings in WSS, and
> >>>>>> everything works perfectly for workstations with XP Pro. The
> >>>>>> workstations that are running
> >>>>>> Windows Vista Business cannot connect to the site via the host
> >>>>>> header name.

>
> >>>>>> All clients are running IE7, and are up to date. I have added
> >>>>>> http://intranet.company.net to all intranet zones and trusted
> >>>>>> zones on the vista workstations. The IP address of the server is
> >>>>>> being resolved just fine when using the host header value.

>
> >>>>>> I'm lost. =P

>
>
>
>
>
>
>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Opening Intranet webpage with Host Header jmarks microsoft.public.windows.vista.general 7 03-18-2009 15:57
webpage opening .xls sheet, not getting security warning Libby H microsoft.public.internetexplorer.general 1 10-31-2008 21:14
Re: "cannot display the webpage" opening a vaid webpage Doug microsoft.public.internetexplorer.general 0 08-13-2008 04:42
Webpage not opening in IE7 HanLee microsoft.public.windows.vista.general 6 10-01-2007 12:53
Opening Security Center causes Windows Host (rundll32) to crash =?Utf-8?B?Sm9lIFdlbmhhbQ==?= microsoft.public.windows.vista.general 3 03-17-2007 15:35




All times are GMT +1. The time now is 05:47.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120