Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

IE Feeds not showing the latest feed items

microsoft.public.internetexplorer.general






Speedup My PC
Reply
  #1 (permalink)  
Old 03-01-2009
Louis Kessler
 

Posts: n/a
IE Feeds not showing the latest feed items
I've searched all over the web for solutions to this but can't find one, so
this forum is my last hope.

This is NOT the problem of feeds not updating. My feeds are updating fine
and indicating when new items are found. I use a 1 hour default update, and
after an hour some feeds are indicated in bold and have the new content.

What is happening is that for some feeds, IE is sometimes not including the
latest items in the feed. But if I look at the feed with Firefox or send the
feed to feedvalidator, they both show the latest items that IE is not showing.

I am not sure what types of feeds this happens for, but it does for all 4 of
my feeds that are on 2 of my sites. Three of those feeds are produced by
WordPress and one is by bbPress. I have compared the xml in the feed with
other feeds that do not have this problem, and I don't see anything that
might be causing this.

I have attempted just about everything, including deleting IE's feed folder
(it's cache) and changing some of the attributes within the feeds themselves,
and even clearing the WordPress feed cache, but the problem persists.
Because the items are truly in the feed and Firefox and feedvalidator can
read them, I presume it must be a problem with IE.

This problem has been happening for at least the last 6 months in IE 7. I
decided to try the IE 8 release candidate today and hoped this problem would
be fixed. But it happens in IE 8 as well.

Has anyone else notice this happening to them?

Does anyone have any ideas of what may be happening, or any ideas of what I
might try to fix this? Any help would be very much appreciated.

--
Louis Kessler
Winnipeg, Manitoba, Canada

Home: www.lkessler.com
GSR: www.gensoftreviews.com
Behold: www.beholdgenealogy.com
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 03-05-2009
Louis Kessler
 

Posts: n/a
RE: IE Feeds not showing the latest feed items
With much work, I discovered the problem wasn't IE's fault. It was WordPress.
The problem then was a stale “Last-Modified:” header in the HTTP response to
the link to the comments feed.

I have now fixed this in WordPress and everything works fine. If you are
interested, see my blog entry on this problem:
http://www.beholdgenealogy.com/blog/?p=667

--
Louis Kessler
Winnipeg, Manitoba, Canada

Home: www.lkessler.com
GSR: www.gensoftreviews.com
Behold: www.beholdgenealogy.com


"Louis Kessler" wrote:

> I've searched all over the web for solutions to this but can't find one, so
> this forum is my last hope.
>
> This is NOT the problem of feeds not updating. My feeds are updating fine
> and indicating when new items are found. I use a 1 hour default update, and
> after an hour some feeds are indicated in bold and have the new content.
>
> What is happening is that for some feeds, IE is sometimes not including the
> latest items in the feed. But if I look at the feed with Firefox or send the
> feed to feedvalidator, they both show the latest items that IE is not showing.
>
> I am not sure what types of feeds this happens for, but it does for all 4 of
> my feeds that are on 2 of my sites. Three of those feeds are produced by
> WordPress and one is by bbPress. I have compared the xml in the feed with
> other feeds that do not have this problem, and I don't see anything that
> might be causing this.
>
> I have attempted just about everything, including deleting IE's feed folder
> (it's cache) and changing some of the attributes within the feeds themselves,
> and even clearing the WordPress feed cache, but the problem persists.
> Because the items are truly in the feed and Firefox and feedvalidator can
> read them, I presume it must be a problem with IE.
>
> This problem has been happening for at least the last 6 months in IE 7. I
> decided to try the IE 8 release candidate today and hoped this problem would
> be fixed. But it happens in IE 8 as well.
>
> Has anyone else notice this happening to them?
>
> Does anyone have any ideas of what may be happening, or any ideas of what I
> might try to fix this? Any help would be very much appreciated.
>
> --
> Louis Kessler
> Winnipeg, Manitoba, Canada
>
> Home: www.lkessler.com
> GSR: www.gensoftreviews.com
> Behold: www.beholdgenealogy.com

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
New worm feeds on latest Microsoft bug Steve Security News 0 10-27-2008 18:40
New worm feeds on latest Microsoft bug Steve Security News 0 10-27-2008 11:30
New worm feeds on latest Microsoft bug Steve Security News 0 10-26-2008 09:50
NEW URL FOR HNS RSS FEED: http://feeds.feedburner.com/HelpNetSecurity Steve Security News 0 01-16-2008 23:00
NEW URL FOR HNS RSS FEED: http://feeds.feedburner.com/HelpNetSecurity Steve Security News 0 01-16-2008 22:30




All times are GMT +1. The time now is 03:34.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120