Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Mhtml doesn't work in Vista IE7

microsoft.public.internetexplorer.general






Speedup My PC
Reply
  #1 (permalink)  
Old 01-12-2009
sunnybear
 

Posts: n/a
Mhtml doesn't work in Vista IE7
Hi all --

I've encountered a problem with mhtml-images in IE7 @ Vista. It seems that
such image are not shown properly (also I have a report that they are not
shown from cache).

Description: I'm trying to embed mhtml resource into CSS file. Then I'm
trying to use this resource (background image) in the same CSS file using
mhtml: protocol as described below. In IE7 @ XP (IE6 @ XP, etc) it works, in
IE7 @ Vista it doesn't work.

Sample site is http://webo.name/,
CSS file with embedded mhtml is http://webo.name/d.css?20081103.

This is very important because we try to merge data:URI and mhtml:
techniques - so they should cover about 99,9% of browsers. W/o IE7 @ Vista we
have only 90% coverage.

Also we launched a project to automate conversion of background images into
data:URI / mhtml form -- http://duris.ru/ - but we can't proceed successful
w/o IE7 @ Vista.

Can anybody investigate this issue or give any information about it? Thanks
in advance.

--
Speed Up Your Website: http://webo.name/

----------------
This post is a suggestion for Microsoft, and Microsoft responds to the
suggestions with the most votes. To vote for this suggestion, click the "I
Agree" button in the message pane. If you do not see the button, follow this
link to open the suggestion in the Microsoft Web-based Newsreader and then
click "I Agree" in the message pane.

http://www.microsoft.com/communities...orer. general
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 01-12-2009
PA Bear [MS MVP]
 

Posts: n/a
Re: Mhtml doesn't work in Vista IE7
See these MSDN pages: http://msdn2.microsoft.com/en-us/ie/default.aspx and
http://msdn.microsoft.com/en-us/library/ms537623.aspx and
http://msdn2.microsoft.com/en-us/ie/aa740476.aspx

You can also post here instead:

MSDN IE Development Forums
http://forums.microsoft.com/MSDN/def...D=253&SiteID=1
--
~Robear Dyer (PA Bear)
MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
AumHa VSOP & Admin http://aumha.net
DTS-L http://dts-l.net/

sunnybear wrote:
> I've encountered a problem with mhtml-images in IE7 @ Vista. It seems that
> such image are not shown properly (also I have a report that they are not
> shown from cache).
>
> Description: I'm trying to embed mhtml resource into CSS file. Then I'm
> trying to use this resource (background image) in the same CSS file using
> mhtml: protocol as described below. In IE7 @ XP (IE6 @ XP, etc) it works,
> in
> IE7 @ Vista it doesn't work.
>
> Sample site is http://webo.name/,
> CSS file with embedded mhtml is http://webo.name/d.css?20081103.
>
> This is very important because we try to merge data:URI and mhtml:
> techniques - so they should cover about 99,9% of browsers. W/o IE7 @ Vista
> we have only 90% coverage.
>
> Also we launched a project to automate conversion of background images
> into
> data:URI / mhtml form -- http://duris.ru/ - but we can't proceed
> successful
> w/o IE7 @ Vista.
>
> Can anybody investigate this issue or give any information about it?
> Thanks
> in advance.


Reply With Quote
  #3 (permalink)  
Old 01-12-2009
sunnybear
 

Posts: n/a
Re: Mhtml doesn't work in Vista IE7
Robear, sorry, I can't find anything useful on the links you provided. I've
already searched through MSDN and Internet to find the clue to this problem -
nothing. I need something very particular: how to solve this bug/feature or
how to avoid it.

Or I can wait till IE7 developers fix this issue

--
Speed Up Your Website: http://webo.name/
Reply With Quote
  #4 (permalink)  
Old 01-12-2009
sunnybear
 

Posts: n/a
Re: Mhtml doesn't work in Vista IE7
Sorry, it doesn't work for me

"PA Bear [MS MVP]" wrote:

> See these MSDN pages: http://msdn2.microsoft.com/en-us/ie/default.aspx and
> http://msdn.microsoft.com/en-us/library/ms537623.aspx and
> http://msdn2.microsoft.com/en-us/ie/aa740476.aspx
>
> You can also post here instead:
>
> MSDN IE Development Forums
> http://forums.microsoft.com/MSDN/def...D=253&SiteID=1

Reply With Quote
  #5 (permalink)  
Old 01-12-2009
PA Bear [MS MVP]
 

Posts: n/a
Re: Mhtml doesn't work in Vista IE7
Did you post your question(s) in IE Dev Forums yet?...

sunnybear wrote:
> Sorry, it doesn't work for me
>
> "PA Bear [MS MVP]" wrote:
>
>> See these MSDN pages: http://msdn2.microsoft.com/en-us/ie/default.aspx
>> and
>> http://msdn.microsoft.com/en-us/library/ms537623.aspx and
>> http://msdn2.microsoft.com/en-us/ie/aa740476.aspx
>>
>> You can also post here instead:
>>
>> MSDN IE Development Forums
>> http://forums.microsoft.com/MSDN/def...D=253&SiteID=1


Reply With Quote
  #6 (permalink)  
Old 01-12-2009
sunnybear
 

Posts: n/a
Re: Mhtml doesn't work in Vista IE7
oh, I've got it. I'm going to post this issue there. I just don't know the
correct place to ask.

> Did you post your question(s) in IE Dev Forums yet?...
>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cause of Unknown HTM, HTML, MHT, & MHTML File Icon? John microsoft.public.internetexplorer.general 9 01-06-2009 09:50
Missing images in MHTML Terry Rasmussen microsoft.public.internetexplorer.general 9 09-02-2008 14:17
Re: Unable to open mhtml files in IE7 on Windows Vista Robert Aldwinckle microsoft.public.windows.vista.general 0 10-03-2007 21:36
archivos mhtml, como verlos en xp? ellie microsoft.public.es.windowsvista 2 07-05-2007 20:44
Lost html and mhtml file icons antius microsoft.public.windows.vista.general 2 06-16-2007 01:09




All times are GMT +1. The time now is 01:39.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120