Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

IE 7 hanging due to modal dialog box

microsoft.public.internetexplorer.general






Speedup My PC
Reply
  #1 (permalink)  
Old 11-19-2008
aquinn_21
 

Posts: n/a
IE 7 hanging due to modal dialog box
IE 7 hangs completely and only way to resume is by killing it from Task
Manager, when we make some changes in a modal dialog that is used for our
application. This behavior is seen in all Windows XP Machines SP2 having IE
7.

The exact problem that we are facing can be found from here :
http://support.microsoft.com/kb/935903

Our Scenario:
When we click on certain link in our application "Add Delta Details" we have
a model dialog that opens. It has 3 buttons in it "Save", "Complete" and
"Save(Complete)" and some text boxes and drop down boxes. Once it is opened
if we perform some changes in the text boxes or drop down boxes and click on
any of the above buttons the IE 7 just hangs and we have to close it from
Task Manager. Ideally once we click on the button the previous page
containing the link should appear.

We have partially resolved the issue by installing the below hotfix:
Microsoft Security Bulletin MS07-045 - Critical
Cumulative Security Update for Internet Explorer (937143).

When I say partially when we are testing our application from some of the
systems which did not have any previously installed hotfixes for the Internet
explorer, it's working fine after installing this. But if a system has any
other hotfix installed and then this is installed, the hanging behaviour
reappears.

So in those systems I removed the exisitng cumulative updates and installed
this hotfix. The problem remains. I have also uninstalled IE7 completely and
installed only this hotfix but the IE still hangs. Can someone please help me
if there are any other way old hotfixes can be completely removed and then
installed like a fresh installation? As I said for a system without any
security updates installed, and then installing the above fix it's working
fine.

I have already posted this query at MSDN forums but there has been no
response. So I thought may be this is a better place to post and it can be
found here:
http://forums.microsoft.com/msdn/Sho...12099&SiteID=1

It's a very critical issue we are facing and we need this fixed as early as
possible. Any help would be deeply appreciated. Please let me know if you
need any other information.

Thank you

Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 11-19-2008
PA Bear [MS MVP]
 

Posts: n/a
Re: IE 7 hanging due to modal dialog box
<QP>
To resolve this problem, install the most current cumulative security update
for Internet Explorer.
</QP>
Source: http://support.microsoft.com/kb/935903

The most current cumulative security update for IE is
http://support.microsoft.com/kb/956390 (Oct-08) while KB937143 dates from
Aug-07. Did you see this behavior with KB956390 installed?

Does the behavior persist if you start IE7 in No Add-ons mode?

Does the behavior persist if you Reset IE7 Advanced settings (RIES)?
http://support.microsoft.com/kb/923737 <= Read before using!

Does the behavior persist in IE6 and/or IE8 Beta 2?
--
~Robear Dyer (PA Bear)
MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
AumHa VSOP & Admin http://aumha.net
DTS-L http://dts-l.net/

aquinn_21 wrote:
> IE 7 hangs completely and only way to resume is by killing it from Task
> Manager, when we make some changes in a modal dialog that is used for our
> application. This behavior is seen in all Windows XP Machines SP2 having
> IE
> 7.
>
> The exact problem that we are facing can be found from here :
> http://support.microsoft.com/kb/935903
>
> Our Scenario:
> When we click on certain link in our application "Add Delta Details" we
> have
> a model dialog that opens. It has 3 buttons in it "Save", "Complete" and
> "Save(Complete)" and some text boxes and drop down boxes. Once it is
> opened
> if we perform some changes in the text boxes or drop down boxes and click
> on
> any of the above buttons the IE 7 just hangs and we have to close it from
> Task Manager. Ideally once we click on the button the previous page
> containing the link should appear.
>
> We have partially resolved the issue by installing the below hotfix:
> Microsoft Security Bulletin MS07-045 - Critical
> Cumulative Security Update for Internet Explorer (937143).
>
> When I say partially when we are testing our application from some of the
> systems which did not have any previously installed hotfixes for the
> Internet explorer, it's working fine after installing this. But if a
> system
> has any other hotfix installed and then this is installed, the hanging
> behaviour reappears.
>
> So in those systems I removed the exisitng cumulative updates and
> installed
> this hotfix. The problem remains. I have also uninstalled IE7 completely
> and
> installed only this hotfix but the IE still hangs. Can someone please help
> me if there are any other way old hotfixes can be completely removed and
> then installed like a fresh installation? As I said for a system without
> any
> security updates installed, and then installing the above fix it's working
> fine.
>
> I have already posted this query at MSDN forums but there has been no
> response. So I thought may be this is a better place to post and it can be
> found here:
> http://forums.microsoft.com/msdn/Sho...12099&SiteID=1
>
> It's a very critical issue we are facing and we need this fixed as early
> as
> possible. Any help would be deeply appreciated. Please let me know if you
> need any other information.
>
> Thank you


Reply With Quote
  #3 (permalink)  
Old 11-20-2008
aquinn_21
 

Posts: n/a
Re: IE 7 hanging due to modal dialog box
Hi Robear,

Thank you very much for your reply.
Of the solutions proposed it is working perfectly when run in No Add-ons
mode and failing with the rest two i.e. either with the installation of
KB956390 or Resetting IE7 Advanced settings.

The issue does not appear in IE 6 and we have not tested it in IE8.

Kindly advice on what action needs to be taken. Also could you tell me if
installing one security update over the the other affects the system or they
are seperate individually?

Thanks again.
Karthik

"PA Bear [MS MVP]" wrote:

> <QP>
> To resolve this problem, install the most current cumulative security update
> for Internet Explorer.
> </QP>
> Source: http://support.microsoft.com/kb/935903
>
> The most current cumulative security update for IE is
> http://support.microsoft.com/kb/956390 (Oct-08) while KB937143 dates from
> Aug-07. Did you see this behavior with KB956390 installed?
>
> Does the behavior persist if you start IE7 in No Add-ons mode?
>
> Does the behavior persist if you Reset IE7 Advanced settings (RIES)?
> http://support.microsoft.com/kb/923737 <= Read before using!
>
> Does the behavior persist in IE6 and/or IE8 Beta 2?
> --
> ~Robear Dyer (PA Bear)
> MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
> AumHa VSOP & Admin http://aumha.net
> DTS-L http://dts-l.net/
>
> aquinn_21 wrote:
> > IE 7 hangs completely and only way to resume is by killing it from Task
> > Manager, when we make some changes in a modal dialog that is used for our
> > application. This behavior is seen in all Windows XP Machines SP2 having
> > IE
> > 7.
> >
> > The exact problem that we are facing can be found from here :
> > http://support.microsoft.com/kb/935903
> >
> > Our Scenario:
> > When we click on certain link in our application "Add Delta Details" we
> > have
> > a model dialog that opens. It has 3 buttons in it "Save", "Complete" and
> > "Save(Complete)" and some text boxes and drop down boxes. Once it is
> > opened
> > if we perform some changes in the text boxes or drop down boxes and click
> > on
> > any of the above buttons the IE 7 just hangs and we have to close it from
> > Task Manager. Ideally once we click on the button the previous page
> > containing the link should appear.
> >
> > We have partially resolved the issue by installing the below hotfix:
> > Microsoft Security Bulletin MS07-045 - Critical
> > Cumulative Security Update for Internet Explorer (937143).
> >
> > When I say partially when we are testing our application from some of the
> > systems which did not have any previously installed hotfixes for the
> > Internet explorer, it's working fine after installing this. But if a
> > system
> > has any other hotfix installed and then this is installed, the hanging
> > behaviour reappears.
> >
> > So in those systems I removed the exisitng cumulative updates and
> > installed
> > this hotfix. The problem remains. I have also uninstalled IE7 completely
> > and
> > installed only this hotfix but the IE still hangs. Can someone please help
> > me if there are any other way old hotfixes can be completely removed and
> > then installed like a fresh installation? As I said for a system without
> > any
> > security updates installed, and then installing the above fix it's working
> > fine.
> >
> > I have already posted this query at MSDN forums but there has been no
> > response. So I thought may be this is a better place to post and it can be
> > found here:
> > http://forums.microsoft.com/msdn/Sho...12099&SiteID=1
> >
> > It's a very critical issue we are facing and we need this fixed as early
> > as
> > possible. Any help would be deeply appreciated. Please let me know if you
> > need any other information.
> >
> > Thank you

>
>

Reply With Quote
  #4 (permalink)  
Old 11-20-2008
PA Bear [MS MVP]
 

Posts: n/a
Re: IE 7 hanging due to modal dialog box
I find it quite unusual that starting IE7 in No Add-ons mode resolves the
behavior but doing a Reset does not.

If you install KB956390 and then start IE7 in No Add-ons mode, does the
behavior persist?

If you install KB956390, start IE7 normally and then do a Reset *before*
running your app, does the behavior persist?

I would recommend installing IE8 Beta 2 (possibly in Virtual Machine) to
test how you app behaves. You may want to wait until the IE8 Release
Candidate becomes available in 1Q09; cf.
http://blogs.msdn.com/ie/archive/200...er-beta-2.aspx

=> KB956390 Support Options:

Start a free Windows Update support incident request:
https://support.microsoft.com/oas/de...spx?gprid=6527

Support for Windows Update:
http://support.microsoft.com/gp/wusupport

For home users, no-charge support is available by calling 1-866-PCSAFETY in
the United States and in Canada or by contacting your local Microsoft
subsidiary. There is no-charge for support calls that are associated with
security updates. When you call, clearly state that your problem is related
to a Security Update and cite the update's KB number (e.g., KB956390).

LOOK! => If your problem relates to a Cumulative Security Update for IE,
call the above number and ask to be transferred to the "Consumer IE queue"
(which is 47830).

For more information about how to contact your local Microsoft subsidiary
for security update support issues, visit the International Support Web
site: http://support.microsoft.com/common/international.aspx

For enterprise customers, support for security updates is available through
your usual support contacts.

=> IE8 Beta Support Options:

Free unlimited installation and usage support is available for Internet
Explorer 8 pre-released versions [i.e., IE8 Beta 2], but only for North
American (i.e., US & CA) English-speaking customers. This support for
Internet Explorer 8 pre-released versions is valid until 31 Dec-08. See
http://support.microsoft.com/oas/def...spx?prid=12357
--
~PA Bear

aquinn_21 wrote:
> Thank you very much for your reply.
> Of the solutions proposed it is working perfectly when run in No Add-ons
> mode and failing with the rest two i.e. either with the installation of
> KB956390 or Resetting IE7 Advanced settings.
>
> The issue does not appear in IE 6 and we have not tested it in IE8.
>
> Kindly advice on what action needs to be taken. Also could you tell me if
> installing one security update over the the other affects the system or
> they
> are seperate individually?
>
> "PA Bear [MS MVP]" wrote:
>> <QP>
>> To resolve this problem, install the most current cumulative security
>> update for Internet Explorer.
>> </QP>
>> Source: http://support.microsoft.com/kb/935903
>>
>> The most current cumulative security update for IE is
>> http://support.microsoft.com/kb/956390 (Oct-08) while KB937143 dates from
>> Aug-07. Did you see this behavior with KB956390 installed?
>>
>> Does the behavior persist if you start IE7 in No Add-ons mode?
>>
>> Does the behavior persist if you Reset IE7 Advanced settings (RIES)?
>> http://support.microsoft.com/kb/923737 <= Read before using!
>>
>> Does the behavior persist in IE6 and/or IE8 Beta 2?
>> --
>> ~Robear Dyer (PA Bear)
>> MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
>> AumHa VSOP & Admin http://aumha.net
>> DTS-L http://dts-l.net/
>>
>> aquinn_21 wrote:
>>> IE 7 hangs completely and only way to resume is by killing it from Task
>>> Manager, when we make some changes in a modal dialog that is used for
>>> our
>>> application. This behavior is seen in all Windows XP Machines SP2 having
>>> IE
>>> 7.
>>>
>>> The exact problem that we are facing can be found from here :
>>> http://support.microsoft.com/kb/935903
>>>
>>> Our Scenario:
>>> When we click on certain link in our application "Add Delta Details" we
>>> have
>>> a model dialog that opens. It has 3 buttons in it "Save", "Complete" and
>>> "Save(Complete)" and some text boxes and drop down boxes. Once it is
>>> opened
>>> if we perform some changes in the text boxes or drop down boxes and
>>> click
>>> on
>>> any of the above buttons the IE 7 just hangs and we have to close it
>>> from
>>> Task Manager. Ideally once we click on the button the previous page
>>> containing the link should appear.
>>>
>>> We have partially resolved the issue by installing the below hotfix:
>>> Microsoft Security Bulletin MS07-045 - Critical
>>> Cumulative Security Update for Internet Explorer (937143).
>>>
>>> When I say partially when we are testing our application from some of
>>> the
>>> systems which did not have any previously installed hotfixes for the
>>> Internet explorer, it's working fine after installing this. But if a
>>> system
>>> has any other hotfix installed and then this is installed, the hanging
>>> behaviour reappears.
>>>
>>> So in those systems I removed the exisitng cumulative updates and
>>> installed
>>> this hotfix. The problem remains. I have also uninstalled IE7 completely
>>> and
>>> installed only this hotfix but the IE still hangs. Can someone please
>>> help
>>> me if there are any other way old hotfixes can be completely removed and
>>> then installed like a fresh installation? As I said for a system without
>>> any
>>> security updates installed, and then installing the above fix it's
>>> working
>>> fine.
>>>
>>> I have already posted this query at MSDN forums but there has been no
>>> response. So I thought may be this is a better place to post and it can
>>> be
>>> found here:
>>> http://forums.microsoft.com/msdn/Sho...12099&SiteID=1
>>>
>>> It's a very critical issue we are facing and we need this fixed as early
>>> as
>>> possible. Any help would be deeply appreciated. Please let me know if
>>> you
>>> need any other information.
>>>
>>> Thank you


Reply With Quote
  #5 (permalink)  
Old 01-12-2009
aquinn_21
 

Posts: n/a
Re: IE 7 hanging due to modal dialog box
Hi Robaer,

First off all extremely sorry for this late reply. I was stuck in the middle
of urgent crisis for which I was not able to concentrate on this
wholeheartedly.

To answer your first question, installing KB956390 and then starting IE7 in
No Add-ons mode is not casuing the behavior and for the next it does cause
the error.

i haven't had any replies/updates/communication for a request raised through
Windows Update support incident request via

https://support.microsoft.com/oas/de...spx?gprid=6527

Could you please help me how to fix this?

The client has contacted us wtih a very high importance in resolving this
issue, hence am getting back again. Also could you please let me know if
installing one security update over the the other affects the system or they
are seperate individually?

Thanks again
Karthik

"PA Bear [MS MVP]" wrote:

> I find it quite unusual that starting IE7 in No Add-ons mode resolves the
> behavior but doing a Reset does not.
>
> If you install KB956390 and then start IE7 in No Add-ons mode, does the
> behavior persist?
>
> If you install KB956390, start IE7 normally and then do a Reset *before*
> running your app, does the behavior persist?
>
> I would recommend installing IE8 Beta 2 (possibly in Virtual Machine) to
> test how you app behaves. You may want to wait until the IE8 Release
> Candidate becomes available in 1Q09; cf.
> http://blogs.msdn.com/ie/archive/200...er-beta-2.aspx
>
> => KB956390 Support Options:
>
> Start a free Windows Update support incident request:
> https://support.microsoft.com/oas/de...spx?gprid=6527
>
> Support for Windows Update:
> http://support.microsoft.com/gp/wusupport
>
> For home users, no-charge support is available by calling 1-866-PCSAFETY in
> the United States and in Canada or by contacting your local Microsoft
> subsidiary. There is no-charge for support calls that are associated with
> security updates. When you call, clearly state that your problem is related
> to a Security Update and cite the update's KB number (e.g., KB956390).
>
> LOOK! => If your problem relates to a Cumulative Security Update for IE,
> call the above number and ask to be transferred to the "Consumer IE queue"
> (which is 47830).
>
> For more information about how to contact your local Microsoft subsidiary
> for security update support issues, visit the International Support Web
> site: http://support.microsoft.com/common/international.aspx
>
> For enterprise customers, support for security updates is available through
> your usual support contacts.
>
> => IE8 Beta Support Options:
>
> Free unlimited installation and usage support is available for Internet
> Explorer 8 pre-released versions [i.e., IE8 Beta 2], but only for North
> American (i.e., US & CA) English-speaking customers. This support for
> Internet Explorer 8 pre-released versions is valid until 31 Dec-08. See
> http://support.microsoft.com/oas/def...spx?prid=12357
> --
> ~PA Bear
>
> aquinn_21 wrote:
> > Thank you very much for your reply.
> > Of the solutions proposed it is working perfectly when run in No Add-ons
> > mode and failing with the rest two i.e. either with the installation of
> > KB956390 or Resetting IE7 Advanced settings.
> >
> > The issue does not appear in IE 6 and we have not tested it in IE8.
> >
> > Kindly advice on what action needs to be taken. Also could you tell me if
> > installing one security update over the the other affects the system or
> > they
> > are seperate individually?
> >
> > "PA Bear [MS MVP]" wrote:
> >> <QP>
> >> To resolve this problem, install the most current cumulative security
> >> update for Internet Explorer.
> >> </QP>
> >> Source: http://support.microsoft.com/kb/935903
> >>
> >> The most current cumulative security update for IE is
> >> http://support.microsoft.com/kb/956390 (Oct-08) while KB937143 dates from
> >> Aug-07. Did you see this behavior with KB956390 installed?
> >>
> >> Does the behavior persist if you start IE7 in No Add-ons mode?
> >>
> >> Does the behavior persist if you Reset IE7 Advanced settings (RIES)?
> >> http://support.microsoft.com/kb/923737 <= Read before using!
> >>
> >> Does the behavior persist in IE6 and/or IE8 Beta 2?
> >> --
> >> ~Robear Dyer (PA Bear)
> >> MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
> >> AumHa VSOP & Admin http://aumha.net
> >> DTS-L http://dts-l.net/
> >>
> >> aquinn_21 wrote:
> >>> IE 7 hangs completely and only way to resume is by killing it from Task
> >>> Manager, when we make some changes in a modal dialog that is used for
> >>> our
> >>> application. This behavior is seen in all Windows XP Machines SP2 having
> >>> IE
> >>> 7.
> >>>
> >>> The exact problem that we are facing can be found from here :
> >>> http://support.microsoft.com/kb/935903
> >>>
> >>> Our Scenario:
> >>> When we click on certain link in our application "Add Delta Details" we
> >>> have
> >>> a model dialog that opens. It has 3 buttons in it "Save", "Complete" and
> >>> "Save(Complete)" and some text boxes and drop down boxes. Once it is
> >>> opened
> >>> if we perform some changes in the text boxes or drop down boxes and
> >>> click
> >>> on
> >>> any of the above buttons the IE 7 just hangs and we have to close it
> >>> from
> >>> Task Manager. Ideally once we click on the button the previous page
> >>> containing the link should appear.
> >>>
> >>> We have partially resolved the issue by installing the below hotfix:
> >>> Microsoft Security Bulletin MS07-045 - Critical
> >>> Cumulative Security Update for Internet Explorer (937143).
> >>>
> >>> When I say partially when we are testing our application from some of
> >>> the
> >>> systems which did not have any previously installed hotfixes for the
> >>> Internet explorer, it's working fine after installing this. But if a
> >>> system
> >>> has any other hotfix installed and then this is installed, the hanging
> >>> behaviour reappears.
> >>>
> >>> So in those systems I removed the exisitng cumulative updates and
> >>> installed
> >>> this hotfix. The problem remains. I have also uninstalled IE7 completely
> >>> and
> >>> installed only this hotfix but the IE still hangs. Can someone please
> >>> help
> >>> me if there are any other way old hotfixes can be completely removed and
> >>> then installed like a fresh installation? As I said for a system without
> >>> any
> >>> security updates installed, and then installing the above fix it's
> >>> working
> >>> fine.
> >>>
> >>> I have already posted this query at MSDN forums but there has been no
> >>> response. So I thought may be this is a better place to post and it can
> >>> be
> >>> found here:
> >>> http://forums.microsoft.com/msdn/Sho...12099&SiteID=1
> >>>
> >>> It's a very critical issue we are facing and we need this fixed as early
> >>> as
> >>> possible. Any help would be deeply appreciated. Please let me know if
> >>> you
> >>> need any other information.
> >>>
> >>> Thank you

>
>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hanging up ROCKY49 microsoft.public.windows.vista hardware devices 2 02-28-2008 04:50
Modal messages interfere with remote control? Mark Conrad microsoft.public.windows.vista.general 11 02-13-2008 10:28
Is Media Center Modal? jonefer microsoft.public.windows.vista.music pictures video 1 10-14-2007 04:05
Off the wire: Border agencies prep for multi-modal biometrics Steve Security News 0 06-27-2007 23:27
Copying Dialog appears over Confirm File Replace dialog theclyde microsoft.public.windows.vista.general 1 06-13-2007 00:16




All times are GMT +1. The time now is 23:18.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120