Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Open link in new tab/ in new window

microsoft.public.internetexplorer.general






Speedup My PC
Reply
  #1 (permalink)  
Old 11-08-2008
Fernand Thill
 

Posts: n/a
Open link in new tab/ in new window
When i'm in a website (XP, ie7) and choose by right click to open a referred
link either by "Open link in new tab" or "Open link in new window" it no
longer works. This happended after I uninstalled an older version of Works,
that in fact I never used as I have Office on the PC.
I don't know if there is a relationship between these 2 facts. Can somebody
advise me how to "repair" ie7 or change settings to fix it.
Many thanks in advance
Fernand

Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 11-08-2008
PA Bear [MS MVP]
 

Posts: n/a
Re: Open link in new tab/ in new window
=> Does this behavior persist if you start IE7 in No Add-ons mode? To start
IE7 in No Add-ons mode:

1. Right-click on the blue IE desktop icon and select Start without Add-ons;
or

2. Start | (All) Programs | Accessories | System Tools | Internet Explorer
(No add-ons).

Troubleshooting and Internet Explorer's (No Add-ons) Mode:
http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx

=> Does the problem persist if you Reset IE7 Advanced settings (RIES)?
http://support.microsoft.com/kb/923737 <= Read before using!
--
~Robear Dyer (PA Bear)
MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
AumHa VSOP & Admin http://aumha.net
DTS-L http://dts-l.net/

Fernand Thill wrote:
> When i'm in a website (XP, ie7) and choose by right click to open a
> referred
> link either by "Open link in new tab" or "Open link in new window" it no
> longer works. This happended after I uninstalled an older version of
> Works,
> that in fact I never used as I have Office on the PC.
> I don't know if there is a relationship between these 2 facts. Can
> somebody
> advise me how to "repair" ie7 or change settings to fix it.
> Many thanks in advance
> Fernand


Reply With Quote
  #3 (permalink)  
Old 11-09-2008
Fernand Thill
 

Posts: n/a
Re: Open link in new tab/ in new window
Yes the behavior persists.
Perhaps that I should add that in the case of "Open link in new tab" the tab
opens but remains blank. In case of "Open link in new window" there is no
opening of a second ie7 window

"PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
news:#Jg#DTfQJHA.4760@TK2MSFTNGP02.phx.gbl...
> => Does this behavior persist if you start IE7 in No Add-ons mode? To
> start IE7 in No Add-ons mode:
>
> 1. Right-click on the blue IE desktop icon and select Start without
> Add-ons; or
>
> 2. Start | (All) Programs | Accessories | System Tools | Internet Explorer
> (No add-ons).
>
> Troubleshooting and Internet Explorer's (No Add-ons) Mode:
> http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx
>
> => Does the problem persist if you Reset IE7 Advanced settings (RIES)?
> http://support.microsoft.com/kb/923737 <= Read before using!
> --
> ~Robear Dyer (PA Bear)
> MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
> AumHa VSOP & Admin http://aumha.net
> DTS-L http://dts-l.net/
>
> Fernand Thill wrote:
>> When i'm in a website (XP, ie7) and choose by right click to open a
>> referred
>> link either by "Open link in new tab" or "Open link in new window" it no
>> longer works. This happended after I uninstalled an older version of
>> Works,
>> that in fact I never used as I have Office on the PC.
>> I don't know if there is a relationship between these 2 facts. Can
>> somebody
>> advise me how to "repair" ie7 or change settings to fix it.
>> Many thanks in advance
>> Fernand

>

Reply With Quote
  #4 (permalink)  
Old 11-09-2008
PA Bear [MS MVP]
 

Posts: n/a
Re: Open link in new tab/ in new window
>> => Does the problem persist if you Reset IE7 Advanced settings (RIES)?
>> http://support.microsoft.com/kb/923737 <= Read before using!


Did you do the above, too?

Right-click on My Computer | select Properties: Is "Service Pack 2" or
"Service Pack 3" listed here? If SP3, did you install IE7 before or after
you installed SP3?

Fernand Thill wrote:
> Yes the behavior persists.
> Perhaps that I should add that in the case of "Open link in new tab" the
> tab
> opens but remains blank. In case of "Open link in new window" there is no
> opening of a second ie7 window
>
> "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
> news:#Jg#DTfQJHA.4760@TK2MSFTNGP02.phx.gbl...
>> => Does this behavior persist if you start IE7 in No Add-ons mode? To
>> start IE7 in No Add-ons mode:
>>
>> 1. Right-click on the blue IE desktop icon and select Start without
>> Add-ons; or
>>
>> 2. Start | (All) Programs | Accessories | System Tools | Internet
>> Explorer
>> (No add-ons).
>>
>> Troubleshooting and Internet Explorer's (No Add-ons) Mode:
>> http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx
>>
>> => Does the problem persist if you Reset IE7 Advanced settings (RIES)?
>> http://support.microsoft.com/kb/923737 <= Read before using!
>> --
>> ~Robear Dyer (PA Bear)
>> MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
>> AumHa VSOP & Admin http://aumha.net
>> DTS-L http://dts-l.net/
>>
>> Fernand Thill wrote:
>>> When i'm in a website (XP, ie7) and choose by right click to open a
>>> referred
>>> link either by "Open link in new tab" or "Open link in new window" it
>>> no
>>> longer works. This happended after I uninstalled an older version of
>>> Works,
>>> that in fact I never used as I have Office on the PC.
>>> I don't know if there is a relationship between these 2 facts. Can
>>> somebody
>>> advise me how to "repair" ie7 or change settings to fix it.
>>> Many thanks in advance
>>> Fernand


Reply With Quote
  #5 (permalink)  
Old 11-09-2008
Fernand Thill
 

Posts: n/a
Re: Open link in new tab/ in new window
Yes, i installed ie7 after SP3. But remember it worked fine until yesterday
before I had this Work removal

"PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
news:#7Fm5jfQJHA.576@TK2MSFTNGP04.phx.gbl...
>>> => Does the problem persist if you Reset IE7 Advanced settings (RIES)?
>>> http://support.microsoft.com/kb/923737 <= Read before using!

>
> Did you do the above, too?
>
> Right-click on My Computer | select Properties: Is "Service Pack 2" or
> "Service Pack 3" listed here? If SP3, did you install IE7 before or after
> you installed SP3?
>
> Fernand Thill wrote:
>> Yes the behavior persists.
>> Perhaps that I should add that in the case of "Open link in new tab" the
>> tab
>> opens but remains blank. In case of "Open link in new window" there is no
>> opening of a second ie7 window
>>
>> "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
>> news:#Jg#DTfQJHA.4760@TK2MSFTNGP02.phx.gbl...
>>> => Does this behavior persist if you start IE7 in No Add-ons mode? To
>>> start IE7 in No Add-ons mode:
>>>
>>> 1. Right-click on the blue IE desktop icon and select Start without
>>> Add-ons; or
>>>
>>> 2. Start | (All) Programs | Accessories | System Tools | Internet
>>> Explorer
>>> (No add-ons).
>>>
>>> Troubleshooting and Internet Explorer's (No Add-ons) Mode:
>>> http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx
>>>
>>> => Does the problem persist if you Reset IE7 Advanced settings (RIES)?
>>> http://support.microsoft.com/kb/923737 <= Read before using!
>>> --
>>> ~Robear Dyer (PA Bear)
>>> MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
>>> AumHa VSOP & Admin http://aumha.net
>>> DTS-L http://dts-l.net/
>>>
>>> Fernand Thill wrote:
>>>> When i'm in a website (XP, ie7) and choose by right click to open a
>>>> referred
>>>> link either by "Open link in new tab" or "Open link in new window" it
>>>> no
>>>> longer works. This happended after I uninstalled an older version of
>>>> Works,
>>>> that in fact I never used as I have Office on the PC.
>>>> I don't know if there is a relationship between these 2 facts. Can
>>>> somebody
>>>> advise me how to "repair" ie7 or change settings to fix it.
>>>> Many thanks in advance
>>>> Fernand

>

Reply With Quote
  #6 (permalink)  
Old 11-09-2008
Fernand Thill
 

Posts: n/a
Re: Open link in new tab/ in new window
Excuse me: Works

"Fernand Thill" <Fern_lu@yahoo.com> wrote in message
news:eirvQ8jQJHA.1448@TK2MSFTNGP04.phx.gbl...
> Yes, i installed ie7 after SP3. But remember it worked fine until
> yesterday before I had this Work removal
>
> "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
> news:#7Fm5jfQJHA.576@TK2MSFTNGP04.phx.gbl...
>>>> => Does the problem persist if you Reset IE7 Advanced settings (RIES)?
>>>> http://support.microsoft.com/kb/923737 <= Read before using!

>>
>> Did you do the above, too?
>>
>> Right-click on My Computer | select Properties: Is "Service Pack 2" or
>> "Service Pack 3" listed here? If SP3, did you install IE7 before or
>> after you installed SP3?
>>
>> Fernand Thill wrote:
>>> Yes the behavior persists.
>>> Perhaps that I should add that in the case of "Open link in new tab" the
>>> tab
>>> opens but remains blank. In case of "Open link in new window" there is
>>> no
>>> opening of a second ie7 window
>>>
>>> "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
>>> news:#Jg#DTfQJHA.4760@TK2MSFTNGP02.phx.gbl...
>>>> => Does this behavior persist if you start IE7 in No Add-ons mode? To
>>>> start IE7 in No Add-ons mode:
>>>>
>>>> 1. Right-click on the blue IE desktop icon and select Start without
>>>> Add-ons; or
>>>>
>>>> 2. Start | (All) Programs | Accessories | System Tools | Internet
>>>> Explorer
>>>> (No add-ons).
>>>>
>>>> Troubleshooting and Internet Explorer's (No Add-ons) Mode:
>>>> http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx
>>>>
>>>> => Does the problem persist if you Reset IE7 Advanced settings (RIES)?
>>>> http://support.microsoft.com/kb/923737 <= Read before using!
>>>> --
>>>> ~Robear Dyer (PA Bear)
>>>> MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
>>>> AumHa VSOP & Admin http://aumha.net
>>>> DTS-L http://dts-l.net/
>>>>
>>>> Fernand Thill wrote:
>>>>> When i'm in a website (XP, ie7) and choose by right click to open a
>>>>> referred
>>>>> link either by "Open link in new tab" or "Open link in new window" it
>>>>> no
>>>>> longer works. This happended after I uninstalled an older version of
>>>>> Works,
>>>>> that in fact I never used as I have Office on the PC.
>>>>> I don't know if there is a relationship between these 2 facts. Can
>>>>> somebody
>>>>> advise me how to "repair" ie7 or change settings to fix it.
>>>>> Many thanks in advance
>>>>> Fernand

>>

Reply With Quote
  #7 (permalink)  
Old 11-09-2008
Fernand Thill
 

Posts: n/a
Re: Open link in new tab/ in new window
I solved the problem, but intellectually it isn't astisfying , by
reinstallung ie7. Happily it works now. But the frustation to never know
what happened , and learn the reasons, remains. It's like in real live, but
not so dramatic, it's only a PC

"Fernand Thill" <Fern_lu@yahoo.com> wrote in message
news:eirvQ8jQJHA.1448@TK2MSFTNGP04.phx.gbl...
> Yes, i installed ie7 after SP3. But remember it worked fine until
> yesterday before I had this Work removal
>
> "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
> news:#7Fm5jfQJHA.576@TK2MSFTNGP04.phx.gbl...
>>>> => Does the problem persist if you Reset IE7 Advanced settings (RIES)?
>>>> http://support.microsoft.com/kb/923737 <= Read before using!

>>
>> Did you do the above, too?
>>
>> Right-click on My Computer | select Properties: Is "Service Pack 2" or
>> "Service Pack 3" listed here? If SP3, did you install IE7 before or
>> after you installed SP3?
>>
>> Fernand Thill wrote:
>>> Yes the behavior persists.
>>> Perhaps that I should add that in the case of "Open link in new tab" the
>>> tab
>>> opens but remains blank. In case of "Open link in new window" there is
>>> no
>>> opening of a second ie7 window
>>>
>>> "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
>>> news:#Jg#DTfQJHA.4760@TK2MSFTNGP02.phx.gbl...
>>>> => Does this behavior persist if you start IE7 in No Add-ons mode? To
>>>> start IE7 in No Add-ons mode:
>>>>
>>>> 1. Right-click on the blue IE desktop icon and select Start without
>>>> Add-ons; or
>>>>
>>>> 2. Start | (All) Programs | Accessories | System Tools | Internet
>>>> Explorer
>>>> (No add-ons).
>>>>
>>>> Troubleshooting and Internet Explorer's (No Add-ons) Mode:
>>>> http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx
>>>>
>>>> => Does the problem persist if you Reset IE7 Advanced settings (RIES)?
>>>> http://support.microsoft.com/kb/923737 <= Read before using!
>>>> --
>>>> ~Robear Dyer (PA Bear)
>>>> MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
>>>> AumHa VSOP & Admin http://aumha.net
>>>> DTS-L http://dts-l.net/
>>>>
>>>> Fernand Thill wrote:
>>>>> When i'm in a website (XP, ie7) and choose by right click to open a
>>>>> referred
>>>>> link either by "Open link in new tab" or "Open link in new window" it
>>>>> no
>>>>> longer works. This happended after I uninstalled an older version of
>>>>> Works,
>>>>> that in fact I never used as I have Office on the PC.
>>>>> I don't know if there is a relationship between these 2 facts. Can
>>>>> somebody
>>>>> advise me how to "repair" ie7 or change settings to fix it.
>>>>> Many thanks in advance
>>>>> Fernand

>>

Reply With Quote
  #8 (permalink)  
Old 11-09-2008
PA Bear [MS MVP]
 

Posts: n/a
Re: Open link in new tab/ in new window
[We still don't know if you tried doing a Reset before you reinstalled IE7.]

Fernand Thill wrote:
> I solved the problem, but intellectually it isn't astisfying , by
> reinstallung ie7. Happily it works now. But the frustation to never know
> what happened , and learn the reasons, remains. It's like in real live,
> but
> not so dramatic, it's only a PC
>
> "Fernand Thill" <Fern_lu@yahoo.com> wrote in message
> news:eirvQ8jQJHA.1448@TK2MSFTNGP04.phx.gbl...
>> Yes, i installed ie7 after SP3. But remember it worked fine until
>> yesterday before I had this Work removal
>>
>> "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
>> news:#7Fm5jfQJHA.576@TK2MSFTNGP04.phx.gbl...
>>>>> => Does the problem persist if you Reset IE7 Advanced settings (RIES)?
>>>>> http://support.microsoft.com/kb/923737 <= Read before using!
>>>
>>> Did you do the above, too?
>>>
>>> Right-click on My Computer | select Properties: Is "Service Pack 2" or
>>> "Service Pack 3" listed here? If SP3, did you install IE7 before or
>>> after you installed SP3?
>>>
>>> Fernand Thill wrote:
>>>> Yes the behavior persists.
>>>> Perhaps that I should add that in the case of "Open link in new tab"
>>>> the
>>>> tab
>>>> opens but remains blank. In case of "Open link in new window" there is
>>>> no
>>>> opening of a second ie7 window
>>>>
>>>> "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
>>>> news:#Jg#DTfQJHA.4760@TK2MSFTNGP02.phx.gbl...
>>>>> => Does this behavior persist if you start IE7 in No Add-ons mode? To
>>>>> start IE7 in No Add-ons mode:
>>>>>
>>>>> 1. Right-click on the blue IE desktop icon and select Start without
>>>>> Add-ons; or
>>>>>
>>>>> 2. Start | (All) Programs | Accessories | System Tools | Internet
>>>>> Explorer
>>>>> (No add-ons).
>>>>>
>>>>> Troubleshooting and Internet Explorer's (No Add-ons) Mode:
>>>>> http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx
>>>>>
>>>>> => Does the problem persist if you Reset IE7 Advanced settings (RIES)?
>>>>> http://support.microsoft.com/kb/923737 <= Read before using!
>>>>> --
>>>>> ~Robear Dyer (PA Bear)
>>>>> MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
>>>>> AumHa VSOP & Admin http://aumha.net
>>>>> DTS-L http://dts-l.net/
>>>>>
>>>>> Fernand Thill wrote:
>>>>>> When i'm in a website (XP, ie7) and choose by right click to open a
>>>>>> referred
>>>>>> link either by "Open link in new tab" or "Open link in new window"
>>>>>> it
>>>>>> no
>>>>>> longer works. This happended after I uninstalled an older version of
>>>>>> Works,
>>>>>> that in fact I never used as I have Office on the PC.
>>>>>> I don't know if there is a relationship between these 2 facts. Can
>>>>>> somebody
>>>>>> advise me how to "repair" ie7 or change settings to fix it.
>>>>>> Many thanks in advance
>>>>>> Fernand


Reply With Quote
  #9 (permalink)  
Old 11-09-2008
Fernand Thill
 

Posts: n/a
Re: Open link in new tab/ in new window
Yes, I did a reset, but it didn't change anything in the behavior

"PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
news:OdsUTKoQJHA.4680@TK2MSFTNGP06.phx.gbl...
> [We still don't know if you tried doing a Reset before you reinstalled
> IE7.]
>
> Fernand Thill wrote:
>> I solved the problem, but intellectually it isn't astisfying , by
>> reinstallung ie7. Happily it works now. But the frustation to never know
>> what happened , and learn the reasons, remains. It's like in real live,
>> but
>> not so dramatic, it's only a PC
>>
>> "Fernand Thill" <Fern_lu@yahoo.com> wrote in message
>> news:eirvQ8jQJHA.1448@TK2MSFTNGP04.phx.gbl...
>>> Yes, i installed ie7 after SP3. But remember it worked fine until
>>> yesterday before I had this Work removal
>>>
>>> "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
>>> news:#7Fm5jfQJHA.576@TK2MSFTNGP04.phx.gbl...
>>>>>> => Does the problem persist if you Reset IE7 Advanced settings
>>>>>> (RIES)?
>>>>>> http://support.microsoft.com/kb/923737 <= Read before using!
>>>>
>>>> Did you do the above, too?
>>>>
>>>> Right-click on My Computer | select Properties: Is "Service Pack 2" or
>>>> "Service Pack 3" listed here? If SP3, did you install IE7 before or
>>>> after you installed SP3?
>>>>
>>>> Fernand Thill wrote:
>>>>> Yes the behavior persists.
>>>>> Perhaps that I should add that in the case of "Open link in new tab"
>>>>> the
>>>>> tab
>>>>> opens but remains blank. In case of "Open link in new window" there is
>>>>> no
>>>>> opening of a second ie7 window
>>>>>
>>>>> "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
>>>>> news:#Jg#DTfQJHA.4760@TK2MSFTNGP02.phx.gbl...
>>>>>> => Does this behavior persist if you start IE7 in No Add-ons mode?
>>>>>> To
>>>>>> start IE7 in No Add-ons mode:
>>>>>>
>>>>>> 1. Right-click on the blue IE desktop icon and select Start without
>>>>>> Add-ons; or
>>>>>>
>>>>>> 2. Start | (All) Programs | Accessories | System Tools | Internet
>>>>>> Explorer
>>>>>> (No add-ons).
>>>>>>
>>>>>> Troubleshooting and Internet Explorer's (No Add-ons) Mode:
>>>>>> http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx
>>>>>>
>>>>>> => Does the problem persist if you Reset IE7 Advanced settings
>>>>>> (RIES)?
>>>>>> http://support.microsoft.com/kb/923737 <= Read before using!
>>>>>> --
>>>>>> ~Robear Dyer (PA Bear)
>>>>>> MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
>>>>>> AumHa VSOP & Admin http://aumha.net
>>>>>> DTS-L http://dts-l.net/
>>>>>>
>>>>>> Fernand Thill wrote:
>>>>>>> When i'm in a website (XP, ie7) and choose by right click to open a
>>>>>>> referred
>>>>>>> link either by "Open link in new tab" or "Open link in new window"
>>>>>>> it
>>>>>>> no
>>>>>>> longer works. This happended after I uninstalled an older version of
>>>>>>> Works,
>>>>>>> that in fact I never used as I have Office on the PC.
>>>>>>> I don't know if there is a relationship between these 2 facts. Can
>>>>>>> somebody
>>>>>>> advise me how to "repair" ie7 or change settings to fix it.
>>>>>>> Many thanks in advance
>>>>>>> Fernand

>

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
When a link is clicked on, why does it open in another window and. Luis III microsoft.public.internetexplorer.general 8 10-18-2008 06:40
Links refuse to open in new tabs - they open in a new window inste Matt microsoft.public.internetexplorer.general 3 09-18-2008 01:37
Open New window on clicking link. medicsource microsoft.public.internetexplorer.general 3 07-24-2008 01:11
Re: link to new window Amandar097 microsoft.public.internetexplorer.general 0 07-09-2008 04:17
click a link, get data in that window, and a new window? Lost in PPT microsoft.public.internetexplorer.general 11 07-08-2008 14:36




All times are GMT +1. The time now is 14:44.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120