Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Mark of the Web

microsoft.public.internetexplorer.general






Speedup My PC
Reply
  #1 (permalink)  
Old 09-28-2008
AD
 

Posts: n/a
Mark of the Web
I have built web pages that will NOT be hosted on the internet but will
instead be distributed by CD. There is a problem with my links not working
from my search engine results page which I have traced down to being a
compatibility issue between Windows and Internet Explorer (The search.html
page has been tagged to be in the "Internet" security zone and will not
follow links to pages in the "Local Machine" zone (hard disk and CD). I
tried adding the MOTW (<!-- saved from url=(0014)about:internet -->) at the
beginning of the HTML pages but now my PDF and JPEG links for the entire site
don't work. Is there a solution to this problem?

Thanks.
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 09-29-2008
ju.c
 

Posts: n/a
Re: Mark of the Web
This is what works for me.


Make sure "saved from url" is located as shown:

<!doctype>
<!-- saved from url=(0014)about:internet -->
<html>

and check that this option is set:

'Internet Options->Advanced->Security'
check "Allow active content to run in files on My Computer"


One trick that may or may not work is to rename
the extension from .htm/.html to .hta


ju.c


"AD" <AD@discussions.microsoft.com> wrote in message news:CFCFCA90-11EA-4492-874F-3FC7588B6075@microsoft.com...
> I have built web pages that will NOT be hosted on the internet but will
> instead be distributed by CD. There is a problem with my links not working
> from my search engine results page which I have traced down to being a
> compatibility issue between Windows and Internet Explorer (The search.html
> page has been tagged to be in the "Internet" security zone and will not
> follow links to pages in the "Local Machine" zone (hard disk and CD). I
> tried adding the MOTW (<!-- saved from url=(0014)about:internet -->) at the
> beginning of the HTML pages but now my PDF and JPEG links for the entire site
> don't work. Is there a solution to this problem?
>
> Thanks.

Reply With Quote
  #3 (permalink)  
Old 09-29-2008
AD
 

Posts: n/a
Re: Mark of the Web
I tried changing my search page to a .hta file but then the results page
won't come up. If I add the MOTW then how does this help the PDF files? Do
I just add it to the search page? That doesn't seem to do anything.

AD

"ju.c" wrote:

> This is what works for me.
>
>
> Make sure "saved from url" is located as shown:
>
> <!doctype>
> <!-- saved from url=(0014)about:internet -->
> <html>
>
> and check that this option is set:
>
> 'Internet Options->Advanced->Security'
> check "Allow active content to run in files on My Computer"
>
>
> One trick that may or may not work is to rename
> the extension from .htm/.html to .hta
>
>
> ju.c
>
>
> "AD" <AD@discussions.microsoft.com> wrote in message news:CFCFCA90-11EA-4492-874F-3FC7588B6075@microsoft.com...
> > I have built web pages that will NOT be hosted on the internet but will
> > instead be distributed by CD. There is a problem with my links not working
> > from my search engine results page which I have traced down to being a
> > compatibility issue between Windows and Internet Explorer (The search.html
> > page has been tagged to be in the "Internet" security zone and will not
> > follow links to pages in the "Local Machine" zone (hard disk and CD). I
> > tried adding the MOTW (<!-- saved from url=(0014)about:internet -->) at the
> > beginning of the HTML pages but now my PDF and JPEG links for the entire site
> > don't work. Is there a solution to this problem?
> >
> > Thanks.

>

Reply With Quote
  #4 (permalink)  
Old 09-29-2008
AD
 

Posts: n/a
Re: Mark of the Web
Your 1st suggestion worked beautifully! Thank you so much for your help!

AD

"ju.c" wrote:

> This is what works for me.
>
>
> Make sure "saved from url" is located as shown:
>
> <!doctype>
> <!-- saved from url=(0014)about:internet -->
> <html>
>
> and check that this option is set:
>
> 'Internet Options->Advanced->Security'
> check "Allow active content to run in files on My Computer"
>
>
> One trick that may or may not work is to rename
> the extension from .htm/.html to .hta
>
>
> ju.c
>
>
> "AD" <AD@discussions.microsoft.com> wrote in message news:CFCFCA90-11EA-4492-874F-3FC7588B6075@microsoft.com...
> > I have built web pages that will NOT be hosted on the internet but will
> > instead be distributed by CD. There is a problem with my links not working
> > from my search engine results page which I have traced down to being a
> > compatibility issue between Windows and Internet Explorer (The search.html
> > page has been tagged to be in the "Internet" security zone and will not
> > follow links to pages in the "Local Machine" zone (hard disk and CD). I
> > tried adding the MOTW (<!-- saved from url=(0014)about:internet -->) at the
> > beginning of the HTML pages but now my PDF and JPEG links for the entire site
> > don't work. Is there a solution to this problem?
> >
> > Thanks.

>

Reply With Quote
  #5 (permalink)  
Old 09-30-2008
ju.c
 

Posts: n/a
Re: Mark of the Web
You're welcome!


"AD" <AD@discussions.microsoft.com> wrote in message news:39F43414-8E55-4FF1-AE55-5100133ACDBC@microsoft.com...
> Your 1st suggestion worked beautifully! Thank you so much for your help!
>
> AD
>
> "ju.c" wrote:
>
>> This is what works for me.
>>
>>
>> Make sure "saved from url" is located as shown:
>>
>> <!doctype>
>> <!-- saved from url=(0014)about:internet -->
>> <html>
>>
>> and check that this option is set:
>>
>> 'Internet Options->Advanced->Security'
>> check "Allow active content to run in files on My Computer"
>>
>>
>> One trick that may or may not work is to rename
>> the extension from .htm/.html to .hta
>>
>>
>> ju.c
>>
>>
>> "AD" <AD@discussions.microsoft.com> wrote in message news:CFCFCA90-11EA-4492-874F-3FC7588B6075@microsoft.com...
>> > I have built web pages that will NOT be hosted on the internet but will
>> > instead be distributed by CD. There is a problem with my links not working
>> > from my search engine results page which I have traced down to being a
>> > compatibility issue between Windows and Internet Explorer (The search.html
>> > page has been tagged to be in the "Internet" security zone and will not
>> > follow links to pages in the "Local Machine" zone (hard disk and CD). I
>> > tried adding the MOTW (<!-- saved from url=(0014)about:internet -->) at the
>> > beginning of the HTML pages but now my PDF and JPEG links for the entire site
>> > don't work. Is there a solution to this problem?
>> >
>> > Thanks.

>>

Reply With Quote
  #6 (permalink)  
Old 10-27-2008
JB
 

Posts: n/a
Re: Mark of the Web
I have a similar problem to the one that AD described. I work for a US
University that creates interactive web-based content for educating people
about physics and other scientific concepts. We allow users to download and
install a full copy of the web site in case they need to use it off line.
When the users do this, any user who uses Internet Explorer gets the security
message that says, "To help protect your security, Internet Explorer has
restricted this webpage from running scripts or ActiveX controls that could
access your computer" on every page. I googled on this message, found out
about the Mark of the Web (MOTW), and tried implementing it. It worked fine
for all HTML pages (i.e. the error message went away), but the links to the
simulations, which are Java files referenced through JNLP, don't work. I
tried adding the MOTW comment to the JNLP file, but to no avail. I also
tried setting the option that ju.c describes below, but the content is still
inaccessible. Finally, I tried linking directly to the .jar file for the
Java app, and got the same result. There are no error messages or any
indication that something is wrong - the JNLP application is simply not
launched when the user clicks on the corresponding link.

Is there any solution to this problem?

Thanks.


"ju.c" wrote:

> This is what works for me.
>
>
> Make sure "saved from url" is located as shown:
>
> <!doctype>
> <!-- saved from url=(0014)about:internet -->
> <html>
>
> and check that this option is set:
>
> 'Internet Options->Advanced->Security'
> check "Allow active content to run in files on My Computer"
>
>
> One trick that may or may not work is to rename
> the extension from .htm/.html to .hta
>
>
> ju.c
>
>
> "AD" <AD@discussions.microsoft.com> wrote in message news:CFCFCA90-11EA-4492-874F-3FC7588B6075@microsoft.com...
> > I have built web pages that will NOT be hosted on the internet but will
> > instead be distributed by CD. There is a problem with my links not working
> > from my search engine results page which I have traced down to being a
> > compatibility issue between Windows and Internet Explorer (The search.html
> > page has been tagged to be in the "Internet" security zone and will not
> > follow links to pages in the "Local Machine" zone (hard disk and CD). I
> > tried adding the MOTW (<!-- saved from url=(0014)about:internet -->) at the
> > beginning of the HTML pages but now my PDF and JPEG links for the entire site
> > don't work. Is there a solution to this problem?
> >
> > Thanks.

>

Reply With Quote
  #7 (permalink)  
Old 10-28-2008
ju.c
 

Posts: n/a
Re: Mark of the Web
Sounds like a problem with your links. For offline, have the support
files in the same folder or a subfolder and use relative paths to them.

If you don't understand then post a sample link and I'll show you.


ju.c


"JB" <JB@discussions.microsoft.com> wrote in message news:9F3D6583-EC46-4F71-B50E-7FE36E3D3679@microsoft.com...
> I have a similar problem to the one that AD described. I work for a US
> University that creates interactive web-based content for educating people
> about physics and other scientific concepts. We allow users to download and
> install a full copy of the web site in case they need to use it off line.
> When the users do this, any user who uses Internet Explorer gets the security
> message that says, "To help protect your security, Internet Explorer has
> restricted this webpage from running scripts or ActiveX controls that could
> access your computer" on every page. I googled on this message, found out
> about the Mark of the Web (MOTW), and tried implementing it. It worked fine
> for all HTML pages (i.e. the error message went away), but the links to the
> simulations, which are Java files referenced through JNLP, don't work. I
> tried adding the MOTW comment to the JNLP file, but to no avail. I also
> tried setting the option that ju.c describes below, but the content is still
> inaccessible. Finally, I tried linking directly to the .jar file for the
> Java app, and got the same result. There are no error messages or any
> indication that something is wrong - the JNLP application is simply not
> launched when the user clicks on the corresponding link.
>
> Is there any solution to this problem?
>
> Thanks.
>
>
> "ju.c" wrote:
>
>> This is what works for me.
>>
>>
>> Make sure "saved from url" is located as shown:
>>
>> <!doctype>
>> <!-- saved from url=(0014)about:internet -->
>> <html>
>>
>> and check that this option is set:
>>
>> 'Internet Options->Advanced->Security'
>> check "Allow active content to run in files on My Computer"
>>
>>
>> One trick that may or may not work is to rename
>> the extension from .htm/.html to .hta
>>
>>
>> ju.c
>>
>>
>> "AD" <AD@discussions.microsoft.com> wrote in message news:CFCFCA90-11EA-4492-874F-3FC7588B6075@microsoft.com...
>> > I have built web pages that will NOT be hosted on the internet but will
>> > instead be distributed by CD. There is a problem with my links not working
>> > from my search engine results page which I have traced down to being a
>> > compatibility issue between Windows and Internet Explorer (The search.html
>> > page has been tagged to be in the "Internet" security zone and will not
>> > follow links to pages in the "Local Machine" zone (hard disk and CD). I
>> > tried adding the MOTW (<!-- saved from url=(0014)about:internet -->) at the
>> > beginning of the HTML pages but now my PDF and JPEG links for the entire site
>> > don't work. Is there a solution to this problem?
>> >
>> > Thanks.

>>

Reply With Quote
  #8 (permalink)  
Old 10-28-2008
JB
 

Posts: n/a
Re: Mark of the Web
ju.c,

Thanks for the response. I tried doing a very simple version of all this in
order to distill the problem down to its essence, and even with all the files
in the same directory, I still run into the same issue.

Below is the text of the HTML file that doesn't work. The behavior is that
when I click on either of the links described in the file, nothing happens.
There is no error message at all, it just doesn't work. If I use the exact
same file witout the MOTW tag, the links work fine, but I get the security
warning.

Any help you (or anyone else) can offer on this would be greatly
appreciated. If you'd like the set of HTML, JAR, and JNLP files (4 total
files) so that you can duplicate the problem, please let me know how to post
them or otherwise get them to you.

HTML File:

<!-- saved from url=(0025)http://phet.colorado.edu/ -->
<html>
<head>
</head>
<body bgcolor="#ffffff" text="#000000" link="#0000ff" vlink="#ff0000"
alink="#ffff00">
<a href="./lasers.jar">Lasers Jar File</a>
<br>
<a href="./lasers.jnlp">Lasers JNLP File</a>
<br>
</body>
</html>


"ju.c" wrote:

> Sounds like a problem with your links. For offline, have the support
> files in the same folder or a subfolder and use relative paths to them.
>
> If you don't understand then post a sample link and I'll show you.
>
>
> ju.c
>
>
> "JB" <JB@discussions.microsoft.com> wrote in message news:9F3D6583-EC46-4F71-B50E-7FE36E3D3679@microsoft.com...
> > I have a similar problem to the one that AD described. I work for a US
> > University that creates interactive web-based content for educating people
> > about physics and other scientific concepts. We allow users to download and
> > install a full copy of the web site in case they need to use it off line.
> > When the users do this, any user who uses Internet Explorer gets the security
> > message that says, "To help protect your security, Internet Explorer has
> > restricted this webpage from running scripts or ActiveX controls that could
> > access your computer" on every page. I googled on this message, found out
> > about the Mark of the Web (MOTW), and tried implementing it. It worked fine
> > for all HTML pages (i.e. the error message went away), but the links to the
> > simulations, which are Java files referenced through JNLP, don't work. I
> > tried adding the MOTW comment to the JNLP file, but to no avail. I also
> > tried setting the option that ju.c describes below, but the content is still
> > inaccessible. Finally, I tried linking directly to the .jar file for the
> > Java app, and got the same result. There are no error messages or any
> > indication that something is wrong - the JNLP application is simply not
> > launched when the user clicks on the corresponding link.
> >
> > Is there any solution to this problem?
> >
> > Thanks.
> >
> >
> > "ju.c" wrote:
> >
> >> This is what works for me.
> >>
> >>
> >> Make sure "saved from url" is located as shown:
> >>
> >> <!doctype>
> >> <!-- saved from url=(0014)about:internet -->
> >> <html>
> >>
> >> and check that this option is set:
> >>
> >> 'Internet Options->Advanced->Security'
> >> check "Allow active content to run in files on My Computer"
> >>
> >>
> >> One trick that may or may not work is to rename
> >> the extension from .htm/.html to .hta
> >>
> >>
> >> ju.c
> >>
> >>
> >> "AD" <AD@discussions.microsoft.com> wrote in message news:CFCFCA90-11EA-4492-874F-3FC7588B6075@microsoft.com...
> >> > I have built web pages that will NOT be hosted on the internet but will
> >> > instead be distributed by CD. There is a problem with my links not working
> >> > from my search engine results page which I have traced down to being a
> >> > compatibility issue between Windows and Internet Explorer (The search.html
> >> > page has been tagged to be in the "Internet" security zone and will not
> >> > follow links to pages in the "Local Machine" zone (hard disk and CD). I
> >> > tried adding the MOTW (<!-- saved from url=(0014)about:internet -->) at the
> >> > beginning of the HTML pages but now my PDF and JPEG links for the entire site
> >> > don't work. Is there a solution to this problem?
> >> >
> >> > Thanks.
> >>

>

Reply With Quote
  #9 (permalink)  
Old 10-28-2008
JB
 

Posts: n/a
Re: Mark of the Web
..p.jm,

I read through the information on the link you provided, but I don't think
it will solve my problem. I am able to put the MOTW tag in all of the HTML
files, but the problem is that the links that point from these HTML files to
my JNLP or JAR files do not work when the MOTW tag/comment is present. Have
you tried this after having inserted the MOTW tag/comment using your program
and, if so, did it work for you?

Thanks,
JB


".p.jm@see_my_sig_for_address.com" wrote:

> On Mon, 27 Oct 2008 12:53:02 -0700, JB <JB@discussions.microsoft.com>
> wrote:
>
> >I have a similar problem to the one that AD described. I work for a US
> >University that creates interactive web-based content for educating people
> >about physics and other scientific concepts. We allow users to download and
> >install a full copy of the web site in case they need to use it off line.
> >When the users do this, any user who uses Internet Explorer gets the security
> >message that says, "To help protect your security, Internet Explorer has
> >restricted this webpage from running scripts or ActiveX controls that could
> >access your computer" on every page. I googled on this message, found out
> >about the Mark of the Web (MOTW), and tried implementing it. It worked fine
> >for all HTML pages (i.e. the error message went away), but the links to the
> >simulations, which are Java files referenced through JNLP, don't work. I
> >tried adding the MOTW comment to the JNLP file, but to no avail. I also
> >tried setting the option that ju.c describes below, but the content is still
> >inaccessible. Finally, I tried linking directly to the .jar file for the
> >Java app, and got the same result. There are no error messages or any
> >indication that something is wrong - the JNLP application is simply not
> >launched when the user clicks on the corresponding link.
> >
> >Is there any solution to this problem?
> >
> >Thanks.

>
> Free program to fix it in 10 seconds
>
> http://www.markoftheweb.com/
>
>
>
> >
> >
> >"ju.c" wrote:
> >
> >> This is what works for me.
> >>
> >>
> >> Make sure "saved from url" is located as shown:
> >>
> >> <!doctype>
> >> <!-- saved from url=(0014)about:internet -->
> >> <html>
> >>
> >> and check that this option is set:
> >>
> >> 'Internet Options->Advanced->Security'
> >> check "Allow active content to run in files on My Computer"
> >>
> >>
> >> One trick that may or may not work is to rename
> >> the extension from .htm/.html to .hta
> >>
> >>
> >> ju.c
> >>
> >>
> >> "AD" <AD@discussions.microsoft.com> wrote in message news:CFCFCA90-11EA-4492-874F-3FC7588B6075@microsoft.com...
> >> > I have built web pages that will NOT be hosted on the internet but will
> >> > instead be distributed by CD. There is a problem with my links not working
> >> > from my search engine results page which I have traced down to being a
> >> > compatibility issue between Windows and Internet Explorer (The search.html
> >> > page has been tagged to be in the "Internet" security zone and will not
> >> > follow links to pages in the "Local Machine" zone (hard disk and CD). I
> >> > tried adding the MOTW (<!-- saved from url=(0014)about:internet -->) at the
> >> > beginning of the HTML pages but now my PDF and JPEG links for the entire site
> >> > don't work. Is there a solution to this problem?
> >> >
> >> > Thanks.
> >>

>
> --
> Click here every day to feed an animal that needs you today !!!
> www.theanimalrescuesite.com/
>
> Paul ( pjm @ pobox . com ) - remove spaces to email me
> 'Some days, it's just not worth chewing through the restraints.'
> 'With sufficient thrust, pigs fly just fine.'
> HVAC/R program for Palm PDA's
> Free demo online at www.pmilligan.net/palm/
> Free 'People finder' program now at www.pmilligan.net/finder.htm
>

Reply With Quote
  #10 (permalink)  
Old 10-28-2008
.p.jm@see_my_sig_for_address.com
 

Posts: n/a
Re: Mark of the Web
On Mon, 27 Oct 2008 12:53:02 -0700, JB <JB@discussions.microsoft.com>
wrote:

>I have a similar problem to the one that AD described. I work for a US
>University that creates interactive web-based content for educating people
>about physics and other scientific concepts. We allow users to download and
>install a full copy of the web site in case they need to use it off line.
>When the users do this, any user who uses Internet Explorer gets the security
>message that says, "To help protect your security, Internet Explorer has
>restricted this webpage from running scripts or ActiveX controls that could
>access your computer" on every page. I googled on this message, found out
>about the Mark of the Web (MOTW), and tried implementing it. It worked fine
>for all HTML pages (i.e. the error message went away), but the links to the
>simulations, which are Java files referenced through JNLP, don't work. I
>tried adding the MOTW comment to the JNLP file, but to no avail. I also
>tried setting the option that ju.c describes below, but the content is still
>inaccessible. Finally, I tried linking directly to the .jar file for the
>Java app, and got the same result. There are no error messages or any
>indication that something is wrong - the JNLP application is simply not
>launched when the user clicks on the corresponding link.
>
>Is there any solution to this problem?
>
>Thanks.


Free program to fix it in 10 seconds

http://www.markoftheweb.com/



>
>
>"ju.c" wrote:
>
>> This is what works for me.
>>
>>
>> Make sure "saved from url" is located as shown:
>>
>> <!doctype>
>> <!-- saved from url=(0014)about:internet -->
>> <html>
>>
>> and check that this option is set:
>>
>> 'Internet Options->Advanced->Security'
>> check "Allow active content to run in files on My Computer"
>>
>>
>> One trick that may or may not work is to rename
>> the extension from .htm/.html to .hta
>>
>>
>> ju.c
>>
>>
>> "AD" <AD@discussions.microsoft.com> wrote in message news:CFCFCA90-11EA-4492-874F-3FC7588B6075@microsoft.com...
>> > I have built web pages that will NOT be hosted on the internet but will
>> > instead be distributed by CD. There is a problem with my links not working
>> > from my search engine results page which I have traced down to being a
>> > compatibility issue between Windows and Internet Explorer (The search.html
>> > page has been tagged to be in the "Internet" security zone and will not
>> > follow links to pages in the "Local Machine" zone (hard disk and CD). I
>> > tried adding the MOTW (<!-- saved from url=(0014)about:internet -->) at the
>> > beginning of the HTML pages but now my PDF and JPEG links for the entire site
>> > don't work. Is there a solution to this problem?
>> >
>> > Thanks.

>>


--
Click here every day to feed an animal that needs you today !!!
www.theanimalrescuesite.com/

Paul ( pjm @ pobox . com ) - remove spaces to email me
'Some days, it's just not worth chewing through the restraints.'
'With sufficient thrust, pigs fly just fine.'
HVAC/R program for Palm PDA's
Free demo online at www.pmilligan.net/palm/
Free 'People finder' program now at www.pmilligan.net/finder.htm
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
question mark question mark microsoft.public.windows.vista.mail 1 02-28-2010 04:19
Mark Russinovitch MCI \(ex do ré Mi chel la si do\) [MVP] microsoft.public.fr.windows.vista.general 3 06-22-2008 22:26
Mark Veldhuis Jack Kloonen microsoft.public.nl.windows.vista 4 04-26-2008 22:45
ANN: We Hit The 50,000 Messages Mark, Just FYI. kevpan815@nospam.msn.com microsoft.public.windows.vista.general 13 11-13-2007 22:49
NAC alternatives hit the mark Steve Security News 0 07-30-2007 09:53




All times are GMT +1. The time now is 11:21.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120