Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Programm startet bedingt nicht

microsoft.public.de.windows.vista.sonstiges






Speedup My PC
Reply
  #1 (permalink)  
Old 12-21-2007
Mario Heller
 

Posts: n/a
Programm startet bedingt nicht
Hallo NG!

Hoffe, es liest noch jemand meinen Beitrag... .

Vista Business, aktueller Patchstand, ca. 15 PCs.
Branchensoftware wird eingeführt. Ist unter Vista getestet und es muß nur
die .exe auf dem Server gestartet werden (Clientanwendung). Es sind also
keinerlei Regitry- oder sonstige Klassen (o.ä.) notwendig.


Beim Programmaufruf startet das Programm meistens nicht. Meistens deshalb,
weil unter dem User, der bei der Vistainst. angegeben werden muß, alles
einwandfrei funktioniert. Unter allen zukünftigen Usern, inkl. DOM-Usern,
besteht das besagte Problem.
Meine Frage: Was ist an dem "Installationsbenutzer" anders?


Tausend Dank im voraus und schon einmal an alle schöne feiertage!


Gruß
Mario

Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 12-21-2007
G. Born
 

Posts: n/a
Re: Programm startet bedingt nicht
Mario Heller wrote:
>> Vista Business, aktueller Patchstand, ca. 15 PCs.

> Branchensoftware wird eingeführt. Ist unter Vista getestet und es muß
> nur die .exe auf dem Server gestartet werden (Clientanwendung). Es
> sind also keinerlei Regitry- oder sonstige Klassen (o.ä.) notwendig.


Da bin ich aber jetzt etwas am rätseln, was Du unter "sonstige Klassen"
verstehst. Handelt es sich um eine .NET-Anwendung, die einfach in einem
Verzeichnis des Servers abgelegt wird und dann über eine Freigabe vom
Benutzer aufgerufen werden kann?

> Beim Programmaufruf startet das Programm meistens nicht. Meistens
> deshalb, weil unter dem User, der bei der Vistainst. angegeben werden
> muß, alles einwandfrei funktioniert. Unter allen zukünftigen Usern,
> inkl. DOM-Usern, besteht das besagte Problem.
> Meine Frage: Was ist an dem "Installationsbenutzer" anders?


Im ungünstigsten Fall fehlt den Benutzern einfach das Recht, die
Anwendung auszuführen. Schau Dir mal die Berechtigungen der .exe-Datei
an. Bei .NET-Anwendungen kenne ich es auch, dass die Ausführung des
Codes, der auf einer Netzwerkfreigabe liegt, wegen fehlender
Berechtigungen (Stichwort Code Access Security) scheitert. Hier findest
Du einige Hinweise zu diesem Thema http://blog.rasehorn.net/?p=44.

Aber über die Problematik müsste doch der Entwickler der Anwendung
Auskunft geben können - oder bist Du der Entwickler? Dann solltest Du
eigentlich herausfinden können, wo die Anwendung geblockt wird.

Vielleicht hilft es weiter.

Gruß

G. Born

Reply With Quote
  #3 (permalink)  
Old 12-21-2007
G. Born
 

Posts: n/a
Re: Programm startet bedingt nicht
>Hier
> findest Du einige Hinweise zu diesem Thema
> http://blog.rasehorn.net/?p=44.

Noch ein Nachschlag - falls ich das Problem getroffen habe. Hier
http://blog.freakfabrik.net/PermaLin...a-1c405efbe3a5
findest Du auch MSI-Dateien, um die benötigten
..NET-Framework-Sicherheitseinstellungen anzupassen.

Gruß

G. Born

Reply With Quote
  #4 (permalink)  
Old 12-21-2007
Mario Heller
 

Posts: n/a
Re: Programm startet bedingt nicht
Hallo,

doch noch jemand zu so "später" Stund´ zu Gange...?
Vielen Dank für die super schnellen Infos!
Es handelt sich um ein Visual C++ Programm. Und ich bin leider nicht der
Programmierer... .
Auf den Clients ist lediglich diese Runtime installiert, mehr nicht.
Seltsam eben, dass es mit dem ersten unter Vista angelegten User (lokal)
funktioniert und mit dem Rest eben nicht.
Da komme ich in meinem Kopf einfach nicht weiter.

Aber ich werde weiter suchen und (hoffentlich) vielleicht noch fündig... .

Dankeschön!

Mario


"G. Born" <No-Spam@discussions.microsoft.com> schrieb im Newsbeitrag
news:OW$sch$QIHA.6060@TK2MSFTNGP05.phx.gbl...
> >Hier
>> findest Du einige Hinweise zu diesem Thema
>> http://blog.rasehorn.net/?p=44.

> Noch ein Nachschlag - falls ich das Problem getroffen habe. Hier
> http://blog.freakfabrik.net/PermaLin...a-1c405efbe3a5
> findest Du auch MSI-Dateien, um die benötigten
> .NET-Framework-Sicherheitseinstellungen anzupassen.
>
> Gruß
>
> G. Born
>


Reply With Quote
  #5 (permalink)  
Old 12-21-2007
G. Born
 

Posts: n/a
Re: Programm startet bedingt nicht
Mario Heller wrote:
> Es handelt sich um ein Visual C++ Programm. Und ich bin leider nicht
> der Programmierer... .

Aber vielleicht setzt diese auf .NET-Bibliotheken auf.

> Auf den Clients ist lediglich diese Runtime installiert, mehr nicht.


Du sprachst Eingangs aber von einem Server <zitat> es muß nur
die .exe auf dem Server gestartet werden</zitat>

Das passt nicht zusammen - und was meinst Du mit "Runtime" auf dem
Client.

> Seltsam eben, dass es mit dem ersten unter Vista angelegten User
> (lokal) funktioniert und mit dem Rest eben nicht.


Auch hier verwirrst Du mich einigermaßen! Installierst Du die Anwendung
lokal auf dem Client und kopierst dann eine .exe auf die Freigabe des
Servers?

> Da komme ich in meinem Kopf einfach nicht weiter.


Ich tippe jetzt wirklich auf Berechtigungsprobleme bzw.
Vertrauensstellung des installierten Codes. Dann sollten Dir die von mir
gegebenen Links eventuell weiter helfen. Testweise würde ich mal
versuchsweise die .exe lokal installieren. Dann siehst Du sehr schnell,
ob es ein Rechteproblem ist.

> Aber ich werde weiter suchen und (hoffentlich) vielleicht noch
> fündig... .


Viel Glück und lasse uns wissen, wie es ausgegangen ist.

Gruß

G. Born

Reply With Quote
  #6 (permalink)  
Old 12-21-2007
Mario Heller
 

Posts: n/a
Re: Programm startet bedingt nicht
Hallo,

nun, am Server läuft eine Serverapplikation. Am Client wird aus einer
Freigabe am Server das Clientprogramm (die besagte .exe) gestartet.
Notwendig am Client, dass diese läuft, ist die Visual C++ Runtime.
Ich glaube, dass war in der Tat etwas missverständlich... .
Sobald es etwas Neues gibt, melde ich mich.

Schöne Feiertage und vielen Dank!

Mario



"G. Born" <No-Spam@discussions.microsoft.com> schrieb im Newsbeitrag
news:erLUcfARIHA.5184@TK2MSFTNGP05.phx.gbl...
> Mario Heller wrote:
>> Es handelt sich um ein Visual C++ Programm. Und ich bin leider nicht
>> der Programmierer... .

> Aber vielleicht setzt diese auf .NET-Bibliotheken auf.
>
>> Auf den Clients ist lediglich diese Runtime installiert, mehr nicht.

>
> Du sprachst Eingangs aber von einem Server <zitat> es muß nur
> die .exe auf dem Server gestartet werden</zitat>
>
> Das passt nicht zusammen - und was meinst Du mit "Runtime" auf dem
> Client.
>
>> Seltsam eben, dass es mit dem ersten unter Vista angelegten User
>> (lokal) funktioniert und mit dem Rest eben nicht.

>
> Auch hier verwirrst Du mich einigermaßen! Installierst Du die Anwendung
> lokal auf dem Client und kopierst dann eine .exe auf die Freigabe des
> Servers?
>
>> Da komme ich in meinem Kopf einfach nicht weiter.

>
> Ich tippe jetzt wirklich auf Berechtigungsprobleme bzw.
> Vertrauensstellung des installierten Codes. Dann sollten Dir die von mir
> gegebenen Links eventuell weiter helfen. Testweise würde ich mal
> versuchsweise die .exe lokal installieren. Dann siehst Du sehr schnell,
> ob es ein Rechteproblem ist.
>
>> Aber ich werde weiter suchen und (hoffentlich) vielleicht noch
>> fündig... .

>
> Viel Glück und lasse uns wissen, wie es ausgegangen ist.
>
> Gruß
>
> G. Born
>


Reply With Quote
  #7 (permalink)  
Old 12-28-2007
Mario Heller
 

Posts: n/a
Re: Programm startet bedingt nicht
Hallo NG,

die Auflösung:
das ServicePack für Vista. Zwar noch als RC, aber für uns die Lösung!

Güße und einen guten Rutsch,

Mario


"Mario Heller" <larsamd@imail.de> schrieb im Newsbeitrag
news:%23gexWYBRIHA.4584@TK2MSFTNGP03.phx.gbl...
> Hallo,
>
> nun, am Server läuft eine Serverapplikation. Am Client wird aus einer
> Freigabe am Server das Clientprogramm (die besagte .exe) gestartet.
> Notwendig am Client, dass diese läuft, ist die Visual C++ Runtime.
> Ich glaube, dass war in der Tat etwas missverständlich... .
> Sobald es etwas Neues gibt, melde ich mich.
>
> Schöne Feiertage und vielen Dank!
>
> Mario
>
>
>
> "G. Born" <No-Spam@discussions.microsoft.com> schrieb im Newsbeitrag
> news:erLUcfARIHA.5184@TK2MSFTNGP05.phx.gbl...
>> Mario Heller wrote:
>>> Es handelt sich um ein Visual C++ Programm. Und ich bin leider nicht
>>> der Programmierer... .

>> Aber vielleicht setzt diese auf .NET-Bibliotheken auf.
>>
>>> Auf den Clients ist lediglich diese Runtime installiert, mehr nicht.

>>
>> Du sprachst Eingangs aber von einem Server <zitat> es muß nur
>> die .exe auf dem Server gestartet werden</zitat>
>>
>> Das passt nicht zusammen - und was meinst Du mit "Runtime" auf dem
>> Client.
>>
>>> Seltsam eben, dass es mit dem ersten unter Vista angelegten User
>>> (lokal) funktioniert und mit dem Rest eben nicht.

>>
>> Auch hier verwirrst Du mich einigermaßen! Installierst Du die Anwendung
>> lokal auf dem Client und kopierst dann eine .exe auf die Freigabe des
>> Servers?
>>
>>> Da komme ich in meinem Kopf einfach nicht weiter.

>>
>> Ich tippe jetzt wirklich auf Berechtigungsprobleme bzw.
>> Vertrauensstellung des installierten Codes. Dann sollten Dir die von mir
>> gegebenen Links eventuell weiter helfen. Testweise würde ich mal
>> versuchsweise die .exe lokal installieren. Dann siehst Du sehr schnell,
>> ob es ein Rechteproblem ist.
>>
>>> Aber ich werde weiter suchen und (hoffentlich) vielleicht noch
>>> fündig... .

>>
>> Viel Glück und lasse uns wissen, wie es ausgegangen ist.
>>
>> Gruß
>>
>> G. Born
>>

>


Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Article ID: 931707 Wenn Sie eine symbolische Verknüpfung oder eine feste Verbindung verwenden, um ein Programm in Windows Vista auszuführen, wird das Programm nicht ausgeführt KBArticles German 0 10-22-2007 21:20
Article ID: 934540 Windows Vista startet nicht mehr Problem und Startup Repair behebt Problem nicht KBArticles German 0 10-22-2007 21:20
Vista: Programm startet nicht mehr Lehmeier microsoft.public.de.windows.vista.sonstiges 2 09-24-2007 19:49
Vista: Programm startet nicht mehr Lehmeier microsoft.public.de.windows.vista.bedienung 0 09-23-2007 21:08
Druckerspooler startet nicht, Audioausgabegeräte nicht installiert Peter Schrader microsoft.public.de.windows.vista.hardware 0 06-22-2007 21:37




All times are GMT +1. The time now is 15:33.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120