Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Trunking / Link Aggregation Problem

microsoft.public.de.windows.vista.netzwerk






Speedup My PC
Reply
  #1 (permalink)  
Old 09-24-2009
Artur Kawa
 

Posts: n/a
Trunking / Link Aggregation Problem
Hallo,

ich habe zwei Rechner mit Intel PT 1000 Dual Port NICs
ausgestattet. Die Rechner haben das BS Win Server 2008 und
im Intel NIC Treiber ist Statische Link Aggregation konfiguriert.
Beide Intel NIC Adapter sind zu einer Gruppe zusammengefasst.

Die beiden PCs habe ich mit jeweils zwei Cat6 Kabeln an einen
Netgear GS108T angeschlossen. Das ist ein Smart Managed Gigabit
Switch. Dort habe ich statische Link Aggregation aktiviert und jeweils
zwei Ports zusammengefasst, an welche die PCs angeschlossen sind.

In den Windows Kisten werden 2 GBit/s als Geschwindigkeit der
Netzwerkumgebung angezeigt. Eine Prüfung der tatsächlichen
Datentransferrate ergibt jedoch, das 1 GBit nicht überschritten werden!

Das Benchmark-Tool netio zeigt Werte um die max. 110000 KBit/s.
Kopieren von Dateien überschreiten keine 100 MB/s. Obwohl die
verbaute Hardware zu dem 3-5fachen fähig ist.

Was mache ich falsch. Bin echt am verzweifeln. Habe verschiedenes
ausprobiert: Die statische Link Aggregation, die dynamische Link
Aggregation. Eingestellt am Switch und den NICs. Auch habe ich
einen anderen Switch probiert, nämlich den Netgear GS724Tv2,
welcher aber nur zu statischem Trunking fähig ist. Trotzdem, das
Ergebnis blieb gleich.

Zum Schluß habe ich jeweils ein Netzwerkkabel abgezogen und
die NICs als Single-Port konfiguriert. Die Anzeige in der
Netzwerkumgebung von Windows zeigte dann logischerweise 1
GBit/s an. Die Tests mit netio und Datei über Netz kopieren,
ergab exakt die gleichen Werte wie oben bei aktiviertem Trunking.

Was mache ich falsch? Ein VLAN habe ich nicht konfiguriert,
da ich keine benötige. Das hat ja auch mit Trunking nichts zu tun, oder?

Ich verstehe das nicht, weshalb die Datenrate bei aktiviertem
Trunking nicht doppelt so hoch war, wie bei Single-Port-Betrieb.

Werden von mir weitere Informationen benötigt, um zu entscheiden,
was ich falsch gemacht habe?

Danke für Eure Hilfe.

Gruss
Artur

P.S.
habe in mehrere Newsgroups gepostet:
de.comp.hardware.netzwerke.misc
de.comp.os.ms-windows.netzwerke
microsoft.public.de.windows.vista.netzwerk

Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 09-24-2009
Helmut Rohrbeck
 

Posts: n/a
Re: Trunking / Link Aggregation Problem
Artur Kawa <arka3332@gmx.net> typed:
> ich habe zwei Rechner mit Intel PT 1000 Dual Port NICs
> ausgestattet. Die Rechner haben das BS Win Server 2008 und
> im Intel NIC Treiber ist Statische Link Aggregation konfiguriert.
> Beide Intel NIC Adapter sind zu einer Gruppe zusammengefasst.
>
> P.S.
> habe in mehrere Newsgroups gepostet:
> de.comp.hardware.netzwerke.misc
> de.comp.os.ms-windows.netzwerke
> microsoft.public.de.windows.vista.netzwerk


Hier OT, wende Dich an
microsoft.public.de.german.windows.server.general
Wenn Du in mehreren Gruppen postest, musst Du ein
"Follow Up" setzen, d. h. eine Gruppe auswählen,
in der Antworten auf Dein Posting erscheinen sollen.
http://www.liesmal.de/fup2-faq/
X-Post gecancelt.

--
Helmut Rohrbeck [MVP]
Using Windows 7 RTM Version...
PM: www.helmrohr.de/Feedback.htm
Neu: http://www.helmrohr.de/
Reply With Quote
  #3 (permalink)  
Old 09-24-2009
Bastian Lutz
 

Posts: n/a
Re: Trunking / Link Aggregation Problem
Hallo Artur!

X-Post ohne F'up2 ist boese, F'up2dchnm.

Artur Kawa schrieb:
> ich habe zwei Rechner mit Intel PT 1000 Dual Port NICs
> ausgestattet. Die Rechner haben das BS Win Server 2008 und
> im Intel NIC Treiber ist Statische Link Aggregation konfiguriert.
> Beide Intel NIC Adapter sind zu einer Gruppe zusammengefasst.
>
> Die beiden PCs habe ich mit jeweils zwei Cat6 Kabeln an einen
> Netgear GS108T angeschlossen. Das ist ein Smart Managed Gigabit
> Switch. Dort habe ich statische Link Aggregation aktiviert und jeweils
> zwei Ports zusammengefasst, an welche die PCs angeschlossen sind.
>
> In den Windows Kisten werden 2 GBit/s als Geschwindigkeit der
> Netzwerkumgebung angezeigt. Eine Prüfung der tatsächlichen
> Datentransferrate ergibt jedoch, das 1 GBit nicht überschritten werden!
>
> Das Benchmark-Tool netio zeigt Werte um die max. 110000 KBit/s.


Welche Paketgroesse? Evtl. zu klein gewaehlt?

> Kopieren von Dateien überschreiten keine 100 MB/s.


Welches Protokoll bzw. wie gemessen? SMB hat einen ziemlichen Overhead,
mit FTP waerst du da viel genauer.

> Obwohl die
> verbaute Hardware zu dem 3-5fachen fähig ist.


Was sagt ein HD-Benchmark?

> Was mache ich falsch. Bin echt am verzweifeln. Habe verschiedenes
> ausprobiert: Die statische Link Aggregation, die dynamische Link
> Aggregation. Eingestellt am Switch und den NICs. Auch habe ich
> einen anderen Switch probiert, nämlich den Netgear GS724Tv2,
> welcher aber nur zu statischem Trunking fähig ist. Trotzdem, das
> Ergebnis blieb gleich.


1. Der Switch beherscht offenbar QOS -> Switch richtig konfiguriert,
Firmware-Update verfuegbar, dass das Problem behebt oder reicht evtl.
die Backplane nicht?
2. Kann man bzgl. QOS was im OS einstellen?
3. Hab bei Intel was gefunden:
"Intel® I/O Acceleration Technology (Intel® I/OAT) Drivers and System
Check Utility

Provides device drivers and checks your Windows* system for hardware and
software components necessary to run Intel® I/O Acceleration Technology."

Ich kenne mich damit zwar nicht aus, aber mir scheint es so, als ob es
dir bei der Analyse des Problems behilflich sein koennte.

Bastian Lutz

--
Wenn jemand irgendwas von Anonymitaet faselt, wenn er oder jemand
anderes (meist Newbies) darauf hingewiesen wurde, dass er einen Realname
verwenden sollte, hat er den Hinweis nicht richtig gelesen.
Reply With Quote
  #4 (permalink)  
Old 09-25-2009
Christian Dürrhauer
 

Posts: n/a
Re: Trunking / Link Aggregation Problem
On the seventh day, Artur Kawa wrote:

> Ich verstehe das nicht, weshalb die Datenrate bei aktiviertem
> Trunking nicht doppelt so hoch war, wie bei Single-Port-Betrieb.
>
> Werden von mir weitere Informationen benötigt, um zu entscheiden,
> was ich falsch gemacht habe?


Bastian hat ja schon ein paar allgemeine zu beachtende Tips gegeben.
Konkret auf den ersten Blick sehe ich in Deiner Beschreibung nichts, wo ich
sagen würde "Das ist es!".

Aber folgenden Vorschlag hätte ich noch:
-beide Maschinen mit statischem Trunking konfigurieren
-man sollte "round robin" einstellen können (zumindest bei den älteren
Treiberversionen bei 1000MT Dual bis 13.xx wird mir das so angezeigt, dann
wird abwechselnd die eine, dann die andere Karte angesprochen). Getestet
habe ich selbst jedoch nur den FastEthernet Trunk.
-Switch ebenso statisch
-richtig verkabeln
-beide Maschinen! (sonst ist der Testcase ungültig - kann nur eine Seite
1GB/s liefern oder empfangen, wird die andere Seite entsprechend
ausgebremst ;-) )

Ein VLAN brauchst Du nicht zwangsweise.

Zwar ist es spekulativ, aber es ist auch möglich, dass Deine
Switch-Hardware irgendwo limitiert ist. Bei mir wird Netgear eher nicht so
eingesetzt ;-)

HTH

--
mit freundlichen Grüßen/with kind regards
Christian Dürrhauer

I want to die peacefully, in my sleep, like my grandfather. Not screaming,
terrified, like his passengers.
Reply With Quote
  #5 (permalink)  
Old 09-25-2009
Artur Kawa
 

Posts: n/a
Re: Trunking / Link Aggregation Problem
Hallo,

und danke für die Hinweise.

Ich habe auch in Foren gefragt. Dort habe ich teilweise die Antwort
bekommen, dass mein Problem keines ist, sondern es so richtig ist,
wenn es so funktioniert.

Ich bekam die Aussage, dass wenn ich: PC1 und PC2 habe und beide
mit Duall Link Gigabit NICs ausgestattet habe. Dann beide Rechnern
mit jeweils zwei Netzwerkkabeln an einen Static Link Aggregation
fähigen Switch angeschlossen habe.

Also konkret, PC1 habe ich an die Ports 1 und 2 des Switches
angeschlossen.

PC2 habe ich an die Ports 7 und 8 angeschlossen.

Am Switch habe ich statisches Trunking (statisches Link Aggregation)
aktiviert und zwar so, dass der erste Trunk die Ports 1 und 2 umfasst
und der zweite Trunk die Ports 7 und 8.

Nun habe ich auf den Windows Server 2008 Kisten (PC1 und PC2)
in der Intel NIC Konfiguration beide Ports der NIC gebündelt und
dort im Treiber statische Link Aggregation eingestellt.

Beide Rechner zeigen 2 GBit als Verbindung an und können gegenseitig
angepingt werden.

Datendurchsatztest mit netio zeigt leider 110.000 KBit/s an.

Man hat mir in den anderen Foren gesagt, dass dies so der Normalzustand
wäre.

Würde ich mit zwei PCs auf den mit Dual-NIC ausgestatteten Server
zugreifen, hätte ich die 2 GBit. Von einem Rechner auf den anderen
zuzugreifen, wird jedoch immer nur 1 GBit erreicht, da der Datentransfers
von MAC zu MAC erfolgt.

Gruss
Artur

Reply With Quote
  #6 (permalink)  
Old 09-25-2009
Christian Dürrhauer
 

Posts: n/a
Re: Trunking / Link Aggregation Problem
On the seventh day, Artur Kawa wrote:

> Hallo,
>
> und danke für die Hinweise.
>
> Ich habe auch in Foren gefragt. Dort habe ich teilweise die Antwort
> bekommen, dass mein Problem keines ist, sondern es so richtig ist,
> wenn es so funktioniert.
>
> Ich bekam die Aussage, dass wenn ich: PC1 und PC2 habe und beide
> mit Duall Link Gigabit NICs ausgestattet habe. Dann beide Rechnern
> mit jeweils zwei Netzwerkkabeln an einen Static Link Aggregation
> fähigen Switch angeschlossen habe.
>
> Also konkret, PC1 habe ich an die Ports 1 und 2 des Switches
> angeschlossen.
>
> PC2 habe ich an die Ports 7 und 8 angeschlossen.
>
> Am Switch habe ich statisches Trunking (statisches Link Aggregation)
> aktiviert und zwar so, dass der erste Trunk die Ports 1 und 2 umfasst
> und der zweite Trunk die Ports 7 und 8.
>
> Nun habe ich auf den Windows Server 2008 Kisten (PC1 und PC2)
> in der Intel NIC Konfiguration beide Ports der NIC gebündelt und
> dort im Treiber statische Link Aggregation eingestellt.
>
> Beide Rechner zeigen 2 GBit als Verbindung an und können gegenseitig
> angepingt werden.
>
> Datendurchsatztest mit netio zeigt leider 110.000 KBit/s an.
>
> Man hat mir in den anderen Foren gesagt, dass dies so der Normalzustand
> wäre.
>
> Würde ich mit zwei PCs auf den mit Dual-NIC ausgestatteten Server
> zugreifen, hätte ich die 2 GBit. Von einem Rechner auf den anderen
> zuzugreifen, wird jedoch immer nur 1 GBit erreicht, da der Datentransfers
> von MAC zu MAC erfolgt.


zwar habe ich nicht mit Gigabitlinks getestet, sondern dasselbe nur mit
FastEthernetlinks, doch dort multipliziert sich die verfügbare Bandbreite
mit der Anzanl der Ports. Man kann den Testcase natürlich nur dann nicht
nachstellen, wenn der Host, der die Messung macht, den Server künstlich
limitiert, z.B. weil er ein langsameres Interface hat.

Aber so schlau sollte jeder selbst sein ;-)

--
mit freundlichen Grüßen/with kind regards
Christian Dürrhauer

I want to die peacefully, in my sleep, like my grandfather. Not screaming,
terrified, like his passengers.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
SIP Trunking: VoIP's Threatening Opportunity Steve Security News 0 02-13-2009 17:50
Symantec dabbles with cloud app aggregation; Launches beta of GoEverywhere Steve Security News 0 01-26-2009 21:10
Problem with '#' in link Ronald C. microsoft.public.windows.vista.mail 1 05-01-2008 13:13
URL Link Problem Art microsoft.public.windows.vista hardware devices 1 03-14-2008 02:55
Social Network Aggregation, Killer App in 2008? Steve General Technology News 0 01-02-2008 14:50




All times are GMT +1. The time now is 18:45.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120